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Overview

How to use these help files:

Welcome to iBank! This manual is provided to assist you in finding your way around the iBank application. 
Whether you are a first-time user just learning the ropes, or an iBank expert hunting for power user tips, we trust 
that this guide will help you take advantage of everything iBank has to offer. To get you started, here are a few 
notes about how to use the iBank User Manual.

Browsing: To get a quick overview of what is contained in this manual, please visit the Table of Contents sec-
tion and browse the chapter headings. Page numbers are included for quick reference. If your PDF viewer has a 
Bookmarks tab, you can also use this to easily jump between chapters.

Searching: If you have a particular question in mind, you can use the search function in your PDF viewer to 
locate the section of the manual that addresses it. The contents of this manual have been organized in question 
format to better help you find what you are looking for. 

Hyperlinks: Throughout the guide, you will find words or phrases that are highlighted in yellow. The color 
indicates that the word or phrase is a hyperlink. If you are reading the manual in PDF format, you can click any 
hyperlink to jump to another section for more information on that topic. These cross-references should help to 
ensure that you always find the right answers to your questions, no matter where you start your search.

Notes: Interspersed throughout the manual you will find boxes containing extra information about the topic at 
hand. They might offer caveats about certain features, explain in greater detail how certain functions work, or 
provide extra tips for power users who want to get a little bit more out of iBank.
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Look for boxes like this one for hints, tips, and extra info. 

Menu commands: In this manual, you are often instructed to choose commands from the various menus 
provided in iBank. To simplify the menu hierarchy, we chose to use the ‘>’ character to denote each sub-menu or 
menu item. To illustrate, when you see View > Show Transactions > Recent, this can be interpreted 
as “Go to the View menu, then go to the Show Transactions submenu, then choose Recent.”

On your first launch:

The first time you run iBank 4, the new document assistant will launch automatically to help you get started. 
Once you finish creating your document, add some accounts to the file and/or configure bank downloads for 
your accounts so that you can keep them up-to-date.

On subsequent launches, iBank will prompt you to purchase or register the program. Feel free to click the “Use 
Demo” button to continue using iBank in trial mode for up to 30 days. Once you are satisfied that iBank is right 
for you, choose iBank > License and click “License Info” to purchase a license.

About tracking finances with iBank:

Tracking your finances can be a lot like cleaning the house: you really want to do it, but sometimes it just doesn’t 
get done. Just like cleaning the house can be more enjoyable with good cleaning supplies and tools, tracking 
your money can be much easier if you have the appropriate software application to assist you. iBank is the 
premier Mac OS X financial application to make tracking your finances as easy as possible.
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System requirements:

iBank 4 requires Mac OS X 10.5.8 or higher and a screen resolution of at least 1024x768. For older systems, try 
iBank 3 (10.5) or iBank 2 (10.4).

http://www.iggsoftware.com/ibank/downloads.php#older
http://www.iggsoftware.com/ibank/downloads.php#older
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What’s New in iBank 4?

Take a look at these new and improved features:

Killer reports. iBank 4 features a brand new reporting system, designed to make analysis of your finan-
cial data a breeze. Examine your income and expenses by category, monitor your net worth over time, 

check the performance of your investments, analyze your spending by payee, compile tax-related information, 
and keep track of your debt, all with just a few button clicks. Best of all, you can drill down into any report - click 
to zoom in from the big picture to a detailed view and all the way down to individual transactions. Plus, you can 
print or save any report just as it appears on your screen. You’ll never miss another penny!

Awesome budgeting. Take a whole new approach to budgeting with envelopes in iBank 4. Drag and 
drop cash from income categories into envelopes that represent different types of expenses. See at a 

glance how much money you have available for a particular purchase at any point in time. Move cash between 
envelopes to balance out surpluses and shortfalls in different categories, carry over extra cash from month to 
month, and incorporate one-off expenses or bonuses into your budget plan. The ease and flexibility of iBank’s 
new system does the impossible - it makes budgeting fun!

Streamlined interface. iBank has already earned a reputation for outpacing its competition in Mac-
friendliness. Now in version 4, we’ve packed hundreds of spectacular features into a cleaner and more 

intuitive interface. Quickly access the accounts and features you need most in the redesigned source list; get a 
quick look at your total assets, liabilities, and net worth (as a table or bar graph) in the new summary pane; 
easily locate specific transactions with the help of separate deposit and withdrawal columns in the account 
register; enter transactions faster than ever before with the new keyboard-friendly transaction editor; and 
record split transactions in a flash with automatic summing of split amounts. Give iBank 4 one try, and you’ll 
never go back! Who ever thought financial management could be so much fun?
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Ridiculously simple importing. Now iBank makes it easier than ever to switch from Quicken or Micro-
soft Money. Simply export your Quicken Essentials data to a QMTF file, Quicken for Mac or Windows data 

to a QIF file, or Microsoft Money data to a set of QIF files. Copy the exported file(s) to your Mac, and create a new 
iBank document. The setup assistant lets you choose which program to import from, then prompts you to 
choose the file(s) to import. The rest is done automatically! iBank sets up all of your accounts, transactions, 
categories, and investments so that you can pick up right where you left off with your old software. No more 
struggling with date formats, no need to configure accounts ahead of time, and no messy account transfers - 
iBank handles all your data with ease.

Exceptional investment tracking. Building on the powerful investment management capabilities of its 
predecessor, iBank 4 adds more options to help you keep track of your holdings and the return on your 

investments. Download and view price histories for securities you own or are just watching, draw cash from a 
banking account and purchase shares in an investment account with a single transaction, and assign risk levels 
to your securities to help balance your portfolio. Combine these features with iBank’s new reports - which 
include information about your realized and unrealized gains, return on investment (ROI), portfolio composi-
tion, and net worth - and you’ve got an incredible new set of tools to help you stay on top of your investments.

Powerful currency support. iBank 4 takes the guesswork out of tracking accounts in multiple curren-
cies. Reports and budgets now apply currency conversions automatically, currencies are assigned to new 

accounts with the ease of a pull-down menu, and exchange rates are downloaded with the click of a button. 
Conversions can be applied to transactions simply by choosing a second currency and typing in the exchange 
rate or the converted amount. Currency symbols are shown throughout the software, so you never have to 
guess which currency is being used.
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Innovative transaction templates. iBank 4 features a new template system that merges the functional-
ity of memorized transactions, scheduled transactions, and smart import rules into one killer feature. Not 

only does iBank record your payees as you type them, so that you can autofill the same transaction details 
(including splits) later on, but iBank actually records the changes you make when you download data! It learns 
the way you clean up and categorize your imported transactions and applies those changes the next time you 
import - no setup required. You can then take the same templates created by these two methods and add 
schedules to them, so that you can post similar transactions automatically at specified intervals. The same 
features you loved in older versions of iBank are now more powerful and accessible through one handy inter-
face - transaction templates.

Slick web downloading. Based on the same underlying technology as Safari, iBank’s built-in web 
browser now features a much simpler setup process that will have you importing account data from 

your bank’s website in no time. When you set up a new account, simply choose your bank from a list and iBank 
configures the web browser for you. Update your accounts by clicking a website link right in the source list, 
which opens the browser to your bank’s login page so that you can log in and start the download - iBank then 
takes over the download and helps you process the incoming transactions.

Superior reconciling. Due to popular demand, iBank 4 brings back the “checkmark” approach to recon-
ciliation, where transactions in a list are compared against a printed bank statement simply by checking 

them off. Once a statement is balanced, it can be locked so that only the transactions reconciled on that state-
ment are visible and cannot be edited in the account register. Summary figures in the reconciling interface help 
you to balance the statement and pinpoint discrepancies in your records.

Effortless file attachments. Just like its predecessor, iBank 4 allows you to take pictures with your iSight 
and save them with your transactions. Now, go a step further and attach files of any type! iBank 4 lets 
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you associate multi-page PDF documents, iTunes music files, Microsoft Word documents, Adobe Photoshop 
images, ZIP archives, and all other types of files you can imagine with your financial transactions. Attach all of 
your important documents to their related transactions, and never lose those records again!

...and much more! Continue reading to learn about getting started with iBank 4.
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How do I install iBank?

If you purchased iBank from our online store:

Download the iBank application from our website at: 1.	 www.iggsoftware.com/ibank

Look for “iBank4_Web.dmg” on your Desktop or in your Downloads folder. Double-click this file to mount 2.	
the “iBank 4” disk image on your Desktop.

The disk image should appear on your Desktop - 3.	
it looks like a white external drive icon. Double-
click the disk image to open it.

In the window that appears, drag and drop the 4.	
iBank icon onto the Applications folder to copy 
the software to your computer. If you have a 
previous version of iBank installed, allow the 
computer to replace the existing application.

Close the disk image window, then drag both 5.	
the “iBank 4” disk image and “iBank4_Web.dmg” 
from your Desktop or Downloads folder to the 
Trash.

Open your Applications folder and drag “iBank” 6.	
onto your Dock to keep it there for easy access.

Click the iBank icon on your Dock to launch the 7.	
software.

http://www.iggsoftware.com/ibank
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If you purchased iBank from a retail store or Amazon.com:

Insert the iBank CD into your drive.1.	

The CD should appear on your Desktop - double-click the CD icon to open it.2.	

In the window that appears, you should see the iBank application and some other files. Drag and drop the 3.	
iBank icon onto your Applications folder to copy the software to your computer. If you have a previous 
version of iBank installed, allow the computer to replace the existing application.

Close the CD window, then drag the CD icon from your Desktop to the Trash to eject it.4.	

Open your Applications folder and drag “iBank” onto your Dock to keep it there for easy access.5.	

Click the iBank icon on your Dock to launch the software.6.	

If you purchased iBank from the Mac App Store:

Launch the App Store from your Applications folder.1.	

Click “Purchases” on the toolbar.2.	

Click the “Install” button next to iBank, then wait for the download to finish.3.	

Open your Applications folder and drag “iBank” onto your Dock to keep it there for easy access.4.	

Click the iBank icon on your Dock to launch the software.5.	

That should do it! iBank should now be installed correctly on your computer.
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How do I create documents in iBank?

To get started using iBank, the first thing you will need to do is create a document. Choose File > New 
iBank Document to start the new document assistant:

This assistant opens automatically the first time you launch iBank 4, as well as any time you create a new docu-
ment. Choose one of the following options to determine how iBank should set up the new file:

Create New iBank Document

Choose this option and click “Next” to start fresh with a blank document. The next screen will ask you to choose 
a location in which to save your document: click “Next,” enter a name for the document in the sheet that ap-
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pears, choose a location, and click “Save.” On the next screen, you will be asked to choose a primary currency 
for the new document. New accounts will use this currency by default, but other currencies can also be used as 
needed. Choose a currency and click “Next” to continue.

The next screen will allow you to choose which categories, if any, you would like iBank to add to your document. 
iBank includes two predefined sets of categories: “Home” is intended for personal use, “Business” for professional 
use. Both sets include categories that are assigned standard US tax codes. You may check one or both sets of 
categories, or choose not to add either set to your document.

Click “Next” to continue - iBank will take a few seconds to add the chosen category sets to your document, and 
then present you with a “Congratulations” screen to inform you that your new document is ready to use. Click 
“OK” to continue to the main window, or click “Set Up Accounts” to begin adding accounts to the file.

Open iBank Document from Previous Version

If you previously used iBank 2 or 3, and want to upgrade your data for use with iBank 4, choose this option and 
click “Next.” The next screen will ask you to choose the file you wish to open:
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If you previously used iBank 3, the last file you opened will appear by default. Click “Choose File...” to select a 
different document, or drag and drop an iBank document onto the box under that button, then click “Next” to 
continue.

On the next screen, iBank will ask you to choose a location in which to save your document: click “Next,” enter 
a name for the document in the sheet that appears, choose a location, and click “Save.” iBank will then upgrade 
your data and save it in the location you specified. Some basic reports will be added to help you analyze your 
data. Your original document will not be modified, in case you ever want to open it using an old version of 
iBank.

Once the upgrade process has finished, iBank will present you with a “Congratulations” screen to inform you that 
your new document is ready to use. Click “OK” to continue to the main window. If any changes were made to 
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your data during the upgrade process, a window will appear to show you the details. See “What changes were 
made when my document was upgraded?” later in this chapter for more information about this window.

Open Existing iBank 4 Document

Choose this option to open an existing iBank 4 document instead of creating a new one. Click “Next,” select the 
file you want to open, and click “OK.” iBank will open the file and leave you at the main window so that you can 
continue using it where you left off.

Import from Quicken Essentials Mac

Choose this option and click “Next” to import your financial accounts from Quicken Essentials for Mac. The next 
screen provides directions for transferring your data:

Launch Quicken Essentials.1.	

Review your account names. If any names are longer than 31 characters, please abbreviate them (this is a 2.	
limitation of Quicken’s export format). The names can be restored to full length in iBank after the import is 
complete.

Review your category names. If any names are longer than 55 characters, please abbreviate them (they can 3.	
be restored in iBank after the import is complete). Please note that subcategory names, when exported, 
will include the names of their parent categories in the following manner: Category:Subcategory1:Subcate
gory2. This entire set of names must be 55 characters or less (including the colons) in order to avoid being 
truncated during the export process.

Choose 4.	 File > Export > Quicken 2007  and save the QMTF file on your Desktop.
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Drag and drop the QMTF file from your Desktop onto the box in the iBank new document assistant, or click 5.	
“Choose File...” and select the QMTF file.

Click “Next” to continue.6.	

On the next screen, iBank will ask you to choose a location in which to save your document: click “Next,” enter 
a name for the document in the sheet that appears, choose a location, and click “Save.” You will then be asked 
to choose a primary currency for the new document. New accounts will use this currency by default, but other 
currencies can also be used as needed. Choose a currency and click “Next” to continue.

After processing the data in the QMTF file, iBank will ask you to verify that each of the accounts you are import-
ing is assigned the correct type. iBank offers more account types than the QMTF file format supports, so take 
this opportunity to decide which type is most appropriate for each account. Be sure to choose carefully, because 
you will not be allowed to change the account types once you have finished setting up your document. Once 
you have verified the account types, click “Next” to continue.

iBank will then import the accounts, transactions, and categories from the QMTF file (other features such as 
investments, scheduled transactions, memorized transactions, budgets, and reports cannot be imported). 
iBank will automatically create a set of basic reports to help you analyze your data. Once the import process has 
finished, iBank will present you with a “Congratulations” screen to inform you that your new document is ready 
to use. Click “OK” to continue to the main window.

	 If transfers between your accounts are broken after the import, please create a new iBank document and 
try the import again, paying special attention to step 2 above. Quicken Essentials limits account names to 
31 characters during the export process, and this can interfere with account transfers. Keeping your ac-
count names below this length will ensure that iBank imports your transfers properly.
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Import from Quicken for Mac

Choose this option and click “Next” to import your financial accounts from Quicken for Mac. The next screen 
provides directions for transferring your data:

Launch Quicken.1.	

Choose 2.	 File > Export > To QIF and save the QIF file on your Desktop.

Drag and drop the QIF file from your Desktop onto the box in the iBank new document assistant, or click 3.	
“Choose File...” and select the QIF file.

Click “Next” to continue.4.	

On the next screen, iBank will ask you to choose a location in which to save your document: click “Next,” enter 
a name for the document in the sheet that appears, choose a location, and click “Save.” You will then be asked 
to choose a primary currency for the new document. New accounts will use this currency by default, but other 
currencies can also be used as needed. Choose a currency and click “Next” to continue.

After processing the data in the QIF file, iBank will ask you to verify that each of the accounts you are importing 
is assigned the correct type. iBank offers more account types than the QIF file format supports, so take this op-
portunity to decide which type is most appropriate for each account. Be sure to choose carefully, because you 
will not be allowed to change the account types once you have finished setting up your document. Once you 
have verified the account types, click “Next” to continue.

iBank will then import the accounts, transactions, categories, and investments from the QIF file (other features 
such as scheduled transactions, memorized transactions, budgets, and reports cannot be imported). iBank will 
automatically create a set of basic reports to help you analyze your data. Once the import process has finished, 
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iBank will present you with a “Congratulations” screen to inform you that your new document is ready to use. 
Click “OK” to continue to the main window.

Import from Quicken for Windows

Choose this option and click “Next” to import your financial accounts from Quicken for Windows. The next 
screen provides directions for transferring your data:

On your PC, launch Quicken.1.	

Open any closed accounts.2.	

Export your data to a QIF file. Since the export command may vary between different versions of Quicken, 3.	
consult the documentation for help with locating and using this command. All of your Quicken data should 
be saved to a single file if possible.

Copy the QIF file to your Mac’s Desktop using a flash drive, network transfer, email attachment, or other 4.	
means of PC-to-Mac file transfer.

Drag and drop the QIF file from your Desktop onto the box in the iBank new document assistant, or click 5.	
“Choose File...” and select the QIF file.

Click “Next” to continue.6.	

On the next screen, iBank will ask you to choose a location in which to save your document: click “Next,” enter 
a name for the document in the sheet that appears, choose a location, and click “Save.” You will then be asked 
to choose a primary currency for the new document. New accounts will use this currency by default, but other 
currencies can also be used as needed. Choose a currency and click “Next” to continue.
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After processing the data in the QIF file, iBank will ask you to verify that each of the accounts you are importing 
is assigned the correct type. iBank offers more account types than the QIF file format supports, so take this op-
portunity to decide which type is most appropriate for each account. Be sure to choose carefully, because you 
will not be allowed to change the account types once you have finished setting up your document. Once you 
have verified the account types, click “Next” to continue.

iBank will then import the accounts, transactions, categories, and investments from the QIF file (other features 
such as scheduled transactions, memorized transactions, budgets, and reports cannot be imported). iBank will 
automatically create a set of basic reports to help you analyze your data. Once the import process has finished, 
iBank will present you with a “Congratulations” screen to inform you that your new document is ready to use. 
Click “OK” to continue to the main window.

	 If your version of Quicken does not allow you to export all accounts to a single QIF file, export each account 
to a separate QIF file and follow the instructions in Importing Multiple QIF Files to import them into iBank. 

Import from MS Money

Choose this option and click “Next” to import your financial accounts from Microsoft Money. The next screen 
provides directions for transferring your data:

On your PC, launch Money.1.	

Open any closed accounts.2.	

Export each 3.	 account to a QIF file. Since the export command may vary between different versions of Money, 
consult the documentation for help with locating and using this command. Make sure to name each QIF 
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file after the account it came from - if the account names do not match exactly, errors may result in the 
imported data (particularly with transfers between accounts).

Copy the QIF files to your Mac’s Desktop using a flash drive, network transfer, email attachment, or other 4.	
means of PC-to-Mac file transfer.

Click “Choose File...,” select all of the QIF files at once, and click “Open.”5.	

Click “Next” to continue.6.	

On the next screen, iBank will ask you to choose a location in which to save your document: click “Next,” enter 
a name for the document in the sheet that appears, choose a location, and click “Save.” You will then be asked 
to choose a primary currency for the new document. New accounts will use this currency by default, but other 
currencies can also be used as needed. Choose a currency and click “Next” to continue.

After processing the data in the QIF file, iBank will ask you to verify that each of the accounts you are importing 
is assigned the correct type. iBank offers more account types than the QIF file format supports, so take this op-
portunity to decide which type is most appropriate for each account. Be sure to choose carefully, because you 
will not be allowed to change the account types once you have finished setting up your document. Once you 
have verified the account types, click “Next” to continue.

iBank will then create accounts based on the names of the QIF files and import the transaction data into 
them. Categories and investments will also be imported, but other features such as scheduled transactions, 
memorized transactions, budgets, and reports cannot be imported. iBank will automatically create a set of 
basic reports to help you analyze your data. Once the import process has finished, iBank will present you with 
a “Congratulations” screen to inform you that your new document is ready to use. Click “OK” to continue to the 
main window.
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Import from Other Financial Application

Choose this option and click “Next” to import your financial accounts from another financial program. The next 
screen provides directions for transferring your data:

Launch your other financial program.1.	

Open any closed or hidden accounts (if your software lets you close or hide accounts).2.	

Export your data to a QIF file. Since the export command may vary from one financial manager to the next, 3.	
consult the documentation for help with locating and using this command. All of your financial data should 
be saved to a single file if possible.

If your financial program does not run on a Mac, copy the QIF file to your Mac’s Desktop using a flash drive, 4.	
network transfer, email attachment, or other means of PC-to-Mac file transfer.

Drag and drop the QIF file from your Desktop onto the box in the iBank new document assistant, or click 5.	
“Choose File...” and select the QIF file.

Click “Next” to continue.6.	

On the next screen, iBank will ask you to choose a location in which to save your document: click “Next,” enter 
a name for the document in the sheet that appears, choose a location, and click “Save.” You will then be asked 
to choose a primary currency for the new document. New accounts will use this currency by default, but other 
currencies can also be used as needed. Choose a currency and click “Next” to continue.

After processing the data in the QIF file, iBank will ask you to verify that each of the accounts you are importing 
is assigned the correct type. iBank offers more account types than the QIF file format supports, so take this op-
portunity to decide which type is most appropriate for each account. Be sure to choose carefully, because you 
will not be allowed to change the account types once you have finished setting up your document. Once you 
have verified the account types, click “Next” to continue.
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iBank will then import the accounts, transactions, categories, and investments from the QIF file (other features 
such as scheduled transactions, memorized transactions, budgets, and reports cannot be imported). iBank will 
automatically create a set of basic reports to help you analyze your data. Once the import process has finished, 
iBank will present you with a “Congratulations” screen to inform you that your new document is ready to use. 
Click “OK” to continue to the main window.

	 If your financial program does not allow you to export all accounts to a single QIF file, export each account 
to a separate QIF file and follow the instructions in the next section to import them into iBank. 
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How do I create a document from multiple QIF files?

When you first create a document in iBank, several options are provided to help you import data from other 
financial programs. If your old program allows you to export your data in QIF format, but does not provide the 
option to export all accounts to a single QIF file, the process to import that data into iBank requires a bit of extra 
work - follow the steps below to create a document and import your data. Otherwise, please see the preceding 
article for information about importing your data into a new iBank document.

	 One exception is Microsoft Money: if you are switching to iBank from Money, you can use the “Import from 
MS Money” option to set up your document with multiple QIF files. 

Export your data:

Open your old financial program, open any closed accounts, and export each account to a QIF file. Consult that 
program’s documentation if you are not sure how to locate or use the export command. It may be helpful to 
name each file after the account it was created from. If necessary, copy the QIF files to your Mac’s Desktop using 
a flash drive, network transfer, email attachment, or other means of file transfer.

Create a new iBank document:

Open iBank and choose File > New iBank Document. Choose “Create New iBank Document” (the default 
option) and proceed with the setup process as described in the preceding article. When iBank asks you to 



choose categories, uncheck both “Home” or “Business” so that the new document will only use the categories 
that you import.

Set up your accounts:

Once the document setup is complete, add an account for each QIF file you will import. Take care to name each 
account exactly as it was named in the old program - if the account names do not match exactly, errors may 
result in the imported data (particularly with transfers between accounts).

Import the data:

Once all your accounts have been configured, you may begin importing the data. Select an account, choose 
File > Import, choose the QIF file that corresponds to that account, and click the “Import” button when the 
import window opens. Repeat for each account, and be sure you do not use the “Select/Deselect All for Import” 
command in the import window - it is key to allow iBank to screen out the duplicates that would otherwise be 
created by account transfers.

	 To minimize the potential for error, it is best to import investment accounts first, then any banking accounts 
that transfer funds to multiple accounts, and finally the remaining accounts. 
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Check for errors:

Once all accounts have been imported, click “Security Prices” on the toolbar to download quotes for your 
investments, then check your account balances in the source list to make sure they are accurate. If there are any 
discrepancies between the figures in iBank and those in your old program, take a look through the accounts to 
see if you can spot any errors, and contact us for assistance.
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What changes were made when my document was 
upgraded?

When upgrading your data from a previous version of the software, iBank may present you with a window 
stating, “We fixed your database.” This window contains a log of changes that were made to your data during the 
upgrade process. Due to differences in the way old versions of iBank managed data, modifications are some-
times necessary in order to make the data usable in iBank 4. In addition, iBank examines your database for errors 
during the upgrade process and corrects any problems that it finds. In both cases, iBank takes care to notify you 
when any significant changes are made. Below, you will find a description of each message that may appear in 
the upgrade log.

Two types of messages may appear in the log:

•	  Notices: These messages provide information about routine changes that iBank 4 has made to your 
data due to the new features and upgrades that have been implemented. You should review the changes, 
but they indicate a healthy database.

•	  Warnings: These messages alert you to changes made to your data that we highly recommend 
you verify. Although the errors have been fixed and the database is now healthy, you should review the 
changes and make any adjustments that may be necessary. Instructions are provided to direct you to the 
appropriate places where you can review the changes.

In some cases, you may want to check your accounts to see the effects of the changes that were made, and 
make adjustments or corrections as needed. Click “Save Log” at the bottom of the log window to save the list 
of changes to a text file so that you can refer back to it at any time. Enter a name for the file and choose a save 
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location when prompted, then click “Save” to save the file. You can open this file with TextEdit or any other text 
editor.

 Account “account name” was assigned “currency name” (currency symbol) as a currency.

This message indicates that one of your accounts did not have a currency assigned to it. Your Mac’s default 
currency was assigned to the account.

 Account name changed to “new name” (was “old name”)

This message indicates that one of your accounts had the same name as another account or one of your catego-
ries. Since this is not permitted in iBank 4, the account’s name was changed. Any transfers linked to the account 
were also changed accordingly.

 Added split to balance a transfer.

This message indicates that one of your transfers had split items that did not balance to the transaction’s total 
amount. A split item was added to the transaction to cover the difference.

 Category name changed to “new name” (was “old name”)

This message indicates that one of your categories had the same name as another category or one of your ac-
counts. Since this is not permitted in iBank 4, the category’s name was changed. This message could also indi-
cate that one of your categories had a colon in its name, but was not a sub-category, so its name was changed. 
Any transactions assigned to the category were also changed accordingly.
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 Couldn’t update search criteria for smart account “account name”. The smart account was deleted.

This message indicates that one of your old smart accounts could not be converted for use with iBank 4, due 
to differences in the way smart accounts function in this version of iBank. The smart account was deleted - you 
should probably create a new one in its place.

 Couldn’t update smart import rule criteria for “rule name”.

This message indicates that one of your old smart import rules could not be converted for use with iBank 4, due 
to differences in the way smart import rules function in this version of iBank. You should probably delete the 
rule and create a new one in its place.

 Date for transaction with payee “payee name” was set to date, it was nil.

This message indicates that one of your transactions did not have a date assigned to it. It was assigned the date 
on which the transaction was originally recorded or imported into iBank. If that date was also missing, it was 
assigned today’s date.

 Deleted stranded line item from account/category name. Amount was amount.

This message indicates that one of your accounts or categories contained a corrupted transaction. The cor-
rupted transaction was deleted; the account balance or category value should not be affected.

 Duplicate currency names. Currency named “old currency name” changed to “new currency 
name.”

This message indicates that two of your currencies shared the same name. iBank 4 does not allow duplicate 
currency names, so a number was added to the name of one of the currencies to differentiate it from the other.
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 Exchange rate changed to 1 (was old exchange rate) for “payee name” on date in account/
category “account name”.

This message indicates that one of your transactions had an exchange rate applied to it, but did not appear to 
need one (the transaction currency and the account currency were the same). The exchange rate was discarded; 
the transaction amount was preserved.

 Found a non-account line item associated with security “security name”. We will remove the secu-
rity from it.

This message indicates that some investment details were found where they don’t belong (a bad database 
record was found). The investment details were removed from the database, but your transactions were not 
affected.

 Found a line item associated with security “security name”, but this line item’s account had no 
currency. We will remove the security from it.

This message, like the one above, indicates that some investment details were found where they don’t belong (a 
bad database record was found). The investment details were removed from the database, but your transactions 
were not affected.

 Group account name changed to “new name” (was “old name”).

This message indicates that one of your account groups had the same name as one of your accounts or catego-
ries. Since this is not permitted in iBank 4, the group’s name was changed. Any transfers linked to an account in 
the group were also changed accordingly.
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 Report date ranges are handled differently in iBank 4. The start dates of your reports were estimated; 
you should verify and adjust them accordingly.

This message indicates that the starting date for some of your reports may have been adjusted due to differ-
ences in the way iBank 4 handles report date ranges. Unlike previous versions, iBank 4 tracks reports from their 
end dates backwards according to predefined intervals (weekly, monthly, etc.), which may prohibit certain date 
ranges from being used. In these cases, iBank 4 substitutes the closest available range.

 Scheduled transaction payee name repeat option was once, changed number of times it repeats to 
1.

This message indicates that one of your scheduled transactions was set to use the frequency “once.” Since this 
option is no longer available in iBank 4, the scheduled transaction was assigned an equivalent setting, which is 
to repeat only one time.

 Securities with duplicate symbols (symbol) found. They will be merged.

This message indicates that your portfolio contained more than one security that was assigned to the same 
ticker symbol. These securities were combined into a single security for iBank 4.

 Set transaction’s currency to default currency: currency name (currency symbol). None of the 
transaction’s line items had an account with a currency.

This message indicates that one of your transactions did not have a currency assigned to it. Your Mac’s default 
currency was assigned to the transaction.
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 Smart account name changed to “new name” (was “old name”).

This message indicates that one of your smart accounts had the same name as another account or one of your 
categories. Since this is not permitted in iBank 4, the smart account’s name was changed.

 All of your accounts were used in budget “budget name”. Number budget items were removed. All 
existing accounts will be used as the source for this budget.

This message indicates that account transfers were removed from one of your budgets. In iBank 4, budgets can 
be limited to specific accounts. In order to monitor transfers into a particular account, that account must be 
excluded from the budget setup. In this case, your budget was monitoring transfers into all available accounts, 
so the transfers needed to be removed (otherwise all accounts would have been excluded from the budget 
setup).

 Duplicate currency codes. Currency with code “old currency code” changed to “new currency 
code.”

This message indicates that two of your currencies shared the same code. iBank 4 does not allow duplicate cur-
rency codes, so a number was added to the code of one of the currencies to differentiate it from the other. This 
will prevent iBank from downloading exchange rates for the currency, so you should either change the code to 
one that is unique or reconfigure your accounts and transactions to avoid using this currency. The currency can 
be deleted if no accounts or transactions are associated with it.
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 iBank estimated the minimum payment for loans, but you should set it according to your loan docu-
ments.

iBank 4 handles loans differently from previous versions of iBank, in that you can now enter your loan payment 
amount directly (previous versions calculated this amount based on the other loan settings). When upgrading 
loan accounts, iBank 4 determines the minimum payment based on the other loan settings. This message ap-
pears simply to remind you to check your loan settings and verify that they are correct after the upgrade.

 On date in “account name”, you sold more shares than you own of security name. You should 
correct this.

This message indicates that a “Sell” transaction was recorded in an investment account that caused iBank to 
deduct more shares of a security than were available at the time. There are two common causes for this error: 
sales being recorded before purchases on the same date, and short sales being recorded improperly. To correct 
the error in the former case, locate the transactions in your investment account and move the “Buy” transactions 
ahead of the “Sell” transactions via drag & drop (this will only work if the transactions have the same date). In the 
latter case, change the transaction type from “Sell” to “Sell to Open” to indicate that the transaction represents 
a short sale. You may also need to change one of your “Buy” transactions to “Buy to Close” in order to cover the 
short sale.

 Security info deleted from transaction “payee name” on date in account/category “account 
name”. Security line items have to be in an investment account.

This message indicates that a transaction in one of your banking accounts had investment details associated 
with it. This is not allowed in iBank 4, so the investment details were removed.
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 Security security name is in use with an account with a different currency. You should a make new 
security using currency currency name.

This message indicates that one of your securities is using a different currency than some of the transactions as-
sociated with it. Nothing was changed, but we recommend that you fix the problem by creating a new security 
that uses the appropriate currency.

 The variable interest rate for your loan to lender’s name should be updated.

This message indicates that one or more of your loans has a variable interest rate which may have been modi-
fied during the upgrade due to differences in the way interest rates are handled in iBank 4. This message ap-
pears simply to remind you to check your loan settings and verify that the current interest rates are correct after 
the upgrade.

 Transaction on date with payee “payee name” had invalid security info. The security info was re-
moved.

This message indicates that one of your transactions had security information associated with it when none 
should have been present, so the security details were removed. This could affect your current holdings for that 
security - please check the security using a Portfolio Summary report. If you find a discrepancy, you may want to 
go back to iBank 3, locate the transaction indicated in the error message, delete it and recreate it, and upgrade 
to iBank 4 again.
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 You need to set up syncing again if you are using iBank Mobile on an iOS device.

This message indicates that some of your data was corrupted in a way that could result in inconsistent syncing 
with iBank Mobile or even sync failure. The data has been repaired, but you will need to delete the sync settings 
for your mobile devices and reconfigure them to ensure that syncing works properly.
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How do I manage iBank documents?

An iBank document contains all of the financial information that you will use when working with iBank. This 
typically includes accounts and their transactions, categories, transaction templates, scheduled transactions, 
import settings, reports and budgets. Storing all of this information in a single file allows for greater portability 
as well as easier backups.

In the Finder, an iBank document looks like this:  

To create a new document:

Choose File > New iBank Document to open the new document assistant, then follow the prompts to 
create a file. For more information, see How do I create documents in iBank?, earlier in this chapter.

To open an existing document:

Choose File > Open and select a valid iBank 4 document, or double-click the document in the Finder. iBank 
will remember the last several documents you opened under File > Open Recent. You can clear this 
menu by choosing File > Open Recent > Clear Menu. When you launch iBank, it will automatically 
show the last document that was opened.
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Using multiple documents:

You can have multiple iBank documents open at one time, but most information cannot be transferred between 
them. Transactions can be moved from one document to another using copy & paste. You may want to create 
a separate document for accounts you don’t use anymore, or you may want to keep separate documents for 
you and your spouse. In most cases, however, only one iBank document is necessary for tracking your personal 
finances.

To save changes to a document:

iBank automatically saves the document whenever you make changes to your data. If you want to save manu-
ally, choose File > Save. If iBank is unable to save your changes for any reason, it will alert you to the error 
and advise you about how to fix the problem.

To save a copy of a document:

Open the document you want to copy and choose File > Save As. iBank will prompt you to enter a name 
for the new file and choose the location where you want to save it. The current document will be saved in the 
new location, and the original document will be left where it was.
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To learn the location of the current document:

Hold the Command key on your keyboard and click the title of the main window. A menu will appear showing 
you the path to your document in the Finder:

	  
This command is a feature of Mac OS X and will work the same way for all document-based applications. 

To delete a document:

Quit iBank and locate the document on your hard drive. Drag it to the Trash to delete it. The next time you open 
iBank, you will need to open a different document or create a new one.
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How do I use the main window?

The main window displaying your iBank document appears like this:

1

4
2

3

5
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The numbers on the image above correspond to the following program areas:

Toolbar1.	 : Contains shortcuts to many program functions, including the search box. Click the oval-shaped 
button at the top right corner to show and hide the toolbar.

Source list2.	 : Use this section to navigate through iBank’s main features, which are organized under different 
headings: accounts, websites, reports, and budgets. The “Manage” heading contains several additional fea-
tures: categories, securities, transaction templates, scheduled transactions, and import rules. The window 
contents displayed to the right of the source list change depending on your current selection.

Summary pane3.	 : Provides some basic information about your overall financial picture, including your net 
worth and upcoming scheduled transactions. This pane may also show a graph of your net worth over time, 
or be hidden from view.

Account register4.	 : When an account is selected in the source list, this part of the window shows a list of all 
the transactions in the account. Buttons below the register allow you to change the display to cover flow or 
statement view.

Transaction editor5.	 : When a transaction is selected in the account register, this editor appears automatically 
to allow you to view and edit the transaction details.

Many of these window panes can be resized by clicking and dragging the dividers between them. You can hide 
the summary pane by clicking the up/down arrow button  at the bottom of the window. When an account is 
selected in the source list, the balance of the account appears at the bottom right corner of the main window.
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How do I purchase and/or register iBank?

	 If you purchased and installed iBank through the Mac App Store, the software does not need to be regis-
tered. The information below only applies to the version of iBank that is available for download from the 
IGG Software website. 

Each time you open a document while iBank is running in trial mode, you will be prompted to purchase a 
license for the software.
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If you are not ready to purchase yet, click “Use Demo” to continue using iBank in trial mode. The software will 
run unrestricted for 30 days, after which the software will only run for 5 minutes before asking you to purchase a 
license.

To purchase iBank:

If you have not already registered iBank, you will be prompted to buy the software each time you open a docu-
ment. To purchase a license, click “Purchase Info” and then click “Secure Purchase.” Our secure online purchase 
window will appear:



50 Chapter 1: Getting Started

The top-right corner of the window will show you the license you are about to order. If you previously had a 
registered copy of iBank 3 running on your computer, iBank 4 should recognize your old license automatically 
and indicate that you are purchasing an upgrade (at a discount!). If you are not a registered user of a previous 
iBank version, iBank 4 will indicate that you are purchasing a full license.
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In the space provided, enter your contact information and credit card details. Once you have verified that 
everything has been entered correctly, click “Purchase” to have iBank connect to our online store and submit 
your order (you must be connected to the Internet to complete this step). Once the order has been accepted, 
iBank 4 will register itself automatically and cease to operate in trial mode. An alert will display your license code 
(you may wish to write this down) and confirm that your order was processed successfully. You will also receive 
a confirmation email within 24 hours containing a receipt of your purchase and a copy of your license code. Be 
sure to print a copy of this email and file it away for safe keeping!

	 If you prefer not to purchase iBank directly through the software, if you have problems with the built-in 
order form, or if you wish to purchase iBank together with other software as part of a package deal, please 
visit the order page on our website: https://secure.iggsoftware.com/store

To register iBank with an existing license:

If you are reinstalling iBank, or you obtained a registration code from the order page on our website, click “Enter 
License” in the purchase window (choose iBank > License if you don’t see the purchase window).

https://secure.iggsoftware.com/store
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Enter your name, email address, and registration code exactly as they appear in your confirmation email, paying 
attention to capitalization and other such details. If you have trouble with this step, see What if iBank doesn’t 
accept my code? in Chapter 12: Frequently Asked Questions. Upon successful entry of your registration info, the 
program’s trial limitations will be disabled and you can enjoy full use of the software, without disruption.

To verify your registration:

To review your registration details at any time, choose iBank > Registration Info. A window will 
appear displaying your registered name, email address, and license code. If you do not see “Registration Info” in 
the iBank menu, but instead see “License,” then your copy of iBank has not yet been registered.
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Money-back guarantee:

If you purchase iBank from our online store (either through the iBank application or our website), we include a 
30-day guarantee with your order. Feel free to register iBank and use it risk-free for up to a month. If you’re not 
satisfied with the software for any reason, simply contact usl (within 30 days of your purchase) at iggsoftware.
com/support, and we’ll refund your purchase in full.

http://www.iggsoftware.com/support/
http://www.iggsoftware.com/support/
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How do I customize the toolbar?

To customize the toolbar (located across the top of the main iBank window), Control-click anywhere in the 
toolbar area and choose “Customize Toolbar” from the contextual menu (or choose View > Customize Toolbar). 
The sheet that appears will allow you to add or remove toolbar items via drag & drop, and choose how these 
items appear (e.g. whether to show text or what size icons to use). Click “Done” when you have finished custom-
izing the toolbar.

You can show or hide the entire toolbar at any time by clicking the oval-shaped button at the top right corner of 
the main iBank window, or by choosing View > Hide Toolbar (this is standard for most Mac OS X applica-
tions).
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How do I use the summary pane and mini-graph?

The summary pane appears in the lower left corner of the main window, below the source list. It is designed to 
provide a summary of your accounts at a glance:

Money you have:•	  This represents your total assets, i.e. the total amount of cash in your visible accounts 
and any unrealized gains from your investments.

Money you owe:•	  This represents your total liabilities, i.e. the total amount of money you owe in credit card, 
line of credit, loan, and liability accounts, as well as any unrealized losses from your investments.

Total:•	  This represents your current net worth, determined by subtracting your liabilities from your assets.

The summary pane also lists the next three upcoming scheduled transactions. Click the small arrow button next 
to one of these to view and edit its details in the main “Scheduled Transactions” list.
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To show the net worth mini-graph:

Click the arrow button  at the top right corner of the summary pane to show a miniature net worth bar chart 
that depicts your net worth over the last six months. Each bar represents the total value of your accounts on 
today’s date in a past month.

Assets are drawn above the horizontal axis in green. The dark green portions represent cash assets (money you 
have on hand), while the light green portions represent security assets (shares you own that are worth more 
than what you paid for them). Liabilities are drawn below the axis in red. The dark red portions represent cash 
liabilities (money you owe), while the light red portions represent security liabilities (shares you own that are 
worth less than what you paid for them).

To change the currency used for the summary figures:

If you are using multiple currencies, a currency symbol will appear at the top left corner of the summary pane. 
Click this symbol to change the currency used for the figures in the summary pane and net worth mini-graph. 
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Amounts from accounts that use different currencies will be converted automatically using iBank’s current 
exchange rates.

To hide and show the summary pane:

Click the up/down arrow button  below the summary pane to toggle the display off and on.
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How do I get started with iBank? (Quick basics)

To use iBank to track your finances, you will want to set up accounts for each “real-life” account you have. That 
is, you will want an account for each of your credit cards as well as checking, savings, and investment accounts. 
Then, for each account you will want to record a transaction for each “real-life” transaction that occurs in the 
account. For example, if you receive a bank statement that shows two trips to the ATM and one point-of-sale 
(aka debit) purchase, then you will want to enter three transactions in iBank to match those.

We have mentioned transactions a lot, and for good reason - they are the core “unit” in iBank for effectively 
tracking your money in each of your accounts. In iBank, each transaction that results in money being taken out 
of your account (e.g. a withdrawal) should have a negative value and each transaction that results in money go-
ing into your account (e.g. a deposit) should be positive. So far, if you do as suggested and record a transaction 
in iBank for each transaction that occurs in real-life, iBank will track, to the penny, exactly how much money you 
have in each of your accounts.

This should be reason enough to use iBank: to know exactly, at any minute, the balances of all of your accounts. 
However, the real power of iBank comes into play when you start tracking where you are spending your money. 
For example, you might enter a transaction of -$20.00 and make the payee “Starbucks.” Although this informa-
tion is helpful, it would be better to categorize this transaction by associating it with a category like “Meals,” or 
“Coffee.” By assigning categories to your iBank transactions, you’ll be able to run robust reports to analyze your 
spending based on those categories. Categorizing your transactions will also allow you to set up budgets to 
help you plan ahead.

In a lot of ways, you can think of categories as accounts, and you can think of a transaction as always moving 
money from one account to another (fancy accountants will call this “double-entry bookkeeping”). So if you buy 
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dinner on your checking account debit card, you are essentially moving money from the checking account and 
adding money to the “Dining” category-type account.

In summary:

•	  Accounts mirror your real-life bank accounts.

•	  Transactions record deposits and withdrawals in your accounts.

•	  Categories track where your money comes from and goes to.

•	  Reports allow you to quickly analyze your spending habits.

Don’t forget - this is just an overview of iBank’s major features; much more awaits inside! Hopefully these prin-
ciples and guidelines will help you get started tracking your money and spending with iBank. Read on for more 
detailed information about using iBank’s various features.





Chapter 2: Accounts
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What are accounts all about?

Accounts in iBank are designed to mirror your real-life bank accounts. They are the first thing you need to set 
up in iBank after creating a document. All of your accounts are kept in the “Accounts” section of the source list, 
which appears on the left side of the main window and looks like this:

Account group

Accounts

Other features

Balances

Click the disclosure triangle next to “Accounts” to show and hide your accounts in the source list. Four pieces 
of information are displayed about each account: its type (as indicated by the icon shown), its name, and its 
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balance, which also indicates the default currency for the account. Double-click an account to open the popup 
account inspector, which will let you view and edit more information about the account. Accounts can be 
repositioned by clicking and dragging them to different places in the source list.

Changing account views:

When an account is selected in the source list, a set of buttons will appear at the bottom of the main window: 
 Each button represents a different account view - click one to show the corresponding view:

•	  Account register: Use this view to record transactions in the account and check its balance. For more 
information, see Chapter 3: Transactions.

•	  Cover flow view: Use this view to see the transactions in the account in a graphical style similar to 
Cover Flow in iTunes or the Finder. Transactions are represented by the images assigned to their categories, 
or by the images attached to them, and arranged in chronological order from left to right. Click on an 
image to bring that transaction to the front and view more information about it, or use the left and right 
arrow keys on your keyboard to browse back and forth. You can also click and drag the small blue dot 
appearing below the transactions to browse left and right. 
 
Below the transactions is a line graph representing the overall account balance over time. The graph ap-
pears in green as long as the balance is above the minimum balance specified for that account; it appears 
in red when the balance goes below the minimum. Transactions in cover flow view cannot be edited.

•	  Statement view: Use this view to make sure the account is properly balanced by reconciling its 
transactions with statements from your financial institution. For more information, see How do I reconcile 
my account with a bank statement? at the end of this chapter.
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Using multiple windows:

To open the register for a particular account in a separate window, select the account in the source list and 
choose View > Open In Separate Window. This will allow you to view and edit the transactions in that 
account while performing other tasks in the main window. Websites, reports, budgets, and items in the “Man-
age” section of the source list can also be opened in separate windows.

View options:

You may choose whether to display large or small icons in the source list. Choose iBank > Preferences, 
click the “Appearance” button, and check or uncheck “Use large source list icons” as desired.
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How do I add accounts?

The first thing to do with iBank after creating a document is to set up your accounts. Start by creating an iBank 
account for each financial account you have in real life (e.g. checking, savings, credit card, mortgage, 401k). You 
may also want to add a cash account to keep track of the money in your pocket.

Set up a new account:

To begin,click the “Add Account” button on the toolbar, or click the plus (+) button below the source list and 
choose “Add Account.” The new account assistant will open to help you create an account:
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On this screen, enter a name for the new account, choose the appropriate account type, and select a primary 
currency to use for the account. Click “Next” to continue to the next screen.

Record the interest rate:

If the account is a credit card or line of credit, iBank will ask you to enter the interest rate. The rate you enter will 
be used in reports that make calculations regarding your debts. Click “Next” to continue.

Choose a financial institution:

On this screen, if the account is not a loan, you will be asked to choose which financial institution you hold the 
account with. iBank will take a moment to download an updated list of financial institutions and display them in 
a list:
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Begin typing the name of your financial institution in the search box to narrow down the choices, then select 
the appropriate item from the list. You will notice that one of two download methods is displayed next to each 
financial institution:

Direct:•	  This indicates that direct downloads are offered by the institution. By entering a username and 
password provided by the institution (see below), you will be able to download new transactions into the 
account with one click. This is the most convenient way to update your accounts, but many institutions 
require a separate enrollment and charge a monthly fee for this service.

Web:•	  This indicates that downloads are only available through the institution’s website. iBank provides an 
integrated browser to streamline the process of downloading and importing transactions from the web 
into the account. This method is less convenient than direct downloads, but typically does not involve an 
enrollment process or additional fees.
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Some financial institutions offer both download methods; others only offer one. Choose whichever method you 
prefer to use. If your financial institution does not appear in the list at all, choose “Other Financial Institution” to 
manually configure web downloads. If your account is not held at a financial institution, click “This account is 
not held at a financial institution” to skip the download configuration process. The following sections outline the 
setup process for each option:

Direct download

If your financial institution offers direct downloads, the first thing you will need to do is contact the institu-1.	
tion and find out if enrollment is required to use “Direct Connect” with your accounts. Select your financial 
institution from iBank’s list and click “Next” to see a phone number you can call for information about 
enrollment:
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	 Some financial institutions require you to fill out a paper form and mail it in, then wait for a welcome packet 
to be mailed back to you. Some offer online enrollment, and some do not require enrollment at all. Some 
charge monthly fees for using direct downloads, and some do not. Before you begin using this service, be 
sure you are aware of your financial institution’s requirements and fees!

If you learn that the enrollment process will take some time, and you want to set up the account right away, 
click the “Back” button and then click “This account is not at a financial institution.” You can always configure 
direct downloads for your account at a later date.

Once you have completed the enrollment process (if required), your financial institution will provide you 
with a username and password to connect to its download server. These details vary with different institu-
tions; sometimes they will match your website login, sometimes your social security number will be used 
along with a PIN number, and sometimes they will be altogether different. Be sure to enter the appropriate 
login details for your financial institution in the spaces provided, then click “Connect” to continue. 
If a mistake is made in your login, or iBank is otherwise unable to reach the institution, you will be pre-
sented with an error message. If you are unable to connect after repeated attempts, please contact us at 
iggsoftware.com/support for assistance.

Once iBank is able to establish a connection, a list of accounts will appear:2.	

http://www.iggsoftware.com/support/
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Select the account that corresponds to the one you are setting up in iBank and click “Next.” iBank will check 
to make sure the account types match, and present you with a warning if they do not.

In the event of a mismatch, you will have the option to return to the beginning of the account setup pro-3.	
cess so that you can choose a different account type. The type that is displayed in the account list pictured 
above is the one you should choose.

When the account types are properly matched, iBank will automatically download all available transactions 4.	
for the account. Most financial institutions only allow direct downloads for a limited number of recent trans-
actions (often the last 6-12 months’ worth). In that case, iBank will check to see if your institution sent the 
account balance along with the transactions. If it did, iBank will automatically adjust your account balance 
accordingly. Otherwise, iBank will ask you to type in the current balance of the account.
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	 For investment accounts, enter the cash balance only. Do not include the market value of shares that are 
held in the account. In most cases, the cash balance should be 0. 

Once the download process is complete, the next screen will appear depending on the account’s 5.	 type:

Banking account:•	  iBank will show you the transactions that were downloaded, and ask you to assign 
categories to them. Categorize and/or split your transactions as appropriate, and iBank will learn from the 
changes you make so that it can help you categorize transactions automatically in the future.

When you are done assigning categories, click “Next” to continue.
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Investment account:•	  iBank will compare the account’s transaction history against your current security 
positions. If it finds that the cost basis is incomplete for any of your securities, you will be shown a list of 
those securities:

Click the “Print...” button to print a copy of the list for reference, then either click “I’ll Enter It Later” to ignore 
the discrepancies and complete the account setup, or click “Enter Cost Basis” to fill in the missing data:
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On this screen, iBank will present one security at a time. In the box at the top is shown the security’s name 
and ticker symbol, along with the number of shares for which the cost basis is missing. Fill in the fields 
below (date, number of shares, total cost, and commission) to record the cost basis for the missing shares, 
then click “Next” to continue to the next security. If you purchased multiple share lots at different prices, 
feel free to record multiple entries for the same security - iBank won’t move on to the next security until all 
shares have been accounted for. To skip a particular security, click the “Skip” button.

	 It pays to be meticulous when recording your cost basis! Missing or incorrect cost data can cause iBank to 
miscalculate the value of your investments when you generate reports. Request a copy of your transaction 
history from your brokerage, if necessary, to ensure that you are recording the correct information in iBank.
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Click “Next” after entering cost data for the final security to continue. iBank will automatically add “Buy” 
transactions to the account to update your cost basis and add an adjustment to correct the cash balance.

Web download

When you select a financial institution from the list that uses web downloads, iBank will show you a set of 1.	
instructions for downloading your account history:

Click the “Download” button to open iBank’s integrated browser - a new window will pop up and load the 2.	
login page on your financial institution’s website. Enter your login details to access the site, then down-
load all transactions for the account which you are currently setting up. For help using iBank’s integrated 
browser, see How do I use the built-in web browser to download transactions? in Chapter 5: Importing Data. 
When you click the button or link to download the transactions, iBank will automatically import the data 
into your new account and show you a screen that says, “Import Successful.” Click “Next” to continue.
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Alternatively, if you do not want to import your transaction history at this time, click “Skip This Step.”

iBank will then check to see if your institution included the account balance along with the transactions 3.	
that were downloaded. If it did, iBank will automatically adjust your account balance accordingly. If the bal-
ance was not included, or if you chose to skip the import process, iBank will ask you to type in the current 
balance of the account. Enter the balance, then click “Next” to continue.

	 For investment accounts, enter the cash balance only. Do not include the market value of shares that are 
held in the account. In most cases, the cash balance should be 0. 

Next, iBank will show you the transactions that were downloaded, and ask you to assign 4.	 categories to them. 
Categorize and/or split your transactions as appropriate, and iBank will learn from the changes you make so 
that it can help you categorize transactions automatically in the future.
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When you are done assigning categories, click “Next” to continue.

Institution not listed

If your institution is not on the list, but offers online banking tools, you can manually configure a web down-1.	
load connection. Select “Other Financial Institution” from the list of financial institutions and click “Next” to 
begin:
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On the screen that appears, enter the name of your financial institution and the URL of the login page on 2.	
the institution’s website:

Click “Next” to continue. iBank will show you a set of instructions for downloading your account history:3.	
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Click the “Download” button to open iBank’s integrated browser - a new window will pop up and load the 4.	
login page on your financial institution’s website. Enter your login details to access the site, then down-
load all transactions for the account which you are currently setting up. For help using iBank’s integrated 
browser, see How do I use the built-in web browser to download transactions? in Chapter 5: Importing Data. 
When you click the button or link to download the transactions, iBank will automatically import the data 
into your new account and show you a screen that says, “Import Successful.” Click “Next” to continue.

Alternatively, if you do not want to import your transaction history at this time, click “Skip This Step.”

iBank will then check to see if your institution included the account balance along with the transactions 5.	
that were downloaded. If it did, iBank will automatically adjust your account balance accordingly. If the bal-
ance was not included, or if you chose to skip the import process, iBank will ask you to type in the current 
balance of the account. Enter the balance, then click “Next” to continue.

	 For investment accounts, enter the cash balance only. Do not include the market value of shares that are 
held in the account. In most cases, the cash balance should be 0. 

iBank will then show you the transactions that were downloaded, and ask you to assign 6.	 categories to them. 
Categorize and/or split your transactions as appropriate, and iBank will learn from the changes you make so 
that it can help you categorize transactions automatically in the future.
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When you are done assigning categories, click “Next” to continue.

Account not held at a financial institution

If the account is not managed by a financial institution (e.g. a cash account or personal loan), click the “This 1.	
account is not held at a financial institution” button below the list of institutions. iBank will skip the down-
load configuration process for the account.
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	 This option can be used to postpone download configuration for any new account. You can always set up 
direct downloads at a later date by selecting the account in the source list and choosing Account > Set 
Up Online Account Access. To set up web downloads, double-click the account and enter a URL and 
Bank name in the pop-up account inspector.

The next screen will ask you to enter the balance of the account. In most cases, you’ll want to enter the 2.	
current balance and today’s date. If you want to start tracking the account from a particular date in the past, 
however, you can enter that date and the the amount of money that was in the account on that date. Keep 
in mind the following:

Credit cards, lines of credit, liabilities, and loan•	 s typically carry a negative balance. Take care to 
enter the balance with a minus sign (-) to indicate that it is negative, i.e. money you owe rather than 
money you have available to you.

For an investment account, only record the cash balance. Do not include the market value of shares •	
that are held in the account. In most cases, the cash balance should be 0.

Once you have entered a balance and a date, click “Next” to continue.

Configure loan settings:

If the account is a loan, you will not be asked to choose a financial institution. After you choose a name, type, 
and currency for the account, the two screens that follow will help you configure the loan settings. For more 
information about configuring loans, see How do I track loans in iBank? in this chapter.
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Finish the account setup:

Once the account configuration is complete, the new account will be added to the source list, and iBank will 
show you a “Congratulations” screen to notify you that the account setup was successful. If you added an invest-
ment or 401k account, and you do not have a Portfolio Summary report set up, iBank will create one for you 
automatically.
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How do I delete an account?

Select the account in the source list and click the minus (-) button at the bottom of the list, or choose Edit > 
Delete. A sheet will appear asking you to confirm that you want to permanently delete the account. All trans-
actions contained within the account will also be deleted. Any transfers in the account will be deleted, but the 
transactions in other accounts to which those transfers are connected will not be deleted (they simply will no 
longer show the account in their category fields).
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How do I edit account information?

Double-click an account in the source list or select it and choose View > Show Popup Inspector. The 
account inspector will open next to the account to show you the account details:

Add information or make changes as appropriate, then click the “Save” button to save your changes and close 
the account info pane, or click “Cancel” to discard them. Following is a description of the information displayed 
in the inspector:
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Name

The name of the account. Each account name must be unique, and cannot have the same name as a category. 
Any changes made to an account’s name will automatically update all transactions, reports, budgets, etc. that 
are associated with the account.

Cleared bal.

The total value of all transactions in the account that have their status set to “cleared” or “reconciled.” This figure 
is calculated automatically and cannot be edited directly.

Currency

The default currency used by the account. This setting was chosen when the account was first created, and 
cannot be changed.

Type

The type of account, such as Checking or Savings. This setting was chosen when the account was first created, 
and cannot be changed.

Downloads

The type of download connection that is configured for the account:

OFX (direct connect):•	  The account is configured for direct download. Click “Download” on the toolbar to 
download and import new transactions.
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Web browser:•	  The account is configured for web download. Click “Web Download” on the toolbar to open 
iBank’s built-in browser so that you can log in to the financial institution’s website to download and import 
new transactions.

Not set up:•	  The account is not configured for either download method. Choose Account > Set Up 
Online Account Access to configure direct download, or enter a URL in the field below to configure 
web download.

Include in total

Use this checkbox to mark whether or not an account’s balance should be included in the totals shown in the 
summary pane. If an account is not marked to be included in the total, its balance in the source list is displayed 
in gray.

Last import

When you import transactions, whether from a direct download, web download, or file import, this date is 
automatically updated to the current date. By adjusting this date manually, you can control which transactions 
are retrieved during a direct download (only transactions after the date specified will be downloaded).

Min. bal.

The minimum balance allowed for the account, or the credit limit for credit cards and other accounts that track 
debt. For personal reference only.

Int. rate

The interest rate associated with the account. For credit cards, this rate is used when calculating figures in debt/
liability reports. For loans, the interest rate should be entered in the loan settings instead.
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Note

Any additional information you want to record about the account. For personal use only.

URL

The web address of the login page for the financial institution where the account is held. Clicking the “Web 
Download” button on the toolbar will open this page using iBank’s built-in browser. When a URL is present 
in this field, iBank will automatically create an item in the “Website” section of the source list for that address. 
Removing the URL will delete the the item from the source list.

Bank

The name of the financial institution where the account is held. This name is used to look up the financial insti-
tution’s contact information in Address Book when printing checks.

Account #

The account number for the account. iBank prints this number in MICR code along the bottom of checks that 
use the “Custom” template.

Routing #

The routing number for the account. iBank prints this number in MICR code along the bottom of checks that use 
the “Custom” template.
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What are the different account types?

iBank offers a number of different types to choose from when creating an account. By selecting the appropriate 
types, your iBank accounts can be set up to mirror your real-life bank accounts. Here is an overview of each type 
and what it is used for:

 Checking

Used to track deposits and withdrawals from a typical bank checking account.

 Savings

Used to track deposits and withdrawals from a typical bank savings account.

 Credit Card

Used to track charges and payments made against a credit account. When using a credit card account, be sure 
to record its interest rate so that iBank can generate more accurate reports on your debt. Charges made to the 
account should be entered as negative transactions; payments should be positive (either deposits or transfers 
from other accounts). The balance of a credit card account should almost always be negative or zero - a positive 
amount would indicate a credit on the account due to overpayment.
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 Investment

Used to track purchases and sales of stocks, bonds, and mutual funds, as well as other security-related transac-
tions. Investment accounts should be set up to reflect your brokerage accounts, not specific funds. The balance 
of each investment account (shown in the source list) includes the cash value of the account in addition to the 
market value of its securities. For more information about tracking investments, see Chapter 6: Investments.

 401k

Used to track purchases and sales of stocks, bonds, and mutual funds in a 401k retirement account, as well as 
other security-related transactions. 401k accounts should be set up to reflect your brokerage accounts, not spe-
cific funds. The balance of each 401k account (shown in the source list) includes the cash value of the account in 
addition to the market value of its securities. For more information about tracking investments, see Chapter 6: 
Investments.

 Money Market

Used to track deposits and withdrawals from a typical bank money market account.

 Line of Credit

Used to track charges and payments made against a line of credit. When using a line of credit account, be sure 
to record its interest rate so that iBank can generate more accurate reports on your debt. Charges made to the 
account should be entered as negative transactions; payments should be positive (either deposits or transfers 
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from other accounts). The balance of a line of credit account should almost always be negative or zero - a posi-
tive amount would indicate a credit on the account due to overpayment.

 Asset

Used to track the value of an object, or money that is owed to you. For example, if you own a house, an asset ac-
count can help you track appreciation and depreciation on the equity that you hold in your home. When using 
an asset account, record the base value of the asset as a deposit into the account, then enter gains or earnings 
as positive transactions and losses as negative transactions.

 Liability

Used to track debt or money owed for which you do not make regular payments. When using a liability account, 
record the initial amount owed as a withdrawal from the account, then enter any payments made against the 
debt as deposits or transfers into the account.

 Loan

Used to track loans for which you maintain a payment schedule, such as a mortgage, auto loan, or student loan. 
Payments made towards the loan should be recorded as deposits or transfers into the account. For more infor-
mation about configuring loan settings and scheduling automatic payments, see How do I track loans in iBank? 
later in this chapter.
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 Cash

Used to track the spending of cash you withdraw from a bank account (or credit card, in the case of a cash 
advance). Whenever you take cash out of an account (e.g. an ATM withdrawal), transfer the money to your newly 
created cash account. Then, whenever you spend the cash on something, create a transaction in the cash ac-
count for the appropriate amount and set the other attributes of the transaction as appropriate.
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How do I configure direct download for my account?

iBank features the ability to connect directly to many financial institutions via the Internet and update your 
accounts automatically. Transactions are downloaded using the Open Financial Exchange (OFX) protocol, which 
is not supported by all financial institutions (and some may charge a fee for this service). We do not guarantee 
direct download access for all accounts.

To confirm availability:

First, check our website to see if your financial institution is on our direct download list: http://www.iggsoftware.
com/ibank/ofx_info.php. If your institution is supported, the first thing you will need to do is contact the institu-
tion and find out if enrollment is required to use “Direct Connect” with your accounts.

	 Some financial institutions require you to fill out a paper form and mail it in, then wait for a welcome packet 
to be mailed back to you. Some offer online enrollment, and some do not require enrollment at all. Some 
charge monthly fees for using direct downloads, and some do not. Before you begin using this service, be 
sure you are aware of your financial institution’s requirements and fees!

To set up online account access:

Once you have completed the enrollment process (if required), your financial institution will provide you with a 
username and password to connect to its download server. These details vary with different institutions; some-
times they will match your website login, sometimes your social security number will be used along with a PIN 

http://www.iggsoftware.com/ibank/ofx_info.php
http://www.iggsoftware.com/ibank/ofx_info.php
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number, and sometimes they will be altogether different. Be sure to have the appropriate login details on hand 
before beginning the setup process.

If you are creating a new account, iBank will guide you through the download configuration process automati-
cally. To enable access for an existing account, select the account in the source list, make sure you are connected 
to the Internet, and choose Account > Set Up Online Account Access. iBank will update its list of 
supported financial institutions and then present the following sheet:

Begin typing the name of your financial institution in the search box at the top of the sheet to narrow down 
the list of available options. When you locate the correct institution, select it and click “Continue Setup.” You will 
then be asked for the username and password required to access your account online - enter the login details 
provided by your financial institution.
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If a mistake is made in your login, or iBank is otherwise unable to reach the institution, you will be presented 
with an error message. If you are unable to connect after repeated attempts, please contact us at iggsoftware.
com/support for assistance.

If multiple accounts are available for download, you will be asked which one to use. Select the account that 
corresponds to the iBank account you are configuring. iBank will then attempt to connect to your financial 
institution. After establishing a successful connection, iBank will give you the option to “Download Transactions 
Now,” if you wish. Click this button to update your account, or else click “OK” to wait for another time.

	 Transactions are downloaded using the Open Financial Exchange (OFX) protocol, which is not supported by 
all financial institutions (and some may charge a fee for this service). We do not guarantee direct download 
access for all accounts.

To download transactions into your accounts:

See How do I update my accounts using direct download? in Chapter 5: Importing Data for more information.

To disable online access:

If you no longer want to use the direct download feature with a particular account, select that account in the 
source list and choose Account > Disable Online Account Access. The account will no longer be 
configured for direct download. You may reestablish online access for that account at any time.

http://www.iggsoftware.com/support/
http://www.iggsoftware.com/support/
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How do I track loans in iBank?

iBank can help you keep track of money you that borrow for large expenses like a mortgage, auto purchase, 
or college tuition, and help you analyze how payments you make toward those loans are allocated. In order to 
track a loan and its associated payments, create a new account and choose the “Loan” type. On the next screen, 
iBank will help you to configure the loan settings:

Enter the following details according to the terms of your loan:

Lender’s name:•	  The name of the lender. The name you enter will be used as the payee for your loan pay-
ments.

Loan balance:•	  The current balance of the loan principal (the amount remaining to be paid, as of today).
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Total # payments:•	  The total number of payments scheduled over the loan’s entire repayment plan.

Min. payment:•	  The minimum payment required per term by your lender, including principal and inter-
est, but excluding additional fees (such as property tax or mortgage insurance). iBank will calculate this 
amount automatically based on the balance, number of payments, and interest rate you enter. If you 
manually adjust the payment, iBank will use the amount you enter.

Interest rate:•	  Enter the loan’s current interest rate as a percentage. If the rate is variable, check the “Vari-
able rate loan” box. When the interest rate changes, you will need to adjust the loan settings accordingly 
(see below for more information).

Payment frequency:•	  How often payment is required on the loan.

Canadian loan:•	  By default, interest is compounded monthly. Check this option to have the interest com-
pounded every 6 months (semi-annually) instead.

Once the details on this screen have been properly entered, click “Next” to continue. The next screen will help 
you to configure a scheduled transaction that will allow iBank to record your loan payments automatically when 
they come due:
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If you do not want to set up scheduled payments at this time, click “Skip This Step” to complete the account 
setup. Otherwise, proceed by configuring the following options:

Next payment date:•	  The date on which your next payment is due.

Interest category:•	  Your loan payments will be tracked as split transactions, with one part directed towards 
the principal and the other towards interest. Choose here the category that you want to use to track the 
interest portion of each payment.

Additional principal:•	  If you regularly pay more than the minimum payment, with the extra amount 
directed towards the loan principal, enter the extra amount here. The total payment at the bottom of the 
window will update accordingly.

Additional payments:•	  If your loan payment includes additional fees, such as taxes or surcharges, click the 
plus (+) button to add them to this list. Click the left side of each item in the list to choose a category for 
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that item, and double-click the right side to enter the payment amount. Select an item and click the minus 
(-) button to remove it from the list.

Total payment from:•	  Choose which account should be used to make payments on the loan. iBank will 
automatically generate a scheduled transaction to transfer funds from the specified account into the loan 
account. To the right is shown the total amount of the next payment, based on the details you entered 
above.

Once you finish configuring the loan and your payment amount is accurate, click “Next” to complete the ac-
count setup. iBank will automatically create a scheduled transaction based on the details you entered. To view 
this transaction, select “Scheduled Transactions” in the “Manage” section of the source list:

	 Scheduled loan payments cannot be edited directly in the same manner as other scheduled transactions. 
Since they are tied to loan accounts, any adjustments to the payments must either be made through the 
loan settings before the payments are posted, or to the transactions in the loan accounts after the pay-
ments have been posted.

To review and edit loan settings:

Select a loan account in the source list and choose Account > Show Loan Settings. The first two tabs 
on the sheet that appears correspond to the two setup screens described above. Feel free to make any changes 
necessary to the loan settings (apart from changing the original balance, which is not permitted) and then close 
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the sheet. If you have a scheduled payment set up for the loan, iBank will automatically update it to reflect the 
changes you made.

To adjust the interest rate on a variable rate loan:

In iBank 4, the interest rate on a variable rate loan can be changed at any time. You do not need to record 
changes in the rate ahead of time - simply adjust the rate whenever it changes. In the loan settings sheet, click 
the “Info” tab to view the loan terms. Make sure the “Variable rate loan” option is checked, then click “Change 
Rate” to adjust the interest rate:

Type in the new minimum payment amount, including principal and interest but excluding additional fees, 
and the new interest rate, then click “OK.” iBank will update the loan’s scheduled payment automatically (if one 
exists) as well as the loan payoff schedule.

	 If you type in a payment amount that is smaller than the interest due, iBank will alert you that the payment 
is too small and show you the minimum allowable payment. Be sure you are making a payment that is 
higher than what is displayed; payments at that rate will only service your debt and not reduce the amount 
you owe.
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To add or remove a scheduled loan payment:

In the loan settings sheet, click the “Payment” tab to view the scheduled payment options. To have iBank create 
a scheduled payment automatically (if you skipped this step during the account setup, for example), configure 
the options as needed and check “Make Scheduled Transaction.” To delete an existing scheduled payment for 
the loan, uncheck “Make Scheduled Transaction.” The corresponding transaction in iBank’s scheduled transac-
tion list will be deleted automatically.

To view your payoff schedule:

In the loan settings sheet, click the “Payoff Schedule” tab. Here you will see a table listing the number of pay-
ments remaining before the loan is paid in full, the amount of each payment that is directed towards the loan 
principal and interest, and the balance that remains after each payment. This table updates automatically every 
time you view the loan settings, and will take into account all transactions that are recorded in the loan account, 
regardless of whether they were created by the loan’s scheduled payment.

	 It is not possible to print or save this schedule directly. Instead, create a debt/liability report and click the 
minimum payment to view the details of the schedule. You can then print or save the report as needed. 
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How do I use smart accounts?

 Smart accounts are special accounts that are used to dynamically group transactions based on criteria 
you specify. They do not necessarily reflect real-life bank accounts, rather they use customizable rules to compile 
and display transactions from multiple iBank accounts. Smart accounts work in very similar fashion to smart 
playlists in iTunes, or smart albums in iPhoto.

To create a smart account:

Choose Account > New Smart Account, or click the plus (+) button below the source list and choose 
“Add Smart Account.” Using the sheet that appears, give the smart account a name, then click the ‘+’ and minus 
(-) buttons, respectively, to add and remove the rules that will determine which transactions are displayed in the 
account:
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This example will show all transactions in the account named “Checking” that have dates within 2009 and are 
assigned to either the “Rent” or “Utilities” category.

Smart account rules:

Any/All of the following are true:•	  If you choose “Any” as the option for this rule, all transactions that 
match at least one of the rules that follow will be displayed in the smart account. If you choose “All,” only 
transactions that match all of the rules that follow will be displayed. The first instance of this rule cannot be 
removed. Additional “Any/All” rules can be added by holding the Option key and clicking the ‘...’ button next 
to one of the existing rules. This will allow you to create more complex rule hierarchies (see the example 
pictured above).

Date:•	  Use one or more date rules to specify a timeframe for transactions to include. “Is less than” and “is 
greater than or equal to” allow you to specify exact dates; “within” and “before” use ranges that automati-
cally adjust based on the current date.

Transaction payee:•	  Use this rule to display transactions that include or exclude a specified payee.

Transaction memo: •	 Use this rule to display transactions that contain or do not contain a specified word or 
phrase in their memo fields.

Amount: •	 Use this rule to include transactions matching a specific amount, or use several of them to specify 
a range of values to include.

Category:•	  Use this rule to include or exclude transactions that are assigned to a specific category. Sub-
categories of the specified category are not included; a separate rule for each sub-category must be cre-
ated. If a split is assigned to the category specified, the entire split transaction will be included in the smart 
account.

Account:•	  Use this rule to include or exclude transactions recorded in a particular account.
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Type:•	  Use this rule to include or exclude transactions of a specific type.

Rules are executed in the order in which they appear. To illustrate, the example above will first look at transac-
tions in the account “Checking,” then it will narrow those down to ones that are dated on or after January 1, 
2009. Next it will eliminate any dated on or after January 1, 2010. Finally, it will check the transactions that 
remain to see what categories they are assigned to, and eliminate any that are not assigned to either “Rent” or 
“Utilities.”

When you are done configuring the smart account rules, click “OK” to add the new smart account to the source 
list. The account will dynamically update to show you all transactions that match the rules you defined when the 
account was created.

Editing smart accounts:

To edit the rules for an existing smart account, double-click it in the source list, or select it and choose View > 
Show Popup Inspector. Make any changes necessary, then click “Save.” iBank will automatically update the 
account’s register to reflect the changes.

To delete a smart account:

Select the account in the source list and click the minus (-) button below the source list, or choose Edit > 
Delete. A sheet will appear asking you to confirm that you want to permanently delete the account. The 
transactions displayed in the smart account will not be affected.
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Limitations of smart accounts:

Transactions cannot be created in smart accounts, but you may edit or delete transactions in them. Any changes 
you make affect the transactions in their original accounts. Smart accounts cannot be used in reports or bud-
gets. They do not show balances in the source list, nor do they affect the totals displayed in the summary pane. 
Smart accounts do not keep running balances like other accounts - instead, they show the name of the account 
to which each transaction belongs.

Split transactions are not broken apart for inclusion in smart accounts. If a smart account rule matches one part 
of a split transaction, the entire transaction will be included. “Transaction memo” and “Amount” rules do not 
search individual split items, but “Category” rules do.
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How do I group accounts?

 Account groups can be created to organize your accounts hierarchically.

To create an account group:

Click the plus (+) button below the source list and choose “Add Account Group,” or choose Account > New 
Account Group. Enter a name for the group in the sheet that appears and click “Create Account Group” to 
add it to the source list. Use drag & drop to move accounts in and out of the group. Click the small disclosure 
triangle next to the group’s icon to hide or display the accounts within.

Account group

Enclosed accounts

Other accounts

Total balance

The amount that displays in the source list, below the group’s name, represents the total balance of all the ac-
counts within the group. Selecting the account group itself will display transactions from the enclosed accounts 
in the register. Transactions cannot be added when a group is selected, but you can edit and delete  transac-
tions. Any changes you make in the register will be applied to the transactions in their original accounts.
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Like smart accounts, account groups do not show a total in the bottom-right corner of the main window, nor do 
they keep running balances in the register. In place of the running balance, the name of the account to which 
each transaction belongs is displayed.

	 When you add accounts that use different currencies to a group, the group’s total is displayed in the cur-
rency indicated in the summary pane. Any accounts that use a different currency will have their balances 
converted to the group’s currency (using iBank’s current exchange rates) before they are added to the total.

To delete an account group:

Select the group and click the minus (-) button at the bottom of the source list, or choose Edit > Delete. A 
sheet will appear asking you to confirm that you want to permanently delete the group. All accounts contained 
within the group will also be deleted. To remove accounts from the group before deleting it, drag and drop 
them to another location in the source list.
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How do I hide unused accounts?

If you have old or unused accounts in iBank that you no longer want cluttering up your source list, but you 
don’t want to delete them entirely, you can easily hide them from view. Choose Account > Show Account 
Manager and the following sheet will appear:

Check the box next to any accounts you want to hide, and 
they will no longer appear in the source list. The balances 
of hidden accounts are not counted in the totals displayed 
in the summary pane. Hidden accounts are not available 
for use when you create new transfers, scheduled transac-
tions, budgets, or reports. Shares from hidden investment 
accounts are not counted in investment reports.

Uncheck an account in the account manager to show it in 
the source list again. You can return to the account man-
ager at any time to show and hide your accounts.

	 Toggling an account group will show or hide all accounts inside the group. It is not possible at this time to 
show or hide individual accounts within a group. 

If you want to hide the checked accounts from the source list, but still want to be able to analyze the data in 
those accounts using reports and smart accounts, check “Transactions in hidden accounts appear in reports and 
smart accounts.”
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How do I manage accounts in multiple currencies?

One of iBank’s more advanced features is the ability to manage accounts in different currencies and track 
exchange rates automatically. By default, iBank sets your main currency to match the one you have specified in 
System Preferences, under the “Formats” tab in the Language & Text pane:

System currency
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To specify which currency to use with a particular account:

When you add an account to the current document, iBank prompts you to choose a currency to use with the 
account. Be sure to choose the appropriate currency, because this setting cannot be changed after the account 
has been created.

Each account shows its balance, in its own currency, in the source list. The summary table and net worth chart 
at the bottom of the source list automatically convert all figures to a single currency (based on iBank’s current 
exchange rates: see below). To select which currency to use, click the currency symbol to the left of the Sum-
mary/Net Worth title:

To view and edit the list of available currencies:

Choose Account > Show Currencies to view a list of all currencies that are used by your accounts:
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To add a currency to the list, click the “+ Currency” button and then choose which currency you want to add. You 
can change the name, code, or symbol associated with any currency by double-clicking the field you want to 
edit:

Name: •	 Enter the full name of the currency for easy reference. This name is displayed in the drop-down 
menu shown when you are creating new accounts.

Code:•	  Enter the Alpha-3 code used to identify the currency on the market. It is important that you enter a 
valid code here, or iBank will not be able to retrieve exchange rates automatically for that currency. To view 
a complete list of supported currency codes, visit Yahoo! Finance at http://finance.yahoo.com/currency.

Symbol:•	  Enter the symbol typically used with values displayed in this currency. Currency symbols appear 
in various places throughout iBank, including the drop-down menu next to the totals in the summary 
pane.

http://finance.yahoo.com/currency
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Rate:•	  The exchange rate cannot be edited directly. The figure displayed on each line represents a compari-
son between the currency on that line and the currency specified for the summary table and net worth 
chart in the source list (see above). To update the exchange rates, click “Download Rates.”

To update the exchange rates for your currencies:

First, make sure you are connected to the Internet. Choose Account > Download Currency Ex-
change Rates, or open the list of currencies (see above) and click the “Download Rates” button. iBank will 
connect to Yahoo! Finance and download updated exchange rate information automatically.

To remove a currency from iBank:

Choose Account > Show Currencies to open the list of currencies, select the item you want to remove, 
and click the “- Delete” button. You cannot delete a currency that is used by any accounts or transactions.

To apply an exchange rate to an individual transaction:

Sometimes a transaction is conducted in a currency that is different from the currency of the account affected 
by the transaction. For example, you might use a USD credit card to purchase coffee in Paris, where the charge 
is made in EUR. To record this transaction, create a charge in the credit card account and enter the withdrawal 
amount of the transaction in either USD or EUR. Since you are using multiple currencies, the currency popup 
button will automatically be shown in the transaction editor. Use this popup to choose Euro as the transaction’s 
currency, at which point the Exchange Rt and Foreign fields will be enabled:
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By default, the exchange rate is set to 1 (indicating no conversion) and the Foreign field shows the same amount 
that you entered in the Withdrawal field. To apply a conversion, adjust the exchange rate or the amount in the 
Foreign field. To indicate a negative amount in the Foreign field, enclose the amount in parentheses, e.g. ($5.50). 
The other figure will automatically adjust itself based on your change and the amount in the Withdrawal field.

In the example pictured above, a cup of coffee was purchased for 2.00 Euro through an account that uses U.S. 
Dollars. An exchange rate of 1.5 was applied, so the final withdrawal (in USD) was 3.00.

Transferring money between accounts with different currencies:

When you transfer money between accounts with different currencies, you may wish to apply a conversion so 
that the correct amount is recorded in each account. Add a transaction to an account, set its type to “Transfer,” 
enter the amount you want to transfer, and specify the name of the receiving account in the Category field. Click 
on the currency symbol in the transaction editor and choose the currency used by the account you entered in 
the Category field. The Exchange Rt, Foreign, and Currency fields will appear so that you can apply a currency 
conversion.

By default, the exchange rate is set to 1 (indicating no conversion), the Foreign field shows the amount of the 
transfer in the original currency, and the currency field shows that of the original transaction. To apply a conver-
sion, adjust either the exchange rate or the amount shown in the Deposit or Withdrawal field (which uses the 
current account’s currency). The Foreign field will automatically adjust itself based on the changes you make to 
the exchange rate and transaction amount.
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How do I reconcile my account with a bank statement?

If you are in the habit of comparing your own records against your bank’s on a regular basis, iBank makes it easy 
to track the statements your bank sends in the mail. Create a virtual statement in iBank to mirror the printed 
copy your financial institution sends periodically.

When you receive a statement from your financial institution, select the iBank account you want to reconcile, 
then click the  button below the account register or choose Account > Reconcile with Bank 
Statement. The statement view will appear onscreen:



114 Chapter 2: Accounts

Displayed across the top of the screen are all the statements you have previously reconciled. The middle section 
displays information about the current statement, and the bottom section shows a list of transactions available 
for reconciling.

To create a new statement:

Click the plus (+) button at the top right corner of the statement view. The following sheet will appear so that 
you can configure the new statement:

Open balance:•	  Enter the account’s balance as of the beginning of the statement period (as indicated 
on the printed statement). By default, iBank shows the close balance from the previous statement. If you 
are reconciling an account for the first time, set the open balance to 0.00 in order to accommodate the 
account’s initial balance adjustment. For credit cards and other liabilities, be sure to enter the balance as a 
negative number.
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Open date: •	 Enter the starting date for the statement period. By default, iBank shows the close date of the 
previous statement.

Close balance:•	  Enter the account’s balance as of the end of the statement period (as indicated on the 
printed statement). By default, iBank shows the balance recorded one month after the previous statement’s 
close date. For credit cards and other liabilities, be sure to enter the balance as a negative number.

Close date:•	  Enter the ending date for the statement period. By default, iBank shows a date one month 
after the previous statement’s close date.

Populate statement with:•	  Choose “No Transactions” to reconcile the statement by hand. Choose “Cleared 
Transactions” to have iBank automatically change all cleared transactions within the statement period to 
reconciled, but leave uncleared transactions untouched so that you can reconcile them manually. Choose 
“All Transactions” to have iBank automatically mark all transactions within the statement period as recon-
ciled.

Once you have configured the statement settings, click “OK” to create the statement. You will see a new icon 
appear in the top section of the statement view, labeled with the month and year of the statement’s close date. 
Assuming the statement is not yet properly balanced, the amount missing will be displayed there as well.

To reconcile a statement:

Select the statement you want to reconcile in the top section of the statement view, then take a look at the 
middle section. Here you can see summary information about the statement, which will help you to reconcile 
the transactions shown in the bottom section:
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Deposits:•	  The total value of all transactions on the statement that are marked as reconciled and have 
amounts in the “Deposit” column.

Withdrawals: •	 The total value of all transactions on the statement that are marked as reconciled and have 
amounts in the “Withdrawal” column.

Sum: •	 The total value of all reconciled transactions on the statement, equal to Deposits plus Withdrawals.

Missing:•	  The difference between the value of the reconciled transactions (the Sum shown above) and 
the expected statement total (the Total shown to the right). To balance the statement, this figure must be 
brought to zero.

Open/Close balance/date: •	 These fields show the same information you entered when you created the 
statement (see above). Feel free to adjust them as necessary.

Total:•	  The expected value of the statement once all transactions are properly reconciled. Equal to the 
difference between the Close balance and Open balance shown above.

	  
Here, as elsewhere, negative values are enclosed in parentheses, e.g. ($325.51). 

To reconcile the statement, check off the transactions listed in the bottom section of the statement view by 
clicking the circles along the left side of the list. By default, the register shows all transactions that fall within the 
statement period, as well as any unreconciled transactions:
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Compare the transactions that appear in the register to those on the printed statement from your financial 
institution. When a transaction matches, click the circle next to it to mark it with a green check . You will 
notice that the status of the transaction changes to the balance icon  when the green check is present, indi-
cating that the transaction has been reconciled. If you need to edit a transaction, select it and make the required 
changes just as you would in a normal account register. You can also add and delete transactions directly in the 
statement view if necessary - just keep in mind that any changes you make here will show up in the account 
register as well.

Each time you mark a transaction as reconciled, the summary figures in the middle section of the statement 
view update automatically. At the top of the register, you can see how many reconciled transactions are present 
and how many unreconciled transactions (cleared and uncleared) still remain. Continue marking transactions as 
reconciled until the “Sum” figure in the summary section matches the “Total” figure, and “Missing” is zero. When 
you have successfully reconciled the statement, a green check  will appear on the statement’s icon at the 
top of the statement view.
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To adjust your account balance to cover a discrepancy:

Sometimes, after you have finished reconciling the transactions in iBank with those on your printed statement, a 
discrepancy may still exist between your reconciled sum and the statement total. If you check and double-check 
your records, and just can’t seem to find a transaction that was overlooked, you can enter a balance adjustment 
to sync up your records. Choose Account > Adjust Balance, and the following sheet will appear:

Enter the desired account balance and click “OK.” A transaction similar to this one will be added to the state-
ment:

Click on the circle to the left of the adjustment transaction to mark it with a green check, and your statement 
should now be properly reconciled.

When you finish reconciling a statement:

Once the “Sum” figure in the summary section matches the “Total” figure, and “Missing” is zero, the statement is 
successfully reconciled. At that point, a green check  will appear on the statement’s icon at the top of the 
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statement view. To complete the reconciliation process, click the padlock image in the summary section in the 
middle of the statement view:

The statement will lock, and all unreconciled transactions will be removed from the register. You may return 
to the statement view at any time to review the statement and its reconciled transactions, but you will not be 
permitted to make changes to the statement without first clicking on the padlock to unlock it. To print a list of 
reconciled transactions on the statement, choose File > Print.

	 If you attempt to edit a reconciled transaction in an account register, iBank will warn you that the transac-
tion appears on a statement before it will let you make changes. If you ignore the warning and adjust the 
transaction amount, the statement on which the transaction was reconciled will no longer be balanced.

To delete a statement:

Select the account from which you want to delete the statement, and click the statement view button below 
the account register. At the top of the screen, select the statement you want to remove, then click the minus (-) 
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button to the right. iBank will ask for confirmation before deleting the statement. Any transactions that were 
reconciled on the statement will have their status changed to “cleared.”
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What are transactions all about?

Transactions are what iBank uses to store the bulk of your financial data. Transactions are kept under each 
account you set up, and are intended to represent deposits, withdrawals, transfers, and any other exchange of 
money that takes place in real life and would normally appear on a bank statement. Some examples of transac-
tions that can be tracked in iBank are a visit to the ATM, an online account transfer, a grocery store purchase 
made with a debit card, and a check written to pay a bill.

Viewing the account register:

When you select an account in the source list, its transactions are displayed in a table to the right. If you see a 
different account view, click the  button at the bottom of the main window to show the register:

The account register is designed to look similar to the kind of check register that you keep with your check-
book. Each pair of lines represents a single transaction. Clicking on a transaction reveals additional information 
about that item and allows you to modify the transaction details using the transaction editor:
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When you scroll the register up and down, iBank will display the date of the transaction at the top of the register 
to help you quickly locate the transaction you are looking for. If you are sorting the register by the values in a 
different column (see below), the information from that column will be displayed instead.

Opening multiple windows:

To open the register for a particular account in a separate window, select the account in the source list and 
choose View > Open In Separate Window. This will allow you to view and edit the transactions in that 
account while performing other tasks in the main window.

Sorting the register:

At the top of the register is a series of column headers that identify the information shown in each transaction. 
To sort the register, click a column header; the transactions will automatically sort according to the values in 
that column. For example, if you want to sort your transactions chronologically, click “Date.” Click the column 
header a second time to reverse the direction of the sort. Sorting can also be controlled by using the View > 
Sort Transactions By menu.

	 The balance column will always calculate its figures in chronological order, regardless of how your transac-
tions are sorted. If you want the balance column to display in logical fashion, be sure to sort your transac-
tions according to date.

When the account register is sorted chronologically, transactions that share the same date can be rearranged by 
dragging and dropping them in whatever order you prefer.
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Showing colors in the register:

Transactions that have categories assigned to them can be displayed in the register with background colors that 
correspond to the category colors. If you want iBank to display these colors in the register, choose iBank > 
Preferences, click the “Appearance” button, and check the “Show category background colors” option. When 
you enable this option, the category colors will also be used for pie charts on Income & Expense reports.

Printing the register:

Choose File > Print and click the “Print” button to print out a report showing the details of the transac-
tions in the current account register. You can also use the “PDF” button in the print window to save the report to 
a PDF file.
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How do I add, edit, and delete transactions?

To add a transaction:

Select an account in the source list and click the plus (+) button at the bottom of the account register (or choose 
Transaction > Add New Transaction). A new transaction will appear in the register with the transac-
tion editor showing:

Different fields are shown in the editor depending on whether the selected account is used for banking or 
investments, and depending on the type assigned to the transaction. The headers displayed at the top of the 
account register show what information is contained within each field:

The editor can be used to record basic transaction properties such as the type and number, date, payee, memo, 
withdrawal and deposit (for a descriptive list of all properties, see the next section in this chapter). It can also 
be used to categorize transactions, record account transfers, enter investment details, split transactions, track 
cleared/reconciled status, attach files, and record currency information (refer to the sections about these topics 
for more information).

To make changes to the selected transaction, click the field you want to edit, or use the Tab key to cycle through 
the available fields. Make any adjustments that are necessary, and you will see two buttons appear in the editor: 
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“Save” and “Revert.” Click “Save” (or press Return on your keyboard) to keep the changes you entered, or click 
“Revert” (or press Escape on your keyboard) to discard them and return the transaction to its previous state. If 
you select a different transaction in the register while unsaved changes are present, iBank will pop up an alert to 
you whether to save or discard the changes.

	 Power User Tip: To enter transactions as efficiently as possible, use keyboard shortcuts. You can add new 
transactions by typing Cmd-N on your keyboard, then use the Tab key to quickly cycle through each field 
and enter the transaction details. Press Return to save the new transaction, type Command-N for another 
new transaction, and continue on in this manner.

Autofill

When you begin typing a payee, iBank will automatically suggest names that you have entered previously, 
based on its list of transaction templates. As you are typing, a drop-down list will appear showing the payees 
that match what you are typing:

In this example, only the letter ‘L’ was typed. Use the mouse to click one of the names, or use the arrow keys 
to select one and then press the Tab or Return key. iBank will fill in several of the transaction details (type, cat-
egory/splits, and amount) based on the template associated with that payee (these fields will be shaded yellow 
as a result). If you don’t want to accept a suggestion, simply ignore it and continue typing.
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In the same manner, iBank also suggests categories as you type. To quickly enter a sub-category, type the first 
few letters of the parent category (so that the category name is highlighted for autofill), then type a colon (:). 
You can then type the first few letters of the sub-category; when the correct sub-category name is suggested, 
press the Tab or Return key to accept it. If you do not want to use one of the existing categories, ignore the 
suggestions that appear and type in a unique category name. When you save the transaction, iBank will prompt 
you to create a new category based on what you typed in.

	 If you can’t recall the name of the payee or category you want to enter, simply press the down arrow key on 
your keyboard before beginning to type - a menu will pop up showing you all the available options. 

Splits

To view the split items associated with a transaction, click the small disclosure triangle to the left of the “Cat-
egory” field:

Here you can add, remove, and modify items that are part of split transactions. For more information about 
splits, see How do I use split transactions? later in this chapter.
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To edit a transaction:

Click a transaction in the account register to select it. The transaction editor will appear automatically to allow 
you to make changes to the transaction. If the transaction is marked “cleared” or “reconciled,” iBank will ask for 
confirmation before allowing you to modify any of the transaction details. When you are done making changes, 
click “Save” (or press Return on your keyboard) to keep the changes you entered, or click “Revert” (or press 
Escape on your keyboard) to discard them and return the transaction to its previous state.

	 You can disable the edit confirmation if you don’t need the extra protection. To restore this and other 
warnings after they have been disabled, choose iBank > Preferences and click the “Reset Alert Dialogs” 
button. 

To delete a transaction:

Click to select the transaction in the register (or Command-click to select multiple transactions), then click the 
minus (-) button at the bottom of the register or press Delete on your keyboard. iBank will ask you to confirm 
that you want to delete the transaction before removing it. If the transaction is a transfer, the corresponding 
transaction in the other account will be deleted as well.

	 You can disable the delete confirmation if you don’t need the extra protection. To restore this and other 
warnings after they have been disabled, choose iBank > Preferences and click the “Reset Alert Dialogs” 
button.
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To edit multiple transactions at once (sometimes called “batch editing”), Command-click transactions in the 
register to select them, then use the commands available under the “Transaction” menu to make changes. The 
status, category, transaction type, and security settings may be changed in this manner.
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What properties do transactions have?

Transactions in banking accounts have the following properties that can be edited using the transaction editor. 
For a list of transaction properties pertaining to investment accounts, see How do I track my investment activ-
ity? in Chapter 6: Investments.

Image/Attachment

By default, the image associated with the category to which the transaction is assigned. For information about 
changing category images, see How do I edit category properties? in Chapter 4: Categories.

This space is also used to attach files to transactions: for example, you could attach a PDF receipt from an online 
purchase or a picture of your latest acquisition from the Apple Store. When an attachment is present, a paperclip 
is shown over the corner of the image, and you may choose to have a picture of the attachment replace the 
category image. For more information, see the next section in this chapter.

	 To hide images from the transaction register, choose iBank > Preferences, click the “Appearance” button, 
and check “Hide category and transaction images.” A small pushpin will be shown in the transaction editor 
in place of the image; double-click the pushpin to use the attachment feature.

Date

The date on which the transaction occurred, or the date on which the transaction was cleared by your bank. 
It is up to you which dates you prefer to track - just remember to be consistent! By default, new transactions 
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are assigned the date of the last transaction recorded. When editing dates, the [ and ] keys will decrement and 
increment, respectively, the day.

	 If you type in a date, even if it does not match the format displayed, iBank will attempt to interpret it into 
the format displayed. For example, if you type “15” in the date field, iBank will assume you mean the 15th 
day of the current month and year, and enter that date. If you type “321”, iBank will assume you mean March 
21 of the current year.

You may also press the down arrow key to open a small calendar to help you choose a date:

When the calendar is visible, use the arrow keys to move the selection to a different date and/or click the but-
tons on the calendar to navigate to the date you want. Click the arrow buttons to change the month displayed; 
click the diamond-shaped button to return to the month that shows the current selection. Click a date to enter 
it, or press the Tab key to accept whatever date is currently selected.

Dates are displayed in the register using your system’s “Short” date format. To change the format: quit iBank, 
open System Preferences, click the “Language & Text” button, click the “Formats” tab, and click the “Customize” 
button in the “Dates” section. Edit the “Short” format as desired, then close System Preferences and launch iBank 
to see the changes.
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# (Transaction Number)

A number that most commonly applies to transactions that have their type set to “Check,” but may be used for 
other transaction types as well. When the “Check” type is assigned to a new transaction, the # field will automati-
cally be assigned the number that follows the highest number in the account. You can manually adjust this 
number as needed.

Payee

The name of the person or institution with whom the transaction was conducted (e.g. the name of the store 
where you purchased your groceries). iBank automatically creates transaction templates based on the payees 
you record via the transaction editor.

Withdrawal

The monetary amount of the transaction, indicating a negative value. Only certain transaction types will allow 
an amount to be entered in this field. This amount always shows the value of the transaction in the account’s 
default currency, even when an exchange rate has been applied.

Deposit

The monetary amount of the transaction, indicating a positive value. Only certain transaction types will allow 
an amount to be entered in this field. This amount always shows the value of the transaction in the account’s 
default currency, even when an exchange rate has been applied.
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	 Basic calculations can be performed when entering withdrawals and deposits. For example, if you type 
“5+3” in the deposit field, iBank will automatically record a value of “8.00”. Multiplication (*) and division 
(/) are performed before addition (+) and subtraction (-). Amounts are rounded to two decimal places. To 
specify the order of operations, you may group together parts of the calculation using square brackets  
[ ]. For example, if you enter “[1/2]*[4-3]” in the withdrawal field, iBank will calculate an amount of “(0.50)”. 
Parentheses may not be used for grouping because they indicate negative amounts.

Balance

A running total of the account’s overall value, showing each transaction’s effect on the total. This field is auto-
matically calculated by iBank and cannot be edited. For investment accounts, this figure represents the value of 
cash in the account only - the market value of shares held in the account is not included.

	 Entries in the balance column are always calculated in chronological order, regardless of the current sort 
order. If the numbers in this column don’t seem to be making sense, click the “Date” column header to make 
sure your transactions are sorted by date.

Account

The account to which the transaction belongs. This field only appears in the account register when an account 
group or smart account is selected. The information in this field cannot be edited directly; to read about how to 
move transactions between accounts, see How do I move a transaction from one account to another? later in 
this chapter.
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 (Status)

One of three icons will appear in this field for each transaction:

•	  Uncleared: This transaction was recorded manually in iBank (or synced from iBank Mobile) and has not 
yet been cleared by the financial institution. Check the box to change the transaction status to “cleared.” 
Uncleared transactions are counted as part of their account’s balance, but excluded from its “cleared total.”

•	  Cleared: This transaction has been processed successfully and recorded by your financial institution. 
Transactions can be checked off manually, or may be checked automatically by iBank for any of these 
reasons:

They were •	 imported into iBank via direct download, the built-in browser, or an external file. In 
these cases, iBank assumes the data to have been obtained from a trusted source.

They were •	 matched against incoming transactions during an import (even if those transactions 
were not imported).

Checked transactions are counted as part of their account’s •	 “cleared total.” Uncheck the box to 
change the transaction status to “uncleared.”

•	  Reconciled: This transaction has been recorded on a statement. When a transaction is marked “recon-
ciled” on a statement, its checkbox is automatically replaced with a balance icon in the account register, 
and its status cannot be modified. Reconciled transactions are counted as part of their account’s “cleared 
total.” In order to change the transaction status to either “cleared” or “uncleared,” you must edit the transac-
tion on the statement to which it belongs.

	 By default, transaction payees, securities, and amounts are displayed in bold type. To have cleared transac-
tions show these fields in regular type, choose iBank > Preferences, click the “Appearance” button, and 
uncheck “Cleared transactions appear in bold.”

http://itunes.com/apps/iggsoftwarellc/ibank
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Check or uncheck multiple transactions at once by using Command-click to select them in the account register, 
then choosing Transaction > Mark > As Cleared (or As Uncleared). 

Type

The activity associated with the transaction, typically some variation of withdrawal (debit) or deposit (credit). 
Some transaction types have a value (positive or negative) assigned to them and will enable or disable the 
“Deposit” and “Withdrawal” fields in the transaction editor accordingly. For detailed descriptions of the various 
types, see What are the different transaction types? later in this chapter.

Category/Transfer

The category associated with the transaction, which is used to account for the transaction in reports and bud-
gets. For more detailed information about how to use categories, see Chapter 4: Categories.

For transfers, this field is used to specify the name of the sending or receiving account. Autofill works the same 
for categories as well as account names - simply begin typing the name of the category or account, then choose 
the correct item from the drop-down menu that appears. iBank will automatically put the ‘•’ character in front of 
account names to indicate that the transactions are transfers.

If the transaction is a split transaction, this field will automatically show “splits....”
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Memo

Any notes or specific details pertaining to the transaction. Examples include a tracking number for the book you 
just ordered from Amazon.com, or a note to help you remember whose birthday card you bought at Hallmark.

Exchange Rt

The rate of conversion between the transaction’s currency and the account’s default currency (only available 
when these two currencies are different). Enter a rate and press Tab on your keyboard; iBank will automatically 
multiply the amount in the “Foreign” field by the rate you entered and record the result in the “Withdrawal” or 
“Deposit” field.

Foreign

The amount of the transaction in its original currency (before an exchange rate is applied). This field is only 
available when the transaction’s currency is not the same as the account’s default currency. Enter an amount 
and press Tab on your keyboard; iBank will automatically multiply the amount you entered by the figure in the 
Exchange Rt field and record the result in the Withdrawal or Deposit field. To indicate a negative amount in the 
Foreign field, enclose the amount in parentheses, e.g. ($5.50).

Currency

The currency in which the transaction was conducted (only visible if you are using multiple currencies). In most 
cases, this will match the account’s default currency, but you can change it to record the transaction in a differ-
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ent currency. Changing the currency will enable the “Exchange Rate” and “Foreign” fields, which you can use to 
record information about the conversion between the selected currency and the account’s currency:

In this example, a cup of coffee was purchased for 2.00 Euro through an account that uses U.S. Dollars. An 
exchange rate of 1.5 was applied, so the final withdrawal (in USD) was 3.00. By default, only currencies that are 
assigned to your accounts are shown in the currency popup menu. For more information, see How do I manage 
accounts in multiple currencies? in Chapter 2: Accounts.
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How do I attach files to my transactions?

iBank allows you to attach a file to each transaction and (optionally) display custom images in the account reg-
ister. You might take a picture of your brand new iPad for posterity, attach a receipt for the books you ordered 
from Amazon.com, or file a scanned copy of Form 1040 with your federal income tax payment. Files of any type 
may be attached.

The left side of each transaction in the account register is used to show images and attachments. By default, 
this space shows the image associated with whatever category is assigned to the transaction. If no category is 
present, or if the category has no image, the space will show a picture of a bank façade:

To attach a file:

Select a transaction to bring up the transaction editor, then double-click the space (or image) on the left side to 
open the popup file inspector:
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Drag and drop a file into the large box to attach it to the transaction, or click “Attach File” and choose the file you 
want. A preview of the file will appear in the box, and the name of the file will appear below it. A copy of the file 
will be stored inside your iBank document, so you can delete the original if desired.

When a file has been attached to a transaction, iBank will show a paperclip icon in the account register:

If you want to show a picture of the attachment in the account register, check the “Display image with transac-
tion” option. iBank will replace the transaction’s category image with the file preview, both in the register and in 
cover flow view.
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To attach a camera snapshot:

If your Mac has a built-in iSight, or if you have another video camera connected to your computer, click the 
small camera button to open the snapshot window. Here you can take a picture with your camera to attach to 
the transaction:

Click the camera button in the snapshot window to take a picture, then use the slider to zoom the image to an 
appropriate size. Click “Recent Pictures” to select a snapshot you took previously, or click the “Choose” button to 
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select an existing image file. Once you have the image prepared the way you want it, click the “Set” button to 
attach it to the transaction.

To reverse an image:

Click the double-arrow button in the file inspector to flip the preview image horizontally (as if it were being 
viewed in a mirror). This can come in handy when you take a snapshot of a receipt, for instance, and want to be 
able to read it properly.

To view an attachment:

If you want to view an attached image at full size, print an attached document, save a copy of a file, etc., open 
the popup file inspector and click the “Open With Finder” button. iBank will open the attached file using the 
default application for its file type. The “Print” and “Save As” commands in that application can be used to print 
and save a copy of the file, respectively.

To remove an attachment:

Open the popup file inspector and click the ‘X’ button to the right of the file preview. The file will be removed 
from the inspector and from the iBank document.
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What are the different transaction types?

Here you will find a list of the various types that can be assigned to transactions in iBank. The definitions pro-
vided for banking transaction types are relatively loose; although some types force transaction amounts to be 
either positive or negative, the differences between types are for the most part nominal. Please feel free to use 
your own discretion in choosing the appropriate type for any given transaction.

Banking account transaction types:

ATM:•	  Deposit or withdraw funds using an ATM.

Charge: •	 Withdraw funds using a debit card, or record a purchase on a credit card.

Check:•	  Withdraw funds by writing a paper check. Choosing this type will automatically insert a number in 
the ‘#’ field (the next number in sequence from the highest in the account).

Deposit:•	  Add funds to an account by any method.

Online:•	  Withdraw funds through a web-based store or online banking service.

POS:•	  Withdraw funds through a point-of-sale transaction (typically a debit card purchase).

Transfer:•	  Move funds from one account to another (for more information, see How do I transfer funds 
between accounts? later in this chapter).

Withdrawal:•	  Deduct funds from an account by any method.

Investment account transaction types:

Buy:•	  Withdraw cash and purchase shares of a security.
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Buy to Close:•	  Close a short position (opened with “Sell to Open”) by withdrawing cash and purchasing 
shares of a security or option (put or call). Use this transaction type with a price of “0.00” to close a short 
position that expired or was exercised.

Buy to Open:•	  Open a long position by withdrawing cash and purchasing shares of an option (put or call).

Dividend:•	  Deposit cash or shares received from the profit made on an investment. Use the funding/distri-
bution setting to designate the dividend as a reinvestment if necessary.

Cap. Distribution:•	  Deposit cash received as a capital distribution (return of capital) that should not be 
treated as a dividend for tax purposes.

Cap. Gains Long:•	  Deposit cash received from a mutual fund, partnership, or hedge fund from the sale of 
long-term security shares (the number of shares you own is not affected).

Cap. Gains Short:•	  Deposit cash received from a mutual fund, partnership, or hedge fund from the sale of 
short-term security shares (the number of shares you own is not affected).

Interest Income:•	  Deposit cash earned as interest on a security (most commonly a bond).

Move Shares:•	  Transfer shares of a security between brokerage accounts, record shares received as a gift or 
inheritance, or otherwise adjust the number of shares of a security without affecting the cost basis or the 
cash balance of the brokerage account.

Sell:•	  Deduct shares of a security and deposit cash from the sale.

Sell to Close:•	  Close a long position (opened with “Buy to Open”) by deducting shares of an option (put 
or call) and depositing cash from the sale. Use this transaction type with a price of “0.00” to close a long 
position that expired or was exercised.

Sell to Open:•	  Open a short position by deducting shares of a security or option (put or call) and depositing 
cash from the sale.
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Split: •	 Record a stock split. Enter the number of shares gained as a result of the split, or enter the number of 
shares lost (as a negative number) in the case of a reverse split.

	 Along with setting these primary transaction types, you can also choose the source of funding for (and 
allocate distributions from) investments. For more information, see How do I track my investment activity? 
in Chapter 6: Investments. 
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How do I transfer funds between accounts?

Basic transfers:

When you want to move money from one account to another, use a transfer transaction:

Create a transactio1.	 n in one of your accounts and set its type to “Transfer.” Enter the date, payee, memo, and 
amount of money to be transferred.

Begin typing the name of the account into which the funds should be transferred in the category field, then 2.	
select the account name when it appears in the drop-down list. Alternatively, press the Down Arrow key on 
your keyboard to pop up the full category list and choose the account name.

A new transaction will automatically appear in the account to which you are transferring the money, with 3.	
the same transaction details as the original (except for the amount, which will be opposite to the original).

The two transactions are now linked: 4.	 changing the details of one will update the other automatically and 
deleting one will delete the other. There are two exceptions to this rule, however: each side of the transac-
tion can be cleared and reconciled separately, and the amounts can be changed independently to indicate 
a currency conversion (see below).

	 Transfer transactions use the Category field to indicate the destination account for the transfer. If the cat-
egory for a particular transaction begins with the ‘•’ character, it is a transfer. These “categories” are consid-
ered a special case and are not displayed in the main category list, but can be used in reports and budgets 
like other categories.



149Chapter 3: Transactions

Split transfers:

Split transactions can also be used to transfer funds between accounts. To transfer part of a split transaction to 
or from a different account, simply enter the account’s name in the Category field for the appropriate split item. 
If you enter the amount for the split item in the Income field, the money will be drawn from the account indi-
cated; if you enter the amount in the Expense column, the money will be deposited into the account indicated.

Transfers with currency conversions:

When you transfer money between accounts with different currencies, you may wish to apply a conversion 
so that the correct amount is recorded in each account. After you finish step 2 in the instructions above, click 
on the currency symbol in the transaction editor and choose the currency used by the account you entered in 
the Category field. The Exchange Rt, Foreign, and Currency fields will appear so that you can apply a currency 
conversion.

By default, the exchange rate is set to 1 (indicating no conversion), the Foreign field shows the amount of the 
transfer in the original currency, and the currency field shows that of the original transaction. To apply a conver-
sion, adjust either the exchange rate or the amount shown in the Deposit or Withdrawal field (which uses the 
current account’s currency). The Foreign field will automatically adjust itself based on the changes you make to 
the exchange rate and transaction amount.

Split transfers with currency conversions:

If you transfer part of a split transaction into an account that uses a different currency from the account in which 
the transaction is being recorded, some additional fields will be displayed in the split editor:
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In the Amount field, enter the value of the transfer in the currency of the receiving account. To indicate money 
being deposited into that account, enter the amount as a positive number; to indicate money being withdrawn 
from that account, enter the amount in parentheses to indicate a negative value, e.g. (¥21,310).

In the Exchange Rate field, enter the rate of conversion between the currencies used by the two accounts. In the 
Value field, enter the value of the transfer in the currency indicated in the pop-up currency button at the top 
right side of the transaction editor. You only need to enter details in two of the three fields mentioned here - 
iBank will automatically calculate the value of the third and fill it in for you.

When split items with categories appear in the same list, no currency conversion needs to be applied. Leave 
the Exchange Rate set to 1 and make sure the Amount and Value fields match. Amounts should be entered as 
positive to indicate expenses and negative to indicate income.

Investment transfers:

When tracking investments, you may want to transfer cash from a banking account to an investment account 
to purchase shares, or transfer cash out of an investment account after a sale or cash distribution. To record this 
type of transfer, add a transaction in the investment account, set its type appropriately (Buy, Sell, Dividend, etc.), 
then set its funding/distribution type to “Transfer.” The category field will then be enabled so that you can type 
in the name of the account where the cash should be drawn from or deposited into (depending on the transac-
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tion type). Once you save the transaction, iBank will create a transaction that is linked to the one you just cre-
ated in the account you specified. Only certain transaction properties can be edited on the linked transaction.

About transfers in budgets and reports:

A transfer is only counted in a budget or report when one of the two accounts involved in the transfer is ex-
cluded from the budget or report. If both accounts are included, there is no net movement of money in or out 
and so the budget or report is not affected by the transfer. To track a transfer in a budget, the account must be 
excluded from the budget’s account list during its initial setup. You will then see the account name included 
with the income and expense category lists so that you can track transfers to and from the account on the 
budget.

To track a transfer in a report, exclude the account by double-clicking the report, choosing the “Limit results to 
specific accounts” option, and checking off all accounts except the one you want to exclude. Transfers to and 
from the account will then be counted in the report. Reports that are based on categories can be configured 
to include or exclude transfers to and from a specific account using the “Report on all categories and accounts 
except” setting. For more information about configuring report settings, see the articles about the different 
report types.
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How do I move a transaction from one account to another?

Select a transaction in any account (or Command-click to select more than one), then choose Edit > Cut. Se-
lect the account to which you want to move the transaction(s) and choose Edit > Paste. The transaction(s) 
will be removed from the original account and added to the selected account. Be sure to use the Cut command 
and not Copy, to ensure that transfers remain properly linked and are not duplicated.

To transfer funds between accounts (instead of moving the transaction records), see the preceding section in 
this chapter.
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How do I search for transactions in my accounts?

To search for a transaction:

Select the account you want to search, then click in the search box on the toolbar and type in a word, phrase, or 
number:

Every transaction in the current account that matches what you typed will be displayed in the account register. 
When searching, iBank examines the following fields: transaction #, payee, withdrawal, deposit, category, 
memo, security name, and security symbol. Split transaction fields are also searched.

To cancel the search and show all transactions in the account, click the ‘x’ button inside the search box.

Other ways to find transactions:

In addition to the search box, smart accounts can also be used to show registers consisting of transactions that 
meet certain criteria. See How do I use smart accounts? in Chapter 2: Accounts for more information.
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How do I use split transactions?

iBank allows you to categorize transactions so that they can be tracked with reports and budgets, but what 
happens when a single transaction needs to be broken down and assigned to multiple categories? For example, 
let’s say that you go to the grocery store and spend $50, but you only spend $30 on groceries - the other $20 is 
spent on pet supplies. How do you enter this into iBank without creating two separate transactions?

Split transactions allow you to itemize your transactions so that categories can be assigned to smaller parts 
of those transactions. You can schedule split transactions and memorize them like other transactions, and use 
them to transfer portions of transactions in addition to categorizing them. iBank provides two different meth-
ods for creating splits: you can either enter the split items first and have iBank calculate the transaction’s total 
amount based on the splits, or enter a total amount and have iBank help you balance the split items against that 
total.

To create a split transaction with an unknown total:

Select one of your accounts and create a new transaction. Choose a transaction type and enter the date, payee, 
and memo as desired. Leave the deposit and withdrawal fields blank and click the disclosure triangle next to the 
category field (or press Command-Option-Y) to reveal the splits table:
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Make sure the “Adjust main transaction” box at the bottom of the editor has a checkmark in it. One blank split 
item will already be listed in the table. Double-click the category field on this line and enter a category (or ac-
count name, if you want the split item to transfer funds). Double-click the memo field if you want to enter some 
notes with the split item, then double-click the income or expense field to record the amount of the split item 
(as positive or negative, respectively). You will note that the main transaction amount automatically updates to 
reflect the amount you entered:

	 Basic calculations can be performed when entering income and expense amounts. For example, if you type 
“5+3” in the income field, iBank will automatically record a value of “8.00”. Multiplication (*) and division 
(/) are performed before addition (+) and subtraction (-). Amounts are rounded to two decimal places. To 
specify the order of operations, you may group together parts of the calculation using square brackets [ ]. 
For example, if you enter “[1/2]*[4-3]” in the expense field, iBank will calculate an amount of “(0.50)”. Paren-
theses may not be used for grouping because they indicate negative amounts.

Click the plus (+) button at the bottom of the table (or press Command-Option-N) to add a new split item. 
Double-click each of the fields on this line and enter the appropriate details. Again, you will note that the main 
transaction amount automatically updates to reflect the total of the splits:
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Continue in this manner until all split items have been recorded, then click the “Save” button (or press Return on 
your keyboard) to save the transaction. The category field on the main transaction will show “splits...” to indicate 
that it is a split transaction.

To create a split transaction with a known total:

Select one of your accounts and create a new transaction. Choose a transaction type and enter the date, payee, 
and memo as desired. Enter the total amount of the transaction in the deposit or withdrawal field (as appropri-
ate), then click the disclosure triangle next to the category field to reveal the splits table:

Click the box next to “Adjust main transaction” to uncheck it. One split item will already be listed in the table, 
with the amount you entered above. In the example pictured here, we have recorded a $50 withdrawal that has 
not yet been categorized. Double-click the split item’s category field and enter a category (or account name, if 
you want the split item to transfer funds). Double-click the memo field if you want to enter some notes with the 
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split item, then double-click the income or expense field to adjust the amount that belongs to that split item (as 
positive or negative, respectively).

Following our above example, let’s split this transaction into two parts: $30 for groceries and $20 for pet sup-
plies. We already split the transaction, so next we assign the category “Groceries” to one split item. Its amount 
started as a $50.00 expense, so we change it to $30.00. Notice that when the amount of the split item changes, 
iBank calculates the difference between that figure and the amount of the main transaction, and displays the 
figure next to “Left to balance” at the bottom of the split editor:

	 Basic calculations can be performed when entering income and expense amounts. For example, if you type 
“5+3” in the income field, iBank will automatically record a value of “8.00”. Multiplication (*) and division 
(/) are performed before addition (+) and subtraction (-). Amounts are rounded to two decimal places. To 
specify the order of operations, you may group together parts of the calculation using square brackets [ ]. 
For example, if you enter “[1/2]*[4-3]” in the expense field, iBank will calculate an amount of “(0.50)”. Paren-

theses may not be used for grouping because they indicate negative amounts.

Click the plus (+) button at the bottom of the table (or press Command-Option-N) to add a new split item. 
Double-click the appropriate fields on this line to enter the category “Pet Supplies” and an expense amount of 
$20.00. Now that the transaction is properly balanced (i.e. the sum of the split items is equal to the main trans-
action amount), the “Left to balance” figure disappears:
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Now we click the “Save” button to save our changes, and the split transaction is complete. Each split item has 
been assigned its own category, so the expenses can be tracked more accurately with reports and budgets.

	 If you save a transaction when there is still a “Left to balance” amount showing, iBank will automatically add 
a blank split item with that amount to the transaction. 

To edit an existing split transaction:

Select the transaction in the account register and click the disclosure triangle next to the category field to reveal 
its splits. If the main transaction amount needs to be changed, check “Adjust main transaction” and adjust the 
splits accordingly - the main transaction amount will update automatically. If you do not want iBank to adjust 
the main transaction amount, but show you if there is a remainder after you change the split items, leave “Adjust 
main transaction” unchecked and make your changes.

While you are editing the splits, click the plus (+) button below the splits table to add a new split item. To re-
move a split item, select it and click the minus (-) button (or press Command-Option-Delete).
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	 If you are editing a split transaction that is based on a transaction template, some of the existing split items 
may be adjusted automatically to balance the transaction. See the next section in this chapter for more 
information.

To record a paycheck:

Create a transaction in the account where your paycheck is being deposited, set its type to “Deposit,” and 1.	
enter the date, payee, and memo (do not enter an amount).

Open the splits table, make sure “Adjust main transaction” is checked, and give the first split item an amount 2.	
equal to your gross pay (be sure to record this in the income field). Assign it to the “Salary” category, or 
whatever category you prefer to use for tracking your income.

Add a split item for each deduction that is taken out of your pay. Each one should be assigned to the ap-3.	
propriate category and have its amount recorded in the expense field. Transfers to other accounts (e.g. 401k 
contributions) can be recorded by specifying the name of the destination account in the split item category 
field.

Once you have finished recording all deductions, save the transaction. You should see that the main trans-4.	
action amount represents the deposit of your net pay into the current account, and all of the deductions are 
categorized appropriately so that you can track them with reports and budgets.

Resizing the split editor:

You can manually adjust the size of the split editor to show more or fewer split items. At the bottom of the 
editor is a thin gray bar with a divot in its center: click and drag this bar up or down to resize the list. iBank will 
remember the size you choose and use it whenever the transaction editor is expanded to show split details.
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Viewing split transactions in cover flow:

In cover flow view, the splits are not shown. The category “splits...” is displayed to 
indicate that there are split items associated with the transaction, and the category 
image from the first split item is displayed:
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Can iBank remember transactions I enter more than once?

 Transaction templates are used to help you enter repeated transactions more quickly, so you can work 
more efficiently. Autofill, scheduled transactions, and import rules are all based on transaction templates, as 
described below. Transaction templates only apply to banking transactions; investment transactions cannot be 
memorized or used with template-related features.

Creating templates

Each time you enter a transaction manually, iBank automatically creates a template based on that transaction, 
recording its type, payee, category, splits, memo, and withdrawal/deposit amount. (Please note that the memo 
field is not autofilled when you create a new transaction - see below for more information about autofill.) To 
create a template from a transaction in an account register, drag & drop the transaction from the register onto 
“Transaction Templates” in the “Manage” section of the source list.

Viewing and editing templates

iBank maintains a list of all the transactions it has memorized under “Transaction Templates” in the source list. 
Select this item to view all of the transactions that iBank currently has stored in its memory:
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When you select a template in the list, the transaction editor will appear to let you make changes, just as it does 
for transactions in the account register. You will notice, however, that the date field is replaced with a “Schedule” 
button, and an “Import Rules” button is displayed next to the payee field (more about these buttons below). As 
with regular transactions, you can edit any of the fields shown here and click “Save” to record the changes or 
“Revert” to discard them. Any changes you make to your templates will automatically be applied to new transac-
tions that are created using the template (through any of the means described below).
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	 Templates automatically update themselves based on the information you enter. If you create a new 
transaction with the same payee as an existing template, or edit a transaction that is based on a template, 
the template will be updated to reflect the new details that you enter along with that payee.

You can create a new transaction template from scratch by clicking the plus (+) button at the bottom of the list 
and filling in the relevant information. To delete a template so that it will no longer be used for autofill, sched-
uled transactions, and imports, select it and click the minus (-) button at the bottom of the list. Any scheduled 
transactions associated with the template will be deleted as well.

Sorting the list

At the top of the template list is a series of column headers that identify the information shown in each tem-
plate. To sort the list, click a column header; the templates will automatically sort according to the values in that 
column. For example, if you want to sort your templates chronologically, click “Date.” Click the column header a 
second time to reverse the direction of the sort.

Split items

Transaction templates may also have split items associated with them; these splits can be edited by clicking 
the disclosure triangle next to the category field. The split editor here works the same as the one used in the 
account register, with one difference: you will notice that each split item has a checkbox next to it. Checking this 
box will designate the item’s amount as variable: it will fluctuate depending on the overall transaction amount, 
whereas unchecked items will remain fixed at the amounts they are assigned. A couple of examples will help to 
illustrate this feature:
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Consider that you set up a template to represent your paycheck. Once a month, a paycheck is deposited •	
into your checking account, and though the amount of payment varies, you always put $100 into your 
savings account. In iBank, you would set up a template with an estimated total amount (your net pay) and 
two split items: one with the amount of your gross pay, and one to transfer $100 into savings. The gross pay 
is variable, and the transfer is fixed, so you check off the gross pay item and leave the transfer unchecked. 
When it comes time to record your paycheck, you create a new transaction in your checking account, 
autofill the details, and then adjust the main transaction amount. iBank automatically adjusts the split item 
with your gross pay, and leaves the transfer at $100.

Consider a payment towards a loan, which is split between principal and interest. You create a template •	
for this transaction by entering the total payment amount on the main transaction (as a withdrawal), then 
splitting the payment into principal and interest portions. The principal portion should be made a transfer 
to the loan account, while the interest may be assigned to a category so that it can be tracked with reports. 
Since the interest amount is fixed for each payment but the principal payment is variable, leave the interest 
unchecked and check off the principal. When you record the payment, you create a new transaction in your 
banking account, autofill the details, and adjust the main transaction amount. iBank automatically adjusts 
the split item with the principal payment, and leaves the interest at the amount you specified.

Autofill

When you create a transaction in an account register and begin typing in the payee field, iBank will automatical-
ly suggest names based on your transaction templates. As you are typing, a drop-down list will appear showing 
the payees that match what you are typing:
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In this example, only the letter ‘L’ was typed. Use the mouse to click one of the names, or use the arrow keys 
to select one and then press the Tab or Return key. iBank will fill in several of the transaction details (type, cat-
egory/splits, and amount) based on the template associated with that payee (these fields will be shaded yellow 
as a result). If you don’t want to accept a suggestion, simply ignore it and continue typing - when you save the 
transaction, iBank will create a new template automatically.

Scheduled transactions

Select a template and click the “Schedule” button to configure the template to post a transaction to one of your 
accounts at regular intervals. Doing so will also add the template to the “Scheduled Transactions” item in the 
source list. For more information, see the next section in this chapter.

Import rules

Select a template and click the “Import Rules” button to configure how the template is used when you import 
data via direct download, using the built-in browser, or from a file. For more information, see How do I use 
import rules? in Chapter 5: Importing Data.
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How do I schedule recurring transactions?

 Scheduled transactions can be created to track financial activities that occur on a repeating basis, for 
example a monthly mortgage payment or biweekly paycheck. Scheduled transactions are based on transaction 
templates. When one or more schedules are associated with a template, transactions based on that template 
will be created in your accounts as the schedules dictate. For more information about templates, see the preced-
ing section in this chapter.

To create a scheduled transaction:

There are several different ways to create a scheduled transaction. Use any of the following methods:

Select “Scheduled Transactions” in the “Manage” section of the •	 source list and click the plus (+) button at 
the bottom of the register. A new template will be added to the list, and the inspector will pop up auto-
matically to let you edit the template’s schedule.

Select one or more transactions in any •	 account register and choose Transaction > Make Sched-
uled Transactions from Selection. A new transaction template will be created with details of 
each transaction that was selected and assigned a monthly schedule. To edit the schedule for one of the 
new templates, select “Scheduled Transactions” in the source list, select a template, and click the button 
where the transaction date is shown.

Drag and drop a transaction from any account register onto the “Scheduled Transactions” item in the •	
source list. A new transaction template will be created with details of the transaction and a monthly sched-
ule. To edit the schedule, select “Scheduled Transactions” in the source list, select the new template, and 
click the button where the transaction date is shown.
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Select “Scheduled Transactions” in the source list and click “All Templates” at the bottom of the register. •	
Select any template that you want to use as a scheduled transaction, then click the “Schedule” button in 
the transaction editor to add a schedule to the template. The template will be added to the “Scheduled” list 
automatically when you save the schedule.

To edit a template’s schedules:

Each transaction template can be assigned one or more schedules to determine when transactions based on 
that template will be posted to your accounts. To configure the schedules associated with a template, select 
“Scheduled Transactions” in the source list, select the template you want to edit, and click the button where the 
transaction date is shown. The schedule inspector will appear:
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Click the plus (+) button at the bottom of the inspector to add a new schedule. Each schedule is represented 
by a set of options enclosed in a box with the label, “Schedule.” To delete a schedule, click the box surrounding 
one of the schedules (so that it turns blue), then click the minus (-) button to remove it. Each schedule has the 
following options that you can configure:

Account:•	  Choose which account the transaction will be posted to.

Next date:•	  Enter the date on which the next transaction will be posted to the account.

Every: •	 Enter a number and choose a period of time to indicate how often the transaction will be posted.

Stop after/Unlimited:•	  Choose “Stop after” and enter a number to have only a fixed number of transactions 
posted to the account; the schedule will be deleted after the last transaction has been posted. Choose 
“Unlimited” to have the schedule continue posting transactions until it is modified or deleted.

Reminders:•	  Choose “Always” to show an alert when the transaction is due to be posted to the account, so 
that you can edit the transaction details and choose whether or not to post the transaction at that time 
(see below). Choose “Never” to post the transaction automatically whenever it is due, without confirmation.

Add to iCal:•	  Check this option and choose a calendar to create an event in iCal for the transaction’s next 
due date. When you post (or skip) the transaction, a new iCal event will automatically be created for the 
next due date. In iCal, you can view the event and click the displayed URL to open the scheduled transac-
tion in iBank. Any changes you make to the event in iCal will not affect the scheduled transaction, but if 
you delete the event, the “Add to iCal” option will be unchecked in iBank.

When you are done configuring schedules for the template, click “Save” to record your changes, or click “Cancel” 
to discard them. You may edit the other template details (payee, amount, etc.) just like you would edit a transac-
tion in an account register.
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	 Multiple schedules come in handy when you want to post transactions at irregular intervals. For example, 
to post a transaction on a semi-monthly basis, you could configure one monthly schedule for the 1st of the 
month and a second monthly schedule for the 15th.

To delete a scheduled transaction:

Select “Scheduled Transactions” in the source list, select a template, and click the button that shows the transac-
tion date to open the schedule inspector. Select a schedule and click the minus (-) button at the bottom of the 
inspector to remove it. Any transactions that were already posted to your accounts will not be affected. Remove 
all of a template’s schedules in this manner and save your changes - the next time you view the scheduled 
transaction list, that template will not be displayed.

	 If you select a template and click the minus (-) button at the bottom of the register to delete it, the original 
template will be deleted from the “Transaction Templates” section. All schedules and import rules associ-
ated with the template will be deleted along with it.

To use scheduled transaction reminders:

Make sure you have at least one scheduled transaction configured to use “Reminders: Always,” then wait until 
the transaction’s due date arrives. When you open your iBank document, a reminder will appear automatically 
to show you the transactions that are ready to be posted to your accounts:
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By default, scheduled transactions that are due to be posted are displayed in the list. To view all scheduled 
transactions, click the “All” button. Select a transaction in the list and make any changes necessary, then click 
“Post” to post the transaction to the account indicated, or click “Skip” to move to the next due date in the sched-
ule without posting the transaction to an account. Any changes you make to a transaction before posting it will 
only affect that transaction; the template upon which the transaction is based will not be affected.

You can also print a check for a transaction by selecting it and clicking “Print Check” before posting it. Click 
“Done” when you are finished - any transactions that are left will still be there the next time the confirmation 
window appears.

	 You can open the scheduled transaction confirmation window at any time by choosing Manage > Confirm 
Scheduled Transactions. 
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To view upcoming scheduled transactions:

The summary pane at the bottom left corner of the main window shows the next three upcoming scheduled 
transactions. If you don’t see the summary pane, click the up/down arrow button  to show it, and/or click the 
arrow button  at the top right corner of the pane to switch from the net worth mini-graph to the summary 
figures. Click the arrow next to any scheduled transaction to view and edit it in the main Scheduled Transactions 
list.
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How do I use categories?

 Categories help you track where your money actually comes from and goes to, and they enable you to use 
reports and budgets to manage your finances more effectively. Once you have created accounts and added 
transactions, the real strength of iBank comes in assigning categories to those transactions. To do so, create a 
transaction or edit an existing one, and type a category name in the category field. iBank will suggest the names 
of existing categories as you type: when the drop-down list of category names appears, use the Up and Down 
Arrows on your keyboard to highlight one, then press Tab to accept it.

iBank includes default sets of “Home” and “Business” categories which you may choose when you create a new 
document, but you can customize each document’s category list to your heart’s content.

To view the main category list:

Click “Categories” in the “Manage” section of the source list. Your categories will appear to the right:
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Here you can see all of your categories organized by Name, Description, or other criteria - just click the header at 
the top of any column to sort the list according to the information in that column. Click a second time to reverse 
the direction of the sort. Categories that contain sub-categories will display small disclosure triangles next to 
their names: click one of these triangles to view that item’s sub-categories.
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How do I add and delete categories?

To add a category:

Click “Categories” in the source list. The right side of the main window will display a list of all categories that are 
currently available for use. Click the plus (+) button below the list, and a sheet will appear asking you to enter 
information about the new category:

Type in a name for the category and a longer description, if desired. Choose whether the category is intended 
for tracking expenses or income by selecting the appropriate item next to “Type,” and check the “Taxable” check-
box if you want to designate the category as being tax-related. Enter a tax code if desired, then click “Create 
Category” to add the new category to iBank’s list. Read more about these options in the next section.
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	 You can also create a new category simply by typing it into a transaction’s category field. When you save the 
transaction, iBank will ask you to configure the new category as described above. 

To add a sub-category, click the  button below the main category list. The same sheet will appear to allow 
you to create a new sub-category. Read more about sub-categories in How do I organize my categories hierar-
chically? later in this chapter.

To delete a category:

Select the category you want to remove and click the minus (-) button at the bottom of category list, or press 
Delete on your keyboard. You will be asked to confirm that you want to remove the category. If the selected 
category has sub-categories, those will be deleted as well.

When you delete a category that has transactions assigned to it, iBank will present you with options for how to 
handle those transactions:
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If you want to assign the transactions to a different category, check the box and select the desired category 
from the drop-down list. If you simply want to remove the category from any transactions to which it had been 
assigned, uncheck the box: the transactions themselves will not be deleted, but they will no longer have catego-
ries assigned to them. Click “Delete” to finish deleting the category, or click “Cancel” to keep it.
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How do I edit category properties?

Click “Categories” in the source list to view the list of available categories. When you select a category, the editor 
at the bottom of the list changes to reflect the details of that item:

To modify a category, simply select the field you want to edit and type in the desired changes. When you do so, 
“Save” and “Cancel” buttons will appear below the editor to allow you to record or discard your changes, respec-
tively. Each category has the following properties which may be edited:

Name

The name assigned to the category. If you change the name of a category, your category assignments will not 
be lost - any transactions to which the category is assigned will automatically update to reflect its new name.

Description

Enter a longer description about the category (if desired) to help you remember what it is used for. This is also a 
handy place to store tax reference information for taxable items.
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Type

Choose “Expense” to indicate that the category is used for purchases and withdrawals; choose “Income” to 
indicate that it is used for earnings and refunds. This property determines which section of your budgets the 
category will be available in.

Tax status

Choose “Taxable” to designate the category as tax-related; choose “Not taxable” to indicate that the category is 
not useful for tax purposes. Items that are “Taxable” will be added to U.S. Tax reports automatically.

Tax code

If the category is associated with a particular tax code, enter the number of the code in this field to help you 
remember it. Click the help (?) button to view a list of US tax codes.

Image

To add an image to a category, drag and drop an image file from the Finder onto the image box on 
the left side of the category you want to use it with. Alternatively, you can copy an image to the 
clipboard, click to select the category’s image box, then choose Edit > Paste to add the image. 

To remove an image from a category, click the image to select it and choose Edit > Delete, or press Delete 
on your keyboard.

The image assigned to a category will appear as the default image for any transaction assigned to that category, 
when you view your transactions in the account register or cover flow view. Files that are attached to individual 
transactions can be set to display in place of the category images, but will not affect the images assigned to the 
categories.
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Color

Click the  color box to open the Mac OS X color picker and choose a color for the category. If you want 
the transactions to which the category is assigned to show this as a background color in the account register, 
choose iBank > Preferences, click the “Appearance” button, and check “Show category background col-
ors.” This will also cause reports to represent the category in pie charts and line graphs using the specified color. 
To remove the color from a category and reset it to black, Control-click on the category and choose “Remove 
Color”.
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How do I combine categories?

If you discover that you have duplicate category entries, or if you simply wish to merge two or more different 
categories, what you need to do is combine those categories. In the main “Categories” list, hold down the Com-
mand key and click to select the categories you want to combine. Once they have been selected, Control-click 
and choose “Combine Categories” from the menu that appears:

A single category will be created with “combined” appended to its name. All transactions that were previously 
assigned the original categories will now be assigned the new category. Feel free to edit the new category to 
change its name.
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How do I organize my categories hierarchically?

Categories can be organized into levels of hierarchy so that some categories are listed under others.

Say, for example, that you have a category for auto expenses named “Auto”. You want to track all of your car-
related expenses under this category, but what if you also want to be able to track how much you spend on 
repairs alone, or gas? iBank makes it easy to create sub-categories, so that you can categorize both “Service” 
and “Fuel” under “Auto”. Using charts and reports, you can then see at a glance how much you spent on repairs 
alone, or how much your car is costing you in total:

Creating sub-categories

To add a sub-category, select the category under which you want to create the sub-item, and click the  
button at the bottom of the main window. The “Create New Category” sheet will appear just as it does when you 
create any other category. Enter the appropriate information for the sub-category and click “Create Category.” 
A small disclosure triangle will appear next to the main category - click this to expand the category and view 
the sub-category you just added. Once they have been created, sub-categories can be edited just like any other 
categories.
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Using sub-categories

When you assign a sub-category to a transaction in one of your accounts, the transaction will display both the 
main category and its sub-category, separated by a colon. To illustrate, say that you assign the above-men-
tioned “Fuel” sub-category to a transaction. In the account register, the transaction will then show “Auto:Fuel” in 
its Category field:

When you create transactions, typing in the category field will cause iBank to suggest category names as you 
type. Use the arrow keys to select a category from the drop-down list, then press the Tab or Return key to accept 
it. To quickly enter a sub-category, type the first few letters of the parent category (so that the category name is 
highlighted for autofill), then type a colon (:). You can then type the first few letters of the sub-category; when 
the correct sub-category name is suggested, press the Tab or Return key to accept it. If you do not want to use 
one of the existing categories, ignore the suggestions that appear and type in a unique category name. When 
you save the transaction, iBank will prompt you to create a new category based on what you typed in.

Organizing category hierarchy

You can easily reorganize your category hierarchy at any time by dragging and dropping categories and sub-
categories in the category list view. If you drop one category on top of another, that category will become a 
sub-category of the one you dropped it on. If you drag a sub-category to a place in the list outside of the main 
category to which it belongs, it will become a main category itself. Rearranging categories in this fashion will 
not disrupt any transactions that are assigned to those categories; the transactions will automatically update to 
reflect the category changes. You can create as many levels and sub-levels of categories as you wish.
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Sub-categories in reports

For information about how categories and sub-categories are handled by reports, please refer to the pages 
about each report type in Chapter 7: Reports.
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How do I import transactions from my bank or other 
financial software?

iBank can import transaction data from your financial institutions or other money-management software in a 
variety of formats. You can import transactions regularly to keep current with your bank’s records, or just do a 
one-time import of your transaction history the first time you set up a new account.

You can easily migrate your account data from other financial products like Quicken or Microsoft Money, or if 
you use PDA software such as SplashMoney or Ultrasoft Money to manage your finances you can import that 
data into iBank. iBank also supports direct download so that you can update your accounts at the click of a 
button!

Supported formats:

iBank can import transaction data from the following file formats: QIF (Quicken Interchange Format), OFX (Open 
Financial Exchange, most commonly used by Microsoft Money), QFX (Quicken File Exchange, also known as Web 
Connect format) , and CSV (Comma-Separated Value, most commonly used with Excel and other spreadsheet 
programs).

Import options:

iBank can import transactions using any of the following three methods:

By connecting directly to your financial institution and downloading transaction updates automatically (see 1.	
How do I update my accounts using direct download?).
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By using the built-in web browser to access your bank’s website and downloading transactions manually 2.	
(see How do I use the built-in web browser to download transactions?).

By reading transactions from an external file (see 3.	 How do I import transactions from a QIF, OFX, or QFX file?).

Read more about each type of import in the sections referenced above.
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How do I update my accounts using direct download?

iBank features the ability to connect directly to many financial institutions via the Internet and update your 
accounts automatically. Transactions are downloaded using the Open Financial Exchange (OFX) protocol, which 
is not supported by all financial institutions (and some may charge a fee for this service). We do not guarantee 
direct download access for all accounts.

To configure your accounts for online access:

Before you can download updates directly from your financial institutions, you must configure your accounts for 
online access. If you are setting up an account for the first time, iBank will walk you through the setup process 
automatically. For information about how to configure access for an existing account, see How do I configure 
direct download for my account? in Chapter 2: Accounts.

To update your accounts:

Click the “Download” button on the toolbar or choose Account > Download Transactions for All 
Accounts. If you only want to update one account, select it in the source list and choose Account > Down-
load Transactions for Selected Account. iBank will then attempt to connect to your financial 
institution(s) and retrieve the latest transactions for the account(s) indicated. To cancel downloading for a 
particular account, click the ‘x’ button next to that account’s progress bar. To cancel all downloads, click “Cancel.”
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When downloading is complete, the import window will appear so that you can process the new transactions. 
For more information about working with imported transactions, see How do I process transactions that are 
being imported into iBank? later in this chapter.

If nothing happens when you download:

There may simply be no new transactions available for download. Wait a day or two and try again. If you know 
that some transactions have been posted to your account, but they are not showing up in iBank, try the follow-
ing troubleshooting steps:

Disable online account access and re-enable it, then try the download again.1.	

Change the account’s 2.	 last import date. When updating your accounts automatically, iBank only retrieves 
transactions dated after the last import date recorded for each account. This date updates automatically 
each time you download transactions for that account. If necessary, you can manually edit the date using 
the account inspector.
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Make sure the account is configured with the correct 3.	 type. Sometimes financial institutions identify ac-
counts internally using different types than you would expect. If the account type you specified for the 
iBank account does not match the institution’s type, iBank will connect but will not find any transactions to 
download. Set up a new account with the correct type and try setting up a direct download connection for 
that account.

Change the way iBank identifies itself to your financial institution. Choose 4.	 iBank > Preferences, 
click “Advanced,” and change the setting under “For Direct Connect iBank will identify itself as.” For general 
compatibility, this setting defaults to Quicken Windows 2008, but some financial institutions do not accept 
download connections from that program and software version. If you are not sure which setting to choose, 
contact your financial institution and ask which personal financial management software is preferred. 

Contact us at 5.	 iggsoftware.com/support for assistance.

http://www.iggsoftware.com/support/
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How do I use the built-in web browser to download 
transactions?

For those financial institutions that don’t support direct download, iBank offers a built-in web browser to sim-
plify the process of updating your accounts manually. The first step in downloading transaction updates using 
the built-in browser is to associate a valid URL with your bank account.

To enter a URL for your bank’s website:

In the source list, double-click the account you want to update - the account inspector will pop up next to the 
account. Enter your financial institution’s web address in the “URL” field. Try to be as specific as possible (i.e. 
enter the address that will take you directly to your account login) so as to avoid unnecessary browsing when it 
comes time to update your accounts. When you are done, click “Save” to close the account inspector. A shortcut 
to the web page you entered will be added to the “Websites” section of the source list automatically:
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To visit your bank’s website using the built-in browser:

In the source list, select the account you want to update and click the “Web Download” button on the toolbar, or 
click the shortcut to the financial institution’s site (in the “Websites” section). Assuming you have an active con-
nection to the Internet, iBank will load the web page to the right, where you normally see the account register:

Use iBank’s built-in browser just like you would any other web browser (e.g. Safari, Firefox, Chrome) - click a link 
to browse to that page, and use the buttons along the bottom of the screen to navigate. Click  to go back, 

 to go forward, and  to refresh the current page. A progress indicator  shows when a page is loading, 
and the address of the current page is displayed at the bottom of the window.
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	 Some financial institutions only allow certain browsers to access their websites. If you cannot load your 
institution’s site using iBank’s browser, choose iBank > Preferences, click the “Advanced” button, and 
choose “Safari” from the popup button. Close the preferences window and try loading the website again - if 
your institution allows access for Safari, iBank should now be able to load the page.

Downloading transaction updates:

Each financial institution handles the download process a little bit differently (some do not allow you to down-
load transactions from their websites at all). For specific help with downloading transactions from your institu-
tion’s website, please contact a customer support representative at the institution. In general, however, there 
are four main steps you must follow:

Log into your personal account by typing in your user ID and password.1.	

Browse to the page within your account where you can download transactions.2.	

Select the account from which to download the transactions, and enter a start and end date for the down-3.	
load, and choose a file format.

Choose which iBank account to save the transactions into (at the bottom right corner of the window).4.	

Initiate the download.5.	

	 iBank’s built-in browser does not accept popup windows. If your financial institution utilizes popups in 
order to download data, you will not be able to use iBank’s browser. Download the data using another 
browser, then import it into iBank using File > Import.

Here is a sample download form from one bank’s website:



When specifying a start and end date for the download, be sure to choose dates that are not likely to retrieve 
transactions that you have already imported into iBank. Although iBank will screen for duplicates during the 
import process, it is best to avoid duplicates at the source as much as possible. At the bottom of the browser 
window, iBank displays the date on which data was last imported into the selected account, for easy reference.

If the OFX or QFX file format is available, choose one of those options as they contain the most comprehensive 
transaction data. If neither of those are available, choose QIF or CSV format.

	 Some banks provide several download options without specifying which file type each one uses. Gener-
ally speaking, “Microsoft Money” usually indicates OFX, “Quicken Web Connect” usually indicates QFX, and 
“Quicken” format usually indicates QIF. You do not actually need to own the software indicated to download 
a file in a particular format - just use the software name as a guide to determine the file type you need.

Once you have configured your download settings, choose which account to import the transactions into. Use 
the popup button at the bottom right corner of the window to pick one of your iBank accounts.
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Now you’re ready to begin the download! Click the download button on the web page, and iBank will auto-
matically open the file for importing when the download is complete. If you chose the CSV format, you will be 
prompted to assign labels to the data columns (see the next page for more information). If you chose the QIF or 
CSV format, and iBank cannot recognize the dates in the file, you will be asked to choose a date format before 
proceeding. Otherwise, the import window will open to help you process the new transactions.

To close the built-in web browser:

When you are finished downloading transactions from your financial institution, be sure to log out of your 
account, then select an account (or any other item) in iBank’s source list to leave the browser.
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How do I import transactions from a QIF, OFX, QFX, or CSV 
file?

If you are just getting started with iBank and want to begin by using the transactions you have stored in a file, 
create a new iBank document and follow the prompts to choose the file you want to use to set up your ac-
counts. If you have already set up your accounts in iBank and want to add some transactions from a file, select 
an account and choose File > Import. iBank will then prompt you to locate the document containing the 
transactions you want to import - choose the file and click “Import.”

Labeling CSV columns:

If the file you are importing uses 
the CSV format, iBank will prompt 
you to assign labels to each 
column of data contained in the 
file.

Click the header above each 
column and choose a label 
for the data contained in that 
column. Any columns that are 
not assigned a label will not be 
imported.
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Note that some CSV files use two columns for transaction amounts - in this case, be sure to assign the “With-
drawal” and “Deposit” labels appropriately. For CSV files that only use one column for transaction amounts, 
assign the “Amount” label to that column. Once you have assigned labels to all relevant columns, click “OK” to 
continue.

	 At this time, iBank can only import standard banking transactions from CSV files; split transactions and 
investments cannot be imported from this file type. CSV files that use commas or semicolons as the delim-
iter are accepted.

Choosing a date format:

If the document uses the QIF or CSV format, and iBank cannot recognize the dates in the file, you will be asked 
to choose a date format before proceeding. If you are using OFX or QFX format, no configuration is required - 
continue on to How do I process transactions that are being imported into iBank? later in this chapter.

Setting file associations:

The Finder has the ability to associate certain types of files with applications of your choosing. If you want iBank 
to automatically recognize the files you download from your bank’s website (or bring in from another source), 
you can tell the Finder to associate them with iBank:

In the Finder, select a QIF, OFX, QFX, or CSV file and choose 1.	 File > Get Info.

In the window that appears, click the small disclosure triangle next to “Open With” to view the options in 2.	
that section.

Click the pop-up button and select iBank from the list to set it as the default application for that file.3.	
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Click “Change All” to associate all files of that type with iBank.4.	

From that point forward, any time you double-click a file with that type, it will automatically open iBank and 
begin an import.

	 After associating the file type using the steps above, you can set your web browser to automatically open 
files of that type after they are downloaded. This will allow you to download and begin importing new 
transactions into iBank with one click from your bank’s website! Of course, this is not necessary if you use 
iBank’s built-in web browser.
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How do I choose the date format for a QIF or CSV import?

When importing transaction data from a web download or external file, iBank will typically determine the date 
format used in the file automatically. With some QIF and CSV files, however, iBank may not be able to read the 
format on its own. In those cases, it will prompt you to choose a date format:

Next to “The date currently looks like” is a sample date taken from your import file. Look at this date carefully 
and choose the matching date format from the drop-down menu. Pay attention to the order of the day and 
month, as well as the number of digits in the year. The format code shown at the bottom will update itself 
automatically depending on your menu selection.

Custom formats:

If the sample date doesn’t match any of the drop-down menu selections, choose “Custom” so that you can 
enter a customized date format code. The codes below can be used to match the format of your sample date. 
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For example, to match a date format of “12/31/2005” you would enter “%m/%d/%Y”, or “31.12.05” would be 
“%d.%m.%y”.

These are the codes available for use:

%a - Abbreviated weekday name (e.g. “Mon”)•	

%A - Full weekday name (e.g. “Monday”)•	

%b - Abbreviated month name (e.g. “Jan”)•	

%B - Full month name (e.g. “January”)•	

%d - Day of the month as a two-digit number (01-31)•	

%e - Day of the month as a number, without the leading zeros for 1-9•	

%j - Day of the year as a three-digit number (001-366)•	

%m - Month as a number (01-12)•	

%w - Weekday as a number (0-6), where Sunday is 0•	
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%y - Year without century (00-99)•	

%Y - Year with century (such as 1990)•	

	 Two common mistakes are using an incorrect separator (e.g. entering slashes instead of dashes or dots 
between the month, day, and year codes) or using the wrong code for the year. If the sample date has a 
four-digit year (e.g. “2006”) then be sure your format code includes “%Y” instead of “%y” - the case of the 
letter ‘y’ is important. Choosing a format with a two-digit year when the QIF file uses four digits often results 
in dates importing into iBank with the year “2020.”
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How do I process transactions that are being imported into 
iBank?

When importing transactions into iBank, after you assign labels to CSV columns and choose a date format (if 
required), the import window will appear. This window is used to screen for duplicates, select the transactions 
you want to import, clean up and categorize transactions with import rules, and choose which account to save 
the new transactions into:
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The top half of the import window displays the incoming transactions; the bottom half shows current transac-
tions in the account where the transactions will be saved. If you don’t see any transactions in the bottom half, 
select a destination account using the “Import into” drop-down menu button at the top of the screen. If the 
account is configured for direct download, iBank will show the online account balance below the list of incom-
ing transactions.

	 You can resize the top and bottom panes by clicking the small divot at the center of the window and drag-
ging it up or down. 

Across the top of the import window is a tab bar - when you are importing from more than one file (such as 
when you initiate a direct download for multiple accounts), each file will show its own tab here. On each tab is 
shown the name of the account into which the transactions will be saved, and the number of transactions that 
are marked for importing. Click a tab to view and process the transactions in that file.

To select which transactions to import:

Simply click to place a check  in the left-most column next to any incoming transaction that you wish to 
save to your account. Click “Select/Deselect All for Import” to check or uncheck all of the incoming transactions 
at once. To change the account into which the transactions will be saved, click the drop-down menu button 
labeled “Import into” and choose a new destination account.
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To screen for duplicates:

The split-screen view of the import window allows you to easily compare incoming transactions against those 
already in your account. When the import window opens, iBank will automatically compare the transactions in 
the top half against the transactions in the bottom half; any matches it finds will be unchecked in the top half 
so that they will not import. The corresponding transactions in the bottom half will be marked “cleared” because 
they have now been verified by the bank’s records.

	 iBank checks for duplicates based on the date, amount, and check number only. If two transactions have 
the exact same amount and are less than five days apart, or if they have the same amount and check num-
ber (regardless of their dates), iBank will consider them a match and uncheck the incoming transaction.

It is always a good idea to double-check for duplicates in case iBank makes a mistake during the matching 
process. When you select a transaction in the top half of the import window, iBank will indicate any matches 
in the bottom half with large orange arrows (pictured above). If there are no transactions present which iBank 
considers to match your selection, a box will be displayed in the lower half of the window that says, “No Match-
ing Transactions. This transaction is checked for import.”

If you find any duplicates that iBank failed to detect, simply click the checkbox next to the incoming transaction 
(in the top half of the window) so that it is unchecked; this tells iBank not to import the transaction. If you find 
a transaction that iBank thought was a duplicate but is not, place a check in its box so that it will be imported. 
To assist you in the process of screening your incoming transactions, iBank shows your online account balance 
(when available) below the top half of the import window. Compare this figure to the balance your iBank ac-
count will show after the import, displayed below the bottom half of the import window, to help you determine 
when the correct transactions are marked for importing.
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To edit and categorize incoming transactions:

Incoming transactions can be edited just like transactions in a typical account register: click a transaction to 
bring up the transaction editor, then make changes and click the “Save” button to record them. When you 
modify incoming transactions in the import window, iBank will ask you whether or not to create a rule for those 
changes. If you choose to create a rule, iBank will apply the same changes to all similar transactions in the 
import window (for current and future imports). If you choose not to, iBank will not prompt you to create rules 
for that payee again.

For example, let’s say you have an incoming transaction with the payee “FEDEX 31 MAIN ST 55421.” You want to 
clean up the payee name, add a category, and import it into an account named “Checking.” You select “Checking” 
as the destination account for the import, edit the transaction and change the payee to “FedEx,” then assign 
it to the category “Business Expenses:Shipping.” When you save the changes, iBank prompts you to create a 
rule, and you choose “Create Rule.” iBank automatically creates a template based on “FedEx” and the “Business 
Expenses:Shipping” category, attaches rules to the template that look for the payee “FEDEX 31 MAIN ST 55421” 
and the account “Checking,” and applies the rule to all other incoming transactions that have “FEDEX 31 MAIN ST 
55421” as their payee. For more information about using import rules, see the next section in this chapter.

To complete the import:

Once you have finished preparing your transactions to be imported, click the “Import” button on the right side 
of the window. The progress bar on the left side of the import window will update as iBank processes the new 
transactions. When the import is complete, the new transactions will appear in the account you specified. Any 
new categories associated with those transactions will be added to “Categories” in the source list, and any new 
securities associated with investment transactions will be added to “Securities.”
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	 In some cases, transfers you import from an external file may not be linked once they arrive in iBank. In this 
case, a transaction will be listed in each of the accounts associated with the transfer. Your account balances 
will be accurate - the only difference is that changes made to one side of the transfer will not affect the 
other side. You can re-link imported transfers manually by assigning the appropriate category (the destina-
tion account) to one of the transactions, and deleting the other transaction.

After completing an import, the destination account’s inspector will be updated to show the current date and 
time. You can edit the last import date manually in the account inspector if necessary - just double-click on the 
account you want to modify (for example, you may want to set the last import date to today’s date if you enter 
transactions manually instead of performing an import).

To cancel the import process:

If you are importing from multiple files, click the ‘x’ button on any file’s tab to cancel importing from that file. If 
only one tab is showing, simply close the import window to cancel the import. You can revisit the import win-
dow at any time by choosing Window > Show Import Window. Incoming transactions will only be stored 
in the import window until you close the current iBank document.
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How do I use import rules?

 Import rules are used to help you import transactions more efficiently. Files imported from banks often con-
tain extraneous information or are not worded the way you would like them to be - import rules allow you to 
import your data using words that make sense to you. The best part about them is that iBank does all the work 
for you behind the scenes, by automatically recording the changes you make to the transactions you import! 
You only need to manage import rules if you want more specific control over how they affect your imports.

To illustrate what import rules do, let’s say that a purchase you made at your local market shows a payee of “123 
Main St. Market ID:992311” when downloaded from the bank. Using an import rule, you can choose to have any 
imported transaction that contains “123 Main St.” in the payee field automatically changed to “Mimi’s Market” 
and assigned to the category “Groceries.”

Import rules are based on transaction templates. When one or more import rules are associated with a template, 
that template will be applied to imported transactions that satisfy its rules. For more information about tem-
plates, see Can iBank remember transactions I enter more than once? in Chapter 3: Transactions.

Getting started with import rules:

First, start an import. After choosing a date format (if required), the import window will appear. You can edit the 
incoming transactions (in the top half of the import window) just like the transactions in a typical account regis-
ter. If you make a change to a transaction’s payee, transaction type, category, or memo and save the transaction, 
iBank will ask if you want to create an import rule for the change. If you choose “Create Rule,” iBank will create 
a template based on the new transaction details and attach two import rules to it: one that looks for payees 
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that match the transaction’s original payee, and one that checks that the destination account is the same as the 
current import. The new rule will automatically be applied to the other transactions in the import window.

For example, let’s say you have an incoming transaction with the payee “FEDEX 31 MAIN ST 55421.” You want to 
clean up the payee name, add a category, and import it into an account named “Checking.” You select “Checking” 
as the destination account for the import, edit the transaction and change the payee to “FedEx,” then assign 
it to the category “Business Expenses:Shipping.” When you save the changes, iBank prompts you to create a 
rule, and you choose “Create Rule.” iBank automatically creates a template based on “FedEx” and the “Business 
Expenses:Shipping” category, attaches rules to the template that look for the payee “FEDEX 31 MAIN ST 55421” 
and the account “Checking,” and applies the rule to all other incoming transactions that have “FEDEX 31 MAIN ST 
55421” as their payee.

	 When you first start using iBank, you will be prompted every time you make a change in the import win-
dow. As you choose whether or not to create rules for your payees, the prompts will appear less frequently. 
You can choose to have iBank create rules automatically without prompting you by checking “Always create 
rules for me” and then clicking “Create Rule.”

If you don’t want iBank to create a rule for the changes you make, choose “Don’t Create Rule” after saving the 
transaction. iBank will remember that transaction’s original payee, and will not prompt you for any future 
changes made to imported transactions with that payee. If you ever want iBank to prompt you for that payee in 
the future, choose iBank > Preferences and click “Reset Import Rules Exclusion.” iBank will forget its list of 
excluded payees, and prompt you to create rules for all changes you make in the import window.
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Managing import rules:

Once an import rule has been created for a particular payee, iBank will automatically update the template as-
sociated with that rule as you make changes in the future. For example, if you decide during an import that your 
“FedEx” transactions should actually have the payee “Federal Express” and you change one transaction accord-
ingly, iBank will update your import rule to apply the “Federal Express” payee instead of “FedEx.” Because iBank 
tracks your rule changes behind the scenes like this, you typically don’t need to worry about managing import 
rules. If you want to exert finer control over this feature, however, you can tweak the import rules manually.

To view the import rules that are currently in use, select “Import Rules” in the source list. A list of transaction 
templates that have import rules attached to them will appear to the right:

Edit the template details just as you would edit a transaction in a standard account register. When an incoming 
transaction matches the import rules for that template, the transaction type, payee, memo, category, and splits 
from the template will be applied to it. If any of these fields are left blank in the template, iBank will not change 
those fields on the incoming transactions.
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Editing import rules:

To view and edit the import rules associated with a transaction template, select the template and click the 
“Import Rules” button in the editor. Each transaction that you import, before it is saved to your accounts, will be 
evaluated by the rules in this window in order to determine whether or not the template should be applied to it. 
The following illustration shows our “FedEx” example from above:

You can see that this template is configured to look for any transactions that are being imported into the 
“Checking” account and have the payee “FEDEX 31 MAIN ST 55421.” Any incoming transactions that match both 
of these rules will have the template details applied to them (in this case, the payee “FedEx” and the category 
“Business Expenses:Shipping”) before they are saved to the account.
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Rule sets

iBank allows you to attach multiple sets of import rules to each transaction template. When you are viewing the 
import rules, each set is bordered by a blue box with the title “Import Rules.” In most cases, you will only need 
to use one rule set. If you want to add another set of rules, click the plus (+) button below the table. To remove 
a rule set, click the set so that the box around it shows in blue, then click the minus (-) button below the table. 
When you import transactions, each set of rules will be evaluated against the incoming transactions separately 
(from top to bottom) to determine whether or not the template should be applied.

Rule descriptions

Click the plus (+) and minus (-) buttons next to existing rules to add and remove, respectively, the rules that will 
determine which transactions are to be modified by the template. The following rules are available:

Any/All of the following are true:•	  If you choose “Any” as the option for this rule, all transactions that 
match at least one of the rules that follow will have the template applied to them. If you choose “All,” only 
transactions that match all of the rules that follow will be displayed. The first instance of this rule cannot be 
removed. Additional “Any/All” rules can be added by holding the Option key and clicking the ‘...’ button next 
to one of the existing rules. This will allow you to create more complex rule hierarchies.

	 Be careful with the “any” option - if you choose this option and accidentally leave one of your rules blank, 
you may end up with a rule that applies itself to all of your imported transactions. 

Payee:•	  Use this rule to look for transactions matching a particular payee name. Type in the word or phrase 
you want iBank to look for, then choose how the rule will be applied. Choose “contains” if you want iBank 
to apply the rule to any transaction containing that word or phrase (e.g. “Cat” will match both “Cat” and 
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“Catcher in the Rye”). Choose “is equal to” if you want iBank to apply the rule only to transactions that 
match the word or phrase exactly (e.g. “Cat” will match “Cat” but not “Catcher in the Rye”).

Memo:•	  Use this rule to look for transactions with specific information in their memo fields. Type in the 
word or phrase you want iBank to look for, then choose how the rule will be applied. Choose “contains” if 
you want iBank to apply the rule to any transaction containing that word or phrase. Choose “is equal to” if 
you want iBank to apply the rule only to transactions that match the word or phrase exactly.

Account:•	  Use this rule to limit the import rule for use with specific iBank accounts only.

Once you are done editing the import rules for the current template, click “Save” to record the changes, or click 
“Cancel” to discard them.

Adding and deleting import rules:

To create a new transaction template and add import rules to it, select “Import Rules” in the source list, click the 
plus (+) button at the bottom of the register. A new template will be created with a blank import rule - configure 
the rules as appropriate and save them, then enter the template details you want to be applied to your im-
ported transactions.

To add import rules to an existing transaction template, select “Import Rules” in the source list, then click “All 
Templates” at the bottom of the register. This will allow you to view all of your transaction templates, regardless 
of whether they have import rules associated with them. Select the template you want to use, then click “Import 
Rules” and configure the rules as needed. After saving the changes you make to the import rules, click “Import 
Rules” at the bottom of the register to hide the templates without import rules. You will see that the template 
you edited is now displayed in that list.
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To remove the import rules from a transaction template, select the template, click “Import Rules,” select a rule 
set, and click the minus (-) button at the bottom of the table to remove it. Repeat for each rule set until the 
table of import rules is empty, then click “Save” to record the changes. The transaction template will no longer 
be displayed under “Import Rules” in the source list, but it will still be used to autofill new transactions that you 
record manually.

To delete the entire template, including its import rules and any schedules associated with it, select the tem-
plate and click the minus (-) button at the bottom of the register.

	 Import rules are only applied to transactions during the import process. Adding, changing, and deleting 
import rules has no effect on the transactions that are saved in your accounts. 
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How do I manage investments with iBank?

iBank can be used to track activity in your investment accounts (including 401k’s IRA’s, SEP’s, etc.). There are 
three features that work together to help you track investments in iBank:

Investment accounts reflect your real-life brokerage accounts and are used to record all investment-
related transactions. To get started with investment tracking in iBank, you must first create an investment 

account. Even if you do not maintain a brokerage account in real life, you must create a “virtual” brokerage 
account in iBank to record your security holdings.

Securities are what you use to manage general information about the securities you are tracking, such as 
their ticker symbols, risk level, and price history.

Reports are used to check the performance of your holdings and analyze the return on your investments.

Read more about each feature in the following sections.



224 Chapter 6: Investments

How do I track my investment activity?

To track your investment activity in iBank, you must first set up an investment or 401k account and then add 
transactions to the account as you buy and sell securities. In iBank, investment accounts are set up and main-
tained just like banking accounts, except that they allow transaction types that pertain to securities. When you 
select an investment account in the source list, the account register will appear to the right so that you can man-
age the transactions in the account. You will notice that the register for an investment account shows different 
information than it does for a banking account:

Each time you buy or sell shares, receive a dividend, transfer cash in and out of your brokerage account, receive 
a capital gains distribution, etc., a transaction should be created in your investment account to record that 
action.
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To add an investment transaction:

Select an investment account from the source list and click the plus (+) button at the bottom of the account 
register to add a new transaction:

Choose the appropriate transaction type and enter the trade date into the date field. If the transaction involves 
shares of a security, enter that security’s ticker symbol, then proceed to fill in the other transaction details. In-
vestment transactions have the following properties in addition to some of the standard transaction properties.

Investment transaction properties:

Security

The name of the security, or the ticker symbol used to identify the security on an exchange. When you enter a 
name or symbol for the first time, iBank will ask you to configure some additional options for that security. A 
symbol is required even when the security is not listed publicly; in this case, enter anything that will distinguish 
the security for reporting purposes, such as “_BOND1,” “_CD2,” etc. A suffix may be added to the symbol to 
specify which exchange should be used to retrieve quotes (for example, “GGQ1.MU” will lookup quotes for 
Google on the Munich Stock Exchange).

	 See http://finance.yahoo.com/exchanges for a list of supported exchanges and their suffixes. Be aware that 
each exchange provides quotes in its local currency and that iBank does not automatically convert these to 
the default currency for your investment account.

http://finance.yahoo.com/exchanges
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Price/Share

The price per share paid as the result of a purchase or dividend reinvestment, or collected as the result of a sale. 
When receiving a gift of shares, this field is used to record the cost basis (average cost per share) of the shares 
gained.

Commission

The amount of commission paid to a broker to conduct the transaction.

Div/Int Income

The cash value of a dividend, interest income, capital gains, or capital distribution. If you reinvest the money 
(using the funding/distribution setting), this figure must equal the price per share multiplied by the number of 
shares added or deducted.

Withdrawal

The cash amount of the transaction, indicating a negative value. This figure is calculated automatically when 
buying or selling shares of a security and the “funding/distribution” property (below) is set to “cash.”

Deposit

The cash amount of the transaction, indicating a positive value. This figure is calculated automatically when 
buying or selling shares of a security and the “funding/distribution” property (below) is set to “cash.”
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Balance

A running total of the account’s overall cash value, showing each transaction’s effect on the total. This field is 
automatically calculated by iBank and cannot be edited. Note that this balance represents cash held in your 
brokerage account only. The market value of shares you own is not included - to view this information, create an 
investment report.

	 Entries in the balance column are always calculated in chronological order, regardless of the current sort 
order. If the numbers in this column don’t seem to be making sense, click the “Date” column header to make 
sure your transactions are sorted by date.

Shares Out

The number of security shares deducted from your portfolio as a result of the transaction.

Shares In

The number of security shares added to your portfolio as a result of the transaction.

Funding/Distribution

The source of funding for a purchase, or the means by which funds are distributed after a sale, receipt of a 
dividend, or other investment transaction that generates income. Choose one of the following options:

Cash:•	  Deduct cash from the brokerage account and use it to buy shares, or deposit cash from the sale of 
shares into the brokerage account. For dividends, interest income, and capital gains, use this option to 
indicate that cash was deposited into the brokerage account. iBank will automatically calculate the amount 
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of cash withdrawn or deposited using the price per share, number of shares added or deducted, and com-
mission you enter.

Transfer:•	  Deduct cash from another account and use it to buy shares, or deposit cash from the sale of 
shares into another account. For dividends, interest income, and capital gains, use this option to indicate 
that cash was deposited into another account. Use the category field to indicate which account the cash 
should be withdrawn from or deposited into. iBank will automatically calculate the amount of cash trans-
ferred using the price per share, number of shares added or deducted, and commission you enter.

Reinvest:•	  Only available for dividends, interest income, and capital gains. Use this option to indicate the 
cash received was used to purchase additional security shares. Enter the price per share and number of 
shares added or deducted in the appropriate fields. The price multiplied by the number of shares must 
equal the amount of the dividend/interest income.

Managing investments with multiple currencies:

Transactions in investment accounts do not show currency-related information as transactions in banking 
accounts do. Each security you trade uses a particular currency (depending on which exchange the security 
is traded through), and iBank only allows you to trade a security in an investment account that uses the same 
currency. If you intend to trade shares using an account with a different currency, you must set up an account 
that uses the same currency as the security, record the trade in that account, set the funding/distribution op-
tion to point to the account with the other currency, and then apply an exchange rate to the transaction in that 
account.

To illustrate, let’s say you maintain a checking account and an investment account in GBP, but you wish to 
purchase shares of AAPL (which is traded on the New York Stock Exchange). Since the NYSE trades in USD, you 
cannot purchase shares of AAPL using your GBP account. First, set up a second investment account that uses 
USD as its currency. Second, transfer cash from the GBP checking account into the GBP investment account to 
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fund the purchase. Third, record a Buy transaction in the USD account to purchase the AAPL shares. Be sure to 
set its funding type to “Transfer” and enter the name of the GBP investment account in the category field - this 
will cause iBank to purchase the shares using cash from the GBP investment account. Finally, switch to the GBP 
investment account and apply an exchange rate to the Buy transaction so that the correct amount of GBP funds 
are deducted.

Understanding investment balances:

When dealing with investment accounts, there are two different balances you need to be aware of:

Cash balance

This figure reflects the amount of cash in your brokerage account only. In most cases, cash is not actually held in 
your brokerage account for long - when you purchase shares of a stock, you transfer the money to your broker 
and then it is immediately spent to purchase the securities. When you receive money from the sale of a stock, 
the money is immediately transferred into a savings or other account. In most cases, the cash balance of your 
investment accounts will remain at 0. This figure is shown in the “Balance” column in the account register:
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Cash balance

Total value

This figure represents the combined worth of the cash value of the brokerage account and the market value 
of your investment portfolio. The market value is an estimate based on the quotes iBank has recorded for your 
securities (you can view this by creating a Portfolio Summary report). The total value of each investment ac-
count is displayed below the account’s name in the source list:

Total Value



231Chapter 6: Investments

Need examples?

Even though iBank can help to simplify the process, managing investments is often tricky business. To read 
several examples of how to track various kinds of investment activities in iBank, see Examples of investment 
activity later in this chapter.
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How do I manage information about my securities?

To track securities with iBank, you must first create an investment account and then add investment transac-
tions to record the shares you own. Once investment transactions have been recorded, you can monitor the 
performance of your portfolio using investment reports. To manage general information about your securities, 
such as assigning risk levels, downloading the latest quotes, and checking historical prices, select “Securities” in 
the source list. The securities table will appear to the right:



233Chapter 6: Investments

To add a security:

Click the plus (+) button at the bottom of the security list, and enter details for the security in the sheet that 
appears:

Name:•	  The full name of the security.

Symbol: •	 The ticker symbol used to identify the security on an exchange. iBank uses this symbol to down-
load quotes for the security via the Internet. A symbol is required even when the security is not listed on a 
public exchange; in this case, enter anything that will distinguish the security for reporting purposes, such 
as “_BOND1,” “_CD2,” etc. A suffix may be added to the symbol to specify which exchange should be used to 
retrieve quotes (for example, “GGQ1.MU” will lookup quotes for Google on the Munich Stock Exchange).

	 iBank uses the Yahoo! Finance quote service to download security quotes. To ensure that your securities 
are supported, look them up at http://finance.yahoo.com/lookup. This is also a handy way to identify the 
correct symbol to use for a particular security.

http://finance.yahoo.com/lookup
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Type:•	  The type of security this item represents. iBank will retrieve quotes automatically for stocks, mutual 
funds, ETFs, and indices when you click “Download Quotes” at the bottom of the securities table. Prices for 
other types of securities will need to be entered manually (see below).

Risk:•	  The level of risk involved with holding this security, ranging from the relatively low-risk “inflation 
hedge” to the comparatively high-risk “growth” option.

Currency:•	  The currency in which the security is traded. This is typically determined by the exchange used 
to trade the security: for example, the New York Stock Exchange only trades in USD, whereas the Munich 
Stock Exchange trades in EUR. Be sure to choose the appropriate currency so that the security is properly 
valued in your investment reports.

	 iBank only shows currencies that have been configured for use in your document. For more information 
about adding currencies, see How do I manage accounts in multiple currencies? in Chapter 2: Accounts. 

Notes: •	 Any additional information about the security that you want to record for future reference.

You can also create a security by adding a transaction to an investment account and typing in a symbol for the 
new security. iBank will recognize that the security has not been recorded yet, and will ask you to configure it 
using the same screen pictured above.

To add a watchlist item or index:

Even if you don’t own any shares of a particular security, you can still add it to the securities table in order to 
track it as a watchlist item - simply follow the same steps described above to add the security. The only func-
tional difference between a watchlist item and an active security is that the latter has investment transactions 
associated with it. Both types of securities are displayed the same way in the securities table.
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To track stock indices such as NASDAQ or the Dow Jones, add security as described above. Enter the name of 
the index, and be sure to enter a ‘^’ symbol in front of the index’s ticker symbol (for example, “^IXIC” or “^DJI”). 
Select the “Index” type before you click “Create.” Indices appear in the securities table alongside of your active 
securities and watchlist items.

To download quotes for your securities:

Click “Download Quotes” on the toolbar, or select “Securities” in the source list and click “Download Quotes” at 
the bottom of the securities table. Assuming you have an active connection to the Internet, iBank will look up all 
of your securities on Yahoo! Finance and download the latest quote for each one. When available, the price his-
tory for each security will also be downloaded (see below for more information). Any securities for which quotes 
cannot be downloaded can be updated manually by editing the price history.

To view and edit the details of a security:

Select “Securities” in the source list and select a security. The details of the security will appear below the securi-
ties table:

On the left, you will see the security symbol, an image depicting the security’s type, the current quote, and the 
date and time at which the quote was obtained. To the right are the other security details. Click the right arrow 
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button next to the symbol field to look up additional information about the security on the Yahoo! Finance 
website.

Feel free to edit the security’s name, symbol, type, risk, and notes (the currency cannot be changed). When you 
make a change, you will see “Save” and “Cancel” buttons appear at the bottom of the window - click these to 
record and discard your changes, respectively. Any modifications you make will automatically be applied to the 
investment transactions associated with the security.

To view and edit a security’s price history:

When an item is selected in the securities table, a chart will appear at the bottom of the window to show the 
price history for that security:

Each data point on the graph consists of three lines representing four bits of information for a particular day: 
the horizontal line on the left indicates the security’s opening price, the vertical line indicates the high and low 
prices, and the horizontal line on the right indicates the closing price. Click on one of these data points to view 
the exact figures to the left.

To edit the price for a particular date, simply click the data point you want to modify or type in the date, then 
adjust the Open, Close, High, and Low figures as needed. When you make a change, you will see “Save” and 
“Cancel” buttons appear at the bottom of the window - click these to record and discard your changes, respec-
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tively. For any securities for which iBank cannot download quotes automatically, you should enter prices in the 
history graph on a regular basis. iBank will use these prices when determining the value of your investment 
accounts and generating investment reports.

To clear the entire price history for the selected security, click “Delete Price History” at the bottom of the main 
window. The next time you download quotes, iBank will fill in the price history with information from Yahoo! 
Finance.

To delete a security:

Select it in the securities table and click the minus (-) button at the bottom of the window. If the security has any 
investment transactions associated with it, iBank will alert you that those transactions must be deleted before 
the security can be removed.
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Examples of investment activity

Setting up an IRA:

So you just celebrated your birthday again, and you’ve decided that you just can’t put it off any longer - it’s time 
to start planning for your retirement. You decide to take that $5000 you’ve been saving from your paychecks 
down to Raymond James and open an IRA. You want to keep close tabs on your contributions, however, so you 
want to set up iBank to help you track the account. Here’s what you need to do:

Click the “Add Account” button on the 1.	 toolbar to create a new account.

Enter “Raymond James IRA” as the account name, choose “Investment” as its type, then click “Next” to con-2.	
tinue.
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On the next screen, type “ray” in the search box to narrow down the choices, then select “Raymond James” 3.	
in the list. Only web download is available for this institution, so there is no direct download setup. Click 
“Next” to continue, then click “Skip This Step” on the next screen. (For simplicity’s sake, we’re going to skip 
the web download process and assume you will track your investments manually.)

Since you opened the account with $5000, enter that amount as the starting balance on the next screen 4.	
and click “Next,” then “Done” to complete the account setup.
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The new account will appear in the 5.	 source list, along with a shortcut to the Raymond James website. Select 
the investment account to display its register:

You will see your starting balance listed in the register as a cash deposit. Each time you make a contribution 6.	
to the account, add a “Deposit” transaction (or a “Transfer,” if you are moving the cash from another ac-
count). When you direct your custodian to buy and sell shares, add “Buy” and “Sell” transactions to track the 
purchases and sales.

Sit back and relax, knowing that you’ll be safe and secure when retirement finally arrives (provided you 7.	
keep making those contributions!).
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Purchasing shares using cash from a checking account:

Let’s assume that you already have an investment account set up in iBank. Your monthly salary comes in (direct 
deposited into your checking account), and you determine that you have about $500 to invest. After exploring 
your options, you decide that the best way to spend that money would be to purchase 2.026 shares of Apple 
stock at $252.51 each. Here’s how you would track this in iBank:

Select your checking account in the 1.	 source list. Add a transaction for your paycheck:

Select your investment account in the source list. Add a transaction to 2.	 buy Apple stock:

If you leave the transaction as pictured above, the funds for the purchase would be taken directly from the 3.	
cash in your investment account. In this case, however, you want the funds to come from your checking 
account instead. Change the funding/distribution setting to “Transfer” and enter “Checking” in the category 
field:

Now that you have recorded the transaction, you want to check the current value of the shares you bought. 4.	
Click “Security Quotes” on the toolbar to download the latest quotes, then click “Add Report” to start setting 
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up a report for your investment account. Enter “IRA Report” as the name of the report, set its date range to 
cover “Last Year to Date,” choose “Investment Summary” on the left, then click “Create Report.”

A new report will appear in the 5.	 source list; double-click this item to view its settings. Since you only want 
to report on the securities in your IRA account, put a check next to the IRA account under “Limit report to 
specific accounts,” then click “Save.”
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On the right side of the screen you should now see the 6.	 investment report. Click “Unrealized Gains” to view a 
detail report of your portfolio. You can now see the AAPL shares in your IRA account, along with their origi-
nal cost, current market value, and gain/loss. In this example, the report shows that the value of the shares 
went up slightly, and your unrealized gain is currently at 1%:

Think about diversifying your investments a bit!7.	
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Selling shares:

Following the example above, let’s say that you decide to diversify your portfolio a bit. The first step is to sell 
some of your Apple stock (prices are up anyways, so why not?). Perhaps later you can use that money to buy 
shares in Microsoft (hey, we’re diversifying, right?). So you decide to sell 1 share of your Apple stock, and put the 
money you get into your savings account for now. Here’s how you would track this in iBank:

Select your 1.	 investment account in the source list. Add a transaction to sell the Apple shares as follows:

Once you have saved the transaction, select your savings account in the source list. You will see that the 2.	
cash from the sale was deposited:

To view the capital gains from the sale, select your “IRA Report” in the source list and click “Realized Gains:”3.	

To view market information about the shares that still remain in the account, click the back button, then 4.	
click “Unrealized Gains:”
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Receiving a gift of stock:

You know that rich uncle of yours who amassed a fortune as a day trader? Right, the one who just passed away. 
Well, it turns out that, even though he never met you, he must have thought well of you, because he left you 
500 shares of Google stock. Imagine that! Here’s how you would track this in iBank:

Assuming that you don’t already have an 1.	 investment account set up, create a new one. It doesn’t matter 
that you don’t actually have a brokerage account and all you own are those 500 Google shares - as far as 
iBank is concerned, you are your own brokerage account. Call the investment account “My Investments” and 
give it a starting balance of 0 (since there is no cash in the account).

Add a2.	  “Move Shares” transaction to record the Google shares (since you got them for free):

Notice that your account balance remains at 0, because you haven’t spent or received any cash. The “Move 
Shares” transaction type allows you to add or deduct shares of a security without affecting its cost basis. If 
you wanted to record a cost basis for the shares, you would need to use a “Buy” transaction instead.
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Click “Security Quotes” on the 3.	 toolbar to update the value of the new shares, then create an investment 
report (as you did in the example above regarding purchasing shares) to view the unrealized gains. Watch 
yourself get rich and ponder how sweet life really is:

Receiving cash dividends:

Now, everybody knows that you’re a hard worker. You may have just been gifted a fortune in Google stock, but 
you’re not ready to retire just yet. No! Instead, you’re going to let the investment sit and watch it grow as you 
keep your nose to the grindstone. Lucky for you, Google just decided to start paying out cash dividends, so 
every month you can get a little bit richer. To track each dividend in iBank:

Select your 1.	 investment account in the source list. Add a transaction and set its type to “Dividend.”

Because this is a cash dividend, leave the 2.	 distribution type set to “Cash.” Enter the ticker symbol (GOOG), and 
put the amount received in the Div/Int Income field:
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When you save the transaction, you will see a 3.	 cash balance in your investment account. Since you got a 
check in the mail from Google, however, this still doesn’t quite represent how you received the dividend. 
In reality, you took that check and deposited it directly into your checking account. To reflect this in iBank, 
change the distribution type to “Transfer” and enter the name of your checking account in the category 
field:

Now you will see that the cash balance of the investment account remains at 0, because the cash from the 
dividend is being deposited into your checking account instead.

Add another one of these each month, and try to find some time to spend all the extra money in between 4.	
your work hours!

Reinvesting dividends:

Being the wise investor that you are, you decide to take the cash you receive from your Google dividends and 
reinvest it back into company stock automatically. Here’s how you record the reinvestments in iBank:

Select your 1.	 investment account in the source list. Add a transaction and set its type to “Dividend.”
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Enter the 2.	 ticker symbol (GOOG) and change the distribution type to “Reinvest.” You can then enter the price 
per share, dividend income, and number of shares added.

(Notice that your account balance remains at 0, because you haven’t spent or received any cash.)

Create an 3.	 investment report to see the unrealized gains on your new shares.

Tracking a stock split:

Now, it just so happens that Google continues to trend upward in the market. The price per share reaches a truly 
astronomical level, so Google execs decide to do a 3-for-1 split, just for the heck of it. This is what you need to do 
to enter the split into iBank:

Select your 1.	 investment account in the source list. Add a transaction, set its type to “Split,” and enter Google’s 
ticker symbol.

Calculate the number of shares you gained in the split and enter this into the transaction. In a 2:1 split, the 2.	
number of shares gained is equal to the number you owned prior to the split. In a 3:1, you gain twice the 
number of shares previously owned, etc. The price in this case is irrelevant, so you can either leave it blank 
or enter the new price after the split (for reference) - either way, it will not affect the value of your securities:
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Click “Security Quotes” on the 3.	 toolbar to update the price of your stocks, then use an investment report to 
view the changes. Consider an early retirement as you wait for the price to continue rising!

Tracking stock options:

After all this time, it looks like your hard work has finally paid off. Google just decided to hire you, and they’ve 
granted you stock options! Here’s how you would track those in iBank:

Let’s say Google gives you the option to buy 200 shares of its stock. In financial terms, you have opened a 1.	
long position (a call) on the options market. Add a “Buy to Open” transaction to your investment account. 
In the symbol field, enter the ticker symbol of the option (not the symbol of the stock which you have the 
option to buy). If this is the first time you are recording a transaction for this option, iBank will ask you to 
configure the new security:
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	 Symbols for options are based on their underlying stock symbols, expiration dates, option types, and strike 
prices. For more information about determining the correct symbols to use for your options, see http://biz.
yahoo.com/opt/symbol.html

Leave the price per share at 0, because you didn’t purchase the options - they were given to you for free. 
Since each option represents 100 shares, enter “2” in the shares in field. Notice that the cash value of your 
account has not changed. Save the transaction, which should now look like this:

To monitor the performance of Google’s stock before you exercise your options (let’s assume you don’t 2.	
already own any Google shares), add Google to the main securities list as a watchlist item. Select “Securities” 
in the “Manage” section of the source list and click the plus (+) button to add a new security. Enter “Google” 
as the name, “GOOG” as the symbol, “Stock” as the type, any risk level you like, and any notes you want to 
keep track of, then click “OK” to add it to the list. Click “Security Quotes” on the toolbar to update quotes for 
your securities. You can now visit the securities list and select Google to check in on its market performance 
at any time.

http://biz.yahoo.com/opt/symbol.html
http://biz.yahoo.com/opt/symbol.html
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Now, let’s say Google’s stock skyrockets and you decide the time is right to cash in - you are going to 3.	
exercise your option to buy the 200 shares and sell them at their current value. In iBank, you record three 
transactions: one to close the position on your options, and one to buy the Google shares. First, add a “Sell 
to Close” transaction to your investment account to deduct the options. Enter the ticker symbol for the 
options, leave the price at 0 (since you’re not selling the options), and enter “2” in the shares out field:

Second, add a “Buy” transaction and enter “GOOG” as the symbol, the options’ strike price as the price per 
share, and “200” as the number of shares added. If you are funding the purchase from another account, set 
the funding source to “Transfer” and enter the name of the account in the category field.
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Finally, add a “Sell” transaction to sell the Google shares for cash. Enter “GOOG” as the symbol, the price per 
share, and “200” as the number of shares sold. To direct the cash towards a different account, set the distri-
bution type to “Transfer” and enter the name of the account in the category field.

Sit back and muse about how best to spend your profits!4.	
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What are reports all about?

 Reports are where iBank really begins to demonstrate its value. After putting in the time and effort to set 
up your accounts, enter transactions, and categorize everything, you can use reports to make sense out of all 
that information quickly and easily. The more meticulously you record and categorize your transactions, the 
more useful iBank’s reports will be in helping you analyze your finances.

With very little setup, you can view breakdowns of your spending habits, see details of all the transactions as-
signed to a particular category or payee, examine the return on your investments, see how well you have been 
managing your debts, quickly access tax-related information, and more. Every report can be printed exactly as it 
appears onscreen or saved to a PDF file for archival purposes.

Each report you create is saved and displayed in the “Reports” section of the source list. Click the small disclosure 
triangle next to “Reports” to reveal your saved reports. Select one to view that report on the right side of the 
main window.
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To add a new report:

Click the plus (+) button at the bottom of the source list, or choose Manage > Add New Report. iBank will 
ask you what type of report to create:

Income & Expense•	 : Analyze the cash flow in and out of your accounts based on your categories and view 
a profit & loss statement.

Net Worth•	 : Compare your assets and liabilities on a balance sheet and graph your wealth over time.

Expense Timeline•	 : View a monthly breakdown of your income and expenses by category.

Category Detail•	 : View a table showing the details of your transactions, grouped and subtotaled by cat-
egory.

Portfolio Summary•	 : Review market information about your investment portfolio.
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Investment Summary•	 : Analyze your investments in more depth, including capital gains, portfolio diver-
sity, and return on investment (ROI).

Payee Summary•	 : View income and expense totals for your payees, and see detailed transaction lists for 
individual payees.

U.S. Tax•	 : Analyze tax-related information including income and expense categories and capital gains from 
your investments.

Debt/Liability•	 : Analyze the money you owe for loans, credit cards, and other forms of debt (including 
investments that aren’t performing well).

Forecast•	 : Project your account balances into the future using scheduled transactions.

After you select a report type, click “Next” to configure options for the new report. Continue reading this chapter 
for more information about setting up and using each type of report.

To edit a report:

Each report has a number of settings that can be configured to adjust the information displayed on the report. 
Once a report has been created, double-click its icon in the source list to open the report inspector and modify 
the report settings. The available options will change depending on the type of report - read on for more infor-
mation about each type.

To delete a report:

Select a report in the source list, then click the minus (-) button at the bottom of the list or choose Edit > 
Delete. iBank will ask for confirmation before deleting the report.
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About the summary pane and mini-graph:

iBank offers the ability to show a miniature net worth graph at the bottom left corner of the main window. To 
show it, click the double-arrow button  at the bottom of the source list to reveal the summary pane, then 
click the arrow button  to switch to the net worth graph. For more information about the summary pane and 
mini-graph, see How do I use the summary pane and mini-graph? in Chapter 1: Getting Started.
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How do I use the Income & Expense report?

The Income & Expense report type is used to analyze the cash that flows in and out of your accounts based on 
the categories assigned to your transactions. It is the easiest way to track trends in specific categories, and to 
see if you are earning more than you spend in a given period of time. iBank’s Income & Expense report includes 
pie charts that show breakdowns of your income and expenses by category, a bar graph that shows your spend-
ing over time (cash flow), and a table of income and expense totals by category.

To create an Income & Expense report:

Choose a report type1.	



262 Chapter 7: Reports

Click the plus (+) button at the bottom of the source list, or choose Manage > Add New Report. A sheet 
will appear to let you choose the type of report you want to create. Choose “Income & Expense,” then click “Next” 
to continue.

Choose accounts2.	

This screen lets you define the scope of the report by choosing which accounts are included. Using the popup 
menu at the top of the screen, choose one of the following options and configure its settings accordingly:

Limit to Specific Accounts:•	

By default, new Income & Expense reports include all visible accounts. If you want to limit the report to 
certain accounts, choose this option from the popup menu button and check off the accounts you want to 
include. When no accounts are checked, all accounts are included in the report.
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Limit to Accounts Using Smart Rules:•	

To limit the report to certain accounts based on dynamic criteria, choose this option from the popup menu 
button. You can then configure a series of rules that define which accounts are included in the report:

Any/All of the following are true:•	  If you choose “Any” as the option for this rule, all accounts that 
match at least one of the rules that follow will be included in the report. If you choose “All,” only ac-
counts that match all of the rules that follow will be included. The first instance of this rule cannot 
be removed. Additional “Any/All” rules can be added by holding the Option key and clicking the ‘...’ 
button next to one of the existing rules. This will allow you to create more complex rule hierarchies.

Group:•	  Use this rule to include or exclude all accounts in a particular account group.

Debit:•	  Use this rule to include or exclude accounts of the following types: Credit Card, Line of 
Credit, Liability, and Loan.
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Currency: •	 Use this rule to include or exclude all accounts that use a specific currency.

Account type:•	  Use this rule to include or exclude all accounts of a particular type.

The advantage of using rules instead of checking off specific accounts is that the report will automatically 
update itself to include all accounts that satisfy the rules you set up. To illustrate, say you create a report 
to track only your assets, by using a rule that excludes all loan, credit, and liability account types. Once 
the report has been created, you can add and delete accounts as needed (of any type), and the report will 
always show all of your asset accounts.

	 Account transfers are only counted in Income & Expense reports when one of their associated accounts is 
included but the other account is excluded. When both accounts are included, the transfer is considered to 
be internal and does not count as either income or an expense. Only when one of the accounts is excluded 
does the transfer gain value, from the perspective of the report.

When you finish configuring accounts for the report, click “Next” to continue.

Choose categories and transfers3.	

This screen lets you choose which categories and transfers are included in the report. Using the popup menu at 
the top of the screen, choose one of the following options and configure its settings accordingly:
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Report on All Categories and Accounts Except:•	

By default, new Income & Expense reports include all categories and account transfers. If you want to 
exclude certain categories and transfers from the report, choose this option from the popup menu button 
and check off the items you want to exclude. Checking a category that contains sub-categories will remove 
both the parent category and its sub-categories from the report. Click “Toggle All Checkboxes” to check or 
uncheck all items in the list. When no items are checked, all categories and account transfers are included.

	 Only accounts that were excluded from the report on the previous screen will appear in this list. Transfers to 
and from accounts that are within the scope of the report cannot be counted in the report. 
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Report on Specific Categories and Accounts:•	

To limit the report to certain categories and account transfers, choose this option from the popup menu 
button and check off the items you want to include. Checking a category that contains sub-categories 
will include both the parent category and its sub-categories in the report. Click “Toggle All Checkboxes” to 
check or uncheck all items in the list.

Report Using Smart Rule Criteria:•	

To limit the report to certain categories and account transfers based on dynamic criteria, choose this 
option from the popup menu button. You can then configure a series of rules that define which items are 
included in the report:
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Any/All of the following are true: •	 If you choose “Any” as the option for this rule, all categories/ac-
counts that match at least one of the rules that follow will be included in the report. If you choose 
“All,” only categories/accounts that match all of the rules that follow will be included. The first 
instance of this rule cannot be removed. Additional “Any/All” rules can be added by holding the 
Option key and clicking the ‘...’ button next to one of the existing rules. This will allow you to create 
more complex rule hierarchies.

Parent Category:•	  Use this rule to include or exclude all sub-categories that fall under a specific 
category.

Category/Account:•	  Use this rule to include or exclude specific categories or transfers associated 
with specific accounts. Choosing a category that contains sub-categories using this rule will not 
include or exclude the sub-categories that belong to it.

Taxable:•	  Use this rule to include or exclude all categories that are designated as “Taxable.”

Debit: •	 Use this rule to include or exclude all categories that are designated as “Expense” categories.

Check “Include uncategorized transactions” if you want to include transactions that do not have categories as-
signed to them in addition to the transactions with categories included in the report. The uncategorized trans-
actions must satisfy the other report options to be included, e.g. fall within the report’s range and be recorded 
in one of the included accounts. When this option is checked, an item named “Uncategorized” will appear in the 
charts and tables on the report.

Once you’ve chosen which categories and transfers to include in the report, click “Next” to continue.
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Choose a date range4.	

This screen lets you choose a date range for the report. Click the popup menu button and select from a variety 
of predefined ranges: options that end with “to Date” indicate periods of time that are relative to the current 
date; other options represent fixed periods of time.

You may also choose “Custom Dates” to enter a more specific range. Use the “starting/ending” popup to deter-
mine whether the report covers a range of dates in the future or past, respectively. Choose “today” to have the 
report start or end on the current date (regardless of when the report is viewed), or choose “on date” to specify a 
fixed start/end date.
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Finish creating the report5.	

This screen lets you configure a few last settings for the new report. Enter a unique name to distinguish the 
report from others in the source list, then pick which currency its figures should be displayed in. If accounts that 
use different currencies are included in the report, their figures will be converted automatically using iBank’s 
current exchange rates.

Check the “Include scheduled transactions” option to include pending scheduled transactions in addition to the 
transactions that are recorded in your accounts. The scheduled transactions must satisfy the other report op-
tions to be included, e.g. fall within the report’s range and be scheduled to post to one of the included accounts. 
These transactions appear with a yellow background in transaction list reports (see below).



270 Chapter 7: Reports

	 This option can be used to project your income and expenses into the future. To forecast your categories in 
this manner, be sure the report is configured with a date range that includes future dates. 

When you are finished configuring these options, click “Next” and then “Done.” The new report will be added to 
the source list, and the report details will be displayed in the main window.

To edit the report settings:

Once a report has been created, you can edit its 
settings at any time. Double-click the report in 
the source list, or select it and choose View > 
Show Popup Inspector. The report inspec-
tor will open to show you the available options. 
Make any changes necessary, then click “Save” to 
record the changes or “Cancel” to discard them.
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To interpret the report:

The report’s name and type are shown at the top of the report. The date range used for the report follows. Three 
charts and a table are displayed below: a pie chart showing your expenses by category, a pie chart showing 
your income by category, a bar chart showing your spending habits over time, and a table detailing your in-
come and expenses by category.

Expenses and Income By Category

These are pie charts depicting your expenses and income over the period of time covered by the report - ex-
penses are on the left and income is on the right. Each pie slice represents the total value of a particular cat-
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egory or transfers associated with a particular account, and the slices are drawn proportionally so that you can 
see which items comprise a larger portion of your cash flow.

Below each chart is a key that shows which colors correspond to which categories/accounts and the total value 
of each item. Mouse over any category or account name to highlight the corresponding slice in the pie chart 
above. Click on any pie slice to “drill down” and see more detail. If you click on a category that contains sub-
categories, iBank will show you an income & expense report for that category and its sub-categories. If you click 
on a category with no sub-categories, iBank will show you a detailed list of the transactions that comprise that 
category (more below). Use the arrow buttons below the report to navigate back and forth as you drill down 
into the report details.

	 By default, iBank generates random colors to differentiate slices in the pie charts. If you want iBank to use 
the colors assigned to your categories, choose iBank > Preferences, click the “Appearance” button, and 
check “Show category background colors.” This will show the category colors in your account registers as 
well as on pie charts.

Spending Over Time
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This is a bar chart depicting your cash flow over time. Each bar represents the total income and expenses 
recorded during a portion of the report’s full date range. Income for each period is drawn above the horizontal 
axis; expenses are drawn below it. The black line indicates the total combined income and expenses for each 
period. Click on a bar to view income and expense pie charts and a category table (see below) for the time 
period the bar represents.

Income & Expenses by Category

This is a table detailing your income and expense categories over the time frame specified for the report. The 
“Category” column lists the category names (and account names, when transfers are included) in alphabetical 
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order and grouped according to their type (income or expense). Sub-categories are grouped under their parent 
categories, and any funds assigned directly to a parent category are displayed under a sub-category named 
“Other.” The “Amount” column shows the total for each category/account as well as totals for each group. The 
total displayed at the bottom of the table is your net profit, also known as the “bottom line.” Click on the name 
of any category or account to view a detailed transaction list for that item (more below).

	 By default, iBank groups categories under “Income” and “Expense” headings based on the total value of 
each category. To group categories according to their category type instead, choose iBank > Prefer-
ences, click “Advanced,” and choose “Category Type” under “Organize categories in reports by.”

Transaction List

This is a table detailing the transactions in a particular category or transfers associated with a particular ac-
count. Only transactions that are counted in the report are displayed here; other transactions may be recorded 
in the category or account but fall outside the scope of the report. Transactions are displayed on this report in 
chronological order and show their dates, status, payees, categories, credit/debit amounts, and account names. 
Click on a transaction to open a new window showing that transaction in its account register. You may edit the 
transaction as needed; when you save your changes, the report will be updated automatically.
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To print or save a copy of a report:

The main report and any of the detailed reports that you can drill down to can be printed simply by choosing 
File > Print and clicking the “Print” button. The paper size used for the printout can be changed by choos-
ing File > Page Setup and selecting a different setting, but the orientation is restricted to portrait mode 
(landscape is not permitted).

To save a copy of a report as a PDF file, choose File > Print, then click the “PDF” button and choose “Save 
As PDF.” Enter a name for the new file, choose where you want to save it, and click “Save.” You will then have a 
copy of the report that you can view and print using the Preview application or any standard PDF reader.

	 You may also export the data from any table on a report to a tab-delimited file. Simply drag and drop the 
table onto your Desktop to create a tab-delimited text clipping, or drag and drop the table directly into 
Microsoft Excel or Apple Numbers to create a spreadsheet using the table data.
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How do I use the Net Worth report?

The Net Worth report type is used to determine the total value of all your accounts. Your “net worth,” also known 
as your “wealth,” is calculated by taking the value of your assets (money you hold) and subtracting the value 
of your liabilities (money you owe). Cash you have in your accounts is included as well as any investments you 
hold. iBank’s Net Worth report includes a bar graph that shows your net worth over time, pie charts showing 
breakdowns of your assets and liabilities by account type, and a balance sheet that details your assets and 
liabilities on a specific date.

To create a Net Worth report:

Choose a report type1.	
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Click the plus (+) button at the bottom of the source list, or choose Manage > Add New Report. A sheet 
will appear to let you choose the type of report you want to create. Choose “Net Worth,” then click “Next” to 
continue.

Choose accounts2.	

This screen lets you define the scope of the report by choosing which accounts are included. Using the popup 
menu at the top of the screen, choose one of the following options and configure its settings accordingly:

Limit to Specific Accounts:•	

By default, new Net Worth reports include all visible accounts. If you want to limit the report to certain ac-
counts, choose this option from the popup menu button and check off the accounts you want to include. 
When no accounts are checked, all accounts are included in the report.
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Limit to Accounts Using Smart Rules:•	

To limit the report to certain accounts based on dynamic criteria, choose this option from the popup menu 
button. You can then configure a series of rules that define which accounts are included in the report:

Any/All of the following are true:•	  If you choose “Any” as the option for this rule, all accounts that 
match at least one of the rules that follow will be included in the report. If you choose “All,” only ac-
counts that match all of the rules that follow will be included. The first instance of this rule cannot 
be removed. Additional “Any/All” rules can be added by holding the Option key and clicking the ‘...’ 
button next to one of the existing rules. This will allow you to create more complex rule hierarchies.

Group:•	  Use this rule to include or exclude all accounts in a particular account group.

Debit: •	 Use this rule to include or exclude accounts of the following types: Credit Card, Line of 
Credit, Liability, and Loan.

Currency:•	  Use this rule to include or exclude all accounts that use a specific currency.
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Account type:•	  Use this rule to include or exclude all accounts of a particular type.

The advantage of using rules instead of checking off specific accounts is that the report will automatically 
update itself to include all accounts that satisfy the rules you set up. To illustrate, say you create a report 
to track only your assets, by using a rule that excludes all loan, credit, and liability account types. Once 
the report has been created, you can add and delete accounts as needed (of any type), and the report will 
always show all of your asset accounts.

When you finish configuring accounts for the report, click “Next” to continue.

Choose a date range3.	

This screen lets you choose a date range for the report. Click the popup menu button and select from a variety 
of predefined ranges: options that end with “to Date” indicate periods of time that are relative to the current 
date; other options represent fixed periods of time.
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You may also choose “Custom Dates” to enter a more specific range. Use the “starting/ending” popup to deter-
mine whether the report covers a range of dates in the future or past, respectively. Choose “today” to have the 
report start or end on the current date (regardless of when the report is viewed), or choose “on date” to specify a 
fixed start/end date.

Finish creating the report4.	

This screen lets you configure a few last settings for the new report. Enter a unique name to distinguish the 
report from others in the source list, then pick which currency its figures should be displayed in. If accounts that 
use different currencies are included in the report, their figures will be converted automatically using iBank’s 
current exchange rates.

Check the “Include scheduled transactions” option to include pending scheduled transactions in addition to the 
transactions that are recorded in your accounts. The scheduled transactions must satisfy the other report op-
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tions to be included, e.g. fall within the report’s range and be scheduled to post to one of the included accounts. 
These transactions appear with a yellow background in transaction list reports (see below).

	 This option can be used to project your net worth into the future. To forecast your account balances in this 
manner, check “Include scheduled transactions,” set “Report on” to “Custom Dates,” and enter a specific date 
in the future.

When you are finished configuring these options, click “Next” and then “Done.” The new report will be added to 
the source list, and the report details will be displayed in the main window.

To edit the report settings:

Once a report has been created, you can edit its 
settings at any time. Double-click the report in the 
source list, or select it and choose View > Show 
Popup Inspector. The report inspector will open 
to show you the available options. Make any changes 
necessary, then click “Save” to record the changes or 
“Cancel” to discard them.
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To interpret the report:

The report’s name and type are shown at the top of the report. The date range used for the report follows, along 
with a description of the information contained within the report. Three charts and a table are displayed below: 
a bar chart showing your net worth over time, a pie chart showing your assets by account type, a pie chart 
showing your liabilities by account type, and a tabular balance sheet detailing your assets and liabilities.

Net Worth Over Time

This is a bar chart depicting your net worth over time. Each bar represents the total value of your accounts at a 
fixed point in time. Assets are drawn above the horizontal axis and consist of cash (money you have on hand) 
and securities (shares you own that are worth more than what you paid for them). Liabilities are drawn below 
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the axis and consist of cash (money you owe) and securities (shares you own that are worth less than what you 
paid for them). The black line that is drawn over the bars indicates your total net worth over time.

Click on a bar to view a detailed balance sheet report for the date it represents (more below). Use the arrow 
buttons below the report to navigate back and forth as you “drill down” into the report details.

Below the bar chart is a written description of some trends in your net worth. iBank provides the starting and 
ending net worth figures for the report’s timeframe, along with the percent change over that period. It shows 
the percent change in your net worth over a more recent period of time, and it indicates the change in your rate 
of wealth accumulation.

Assets and Liabilities by Account Type

These are pie charts depicting your assets and liabilities at a fixed point in time (the end date of the report) - 
assets are on the left and liabilities are on the right. Each pie slice represents the total value of the accounts of a 
particular type, and the slices are drawn proportionally so that you can see which types of accounts are worth 
more. Below each chart is a key that shows which colors correspond to which account types and the total value 
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of each type. Mouse over any account type to highlight the corresponding slice in the pie chart above. Click on 
any pie slice to view a detailed balance sheet report for the accounts that make up that slice (more below).

Balance Sheet

This is a table detailing your net worth at a fixed point in time (the end date of the report). The “Account” column 
lists your accounts in alphabetical order and grouped into cash assets, cash liabilities, security assets, and secu-
rity liabilities. The “Amount” column shows the value of each account as well as totals for each group. The total 
displayed at the bottom of the table is your net worth. Click on the name of any account to view a transaction 
list for that account (more below).

	 If you are using multiple currencies, each group will be subtotaled by currency and a third column will 
appear showing the totals converted into the report’s currency (conversions are based on iBank’s current 
exchange rates).
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Transaction List

This is a table detailing the transactions in a particular account. Only transactions that are counted in the report 
are displayed here; other transactions may be recorded in the account but fall outside the scope of the report. 
Transactions are displayed on this report in chronological order and show their dates, status, payees, categories, 
and credit/debit amounts. When investment transactions are displayed, their security details are shown. A run-
ning balance for the account is also shown. Click on a transaction to open a new window showing that transac-
tion in its account register. You may edit the transaction as needed; when you save your changes, the report will 
be updated automatically.

To print or save a copy of a report:

The main report and any of the detailed reports that you can drill down to can be printed simply by choosing 
File > Print and clicking the “Print” button. The paper size used for the printout can be changed by choos-
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ing File > Page Setup and selecting a different setting, but the orientation is restricted to portrait mode 
(landscape is not permitted).

To save a copy of a report as a PDF file, choose File > Print, then click the “PDF” button and choose “Save 
As PDF.” Enter a name for the new file, choose where you want to save it, and click “Save.” You will then have a 
copy of the report that you can view and print using the Preview application or any standard PDF reader.

	 You may also export the data from any table on a report to a tab-delimited file. Simply drag and drop the 
table onto your Desktop to create a tab-delimited text clipping, or drag and drop the table directly into 
Microsoft Excel or Apple Numbers to create a spreadsheet using the table data.
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How do I use the Expense Timeline report?

The Expense Timeline report type is used to analyze the cash that flows in and out of your accounts over time, 
based on the categories assigned to your transactions. It is a simple tool for looking at trends in your spending 
and seeing fluctuations in your cash flow at different points in time. iBank’s Expense Timeline report consists of 
tables that show breakdowns of your income and expenses by category at regular intervals.

To create an Expense Timeline report:

Choose a report type1.	
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Click the plus (+) button at the bottom of the source list, or choose Manage > Add New Report. A sheet 
will appear to let you choose the type of report you want to create. Choose “Expense Timeline,” then click “Next” 
to continue.

Choose accounts2.	

This screen lets you define the scope of the report by choosing which accounts are included. Using the popup 
menu at the top of the screen, choose one of the following options and configure its settings accordingly:

Limit to Specific Accounts:•	

By default, new Expense Timeline reports include all visible accounts. If you want to limit the report to 
certain accounts, choose this option from the popup menu button and check off the accounts you want to 
include. When no accounts are checked, all accounts are included in the report.
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Limit to Accounts Using Smart Rules:•	

To limit the report to certain accounts based on dynamic criteria, choose this option from the popup menu 
button. You can then configure a series of rules that define which accounts are included in the report:

Any/All of the following are true:•	  If you choose “Any” as the option for this rule, all accounts that 
match at least one of the rules that follow will be included in the report. If you choose “All,” only ac-
counts that match all of the rules that follow will be included. The first instance of this rule cannot 
be removed. Additional “Any/All” rules can be added by holding the Option key and clicking the ‘...’ 
button next to one of the existing rules. This will allow you to create more complex rule hierarchies.

Group:•	  Use this rule to include or exclude all accounts in a particular account group.

Debit:•	  Use this rule to include or exclude accounts of the following types: Credit Card, Line of 
Credit, Liability, and Loan.
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Currency: •	 Use this rule to include or exclude all accounts that use a specific currency.

Account type:•	  Use this rule to include or exclude all accounts of a particular type.

The advantage of using rules instead of checking off specific accounts is that the report will automatically 
update itself to include all accounts that satisfy the rules you set up. To illustrate, say you create a report 
to track only your assets, by using a rule that excludes all loan, credit, and liability account types. Once 
the report has been created, you can add and delete accounts as needed (of any type), and the report will 
always show all of your asset accounts.

	 Account transfers are only counted in Expense Timeline reports when one of their associated accounts is 
included but the other account is excluded. When both accounts are included, the transfer is considered to 
be internal and does not count as either income or an expense. Only when one of the accounts is excluded 
does the transfer gain value, from the perspective of the report.

When you finish configuring accounts for the report, click “Next” to continue.

Choose categories and transfers3.	

This screen lets you choose which categories and transfers are included in the report. Using the popup menu at 
the top of the screen, choose one of the following options and configure its settings accordingly:
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Report on All Categories and Accounts Except:•	

By default, new Expense Timeline reports include all categories and account transfers. If you want to 
exclude certain categories and transfers from the report, choose this option from the popup menu button 
and check off the items you want to exclude. Checking a category that contains sub-categories will remove 
both the parent category and its sub-categories from the report. Click “Toggle All Checkboxes” to check or 
uncheck all items in the list. When no items are checked, all categories and account transfers are included.

	 Only accounts that were excluded from the report on the previous screen will appear in this list. Transfers to 
and from accounts that are within the scope of the report cannot be counted in the report. 
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Report on Specific Categories and Accounts:•	

To limit the report to certain categories and account transfers, choose this option from the popup menu 
button and check off the items you want to include. Checking a category that contains sub-categories 
will include both the parent category and its sub-categories in the report. Click “Toggle All Checkboxes” to 
check or uncheck all items in the list.

Report Using Smart Rule Criteria:•	

To limit the report to certain categories and account transfers based on dynamic criteria, choose this 
option from the popup menu button. You can then configure a series of rules that define which items are 
included in the report:
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Any/All of the following are true: •	 If you choose “Any” as the option for this rule, all categories/ac-
counts that match at least one of the rules that follow will be included in the report. If you choose 
“All,” only categories/accounts that match all of the rules that follow will be included. The first 
instance of this rule cannot be removed. Additional “Any/All” rules can be added by holding the 
Option key and clicking the ‘...’ button next to one of the existing rules. This will allow you to create 
more complex rule hierarchies.

Parent Category:•	  Use this rule to include or exclude all sub-categories that fall under a specific 
category.

Category/Account:•	  Use this rule to include or exclude specific categories or transfers associated 
with specific accounts. Choosing a category that contains sub-categories using this rule will not 
include or exclude the sub-categories that belong to it.

Taxable:•	  Use this rule to include or exclude all categories that are designated as “Taxable.”

Debit: •	 Use this rule to include or exclude all categories that are designated as “Expense” categories.

Check “Include uncategorized transactions” if you want to include transactions that do not have categories as-
signed to them in addition to the transactions with categories included in the report. The uncategorized trans-
actions must satisfy the other report options to be included, e.g. fall within the report’s range and be recorded 
in one of the included accounts. When this option is checked, an item named “Uncategorized” will appear in the 
report tables.

Once you’ve chosen which categories and transfers to include in the report, click “Next” to continue.
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Choose a date range4.	

This screen lets you choose a date range for the report. Click the popup menu button and select from a variety 
of predefined ranges: options that end with “to Date” indicate periods of time that are relative to the current 
date; other options represent fixed periods of time.

You may also choose “Custom Dates” to enter a more specific range. Use the “starting/ending” popup to deter-
mine whether the report covers a range of dates in the future or past, respectively. Choose “today” to have the 
report start or end on the current date (regardless of when the report is viewed), or choose “on date” to specify a 
fixed start/end date.
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Finish creating the report5.	

This screen lets you configure a few last settings for the new report. Enter a unique name to distinguish the 
report from others in the source list, then pick which currency its figures should be displayed in. If accounts that 
use different currencies are included in the report, their figures will be converted automatically using iBank’s 
current exchange rates.

Check the “Include scheduled transactions” option to include pending scheduled transactions in addition to the 
transactions that are recorded in your accounts. The scheduled transactions must satisfy the other report op-
tions to be included, e.g. fall within the report’s range and be scheduled to post to one of the included accounts. 
These transactions appear with a yellow background in transaction list reports (see below).
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	 This option can be used to project your income and expenses into the future. To forecast your cash flow in 
this manner, be sure the report is configured with a date range that includes future dates. 

When you are finished configuring these options, click “Next” and then “Done.” The new report will be added to 
the source list, and the report details will be displayed in the main window.

To edit the report settings:

Once a report has been created, you can edit its 
settings at any time. Double-click the report in 
the source list, or select it and choose View > 
Show Popup Inspector. The report inspec-
tor will open to show you the available options. 
Make any changes necessary, then click “Save” to 
record the changes or “Cancel” to discard them.
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To interpret the report:

The report’s type is shown at the top, followed by the date range used for the report. Several tables are dis-
played below to show your spending habits over time.

Income & Expenses Over Time

This is a table detailing your income and expense categories over the time frame specified for the report. The 
“Category” column lists the category names (and account names, when transfers are included) in alphabetical 
order and grouped according to their type (income or expense). Sub-categories are grouped under their parent 
categories, and any funds assigned directly to a parent category are displayed under a sub-category named 
“Other.” The other columns represent discrete intervals within the report’s date range; each one contains the 
amount earned or spent in each category during that interval, as well as totals for each group. The column on 
the right side of the last table contains totals for each category. The total displayed at the bottom right corner 
of the table is your net profit, also known as the “bottom line.” Click on the name of any category or account to 
view a detailed transaction list for that item (more below).



298 Chapter 7: Reports

	 By default, iBank groups categories under “Income” and “Expense” headings based on the total value of 
each category. To group categories according to their category type instead, choose iBank > Prefer-

ences, click “Advanced,” and choose “Category Type” under “Organize categories in reports by.”

Transaction List

This is a table detailing the transactions in a particular category or transfers associated with a particular ac-
count. Only transactions that are counted in the report are displayed here; other transactions may be recorded 
in the category or account but fall outside the scope of the report. Transactions are displayed on this report in 
chronological order and show their dates, status, payees, categories, credit/debit amounts, and account names. 
Click on a transaction to open a new window showing that transaction in its account register. You may edit the 
transaction as needed; when you save your changes, the report will be updated automatically.



299Chapter 7: Reports

To print or save a copy of a report:

The main report and any of the detailed reports that you can drill down to can be printed simply by choosing 
File > Print and clicking the “Print” button. The paper size used for the printout can be changed by choos-
ing File > Page Setup and selecting a different setting, but the orientation is restricted depending on the 
report you are printing (some use portrait mode and some use landscape).

To save a copy of a report as a PDF file, choose File > Print, then click the “PDF” button and choose “Save 
As PDF.” Enter a name for the new file, choose where you want to save it, and click “Save.” You will then have a 
copy of the report that you can view and print using the Preview application or any standard PDF reader.

	 You may also export the data from any table on a report to a tab-delimited file. Simply drag and drop the 
table onto your Desktop to create a tab-delimited text clipping, or drag and drop the table directly into 
Microsoft Excel or Apple Numbers to create a spreadsheet using the table data.
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How do I use the Category Detail report?

The Category Detail report type is used to quickly view details of all transactions assigned to one or more 
categories within a specific period of time. It is a simple way to view totals for your categories while seeing the 
details of the transactions that make up those totals. iBank’s Category Detail report consists of a single table 
showing transaction details grouped and subtotaled by category. 

To create an Category Detail report:

Choose a report type1.	
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Click the plus (+) button at the bottom of the source list, or choose Manage > Add New Report. A sheet 
will appear to let you choose the type of report you want to create. Choose “Category Detail,” then click “Next” to 
continue.

Choose accounts2.	

This screen lets you define the scope of the report by choosing which accounts are included. Using the popup 
menu at the top of the screen, choose one of the following options and configure its settings accordingly:

Limit to Specific Accounts:•	

By default, new Category Detail reports include all visible accounts. If you want to limit the report to 
certain accounts, choose this option from the popup menu button and check off the accounts you want to 
include. When no accounts are checked, all accounts are included in the report.
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Limit to Accounts Using Smart Rules:•	

To limit the report to certain accounts based on dynamic criteria, choose this option from the popup menu 
button. You can then configure a series of rules that define which accounts are included in the report:

Any/All of the following are true:•	  If you choose “Any” as the option for this rule, all accounts that 
match at least one of the rules that follow will be included in the report. If you choose “All,” only ac-
counts that match all of the rules that follow will be included. The first instance of this rule cannot 
be removed. Additional “Any/All” rules can be added by holding the Option key and clicking the ‘...’ 
button next to one of the existing rules. This will allow you to create more complex rule hierarchies.

Group:•	  Use this rule to include or exclude all accounts in a particular account group.

Debit:•	  Use this rule to include or exclude accounts of the following types: Credit Card, Line of 
Credit, Liability, and Loan.
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Currency: •	 Use this rule to include or exclude all accounts that use a specific currency.

Account type:•	  Use this rule to include or exclude all accounts of a particular type.

The advantage of using rules instead of checking off specific accounts is that the report will automatically 
update itself to include all accounts that satisfy the rules you set up. To illustrate, say you create a report 
to track only your assets, by using a rule that excludes all loan, credit, and liability account types. Once 
the report has been created, you can add and delete accounts as needed (of any type), and the report will 
always show all of your asset accounts.

	 Account transfers are only counted in Category Detail reports when one of their associated accounts is 
included but the other account is excluded. When both accounts are included, the transfer is considered to 
be internal and does not count as either income or an expense. Only when one of the accounts is excluded 
does the transfer gain value, from the perspective of the report.

When you finish configuring accounts for the report, click “Next” to continue.

Choose categories and transfers3.	

This screen lets you choose which categories and transfers are included in the report. Using the popup menu at 
the top of the screen, choose one of the following options and configure its settings accordingly:
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Report on All Categories and Accounts Except:•	

By default, new Category Detail reports include all categories and account transfers. If you want to exclude 
certain categories and transfers from the report, choose this option from the popup menu button and 
check off the items you want to exclude. Checking a category that contains sub-categories will remove 
both the parent category and its sub-categories from the report. Click “Toggle All Checkboxes” to check or 
uncheck all items in the list. When no items are checked, all categories and account transfers are included.

Report on Specific Categories and Accounts:•	

To limit the report to certain categories and account transfers, choose this option from the popup menu 
button and check off the items you want to include. Checking a category that contains sub-categories 
will include both the parent category and its sub-categories in the report. Click “Toggle All Checkboxes” to 
check or uncheck all items in the list.
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Report Using Smart Rule Criteria:•	

To limit the report to certain categories and account transfers based on dynamic criteria, choose this 
option from the popup menu button. You can then configure a series of rules that define which items are 
included in the report:

Any/All of the following are true: •	 If you choose “Any” as the option for this rule, all categories/ac-
counts that match at least one of the rules that follow will be included in the report. If you choose 
“All,” only categories/accounts that match all of the rules that follow will be included. The first 
instance of this rule cannot be removed. Additional “Any/All” rules can be added by holding the 
Option key and clicking the ‘...’ button next to one of the existing rules. This will allow you to create 
more complex rule hierarchies.
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Parent Category:•	  Use this rule to include or exclude all sub-categories that fall under a specific 
category.

Category/Account:•	  Use this rule to include or exclude specific categories or transfers associated 
with specific accounts. Choosing a category that contains sub-categories using this rule will not 
include or exclude the sub-categories that belong to it.

Taxable:•	  Use this rule to include or exclude all categories that are designated as “Taxable.”

Debit: •	 Use this rule to include or exclude all categories that are designated as “Expense” categories.

Check “Include uncategorized transactions” if you want to include transactions that do not have categories as-
signed to them in addition to the transactions with categories included in the report. The uncategorized trans-
actions must satisfy the other report options to be included, e.g. fall within the report’s range and be recorded 
in one of the included accounts. When this option is checked, an item named “Uncategorized” will appear in the 
report tables.

Once you’ve chosen which categories and transfers to include in the report, click “Next” to continue.
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Choose a date range4.	

This screen lets you choose a date range for the report. Click the popup menu button and select from a variety 
of predefined ranges: options that end with “to Date” indicate periods of time that are relative to the current 
date; other options represent fixed periods of time.

You may also choose “Custom Dates” to enter a more specific range. Use the “starting/ending” popup to deter-
mine whether the report covers a range of dates in the future or past, respectively. Choose “today” to have the 
report start or end on the current date (regardless of when the report is viewed), or choose “on date” to specify a 
fixed start/end date.
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Finish creating the report5.	

This screen lets you configure a few last settings for the new report. Enter a unique name to distinguish the 
report from others in the source list, then pick which currency its figures should be displayed in. If accounts that 
use different currencies are included in the report, their figures will be converted automatically using iBank’s 
current exchange rates.

Check the “Include scheduled transactions” option to include pending scheduled transactions in addition to the 
transactions that are recorded in your accounts. The scheduled transactions must satisfy the other report op-
tions to be included, e.g. fall within the report’s range and be scheduled to post to one of the included accounts. 
These transactions appear with a yellow background in transaction list reports (see below).
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	 This option can be used to project your income and expenses into the future. To forecast your cash flow in 
this manner, be sure the report is configured with a date range that includes future dates. 

When you are finished configuring these options, click “Next” and then “Done.” The new report will be added to 
the source list, and the report details will be displayed in the main window.

To edit the report settings:

Once a report has been created, you can edit its 
settings at any time. Double-click the report in 
the source list, or select it and choose View > 
Show Popup Inspector. The report inspec-
tor will open to show you the available options. 
Make any changes necessary, then click “Save” to 
record the changes or “Cancel” to discard them.
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To interpret the report:

The report’s type is shown at the top, followed by the date range used for the report. A table is displayed below 
showing your transaction details grouped and subtotaled by category.

Category Details

This is a table detailing the transactions included in the report, grouped and subtotaled by category and sub-
category. Only transactions that are counted in the report are displayed here; other transactions may be re-
corded in the category or account but fall outside the scope of the report. Categories are grouped according to 
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their type (income or expense) and displayed in alphabetical order. Sub-categories are listed under their parent 
categories, and the transaction details follow.

Transactions for each category and sub-category are displayed in chronological order and show their dates, 
account names, transaction numbers, payees, categories, and credit/debit amounts. Click on a transaction to 
open a new window showing that transaction in its account register. You may edit the transaction as needed; 
when you save your changes, the report will be updated automatically. At the bottom of each category and 
sub-category transaction list is a subtotal showing the combined amount of the transactions in that category or 
sub-category. Subtotals are shown for income and expense groups as well; at the bottom of the report table is 
the total amount of all transactions included in the report.

	 By default, iBank groups categories under “Income” and “Expense” headings based on the total value of 
each category. To group categories according to their category type instead, choose iBank > Prefer-

ences, click “Advanced,” and choose “Category Type” under “Organize categories in reports by.”

To print or save a copy of a report:

The main report and any of the detailed reports that you can drill down to can be printed simply by choosing 
File > Print and clicking the “Print” button. The paper size used for the printout can be changed by choos-
ing File > Page Setup and selecting a different setting, but the orientation is restricted to landscape 
mode (portrait is not permitted).

To save a copy of a report as a PDF file, choose File > Print, then click the “PDF” button and choose “Save 
As PDF.” Enter a name for the new file, choose where you want to save it, and click “Save.” You will then have a 
copy of the report that you can view and print using the Preview application or any standard PDF reader.
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	 You may also export the data from any table on a report to a tab-delimited file. Simply drag and drop the 
table onto your Desktop to create a tab-delimited text clipping, or drag and drop the table directly into 
Microsoft Excel or Apple Numbers to create a spreadsheet using the table data.
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How do I use the Portfolio Summary report?

The Portfolio Summary report type is used to analyze the market value of your investments. It consists of a table 
that details your securities and subtotals their value by account.

To create a Portfolio Summary report:

Choose a report type1.	

Click the plus (+) button at the bottom of the source list, or choose Manage > Add New Report. A sheet 
will appear to let you choose the type of report you want to create. Choose “Portfolio Summary,” then click 
“Next” to continue.
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Choose accounts2.	

This screen lets you define the scope of the report by choosing which accounts are included. Using the popup 
menu at the top of the screen, choose one of the following options and configure its settings accordingly:

Limit to Specific Accounts:•	

By default, new Portfolio Summary reports include all visible accounts. If you want to limit the report to 
certain accounts, choose this option from the popup menu button and check off the accounts you want to 
include. When no accounts are checked, all accounts are included in the report.

	 Accounts that do not contain security transactions will not be counted in the report, even if they are 
checked here; any banking accounts included in the report do not affect the investment data. 
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Limit to Accounts Using Smart Rules:•	

To limit the report to certain accounts based on dynamic criteria, choose this option from the popup menu 
button. You can then configure a series of rules that define which accounts are included in the report:

Any/All of the following are true:•	  If you choose “Any” as the option for this rule, all accounts that 
match at least one of the rules that follow will be included in the report. If you choose “All,” only ac-
counts that match all of the rules that follow will be included. The first instance of this rule cannot 
be removed. Additional “Any/All” rules can be added by holding the Option key and clicking the ‘...’ 
button next to one of the existing rules. This will allow you to create more complex rule hierarchies.

Group:•	  Use this rule to include or exclude all accounts in a particular account group.

Debit:•	  Use this rule to include or exclude accounts of the following types: Credit Card, Line of 
Credit, Liability, and Loan.

Currency:•	  Use this rule to include or exclude all accounts that use a specific currency.
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Account type:•	  Use this rule to include or exclude all accounts of a particular type.

The advantage of using rules instead of checking off specific accounts is that the report will automatically 
update to include all accounts that satisfy the rules you set up. To illustrate, say you manage multiple 
investment accounts for you and your partner, and you keep them in separate account groups in the 
source list. You create a report to analyze only the investments in one group. Once the report has been 
created, you can add and remove accounts as needed, and the report will always show the investments in 
that particular group.

When you finish configuring accounts for the report, click “Next” to continue.

Choose a date range3.	
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This screen lets you choose a date range for the report. Click the popup menu button and select from a variety 
of predefined ranges: options that end with “to Date” indicate periods of time that are relative to the current 
date; other options represent fixed periods of time.

You may also choose “Custom Dates” to enter a more specific range. Use the “starting/ending” popup to deter-
mine whether the report covers a range of dates in the future or past, respectively. Choose “today” to have the 
report start or end on the current date (regardless of when the report is viewed), or choose “on date” to specify a 
fixed start/end date.

Finish creating the report4.	

This screen lets you configure a few last settings for the new report. Enter a unique name to distinguish the 
report from others in the source list, then pick which currency its figures should be displayed in. If accounts that 
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use different currencies are included in the report, their figures will be converted automatically using iBank’s 
current exchange rates.

Check the “Include scheduled transactions” option to include pending scheduled transactions in addition to the 
transactions that are recorded in your accounts. Since investment transactions cannot be scheduled, this option 
will not affect the results of Investment Summary reports.

When you are finished configuring these options, click “Next” and then “Done.” The new report will be added to 
the source list, and the report details will be displayed in the main window.

To edit the report settings:

Once a report has been created, you can edit its 
settings at any time. Double-click the report in the 
source list, or select it and choose View > Show 
Popup Inspector. The report inspector will open 
to show you the available options. Make any changes 
necessary, then click “Save” to record the changes or 
“Cancel” to discard them.
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To interpret the report:

The report’s name and type are shown at the top of the report. The date of the report follows, along with the 
current market value of the shares you hold, the overall unrealized gain or loss for those shares, and the total 
change in value since the close of market on the previous day. After that you will see a table detailing the secu-
rity shares you hold in each investment account.

Securities by Account

The following columns are displayed:

Security:•	  The ticker symbol and name of the security.

Shares:•	  The number of shares of the security held in a particular account as of the report’s end date.
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Price:•	  The price per share as of the report’s end date, as recorded in the security’s price history. The change 
in price since the previous day is also shown along with the percent change. Positive changes are shaded 
green; negative changes are shaded red.

Value:•	  The market value of the shares held, equal to the number of shares multiplied by the price per 
share.

Cost Basis: •	 The amount paid for the shares when they were originally purchased (including reinvested 
dividends).

S Gain:•	  The difference between the market value and cost basis, if the shares were held for one year or less. 
Positive values are shaded green; negative values are shaded red.

L Gain: •	 The difference between the market value and cost basis, if the shares were held for more than one 
year. Positive values are shaded green; negative values are shaded red.

% Gain:•	  The gain or loss on your investment, expressed as a percentage. Positive values are shaded green; 
negative values are shaded red.

The last row of the table shows totals across all of your investment accounts. Click on a security to view a de-
tailed report for that security (more below). Use the arrow buttons below the report to navigate back and forth 
as you “drill down” into the report details.
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Security Detail

This is a report that shows detailed information about a specific security. It consists of two tables - one showing 
basic information about the shares you hold in that security, the other showing information about the return on 
your investment (ROI). The first table lists the security’s type and risk level, along with several other details from 
the main report above: shares, cost/share (which is the cost basis divided by the total number of shares), price, 
value, gain, and % gain.

The second table details the transactions recorded for that security during the report’s time frame, grouped by 
account, and uses the value of those transactions together with the beginning and ending market value of the 
shares to calculate the return on your investment. The following columns are shown:

Date:•	  The date on which the transaction took place.

Description:•	  The transaction type.

Shares:•	  The number of shares affected by the transaction.

Invest.:•	  The amount of money invested, i.e. how much was paid in the transaction.
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Return:•	  The amount of money earned in the transaction.

Return Total: •	 The return on your investment, expressed as a percentage. Only shows at the bottom of the 
table.

	 To ensure accurate ROI calculations, be sure that the report’s date range includes all transactions associated 
with the security shown. If part of the initial investment is outside the scope of the report, the return total 

will be affected.

Investment Transaction List

This is a table detailing the investment transactions in a particular account. Only transactions that are counted 
in the report are displayed here; other transactions may be recorded in the account but fall outside the scope of 
the report. Transactions are displayed on this report in chronological order and show their dates, status, security 
symbols, transaction types, shares in/out, credit/debit amounts, prices per share, and commissions. A running 
cash balance for the account is also shown. Click on a transaction to open a new window showing that transac-
tion in its account register. You may edit the transaction as needed; when you save your changes, the report will 
be updated automatically.
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To print or save a copy of a report:

The main report and any of the detailed reports that you can drill down to can be printed simply by choosing 
File > Print and clicking the “Print” button. The paper size used for the printout can be changed by choos-
ing File > Page Setup and selecting a different setting, but the orientation is restricted depending on the 
report you are printing (some use portrait mode and some use landscape).

To save a copy of a report as a PDF file, choose File > Print, then click the “PDF” button and choose “Save 
As PDF.” Enter a name for the new file, choose where you want to save it, and click “Save.” You will then have a 
copy of the report that you can view and print using the Preview application or any standard PDF reader.

	 You may also export the data from any table on a report to a tab-delimited file. Simply drag and drop the 
table onto your Desktop to create a tab-delimited text clipping, or drag and drop the table directly into 
Microsoft Excel or Apple Numbers to create a spreadsheet using the table data.
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How do I use the Investment Summary report?

The Investment Summary report type is used to analyze the performance of your investments. It includes charts 
and tables to help you review your capital gains (realized and unrealized), the diversity of your portfolio (by 
security type and risk), your net worth, and the return on your investment (ROI).

To create an Investment Summary report:

Choose a report type1.	

Click the plus (+) button at the bottom of the source list, or choose Manage > Add New Report. A sheet 
will appear to let you choose the type of report you want to create. Choose “Investment Summary,” then click 
“Next” to continue.
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Choose accounts2.	

This screen lets you define the scope of the report by choosing which accounts are included. Using the popup 
menu at the top of the screen, choose one of the following options and configure its settings accordingly:

Limit to Specific Accounts:•	

By default, new Investment Summary reports include all visible accounts. If you want to limit the report to 
certain accounts, choose this option from the popup menu button and check off the accounts you want to 
include. When no accounts are checked, all accounts are included in the report.

	 For this report, you may be tempted to include only investment and 401k accounts. Including all accounts 
will allow the net worth graph to show a more accurate picture of your general financial situation. Accounts 
that do not contain security transactions will not be counted in the other tables and charts on the report, so 
you don’t need to worry about your banking accounts skewing the investment information.
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Limit to Accounts Using Smart Rules:•	

To limit the report to certain accounts based on dynamic criteria, choose this option from the popup menu 
button. You can then configure a series of rules that define which accounts are included in the report:

Any/All of the following are true:•	  If you choose “Any” as the option for this rule, all accounts that 
match at least one of the rules that follow will be included in the report. If you choose “All,” only ac-
counts that match all of the rules that follow will be included. The first instance of this rule cannot 
be removed. Additional “Any/All” rules can be added by holding the Option key and clicking the ‘...’ 
button next to one of the existing rules. This will allow you to create more complex rule hierarchies.

Group:•	  Use this rule to include or exclude all accounts in a particular account group.

Debit:•	  Use this rule to include or exclude accounts of the following types: Credit Card, Line of 
Credit, Liability, and Loan.

Currency:•	  Use this rule to include or exclude all accounts that use a specific currency.
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Account type:•	  Use this rule to include or exclude all accounts of a particular type.

The advantage of using rules instead of checking off specific accounts is that the report will automatically 
update to include all accounts that satisfy the rules you set up. To illustrate, say you manage multiple 
investment accounts for you and your partner, and you keep them in separate account groups in the 
source list. You create a report to analyze only the investments in one group. Once the report has been 
created, you can add and remove accounts as needed, and the report will always show the investments in 
that particular group.

When you finish configuring accounts for the report, click “Next” to continue.

Choose a date range3.	
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This screen lets you choose a date range for the report. Click the popup menu button and select from a variety 
of predefined ranges: options that end with “to Date” indicate periods of time that are relative to the current 
date; other options represent fixed periods of time.

You may also choose “Custom Dates” to enter a more specific range. Use the “starting/ending” popup to deter-
mine whether the report covers a range of dates in the future or past, respectively. Choose “today” to have the 
report start or end on the current date (regardless of when the report is viewed), or choose “on date” to specify a 
fixed start/end date.

Finish creating the report4.	

This screen lets you configure a few last settings for the new report. Enter a unique name to distinguish the 
report from others in the source list, then pick which currency its figures should be displayed in. If accounts that 
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use different currencies are included in the report, their figures will be converted automatically using iBank’s 
current exchange rates.

Check the “Include scheduled transactions” option to include pending scheduled transactions in addition to the 
transactions that are recorded in your accounts. The scheduled transactions must satisfy the other report op-
tions to be included, e.g. fall within the report’s range and be scheduled to post to one of the included accounts. 
These transactions appear with a yellow background in transaction list reports (see below).

	 This option can be used to project your net worth into the future. To forecast your accounts in this manner, 
check “Include scheduled transactions,” set “Report on” to “Custom Dates,” and enter a specific date in the 
future.

When you are finished configuring these options, click “Next” and then “Done.” The new report will be added to 
the source list, and the report details will be displayed in the main window.
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To edit the report settings:

Once a report has been created, you can edit its 
settings at any time. Double-click the report in the 
source list, or select it and choose View > Show 
Popup Inspector. The report inspector will open 
to show you the available options. Make any changes 
necessary, then click “Save” to record the changes or 
“Cancel” to discard them.

To interpret the report:

The report’s name and type are shown at the top of the report. The date range used for the report follows, along 
with a table summarizing your capital gains. Next there are two pie charts showing breakdowns of your current 
holdings by type and risk, then a bar graph showing your net worth over time. Finally, the report includes a 
table showing the return on your investment (ROI).
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Capital Gains

This is a table detailing your investment gains and losses during the time period covered by the report. In the 
“Activity” column you will see line items for short- and long-term realized gains, short- and long-term unrealized 
gains, and security income (dividends, interest, return of capital, and capital gains distributions). The “Amount” 
column shows the total for each item. Click on one of the three sections of this table to “drill down” and view 
detailed information about that section (more below). Use the arrow buttons below the report to navigate back 
and forth as you drill down into the report details.

	 For the Investment Summary report, capital gains are always calculated on a FIFO (first in, first out) basis. 
U.S. tax law requires this method to be used unless specific tax lots are detailed. iBank does not support the 
choosing of specific lots at this point in time.

Below the capital gains table is a written description of a few trends that are apparent in your investment data. 
iBank tells you how much income has been generated by your investments over the report’s time frame, your 
total realized gain/loss, and the total (unrealized) gain/loss from the investments you currently hold.
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Realized Short & Long Term Capital Gains

This is a table detailing the gains and losses from investments you sold within the report’s time frame. Only 
transactions that are counted in the report are displayed here; other transactions may be recorded in your 
investment accounts but fall outside the scope of the report. Transactions are displayed on this report in 
chronological order and are grouped by account and security. The following columns are displayed:

Security: •	 The security name and transaction type.

Quantity:•	  The number of shares bought or sold.

Open:•	  The date on which the shares were purchased.

Cost:•	  The amount paid for the shares when they were originally purchased.

Close:•	  The date on which the shares were sold.

Proceeds:•	  The amount of money received as a result of selling the shares.

S Gain: •	 The difference between the proceeds and cost, if the shares were held for one year or less.

L Gain:•	  The difference between the proceeds and cost, if the shares were held for more than one year.
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Click on a transaction to open a new window showing that transaction in its account register. You may edit the 
transaction as needed; when you save your changes, the report will be updated automatically.

Unrealized Gains

This is a table detailing the estimated gains and losses from investments you currently hold (as of the report’s 
end date). Only shares held in accounts that are included in the report are counted. See How do I use the Portfo-
lio Summary report? in this chapter for more information.
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Security Income Detail

This is a table detailing your security income transactions, including dividends, interest income, return of capital, 
and capital gains distributions (short- and long-term). Only transactions that are counted in the report are dis-
played here; other transactions may be recorded in your investment accounts but fall outside the scope of the 
report. Transactions are displayed on this report in chronological order and grouped by security and account. 
The table columns show the transaction dates, types, and amounts. The last row of the table shows the total 
security income from all accounts included in the report. Click on a transaction to open a new window showing 
that transaction in its account register. You may edit the transaction as needed; when you save your changes, 
the report will be updated automatically.

	 As per U.S. tax law, all dividends are counted as income whether they were recorded as cash or reinvest-
ments. 
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Securities by Type and by Risk

These are pie charts depicting the security shares you currently hold (as of the end date of the report). The chart 
on the left shows a breakdown of the shares by security type; the chart on the right shows a breakdown by risk 
level. Each pie slice represents the total market value of the shares of a particular type or risk, and the slices are 
drawn proportionally so that you can see which types of accounts are worth more. Below each chart is a key 
that shows which colors correspond to which types and risks, and the total value of each slice. Mouse over any 
item to highlight the corresponding slice in the pie chart above. Click on any pie slice to view a detailed hold-
ings report for the shares that make up that slice (more below).

	 To calculate the market value of each security, iBank obtains a price from the security’s price history for 
the end date of the report. When a price is not recorded for the date in question, the price from the closest 
available date is used instead.
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Holdings

This is a table detailing the shares represented by one of the slices in the “Securities by Type” and “Securities by 
Risk” charts described above. See How do I use the Portfolio Summary report? in this chapter for more informa-
tion.

Net Worth Over Time
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This is a bar chart depicting your net worth over time. Each bar represents the total value of your accounts at a 
fixed point in time. Assets are drawn above the horizontal axis and consist of cash (money you have on hand) 
and securities (shares you own that are worth more than what you paid for them). Liabilities are drawn below 
the axis and consist of cash (money you owe) and securities (shares you own that are worth less than what you 
paid for them). The black line that is drawn over the bars indicates your total net worth over time.

Click on a bar to view a detailed balance sheet report for the date it represents (more below). Use the arrow 
buttons below the report to navigate back and forth as you drill down into the report details.

Below the bar chart is a written description of some trends in your net worth. iBank provides the starting and 
ending net worth figures for the report’s timeframe, along with the percent change over that period. It shows 
the percent change in your net worth over a more recent period of time, and it indicates the change in your rate 
of wealth accumulation.

Balance Sheet
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This is a table detailing your net worth at a fixed point in time (the end date of the report). The “Account” column 
lists your accounts in alphabetical order and grouped into cash assets, cash liabilities, security assets, and secu-
rity liabilities. The “Amount” column shows the value of each account as well as totals for each group. The total 
displayed at the bottom of the table is your net worth. Click on the name of any account to view a transaction 
list for that account (more below).

	 If you are using multiple currencies, each group will be subtotaled by currency and a third column will 
appear showing the totals converted into the report’s currency (conversions are based on iBank’s current 
exchange rates).

Transaction List

This is a table detailing the transactions in a particular account. Only transactions that are counted in the report 
are displayed here; other transactions may be recorded in the account but fall outside the scope of the report. 
Transactions are displayed on this report in chronological order and show their dates, status, payees, categories, 
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and credit/debit amounts. A running balance for the account is also shown. Click on a transaction to open a new 
window showing that transaction in its account register. You may edit the transaction as needed; when you save 
your changes, the report will be updated automatically.

Return on Investment (ROI) Summary

This is a table summarizing the return on your investment (similar to your unrealized capital gains) for each 
investment account over the report’s time frame. The following columns are displayed:

Account:•	  The name of the account.

Beg. Mkt.:•	  The market value of all shares in the account as of the report’s starting date.

Cash In:•	  The total value of investments made (i.e. share purchases) in the account during the report’s time 
frame.

Cash Out:•	  The total value of proceeds drawn (i.e. share sales) from the account during the report’s time 
frame.

End Mkt.:•	  The market value of all shares in the account as of the report’s starting date.

Return:•	  The return on your investment for the account, expressed as a percentage.

The row at the bottom of the table shows totals across all investment accounts. Click in the table to view a 
detailed ROI report for your accounts (more below).
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	 To ensure accurate ROI calculations, be sure that the report’s date range includes all transactions associated 
with the securities shown. If part of the initial investment is outside the scope of the report, the return total 
will be affected.

Return on Investment (ROI) Detail

This is a table detailing the return on your investment across multiple accounts. It displays a list of investment 
transactions that fall within the report’s date range in chronological order, grouped by account and security. The 
following columns are shown:

Date:•	  The date on which the transaction took place.

Description:•	  The transaction type.
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Shares:•	  The number of shares affected by the transaction.

Invest.:•	  The amount of money invested, i.e. how much was paid in the transaction.

Return:•	  The amount of money earned in the transaction.

Return Total:•	  The return on your investment, expressed as a percentage. Only shows at the bottom of the 
table.

Click on the details of any security to view a transaction list for that security (more below).

	 To ensure accurate ROI calculations, be sure that the report’s date range includes all transactions associated 
with the security shown. If part of the initial investment is outside the scope of the report, the return total 
will be affected.

Investment Transaction List

This is a table detailing the investment transactions in a particular account. Only transactions that are counted 
in the report are displayed here; other transactions may be recorded in the account but fall outside the scope of 
the report. Transactions are displayed on this report in chronological order and show their dates, status, security 
symbols, transaction types, shares in/out, credit/debit amounts, prices per share, and commissions. A running 
cash balance for the account is also shown. Click on a transaction to open a new window showing that transac-
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tion in its account register. You may edit the transaction as needed; when you save your changes, the report will 
be updated automatically.

To print or save a copy of a report:

The main report and any of the detailed reports that you can drill down to can be printed simply by choosing 
File > Print and clicking the “Print” button. The paper size used for the printout can be changed by choos-
ing File > Page Setup and selecting a different setting, but the orientation is restricted depending on the 
report you are printing (some use portrait mode and some use landscape).

To save a copy of a report as a PDF file, choose File > Print, then click the “PDF” button and choose “Save 
As PDF.” Enter a name for the new file, choose where you want to save it, and click “Save.” You will then have a 
copy of the report that you can view and print using the Preview application or any standard PDF reader.

	 You may also export the data from any table on a report to a tab-delimited file. Simply drag and drop the 
table onto your Desktop to create a tab-delimited text clipping, or drag and drop the table directly into 
Microsoft Excel or Apple Numbers to create a spreadsheet using the table data.



343Chapter 7: Reports

How do I use the Payee Summary report?

The Payee Summary report type is used to analyze where you direct your money, based on the payees assigned 
to your transactions. iBank’s Payee Summary report consists of a table showing your payee names and the total 
value of the transactions associated with each one.

To create a Payee Summary report:

Choose a report type1.	

Click the plus (+) button at the bottom of the source list, or choose Manage > Add New Report. A sheet 
will appear to let you choose the type of report you want to create. Choose “Payee Summary,” then click “Next” 
to continue.
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Choose accounts2.	

This screen lets you define the scope of the report by choosing which accounts are included. Using the popup 
menu at the top of the screen, choose one of the following options and configure its settings accordingly:

Limit to Specific Accounts:•	

By default, new Payee Summary reports include all visible accounts. If you want to limit the report to 
certain accounts, choose this option from the popup menu button and check off the accounts you want to 
include. When no accounts are checked, all accounts are included in the report.
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Limit to Accounts Using Smart Rules:•	

To limit the report to certain accounts based on dynamic criteria, choose this option from the popup menu 
button. You can then configure a series of rules that define which accounts are included in the report:

Any/All of the following are true:•	  If you choose “Any” as the option for this rule, all accounts that 
match at least one of the rules that follow will be included in the report. If you choose “All,” only ac-
counts that match all of the rules that follow will be included. The first instance of this rule cannot 
be removed. Additional “Any/All” rules can be added by holding the Option key and clicking the ‘...’ 
button next to one of the existing rules. This will allow you to create more complex rule hierarchies.

Group:•	  Use this rule to include or exclude all accounts in a particular account group.

Debit:•	  Use this rule to include or exclude accounts of the following types: Credit Card, Line of 
Credit, Liability, and Loan.

Currency:•	  Use this rule to include or exclude all accounts that use a specific currency.
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Account type:•	  Use this rule to include or exclude all accounts of a particular type.

The advantage of using rules instead of checking off specific accounts is that the report will automatically 
update itself to include all accounts that satisfy the rules you set up. To illustrate, say you create a report 
to track the charges on your credit cards by using a rule that includes only credit card accounts. Once the 
report has been created, you can add and delete accounts as needed (of any type), and the report will 
always show transactions from your credit cards.

When you finish configuring accounts for the report, click “Next” to continue.

Choose a date range3.	

This screen lets you choose a date range for the report. Click the popup menu button and select from a variety 
of predefined ranges: options that end with “to Date” indicate periods of time that are relative to the current 
date; other options represent fixed periods of time.
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You may also choose “Custom Dates” to enter a more specific range. Use the “starting/ending” popup to deter-
mine whether the report covers a range of dates in the future or past, respectively. Choose “today” to have the 
report start or end on the current date (regardless of when the report is viewed), or choose “on date” to specify a 
fixed start/end date.

Finish creating the report4.	

This screen lets you configure a few last settings for the new report. Enter a unique name to distinguish the 
report from others in the source list, then pick which currency its figures should be displayed in. If accounts that 
use different currencies are included in the report, their figures will be converted automatically using iBank’s 
current exchange rates.

Check the “Include scheduled transactions” option to include pending scheduled transactions in addition to the 
transactions that are recorded in your accounts. The scheduled transactions must satisfy the other report op-
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tions to be included, e.g. fall within the report’s range and be scheduled to post to one of the included accounts. 
These transactions appear with a yellow background in transaction list reports (see below).

	 This option can be used to project your payee expenses into the future. To forecast your payees in this man-
ner, be sure the report is configured with a date range that includes future dates. 

When you are finished configuring these options, click “Next” and then “Done.” The new report will be added to 
the source list, and the report details will be displayed in the main window.

To edit the report settings:

Once a report has been created, you can edit its 
settings at any time. Double-click the report in the 
source list, or select it and choose View > Show 
Popup Inspector. The report inspector will open 
to show you the available options. Make any changes 
necessary, then click “Save” to record the changes or 
“Cancel” to discard them.
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To interpret the report:

The report’s name and type are shown at the top of the report. The date range used for the report follows, along 
with a table listing your payees and the amount spent on (or earned from) each one.

Payee Summary

This is a table showing the total value of the transactions associated with each payee, within the date range of 
the report. The “Payee” column lists the names of your payees in alphabetical order; the “Amount” column lists 
the total amount that corresponds with each payee (negative amounts are displayed in parentheses). If there 
are any transactions in your accounts that do not have payees assigned to them, they will be counted under “No 
Payee,” which appears at the top of the table. If you click on a payee name, iBank will show you a detailed list of 
the transactions assigned to that payee (more below). Use the arrow buttons below the report to navigate back 
and forth as you “drill down” into the report details.
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Transaction List

This is a table detailing the transactions associated with a particular payee. Only transactions that are counted in 
the report are displayed here; other transactions may be assigned to the same payee but fall outside the scope 
of the report. Transactions are displayed on this report in chronological order and show their dates, status, 
payees, categories, credit/debit amounts, and account names. Click on a transaction to open a new window 
showing that transaction in its account register. You may edit the transaction as needed; when you save your 
changes, the report will be updated automatically.

To print or save a copy of a report:

The main report and any of the detailed reports that you can drill down to can be printed simply by choosing 
File > Print and clicking the “Print” button. The paper size used for the printout can be changed by choos-
ing File > Page Setup and selecting a different setting, but the orientation is restricted to portrait mode 
(landscape is not permitted).
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To save a copy of a report as a PDF file, choose File > Print, then click the “PDF” button and choose “Save 
As PDF.” Enter a name for the new file, choose where you want to save it, and click “Save.” You will then have a 
copy of the report that you can view and print using the Preview application or any standard PDF reader.

	 You may also export the data from any table on a report to a tab-delimited file. Simply drag and drop the 
table onto your Desktop to create a tab-delimited text clipping, or drag and drop the table directly into 
Microsoft Excel or Apple Numbers to create a spreadsheet using the table data.
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How do I use the U.S. Tax report?

The U.S. Tax report type is used to analyze tax-related income and expenses based on the categories assigned to 
your transactions as well as capital gains from your investments. iBank’s U.S. Tax report includes tables that show 
income and expense totals by category and capital gains, realized and unrealized.

To create a U.S. Tax report:

Choose a report type1.	

Click the plus (+) button at the bottom of the source list, or choose Manage > Add New Report. A sheet 
will appear to let you choose the type of report you want to create. Choose “U.S. Tax,” then click “Next” to con-
tinue.
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Choose accounts2.	

This screen lets you define the scope of the report by choosing which accounts are included. Using the popup 
menu at the top of the screen, choose one of the following options and configure its settings accordingly:

Limit to Specific Accounts:•	

By default, new U.S. Tax reports include all visible accounts. If you want to limit the report to certain ac-
counts, choose this option from the popup menu button and check off the accounts you want to include. 
When no accounts are checked, all accounts are included in the report.

Limit to Accounts Using Smart Rules:•	
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To limit the report to certain accounts based on dynamic criteria, choose this option from the popup menu 
button. You can then configure a series of rules that define which accounts are included in the report:

Any/All of the following are true:•	  If you choose “Any” as the option for this rule, all accounts that 
match at least one of the rules that follow will be included in the report. If you choose “All,” only ac-
counts that match all of the rules that follow will be included. The first instance of this rule cannot 
be removed. Additional “Any/All” rules can be added by holding the Option key and clicking the ‘...’ 
button next to one of the existing rules. This will allow you to create more complex rule hierarchies.

Group: •	 Use this rule to include or exclude all accounts in a particular account group.

Debit:•	  Use this rule to include or exclude accounts of the following types: Credit Card, Line of 
Credit, Liability, and Loan.

Currency:•	  Use this rule to include or exclude all accounts that use a specific currency.

Account type:•	  Use this rule to include or exclude all accounts of a particular type.
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The advantage of using rules instead of checking off specific accounts is that the report will automatically 
update itself to include all accounts that satisfy the rules you set up. To illustrate, say you create a report 
to track only your assets, by using a rule that excludes all loan, credit, and liability account types. Once 
the report has been created, you can add and delete accounts as needed (of any type), and the report will 
always show all of your asset accounts.

	 Account transfers are only counted in U.S. Tax reports when one of their associated accounts is included but 
the other account is excluded. When both accounts are included, the transfer is considered to be internal 
and does not count as either income or an expense. Only when one of the accounts is excluded does the 
transfer gain value, from the perspective of the report.

When you finish configuring accounts for the report, click “Next” to continue.

Choose categories and transfers3.	

This screen lets you choose which categories and transfers are included in the report. By default, a rule is config-
ured to include all taxable categories. If you want to change which categories are used, click the popup menu at 
the top of the screen, choose one of the following options, and configure its settings accordingly:



356 Chapter 7: Reports

Report on All Categories and Accounts Except:•	

By default, new U.S. Tax reports include all categories and account transfers. If you want to exclude certain 
categories and transfers from the report, choose this option from the popup menu button and check off 
the items you want to exclude. Checking a category that contains sub-categories will remove both the 
parent category and its sub-categories from the report. Click “Toggle All Checkboxes” to check or uncheck 
all items in the list. When no items are checked, all categories and account transfers are included.

	 Only accounts that were excluded from the report on the previous screen will appear in this list. Transfers to 
and from accounts that are within the scope of the report cannot be counted in the report. 



357Chapter 7: Reports

Report on Specific Categories and Accounts:•	

To limit the report to certain categories and account transfers, choose this option from the popup menu 
button and check off the items you want to include. Checking a category that contains sub-categories 
will include both the parent category and its sub-categories in the report. Click “Toggle All Checkboxes” to 
check or uncheck all items in the list.

Report Using Smart Rule Criteria:•	

To limit the report to certain categories and account transfers based on dynamic criteria, choose this 
option from the popup menu button. You can then configure a series of rules that define which items are 
included in the report:

Any/All of the following are true:•	  If you choose “Any” as the option for this rule, all categories/ac-
counts that match at least one of the rules that follow will be included in the report. If you choose 
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“All,” only categories/accounts that match all of the rules that follow will be included. The first 
instance of this rule cannot be removed. Additional “Any/All” rules can be added by holding the 
Option key and clicking the ‘...’ button next to one of the existing rules. This will allow you to create 
more complex rule hierarchies.

Parent Category:•	  Use this rule to include or exclude all sub-categories that fall under a specific 
category.

Category/Account:•	  Use this rule to include or exclude specific categories or transfers associated 
with specific accounts. Choosing a category that contains sub-categories using this rule will not 
include or exclude the sub-categories that belong to it.

Taxable:•	  Use this rule to include or exclude all categories that are designated as “Taxable.”

Debit:•	  Use this rule to include or exclude all categories that are designated as “Expense” categories.

Check “Include uncategorized transactions” if you want to include transactions that do not have categories as-
signed to them in addition to the transactions with categories included in the report. The uncategorized trans-
actions must satisfy the other report options to be included, e.g. fall within the report’s range and be recorded 
in one of the included accounts. When this option is checked, an item named “Uncategorized” will appear in the 
charts and tables on the report.

Once you’ve chosen which categories and transfers to include in the report, click “Next” to continue.
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Choose a date range4.	

This screen lets you choose a date range for the report. Click the popup menu button and select from a variety 
of predefined ranges: options that end with “to Date” indicate periods of time that are relative to the current 
date; other options represent fixed periods of time.

You may also choose “Custom Dates” to enter a more specific range. Use the “starting/ending” popup to deter-
mine whether the report covers a range of dates in the future or past, respectively. Choose “today” to have the 
report start or end on the current date (regardless of when the report is viewed), or choose “on date” to specify a 
fixed start/end date.
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Finish creating the report5.	

This screen lets you configure a few last settings for the new report. Enter a unique name to distinguish the 
report from others in the source list, then pick which currency its figures should be displayed in. If accounts that 
use different currencies are included in the report, their figures will be converted automatically using iBank’s 
current exchange rates.

Check the “Include scheduled transactions” option to include pending scheduled transactions in addition to the 
transactions that are recorded in your accounts. The scheduled transactions must satisfy the other report op-
tions to be included, e.g. fall within the report’s range and be scheduled to post to one of the included accounts. 
These transactions appear with a yellow background in transaction list reports (see below).
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	 This option can be used to project your tax information into the future. To forecast your taxes in this man-
ner, be sure the report is configured with a date range that includes future dates. 

When you are finished configuring these options, click “Next” and then “Done.” The new report will be added to 
the source list, and the report details will be displayed in the main window.

To edit the report settings:

Once a report has been created, you can edit its 
settings at any time. Double-click the report in the 
source list, or select it and choose View > Show 
Popup Inspector. The report inspector will open 
to show you the available options. Make any changes 
necessary, then click “Save” to record the changes or 
“Cancel” to discard them.
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To interpret the report:

The report’s name and type are shown at the top of the report. The date range used for the report follows. Two 
tables are displayed below: one showing income and expenses by category, and one showing capital gains by 
type.

Taxable Categories

This is a table detailing your income and expense categories over the time frame specified for the report. The 
“Category” column lists the category names (and account names, when transfers are included) in alphabetical 
order and grouped according to their type (income or expense). Sub-categories are grouped under their parent 
categories, and any funds assigned directly to a parent category are displayed under a sub-category named 
“Other.” The “Amount” column shows the total for each category/account as well as totals for each group. The 
total displayed at the bottom of the table is the net value of all income and expense categories included on 
the report. Click on the name of any category or account to view a detailed transaction list for that item (more 
below). Use the arrow buttons below the report to navigate back and forth as you “drill down” into the report 
details.
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Transaction List

This is a table detailing the transactions in a particular category or transfers associated with a particular ac-
count. Only transactions that are counted in the report are displayed here; other transactions may be recorded 
in the category or account but fall outside the scope of the report. Transactions are displayed on this report in 
chronological order and show their dates, status, payees, categories, credit/debit amounts, and account names. 
Click on a transaction to open a new window showing that transaction in its account register. You may edit the 
transaction as needed; when you save your changes, the report will be updated automatically.
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Capital Gains

This is a table detailing your investment gains and losses during the time period covered by the report. In the 
“Activity” column you will see line items for short- and long-term realized gains, short- and long-term unrealized 
gains, dividend income, and interest income. The “Amount” column shows the total for each item. Click on one 
of the three sections of this table to drill down and view detailed information about that section (more below).

	 For the U.S. Tax report, capital gains are always calculated on a FIFO (first in, first out) basis. U.S. tax law 
requires this method to be used unless specific tax lots are detailed. iBank does not support the choosing of 
specific lots at this point in time.
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Realized Short & Long Term Capital Gains

This is a table detailing the gains and losses from investments you sold within the report’s time frame. Only 
transactions that are counted in the report are displayed here; other transactions may be recorded in your 
investment accounts but fall outside the scope of the report. Transactions are displayed on this report in 
chronological order and are grouped by account and security. The following columns are displayed:

Security:•	  The security name and transaction type.

Quantity: •	 The number of shares bought or sold.

Open:•	  The date on which the shares were purchased.

Cost:•	  The amount paid for the shares when they were originally purchased.

Close:•	  The date on which the shares were sold.

Proceeds: •	 The amount of money received as a result of selling the shares.

S Gain: •	 The difference between the proceeds and cost, if the shares were held for one year or less.
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L Gain:•	  The difference between the proceeds and cost, if the shares were held for more than one year.

Click on a transaction to open a new window showing that transaction in its account register. You may edit the 
transaction as needed; when you save your changes, the report will be updated automatically.

Unrealized Gains

This is a table detailing the estimated gains and losses from investments you currently hold. Only shares held 
in accounts that are included in the report are counted. See How do I use the Portfolio Summary report? in this 
chapter for more information.
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Security Income Detail

This is a table detailing your security income transactions, including dividends and interest income. Only 
transactions that are counted in the report are displayed here; other transactions may be recorded in your 
investment accounts but fall outside the scope of the report. Transactions are displayed on this report in 
chronological order and grouped by security. The table columns show the transaction dates, status, symbols, 
categories, credit/debit amounts, and account names. Click on a transaction to open a new window showing 
that transaction in its account register. You may edit the transaction as needed; when you save your changes, 
the report will be updated automatically.

	 As per U.S. tax law, all dividends are counted as income whether they were recorded as cash or reinvest-
ments. 

To print or save a copy of a report:

The main report and any of the detailed reports that you can drill down to can be printed simply by choosing 
File > Print and clicking the “Print” button. The paper size used for the printout can be changed by choos-



368 Chapter 7: Reports

ing File > Page Setup and selecting a different setting, but the orientation is restricted depending on the 
report you are printing (some use portrait mode and some use landscape).

To save a copy of a report as a PDF file, choose File > Print, then click the “PDF” button and choose “Save 
As PDF.” Enter a name for the new file, choose where you want to save it, and click “Save.” You will then have a 
copy of the report that you can view and print using the Preview application or any standard PDF reader.

	 You may also export the data from any table on a report to a tab-delimited file. Simply drag and drop the 
table onto your Desktop to create a tab-delimited text clipping, or drag and drop the table directly into 
Microsoft Excel or Apple Numbers to create a spreadsheet using the table data.
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How do I use the Debt/Liability report?

The Debt/Liability report type is used to analyze the money you owe for loans, credit cards, and other forms of 
debt (including investments that aren’t performing well). iBank’s Debt/Liability report includes loan payment 
schedules, charts of your liabilities by type and over time, and a balance sheet summarizing your liabilities by 
account.

To create a Debt/Liability report:

Choose a report type1.	
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Click the plus (+) button at the bottom of the source list, or choose Manage > Add New Report. A sheet 
will appear to let you choose the type of report you want to create. Choose “Debt/Liability,” then click “Next” to 
continue.

Choose accounts2.	

This screen lets you define the scope of the report by choosing which accounts are included. Using the popup 
menu at the top of the screen, choose one of the following options and configure its settings accordingly:

Limit to Specific Accounts:•	

By default, new Debt/Liability reports include all visible accounts. If you want to limit the report to certain 
accounts, choose this option from the popup menu button and check off the accounts you want to in-
clude. When no accounts are checked, all accounts are included in the report.
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	 For this report type, only accounts that are considered liabilities (e.g. loans, credit cards, liability accounts) 
will be counted. You may include other account types, but they will be ignored by the report. 

Limit to Accounts Using Smart Rules:•	

To limit the report to certain accounts based on dynamic criteria, choose this option from the popup menu 
button. You can then configure a series of rules that define which accounts are included in the report:

Any/All of the following are true:•	  If you choose “Any” as the option for this rule, all accounts that 
match at least one of the rules that follow will be included in the report. If you choose “All,” only ac-
counts that match all of the rules that follow will be included. The first instance of this rule cannot 
be removed. Additional “Any/All” rules can be added by holding the Option key and clicking the ‘...’ 
button next to one of the existing rules. This will allow you to create more complex rule hierarchies.
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Group: •	 Use this rule to include or exclude all accounts in a particular account group.

Debit:•	  Use this rule to include or exclude accounts of the following types: Credit Card, Line of 
Credit, Liability, and Loan.

Currency:•	  Use this rule to include or exclude all accounts that use a specific currency.

Account type:•	  Use this rule to include or exclude all accounts of a particular type.

The advantage of using rules instead of checking off specific accounts is that the report will automatically 
update itself to include all accounts that satisfy the rules you set up. To illustrate, say you create a report 
to track your loans by using a rule that only includes loan accounts. Once the report has been created, 
you can add and delete accounts as needed (of any type), and the report will always show all of your loan 
accounts.

When you finish configuring accounts for the report, click “Next” to continue.
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Choose a date range3.	

This screen lets you choose a date range for the report. Click the popup menu button and select from a variety 
of predefined ranges: options that end with “to Date” indicate periods of time that are relative to the current 
date; other options represent fixed periods of time.

You may also choose “Custom Dates” to enter a more specific range. Use the “starting/ending” popup to deter-
mine whether the report covers a range of dates in the future or past, respectively. Choose “today” to have the 
report start or end on the current date (regardless of when the report is viewed), or choose “on date” to specify a 
fixed start/end date.
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Finish creating the report4.	

This screen lets you configure a few last settings for the new report. Enter a unique name to distinguish the 
report from others in the source list, then pick which currency its figures should be displayed in. If accounts that 
use different currencies are included in the report, their figures will be converted automatically using iBank’s 
current exchange rates.

Check the “Include scheduled transactions” option to include pending scheduled transactions in addition to the 
transactions that are recorded in your accounts. The scheduled transactions must satisfy the other report op-
tions to be included, e.g. fall within the report’s range and be scheduled to post to one of the included accounts. 
These transactions appear with a yellow background in transaction list reports (see below).
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	 This option can be used to project your debt into the future. To forecast your account balances in this man-
ner, be sure the report is configured with a date range that includes future dates. 

When you are finished configuring these options, click “Next” and then “Done.” The new report will be added to 
the source list, and the report details will be displayed in the main window.

To edit the report settings:

Once a report has been created, you can edit its 
settings at any time. Double-click the report in the 
source list, or select it and choose View > Show 
Popup Inspector. The report inspector will open 
to show you the available options. Make any changes 
necessary, then click “Save” to record the changes or 
“Cancel” to discard them.
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To interpret the report:

The report’s name and type are shown at the top of the report, followed by the date range used for the report. 
Two tables and two charts are displayed below: a table showing information about paying off your loans, a pie 
chart showing your liabilities by account type, a table summarizing your liabilities by account, and a bar graph 
showing your total debt over time.

Loan Payoff Info

This is a table showing each of your loan accounts, with three possible payoff scenarios for each. Along with 
the name of each loan account is shown the current interest rate and principal balance. On the next line is the 
minimum payment due on that loan, with the amount of time it will take to pay off the loan entirely at that rate 
and the total amount of interest you will pay before the loan is paid off. The next two lines show alternative 
payment amounts and their corresponding payoff times and interest totals. Click on any line to view a detailed 
payment schedule for that scenario (more below). Use the arrow buttons below the report to navigate back and 
forth as you “drill down” into the report details.
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Loan Payment Schedule

This is a table showing a payment schedule from the end date of the report to the point at which the loan 
principal has been fully paid. Above the table, iBank displays the name of the loan account, the current interest 
rate, the payment amount, and the total amount of interest paid over the course of the schedule. Each row in 
the table shows the payment number (counting from the next payment due), the portion of the payment taken 
out as interest, the portion used to pay down the principal, and the remaining principal balance.



378 Chapter 7: Reports

Liabilities by Account Type

This is a pie chart depicting your liabilities at a fixed point in time (the end 
date of the report). Each pie slice represents the total value of the accounts 
of a particular type, and the slices are drawn proportionally so that you can 
see which types of accounts hold more debt. Below the chart is a key that 
shows which colors correspond to which account types and the total value 
of each type. Mouse over any account type to highlight the corresponding 
slice in the pie chart above. Click on any pie slice to view a detailed bal-
ance sheet report for the accounts that make up that slice (more below).

Liabilities Summary

This is a table summarizing your debt by account at a fixed point in time (the end date of the report). The “Ac-
count” column lists your accounts in alphabetical order and grouped into cash liabilities and security liabilities 
(assets may also be shown, if either the cash value or market value of the account is positive). The “Amount” 
column shows the value of each account as well as totals for each group. The figure displayed at the bottom of 
the table is your total debt. Click on the name of any account to view a transaction list for that account (more 
below).
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Liabilities Over Time

This is a bar chart depicting your debt over time. Each bar represents the total value of your liability accounts at 
a fixed point in time, consisting of cash (money you owe) and securities (shares you own that are worth less than 
what you paid for them). Assets may appear on this chart if you have investments with a positive cash or market 
value. The black line that is drawn over the bars indicates the total value of your accounts over time. Click on a 
bar to view a detailed balance sheet report for the date it represents (more below).

Balance Sheet

This is a table detailing your net worth at a fixed point in time (the end date of the report). The “Account” column 
lists your accounts in alphabetical order and grouped into cash liabilities and security liabilities (assets may also 
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be shown, if either the cash value or market value of an investment account is positive). The “Amount” column 
shows the value of each account as well as totals for each group. The total displayed at the bottom of the table 
is your total debt. Click on the name of any account to view a transaction list for that account (more below).

Transaction List

This is a table detailing the transactions in a particular account. Only transactions that are counted in the report 
are displayed here; other transactions may be recorded in the account but fall outside the scope of the report. 
Transactions are displayed on this report in chronological order and show their dates, status, payees, categories, 
and credit/debit amounts. When investment transactions are displayed, their security details are shown. A run-
ning balance for the account is also shown. Click on a transaction to open a new window showing that transac-
tion in its account register. You may edit the transaction as needed; when you save your changes, the report will 
be updated automatically.

To print or save a copy of a report:

The main report and any of the detailed reports that you can drill down to can be printed simply by choosing 
File > Print and clicking the “Print” button. The paper size used for the printout can be changed by choos-
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ing File > Page Setup and selecting a different setting, but the orientation is restricted to portrait mode 
(landscape is not permitted).

To save a copy of a report as a PDF file, choose File > Print, then click the “PDF” button and choose “Save 
As PDF.” Enter a name for the new file, choose where you want to save it, and click “Save.” You will then have a 
copy of the report that you can view and print using the Preview application or any standard PDF reader.

	 You may also export the data from any table on a report to a tab-delimited file. Simply drag and drop the 
table onto your Desktop to create a tab-delimited text clipping, or drag and drop the table directly into 
Microsoft Excel or Apple Numbers to create a spreadsheet using the table data.
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How do I use the Forecast report?

The Forecast report type is used to project your account balances into the future based on your scheduled 
transactions. iBank’s Forecast report includes a line graph that shows your account balances over time and a 
summary table that shows the starting, ending, high, and low balances of each account.

To create a Forecast report:

Choose a report type1.	

Click the plus (+) button at the bottom of the source list, or choose Manage > Add New Report. A sheet 
will appear to let you choose the type of report you want to create:
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Choose “Forecast,” then click “Next” to continue.

Choose accounts2.	

This screen lets you define the scope of the report by choosing which accounts are included. Using the popup 
menu at the top of the screen, choose one of the following options and configure its settings accordingly:

Limit to Specific Accounts:•	

By default, new Forecast reports include all visible accounts. If you want to limit the report to certain ac-
counts, choose this option from the popup menu button and check off the accounts you want to include. 
When no accounts are checked, all accounts are included in the report.
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Limit to Accounts Using Smart Rules:•	

To limit the report to certain accounts based on dynamic criteria, choose this option from the popup menu 
button. You can then configure a series of rules that define which accounts are included in the report:

Any/All of the following are true:•	  If you choose “Any” as the option for this rule, all accounts that 
match at least one of the rules that follow will be included in the report. If you choose “All,” only ac-
counts that match all of the rules that follow will be included. The first instance of this rule cannot 
be removed. Additional “Any/All” rules can be added by holding the Option key and clicking the ‘...’ 
button next to one of the existing rules. This will allow you to create more complex rule hierarchies.

Group:•	  Use this rule to include or exclude all accounts in a particular account group.

Debit:•	  Use this rule to include or exclude accounts of the following types: Credit Card, Line of 
Credit, Liability, and Loan.

Currency:•	  Use this rule to include or exclude all accounts that use a specific currency.
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Account type:•	  Use this rule to include or exclude all accounts of a particular type.

The advantage of using rules instead of checking off specific accounts is that the report will automatically 
update itself to include all accounts that satisfy the rules you set up. To illustrate, say you create a report 
to track only your asset accounts, by using a rule that excludes all loan, credit, and liability account types. 
Once the report has been created, you can add and delete accounts as needed (of any type), and the report 
will always show all of your asset accounts.

When you finish configuring accounts for the report, click “Next” to continue.

Choose a date range3.	

This screen lets you choose a date range for the report. Click the popup menu button and select from a variety 
of predefined ranges: options that end with “to Date” indicate periods of time that are relative to the current 



386 Chapter 7: Reports

date; other options represent fixed periods of time. To ensure that the Forecast report projects your account 
balances into the future, choose a date range that extends into the future.

You may also choose “Custom Dates” to enter a more specific range. Select “starting” in the “starting/ending” 
popup to ensure that the report covers a range of dates in the future. Choose “today” to have the report start or 
end on the current date (regardless of when the report is viewed), or choose “on date” to specify a fixed start/
end date.

Finish creating the report4.	

This screen lets you configure a few last settings for the new report. Enter a unique name to distinguish the 
report from others in the source list, then pick which currency its figures should be displayed in. If accounts that 
use different currencies are included in the report, their figures will be converted automatically using iBank’s 
current exchange rates.
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The “Include scheduled transactions” option is checked by default. This option includes pending scheduled 
transactions in addition to the transactions that are recorded in your accounts. The scheduled transactions must 
satisfy the other report options to be included, e.g. fall within the report’s range and be scheduled to post to 
one of the included accounts. These transactions appear with a yellow background in transaction list reports 
(see below).

	 If you disable this option on a Forecast report, the account balances will be based solely on the transactions 
you have already recorded in your accounts. For a more accurate forecast, be sure to include scheduled 
transactions and choose a date range for the report that extends into the future.

When you are finished configuring these options, click “Next” and then “Done.” The new report will be added to 
the source list, and the report details will be displayed in the main window.
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To edit the report settings:

Once a report has been created, you can edit its 
settings at any time. Double-click the report in the 
source list, or select it and choose View > Show 
Popup Inspector. The report inspector will open 
to show you the available options. Make any changes 
necessary, then click “Save” to record the changes or 
“Cancel” to discard them.

To interpret the report:

The report’s type is shown at the top of the report, followed by the date range used for the report. One chart 
and one table are displayed below: a line plot showing your account balances over time, and a summary table 
highlighting a few key balances for each account included in the report.
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Account Balances

This is a line graph depicting your account balances over time. Time is plotted on the horizontal axis; balance 
amounts are plotted on the vertical axis. Each account included in the report is plotted on the graph in a differ-
ent color: assets are plotted in shades of green and liabilities are plotted in shades of red. A legend is provided 
below the graph to help you identify which account uses which color. Click and drag the vertical black line 
across the graph to view a pop-up box showing the balance of each account on that date:

The figures shown in the pop-up box provide information about the interval in which the slider rests. Each 
interval represents the time between two transactions that affect the account balance. If only one account is 
included in the Forecast report, iBank will shade the current interval so that you can see it on the graph. “Bal-
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ance” indicates the account balance on the date shown at the bottom of the slider. “High” indicates the higher of 
the beginning and ending balances for the interval; “Low” indicates the lower of the two.

	 When a Forecast report is configured to span several years, it may not be possible to plot every day on the 
graph. In this case, iBank will compress multiple days into a single graph point, and the figures in the pop-
up boxes will pertain to all dates covered by that point on the graph.

Click on a pop-up box to view a detailed transaction list for an account during the current interval (more below). 
Use the arrow buttons below the report to navigate back and forth as you “drill down” into the report details.

Summary

This is a table summarizing your account balances at a several points in time. The “Account” column lists your 
accounts in alphabetical order. “Start Balance” indicates the balance of each account on the starting date of 
the report; “End Balance” indicates the balance on the report’s ending date. “Low Balance” indicates the lowest 
amount reached by each account during the report’s time frame; “High Balance” indicates the highest amount 
within the same range. Click on the name of any account to view a detailed transaction list for that account 
(more below).
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Transaction List

This is a table detailing the transactions in a particular account. Only transactions that are counted in the report 
are displayed here; other transactions may be recorded in the account but fall outside the scope of the report. 
Transactions are displayed on this report in chronological order and show their dates, status, payees, categories, 
and credit/debit amounts. When investment transactions are displayed, their security details are shown. A run-
ning balance for the account is also shown. Click on a transaction to open a new window showing that transac-
tion in its account register. You may edit the transaction as needed; when you save your changes, the report will 
be updated automatically.

	 Transactions that appear in this list with a yellow background represent future instances of your scheduled 
transactions. These transactions cannot be edited like the transactions in your accounts, because they have 
not yet been posted to your accounts. To adjust these transactions, you will need to edit the templates on 
which they are based.



392 Chapter 7: Reports

To print or save a copy of a report:

The main report and any of the detailed reports that you can drill down to can be printed simply by choosing 
File > Print and clicking the “Print” button. The paper size used for the printout can be changed by choos-
ing File > Page Setup and selecting a different setting, but the orientation is restricted depending on the 
report you are printing (some use portrait mode and some use landscape).

To save a copy of a report as a PDF file, choose File > Print, then click the “PDF” button and choose “Save 
As PDF.” Enter a name for the new file, choose where you want to save it, and click “Save.” You will then have a 
copy of the report that you can view and print using the Preview application or any standard PDF reader.

	 You may also export the data from any table on a report to a tab-delimited file. Simply drag and drop the 
table onto your Desktop to create a tab-delimited text clipping, or drag and drop the table directly into 
Microsoft Excel or Apple Numbers to create a spreadsheet using the table data.
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How do I set up and track a budget?

 Budgets can be set up in iBank to help you keep a better eye on your spending habits. iBank allows for 
the creation of multiple budgets so that you can, for example, track both a household and a personal budget 
at the same time. Three budget views are offered in iBank 4 so that you may choose whichever approach fits 
your planning style. You may switch between the three views as often as you like, but there are some important 
differences to note about the way they work:

Category View•	

This view is designed to be a quick and easy method to track a budget based on the categories you assign 
to the transactions you record. With this approach, you set targets for specific income and expense catego-
ries for each budget period, and track your progress according to those targets. After the initial setup, no 
maintenance is required to continue using the budget. The disadvantage to this mode is that it does not 
allow cash to be carried over from one period to the next or to be saved for upcoming expenses.

Envelope View•	

This view is based on the envelope method of budgeting, one that many users find to be very intuitive but 
requires a bit more work to manage. The idea is that periodically (weekly, monthly, etc.) you take out part 
of your income as cash and put it into envelopes earmarked for different uses, e.g. one for your mortgage 
payments, one for utilities, one for dining out, etc.

When it comes time to pay a bill, money has already been set aside in an envelope for that purpose, so 
all you need to do is take the cash out of the envelope to make the payment. Throughout the budget 
period, if you want to make additional expenditures, you can look in each envelope to see how much cash 
remains, then decide how you want to spend it. If are considering a purchase and find that the correspond-
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ing envelope has already been emptied, you have three options: 1) don’t make the purchase, 2) wait until 
you are able to save more money in that envelope, or 3) move cash from another envelope to cover the 
expense. At the end of the budget period, any cash that remains in your envelopes rolls over to the next 
period. In this manner, you can save up cash over time for a particular use.

In iBank, paper envelopes are replaced with virtual envelopes, and each envelope corresponds to a par-
ticular category.

Report View•	

This view works in conjunction with both of the other views to present a simple comparison of your bud-
get vs. your actual spending during each budget period. Unlike the other views, it is not used for editing 
your budget configuration, but will help you to analyze your budget performance. Similar to reports found 
elsewhere in iBank, you can drill down to view more detail about any of your budget items, easily print 
what you see on the screen, and save a PDF copy of the report for later reference.

To prepare your categories:

The first key to budgeting effectively, regardless of which mode you are using, is to set up useful categories and 
make sure all of your transactions are categorized appropriately. Select “Categories” under the “Manage” item in 
the source list, review your categories, and think about how you want to structure your budget. Add a category 
for anything that you want to create a budget envelope for, as well as any sources of income you intend to track. 
Be sure each category is assigned the correct type (income or expense) so that it shows up in the correct section 
of your budgets.
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To set up a budget:

Once your categories are all in order, click the plus (+) button below the source list and choose “Add Budget,” 
or choose Manage > Add New Budget. The new budget assistant will appear to help you configure the 
budget:

Enter a name to identify the budget in the source list. Choose a period to indicate how often you want your 
budget to repeat. Keep in mind that individual budget items may occur at different frequencies; right now, you 
are just choosing the default period for the overall budget. The date shown in gray below the currency setting 
indicates when the selected budget period will begin.

Weekly:•	  This budget period is 7 days long, with each week beginning on a Sunday and ending on a Satur-
day.
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Two weeks:•	  This budget period is 14 days long, begins on a Sunday, and ends on a Saturday.

Monthly:•	  This budget period is 1 month long, begins on the first day of each month, and ends on the last 
day of the month.

Quarterly: •	 This budget period is 3 months long, begins on the first day of the first month, and ends on the 
last day of the last month. The first quarter of the year begins January 1.

Annually:•	  This budget period is 1 year long, begins on January 1, and ends on December 31.

	 Please note that budget periods are calculated automatically by iBank; their starting and ending dates can-
not be modified. By the same token, the starting date for the fiscal year cannot be changed. 

Choose which currency the budget’s figures should be displayed in, then click “Next” to continue.
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On this screen, iBank displays all visible accounts and asks you to choose which ones should be included in the 
budget. Check off the ones you want to include, then click “Next” to continue.

	 If you intend to track account transfers as income or expenses on your budget, be sure to exclude the 
relevant accounts from the budget setup. Transfers can only be used as budget items if they are directed to 
accounts that are not part of the budget.

On this screen, iBank displays all of your income categories and asks you to configure the ones that should 
be tracked in the budget. Any accounts that were not included in your budget are also listed, so that you can 
budget for transfers from those accounts. iBank takes a guess at which categories and amounts you might 
want to use, based on the transactions in your accounts. For each income category you want to track, choose 
the frequency with which you expect to receive income in that category, then double-click in the “Amount” 
column and type in how much you expect to receive at each interval. The “Total” column will show how much 
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that amount equates to for the budget’s default period. The total shown below the table is the sum of all the 
individual category totals. Exclude all other categories from the budget by setting their frequencies to “Not 
Budgeted.”

To illustrate, let’s say you are setting up a monthly budget, and you receive a paycheck for $2800 every month. 
On the first budget screen, you chose “Monthly” as the default budget period. On the current screen, you decide 
to use the “Salary” category to track your paycheck, so you click in the “Frequency” column for that item and 
choose “Monthly” from the popup menu. You then double-click in the “amount” column and type in “2800.” Be-
cause your paycheck comes once a month, the “Total” column will show $2,800.00. If you had chosen a different 
frequency for your salary, the “Total” figure would change to estimate how much salary you expect to receive 
over the course of the month. You don’t have any other sources of income, so you mark all other categories “Not 
Budgeted,” and the total at the bottom of the table states that your total income every month is $2,800.00.

Click “Next” to continue on.
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On this screen, iBank displays all of your expense categories and asks you to configure them just as you did the 
income categories. Any accounts that were not included in your budget are also listed, so that you can budget 
for transfers into those accounts. The categories and accounts you configure here will be made into envelopes 
for saving and spending your income (if you decide to use the envelope view). Once all of your expenses are 
planned out, click “Next” to continue.
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On this screen, iBank displays all of the expense categories in your budget, and asks you to specify how much 
cash you currently have saved in each one. These adjustments only pertain to the envelope method of budget-
ing, so if you do not intend to use the envelope view, you may skip this step by clicking “Next” immediately.

The amount budgeted for each expense for the current budget period is displayed in the “Budgeted” column; 
the amount of cash currently saved in each envelope is displayed in the “Starting Cash” column. To adjust the 
amount of cash in an envelope, simply double-click the amount and type in a new figure.

	 Adjusting the starting cash for your expense envelopes can come in handy when you are configuring iBank 
to match a budget that you were previously tracking by other means. For example, if you previously used a 
real-life envelope system, and had saved up $300 in your “Groceries” envelope, you would enter that $300 

on this screen so that your iBank budget will match your real-life cash savings.
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At the bottom of this screen you will see an option to “Adjust amounts using transactions since” the start date of 
the budget. If you check this option, any transactions in your accounts that are assigned to budget categories 
and fall within the current budget period will be used to deduct cash from your envelopes (or add cash to your 
income piles) after the budget has been created. If you leave it unchecked, the cash amounts you entered will 
not be changed after the budget has been created. A good rule of thumb to follow is to uncheck this option 
only if you already accounted for cash spent during the current budget period when you adjusted the cash 
amounts above.

Once you have finished adjusting the available cash in your envelopes, click “Next” to continue. On the following 
screen, iBank will finish creating the budget - click “Done” to view it.

	 When you create a budget, iBank automatically fills your envelopes for the current budget period without 
reducing your income. iBank assumes that expenses in the current period are already accounted for, so your 
income piles start out empty. Any income you receive during the current period should be used to save 
cash in your envelopes for the next period.

Changing budget views:

As mentioned previously, three modes for tracking your budget are available for use. The budget display will 
change depending on which view (category, envelope, or report) you are currently using. To change views, click 
the buttons at the bottom of the main window:  Click the first button to switch to category view, 
the second for envelope view, and the third for report view. You may change between the three views freely, 
although each one allows you to access different information and features.
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Changing the budget period:

Regardless of which view you are currently using, at the top of the budget view you will see a label indicating 
the current budget period:  To change the budget period, click the 
arrows to the left and right of the label. The information shown below will update accordingly so that you can 
see how you performed on your budget in the past or what your budget will look like in the future.

	 Any changes you make to your budget configuration in one budget period will apply to all budget periods. 
iBank cannot adjust the budget settings from one period to the next. 

Understanding the category view interface:

To begin using your budget, you must first understand the information presented in the three main sections of 
the budget screen:

Income

Across the top of the screen is a list showing each of your income categories. The amount of income budgeted 
for the current period is shown next to each category, along with the earnings you’ve recorded in your accounts 
and the difference between those two figures (the amount remaining to earn). A progress bar appears to the 
right of each category to illustrate the ratio between the amount you’ve earned and budgeted: red indicates 
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that you are currently under the budgeted amount, yellow indicates that you are approaching the budgeted 
amount, and green indicates that you are over the budgeted amount. A green checkmark  appears when 
you meet your budget exactly.

Summary info

The middle of the screen displays information about the status of your budget. On the left is a colored bar show-
ing the difference between the expenses you recorded during the current budget period and the total expenses 
for which you budgeted. The “Remaining Cash to Spend” figure indicates how much of the income you received 
during the current budget period has not yet been spent.

On the right is some other helpful information: the total amount of income budgeted for the current period, the 
actual income recorded in your accounts, the total amount of expenses budgeted for the current period, and 
the actual expenses paid from your accounts.

Expenses
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At the bottom of the screen is a list showing each of your expense categories. The amount budgeted for the cur-
rent period is shown next to each category, along with the spending you’ve recorded in your accounts and the 
difference between those two figures (the amount remaining to spend). A progress bar appears to the right of 
each category to illustrate the ratio between the amount you’ve earned and budgeted: green indicates that you 
are currently under the budgeted amount, yellow indicates that you are approaching the budgeted amount, 
and red indicates that you are over the budgeted amount. A green checkmark  appears when you meet your 
budget exactly.

Understanding the envelope view interface:

Income

Across the top of the screen are your income categories, which are displayed as cash piles. Each item shows 
the name of the income category it is associated with, as well as the amount of cash currently available in that 
category. When no cash is available (or all the cash from a particular income category has been allocated to your 
envelopes), the item is shown as the outline of a bill; when cash is available, it is shown as a stack of bills.

Summary info
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The middle of the screen displays information about the status of your budget. On the left is a colored bar 
showing how much cash is still available relative to the total income budgeted for the current period. When you 
receive income and distribute it to your envelopes, the bar fills up; when you spend cash from your envelopes, 
the bar empties out.

On the right is some other helpful information: the number of days remaining in the current budget period, 
the total cash available to spend from your envelopes, and any cash you have in reserve (additional cash in the 
envelopes beyond what is required for your budget).

Expenses

At the bottom of the screen are your expense categories, which are displayed as envelopes. Below each enve-
lope is the name of the expense category it is associated with, the amount budgeted for that category for the 
current budget period, and the amount spent from that envelope during the current period. The amount of 
cash in the envelope is shown on the envelope itself. When an envelope is empty (or negative), its flap is closed; 
when there is cash in an envelope, its flap is open and money is shown inside.
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Understanding the report view:

The report view presents a simple comparison of your budgeted income and expenses against your actual 
income and expenses during a particular budget period. It also includes some summary information written out 
in plain language:
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Summary info

At the top of the report are the starting and ending dates of the budget period. Below those you will find a writ-
ten comparison of your total earnings and total spending, along with a mention of how much time is left before 
the budget period is over.

Income/expense tables

Below the summary information are tables detailing your budgeted income and expenses. Each table is pre-
ceded by a written description of the total amount you budgeted for income/expenses, how much you actually 
earned/spent during the budget period, and the difference between them. Each table includes the following 
columns:

Category:•	  The name of the category (or account, in the case of a budgeted transfer).

Budgeted:•	  The amount you expected to earn or spend in the category during the budget period.

Received/Spent:•	  The amount you actually earned or spent in the category during the budget period.

Remaining:•	  The difference between what you budgeted and what you received/spent. This column is 
colored depending on your performance. For income categories, red indicates that you earned less than 
you budgeted, while green indicates that you met your budget or earned a surplus. For expense catego-
ries, green indicates that your spending was lower than or equal to your budget, while red indicates that 
you created a deficit.

Click on any category to view a list of transactions that make up the total shown for that category. Use the arrow 
buttons below the report to navigate back and forth as you drill down into the report details.
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Category details

This is a table detailing the transactions in a particular category or transfers associated with a particular account. 
Only transactions that are counted in the budget period are displayed here; other transactions may be recorded 
in the category or account but fall outside the scope of the report. Transactions are displayed on this report in 
chronological order and show their dates, status, payees, categories, credit/debit amounts, and account names. 
Click on a transaction to open a new window showing that transaction in its account register. You may edit the 
transaction as needed; when you save your changes, the report will be updated automatically.

To print or save a copy of a report:

The main report and any of the detailed reports that you can drill down to can be printed simply by choosing 
File > Print and clicking the “Print” button. The paper size used for the printout can be changed by choos-
ing File > Page Setup and selecting a different setting, but the orientation is restricted to portrait mode 
(landscape is not permitted).

To save a copy of a report as a PDF file, choose File > Print, then click the “PDF” button and choose “Save 
As PDF.” Enter a name for the new file, choose where you want to save it, and click “Save.” You will then have a 
copy of the report that you can view and print using the Preview application or any standard PDF reader.

	 You may also export the data from any table on a report to a tab-delimited file. Simply drag and drop the 
table onto your Desktop to create a tab-delimited text clipping, or drag and drop the table directly into 
Microsoft Excel or Apple Numbers to create a spreadsheet using the table data.
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To record income and expenses (both views):

When you receive income or make a purchase that qualifies as a budget expense, all you need to do is create 
a transaction for it in the appropriate account register, and make sure to assign the correct category to it. Your 
budget will automatically update its income cash piles and the remaining cash in its envelopes based on the 
transactions that you record in your accounts during the current budget period. There is no need (and no way) 
to record specific income or expense transactions within the budget interface.

To illustrate, let’s say you planned your budget with a monthly “Groceries” expense of $300. That envelope starts 
out with $300 cash inside it, and shows $300 budgeted and $0 spent. You then go to the grocery store and 
spend $65. In iBank, you open up your checking account and record a transaction for $65, taking care to assign 
it to the “Groceries” category. When you switch back to your budget, you see that the “Groceries” envelope now 
contains $235 in cash, and shows $300 budgeted and $65 spent.

	 Because iBank records expenses automatically, it is possible to deduct more cash from an envelope than 
is available to spend. In this case, the envelope will close and show its negative value in red. You will need 
to make up for the extra expenditure by allocating more cash to the envelope from an income cash pile or 
another expense envelope (see below).

To allocate income to an envelope (envelope view only):

When you record an income transaction in one of your accounts and assign it to a budget category, iBank 
automatically shows that amount in the corresponding income cash pile. To use the money in your budget, you 
will need to allocate it to one or more envelopes. To do this, simply drag and drop cash from the cash pile onto 
an envelope. iBank will then ask you how much cash you want to move:
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Type in the amount of cash that should be allocated, then click “OK” to complete the move.

	 The amount shown below an income pile will be shown in orange if you allocate more cash to your 
envelopes than you budgeted as income for the current period, but there is still cash available in the pile 
to cover the difference. If you allocate more cash than is available in the income pile, the amount will be 
displayed in red.

To allocate income to several envelopes (envelope view only):

If you want to distribute your income among several envelopes at once (instead of dragging cash to each one 
individually), click “Fill Envelopes” at the bottom of the main window. iBank will ask you how you want to al-
locate the cash:
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At the top of this window, iBank shows you the total amount of income that is available for allocation. Each of 
your envelopes is listed, along with its target amount (the amount budgeted for each period), the amount of 
cash currently in the envelope, and the difference between the two. The “Additional” column shows the amount 
of cash that will be added to the envelope from your income.

By default, iBank distributes your income in such a manner as to replenish the envelopes back to their target 
amounts. To adjust the amount of cash added to an envelope, double-click in the “Additional” column for that 
item and type in the desired amount. At the bottom of the table, iBank displays the amount of income that 
remains to be distributed.
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To move cash between envelopes (envelope view only):

Drag and drop cash from one envelope onto another. Type in the amount of cash that you want to move, then 
click “OK.” You cannot move more cash than is available in the first envelope.

To move cash from an envelope back to a cash pile (envelope view only):

Drag and drop cash from an envelope onto a cash pile. Type in the amount of cash that you want to move, then 
click “OK.” You cannot move more cash than is available in the envelope.

To adjust the categories in a budget (both views):

Even the best-laid plans sometimes need to adapt to changing conditions. If you need to modify a budget after 
it has been set up, there are certain changes you can make at any time. It is not possible to change the overall 
budget period or to change which accounts a budget uses after the initial setup, but you can add and remove 
categories or adjust the amounts budgeted for them.

Adding categories

To add a category (in category view), or an income pile or expense envelope (in envelope view) to your budget, 
click the plus (+) button at the bottom of the main window:
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Choose a category or account name to use for the new budget item, type in the amount you want to budget, 
and specify how often you expect to earn or pay that amount. If you chose an account name, check “Expense” to 
track transfers from your budget accounts into that account, or uncheck it to track transfers from that account 
into your budget accounts. If it is unclear whether the next payment will fall within the current budget period, 
iBank will prompt you to choose when the next payment is due. When you finish configuring the various op-
tions, click “OK” to add the new item to your budget.

	 iBank also offers “Uncategorized Income” and “Uncategorized Expense” as options when adding a budget 
category in this manner. If you choose one of these two options, all positive and negative transactions 
(respectively) that have no categories assigned to them can be tracked as part of your budget.

Editing categories

To adjust the amount you expect to earn or pay in a particular category during the current budget period, or to 
adjust the frequency of payment, double-click on a category/income pile/expense envelope:
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Make any adjustments necessary, then click “Save” to record the changes. The amount of cash currently in the 
pile or envelope will not be affected, but the figures in the summary section of the budget will update immedi-
ately to reflect the changes.

Removing categories

To remove a category/income pile/expense envelope from your budget, select the item you want to remove 
and click the minus (-) button. iBank will ask for confirmation before removing the category from the budget. 
Other categories in the budget will not be affected, nor will the transactions in your accounts that are associ-
ated with the category you removed. The figures in the summary section of the budget will update immediately 
to reflect the changes.
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To view, edit, and delete budgets:

Each budget you create is saved and displayed in the “Budgets” section of the source list. Click the small dis-
closure triangle next to “Budgets” to reveal your saved budgets, then click a budget to display its details to the 
right.

To edit a budget’s name and the accounts that are counted towards the budget, double-click the budget in the 
source list, use the popup inspector to make your changes, and click “Save.” To delete a budget, select it and click 
the minus (-) button below the source list. iBank will ask you for confirmation before permanently deleting the 
budget. The transactions in your accounts will not be affected when the budget is deleted.

Using multiple budgets:

iBank allows you to set up as many budgets as you find useful. Since budgets do not have any effect on the 
transactions or categories upon which they are based, you can create more than one budget that uses the same 
category without causing any ill effects. Just keep in mind that creating two budgets for the same category 
does not automatically give you license to spend more in that category! Make sure your real-life budgeting 
practices are sound, and iBank will help you to keep your budgets on track.
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How do I lock my data with a password?

If you share your computer with other users, you may be concerned about them accessing your financial 
records. You’ll be pleased to know that iBank provides simple password protection to lock your sensitive data 
away from prying eyes.

To enable password protection:

Open the iBank document you want to lock (if it is not already open) and choose File > Password Pro-
tection. The following sheet will appear:



424 Chapter 9: Security

Enter your desired password (twice for verification) and click “OK.” The padlock will close to show that your docu-
ment is now password protected. The next time you try to open the document with iBank, the following sheet 
will appear before any data is displayed:

Enter your password and click “OK” to open the file, or click “Cancel” to close it. The password lock stays with your 
document, so even if you open it on another computer you will be required to enter your password before it will 
open.

	 Password protection does not encrypt your data - it is merely intended to prevent your iBank document 
from being opened inadvertently by someone who should not see it. For greater security, save your iBank 
document in your home folder and enable Mac OS X FileVault, which you will find in System Preferences 
under “Security.”

To change your password:

Open the document and choose File > Password Protection. Enter your old password when prompt-
ed, then enter a new password twice and click “OK.”
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To disable password protection:

Open the document and choose File > Password Protection. Enter your password when prompted, 
check “Turn off password protection,” and click “OK.” iBank will no longer ask for a password before opening the 
file.
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How do I back up my iBank document?

One of the best ways to protect your financial data is to back up your iBank documents regularly. iBank is de-
signed to play nicely with Time Machine and other backup utilities, and saves your data in document files that 
are easy to copy for backup purposes. To support Apple’s enhanced security features, Gatekeeper and sandbox-
ing, iBank no longer includes an automatic backup feature.

If you don’t use Time Machine, you can easily make a copy of any iBank document in the Finder. Locate the 
document you want to back hold down the Option key (to make sure the Finder copies the file instead of mov-
ing it), and drag and drop the file onto a backup folder. For better security, choose a location outside of your 
local hard drive, such as a flash drive or a shared folder on a network. Feel free to rename the backup file to 
indicate that it is a copy of the original, if you like.

	 If you are handy with Automator, you can easily create a workflow to back up your iBank data. You can then 
attach the workflow to a repeating iCal event to have your Mac run the backup automatically at specified 
intervals.

To restore your data from a backup, simply hold down the Option key and drag and drop a backup file onto your 
Documents folder (or any other location on your local hard drive). You may choose to replace an existing iBank 
document, but be careful not to overwrite a file you need to keep for later use! When the file finishes copying, 
double-click it to launch iBank and open the document.
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How do I export my data for use with other software?

iBank allows you to save the data from your accounts to a file so that you can share it with other programs. You 
may need to send your financial data to an accountant, for example, or import your spending information into a 
tax preparation program. iBank allows you to export data in two formats: Quicken Interchange Format (QIF), for 
use with Quicken and most other financial applications, and Tax Exchange Format (TXF), for use with TurboTax 
and several other tax preparation applications.

To export to QIF:

Open the iBank document you want to export and choose File > Export. The export assistant will open 
to walk you through the process of exporting your data. Using the drop-down menu button, choose “QIF” (if it 
isn’t already selected) and click “Next.” On the next screen, use the two calendars to indicate a starting and end-
ing date for the data you want to export - all transactions that fall within the range you specify will be included 
in the QIF file. By default, the starting and ending dates are set to include all transactions in the document. Use 
the arrow buttons to change months, then click a date to select it. Click the diamond-shaped button above a 
calendar to go back to its default date. Click “Next” to continue.

On the next screen, check off the accounts you want to include in the QIF file. Because the QIF format does not 
support currency information, only accounts that use the same currency may be included in the same QIF file. 
Once you have chosen which accounts to include, click “Next” twice to continue. iBank will prompt you to enter 
a name for the QIF file and choose the location where it should be saved. Click “Save” to complete the export 
process.



428 Chapter 9: Security

To export to TXF:

Open the iBank document you want to export and choose File > Export. Using the drop-down menu but-
ton, choose “TXF” and click “Next.” On the next screen, choose which tax year you want to export data for. Click 
“Next” to continue.

On the next screen, check off the accounts you want to include in the TXF file and click “Next.” On the next 
screen, check off the categories you want to export. Only categories you have designated as “Taxable” are 
displayed in the list, and all of these are selected by default. Once you have chosen which categories to include 
in the TXF file, click “Next” twice to continue. iBank will prompt you to enter a name for the TXF file and choose 
the location where it should be saved. Click “Save” to complete the export process.
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How do I print checks from iBank?

iBank offers completely customizable check printing so that you can either print checks on purchased check-
stock paper or print checks entirely from scratch, on ordinary paper.

Check printing in iBank is done with user-configurable templates. Before you can print checks from an account, 
you must first configure a template to tell iBank how you want the checks to look. Each account stores its own 
template settings, so that you can use a different kind of check with each bank account.

To configure a check template:

First, select the account from which you will be printing checks. Choose Account > Show Check Print-
ing Setup to view the check printing setup window:
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To set the page size and margins:

Choose File > Page Setup and select the appropriate option from “Paper Size” to match the check stock 
you are using, and change the orientation if necessary. To adjust margin settings, you will need to create a 
custom paper size - click the “Paper Size” drop-down menu button and choose “Manage Custom Sizes.” You can 
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then use the available options to configure the page size and margin settings exactly as you need them. Click 
“OK” when you are done with the Page Setup options.

To choose a template style:

Select the appropriate check style from the “Style” pop-up menu button at the bottom of the Check Printing 
Setup window. Choose the style that best matches the type of check you want to print:

Standard:•	  Use this template to print three checks to a page with the date, payee, memo, and amount 
displayed on the check.

Wallet:•	  Use this template to print three checks to a page with the date, payee, memo, and amount dis-
played on the check as well as on a detachable wallet tab on the left side of the check.

Voucher:•	  Use this template to print one check at the top of the page, and two check-sized receipts below. 
Date, payee, memo, and amount information are displayed on each.

Custom:•	  Use this template if you want to print checks on plain paper. The date, payee, memo, and amount 
are displayed in addition to your address, the payee’s address, the bank’s routing number, your account 
number, and the check number. Standard MICR numbers are displayed across the bottom of the check for 
automated processing.

iBank retrieves your address and the bank address automatically from the Mac OS X Address Book. Your address 
is taken from the card designated as “Me” in Address Book. iBank will search for your bank’s address based on 
its name (as specified in the account inspector), so make sure you have a contact card in Address Book with the 
correct company name. The same applies to payees - iBank will search for your payee addresses based on their 
names. The routing number for your bank and your account number should be entered in the account inspector 
(double-click an account to show the inspector). When you print a custom check, the background gradient will 
be printed in addition to the text fields.
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	 When printing checks using the “Custom” template, you must use plain paper - preprinted check stock can 
only be used with the other template styles. Check with your bank for any rules or regulations regarding 
printed checks; in some case, special MICR ink may be required. IGG Software does not guarantee that all 
banks will accept checks that you print yourself.

To set the check size:

At the bottom of the Check Printing Setup window are two figures, ‘H’ and ‘W’, which represent the height and 
width of each check in pixels. Adjust these figures to match the size of your check stock - you may need to print 
a few test pages on blank paper until you are able to make sure things line up properly. Changing the paper size 
will cause the check size to automatically scale itself to fit three to a page.

Please note that the check height and width cannot exceed the paper size. If the check height and width are 
smaller than the paper size, you will see white space to the left and/or bottom of the checks in the Check Print-
ing Setup window. If there is extra space, you can reposition the checks on the paper by adjusting the ‘X’ and ‘Y’ 
coordinates (horizontal and vertical position in pixels) at the bottom of the window.

To adjust field positions & font styles:

Click any text field (e.g. payee name, transaction date, memo) in the top-most check to select it. A box will 
appear around the field to indicate that it is selected:
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To reposition the field, click and drag to move it to a new location. As you are dragging it, two numbers will 
appear at the top-left of the field representing the X and Y coordinates (horizontal and vertical location) of the 
field. You will notice that the two checks below automatically update to match the top check.

	 When using the “Voucher” check style, you can edit the middle check in addition to the top-most check. The 
top-most area controls how information will be printed on the check, while the middle area controls how 
the receipts will look.

To resize the field, click and drag the blue handle at either end of the selection box to make it bigger or smaller.

To change the font, size, shadow, etc. of the selected field, click the “Fonts” button at the bottom of the window 
and make modifications as necessary. To change the color of the text, click the “Color” button and choose a new 
color.

To add the “Payee Address” field:

If you want to display the payees’ addresses on your checks, click the “+ Add” button next to “Style” and choose 
“Payee’s Address” from the pop-up menu. A new field will be added to the template which you can reposition 
and style as necessary. To remove this field from the check template, select it and press ‘Delete’ on your key-
board.
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Payee addresses are retrieved from the Address Book application. Make sure that you have an entry in Address 
Book that matches the payee for whom you are printing the check, otherwise iBank will not be able to display 
address information for that payee.

To add an image or logo:

Drag and drop an image file from the Finder onto the top-most check:

Click and drag the image to reposition it; click and drag the handles around its border to resize it. Note that the 
image will appear in front of any text on the check and cannot be used as a background image. To remove an 
image from the template, click once to select it and press ‘Delete’ on your keyboard.

To reset a template to the default setup:

Choose a different selection from the “Style” menu, then change back to the one you were using. Your changes 
will be erased and the default template will be shown again.
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To print checks:

Once you have finished configuring the check template, close the Check Printing Setup window. Select one or 
more transactions (Command-click to select multiple items in the account register) for which you want checks 
to be printed, then choose File > Print Checks for Selected Transactions.

Configure your printer settings as appropriate, then click “Print.” Each transaction will be printed to a separate 
check. Depending on how you have your template configured, checks will typically print three to a page. If you 
only select one or two checks for printing, only one or two checks will print on the page.
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How do I sync my iBank documents with my iPad, iPhone 
and iPod touch?

We at IGG Software offer three companion apps that you can use to sync your iBank data with Apple mobile 
devices:

•	   iBank for iPad is a full-featured financial manager designed specifically for the iPad. Available 

only at the iTunes App Store, this app handles all account types and includes investment tools, a budget 
planner, and basic reports all wrapped up in a stylish interface. Use it as a stand-alone app or sync with 
iBank for Mac!

•	   iBank Mobile is a simple yet powerful tool for keeping your bank accounts up to date while on 

the go. Enter transactions from your iPhone or iPod touch, check your account balances, and sync with 
iBank for Mac. Investment accounts are not supported in this app, which is available only at the iTunes App 
Store.

•	   iBank Investor is a handy (and free!) app for tracking your investment portfolio on your iPad, 

iPhone, or iPod touch. Enter your current holdings manually or sync them from iBank for Mac, then down-
load the latest market data and track the performance of your investments. Available only at the iTunes 
App Store.

http://itunes.com/apps/iggsoftwarellc/ibankforipad
http://itunes.com/apps/iggsoftwarellc/ibank
http://itunes.com/apps/iggsoftwarellc/ibank
http://itunes.com/apps/iggsoftwarellc/ibankinvestor
http://itunes.com/apps/iggsoftwarellc/ibankinvestor
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iBank for iPad and iBank Mobile sync with your mobile devices via Bonjour Wi-Fi or a WebDAV server; iBank 
Investor syncs via the IGG Software cloud servers. For information about our policies regarding security and 
privacy, please visit our website: iggsoftware.com/legal

Syncing with iBank for iPad

To use iBank for iPad, you will first need to purchase a copy of the app from the iTunes App Store and install it 
on your iPad. iBank for iPad works as a stand-alone application to let you track your accounts, transactions, and 
investments on the go, and can sync with multiple iBank for Mac documents via Bonjour Wi-Fi or a WebDAV 
server.

	 Using iBank for iPad, you may sync multiple iPads with a single iBank document and/or sync a single device 
with multiple iBank documents. The possibilities are practically endless! 

Configuring a financial book for syncing

Make sure your iPad is connected to the same wireless network as your Mac and launch the iBank app. Tap the 
‘+’ (plus) button at the bottom of the screen to create a new financial book. Enter a name for the book and tap 
“Continue,” then tap “Sync with iBank for Mac” to proceed (please note that Direct Access cannot be used for 
financial books that sync with iBank for Mac). On the next page you should see four large numbers displayed in 
the middle of the screen.

Launch iBank for Mac, open the document you want to sync, choose File > Set Up Device for Sync-
ing or select “Sync Settings” in the “Manage” section of the source list, click the “Devices” tab, and then click “Set 
Up New Device.” The following sheet will appear:

http://www.iggsoftware.com/legal
http://itunes.com/apps/iggsoftwarellc/ibankforipad
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This screen provides a basic overview of the sync options available to you. Click “Next” to proceed:
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The name of your financial book should appear in the list automatically. If it does not, check to make sure your 
iPad and Mac are connected to the same wireless network, and that you can still see the four-digit code on your 
iPad screen. If you need to refresh the list, click “Back” and then “Continue” again.

Select your financial book from the list and click “Continue” to proceed:

On this screen, enter the four-digit code that you see on your iPad, then click the option you wish to use for 
syncing:

Bonjour Wi-Fi:•	  Click this button if you want to sync your data directly with your Mac whenever your mo-
bile device and Mac are connected to the same wireless network. iBank for Mac must be running whenever 
you sync using this option.

WebDAV:•	  Click this button if you want to sync your data via a custom WebDAV server.
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Once you have chosen your preferred sync option, click “Next” to proceed. iBank may ask you to complete some 
additional configuration settings depending on your choice. If you chose WebDAV, you will need to enter the 
URL where the server can be accessed, as well as a username and password. Bonjour Wi-Fi does not require any 
additional configuration. Once this step is complete, you will see your financial book added to iBank’s device list. 
If you want to add another device, click “Set Up New Device.”

	 A sync connection can only be established when creating a new financial book in iBank for iPad. It is not 
possible to sync an existing book with iBank for Mac. 

Adding a sync connection manually

If you are syncing via WebDAV and cannot connect your iPad to the same wireless network as your Mac, you can 
still configure the connection manually. When you get to the list of available devices, click “Manual Setup.” Enter 
a name for the sync connection and choose which mobile app you are syncing with. In the box below, enter the 
full URL for the WebDAV server, along with the username and password needed to access the server. When you 
click “Done,” iBank will attempt to connect to the server. If successful, it will add the connection to your device 
list and you may sync your data to the WebDAV server. You will then need to manually configure syncing in 
iBank for iPad as well.

Viewing, editing, and removing synced devices

To view the device list, choose File > Set Up Device for Syncing or select “Sync Settings” in the 
“Manage” section of the source list, then click the “Devices” tab. If you have already configured at least one sync 
connection, it will appear in the list:
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This list shows all the sync connections you have configured. Each item shows an icon for the app it is synced to 
(iBank Mobile or iBank for iPad), the name of the sync connection, the method chosen for syncing, the date and 
time of the last sync, and the URL for the WebDAV server (if applicable). To edit the connection settings, click the 
“Edit” button. To remove a sync connection from the list, select it and click “Delete Device” at the bottom of the 
list.

Syncing your data with iBank for iPad

If you chose the Bonjour Wi-Fi method of syncing, simply connect your iPad to the same wireless network as 
your Mac, make sure iBank for Mac is running, and open the financial book you want to sync. Your accounts will 
update automatically when the book opens; you cannot initiate a Bonjour Wi-Fi sync from iBank for Mac. To 
sync your data via WebDAV, click the “Sync Devices” button on the toolbar in iBank for Mac, or choose File > 



449Chapter 11: Syncing With Mobile Devices

Sync Devices. While iBank is uploading your data to the WebDAV server, you will see a progress bar appear 
at the bottom of the source list. Once the sync is complete on the Mac, open your financial book in iBank for 
iPad to retrieve the latest data from the WebDAV server.

	 To sync your data via WebDAV automatically when you launch and quit iBank, choose iBank > Prefer-
ences, click the “General” button, and check “Sync devices on launch and quit.” This option cannot be used 
when syncing via Bonjour Wi-Fi, because in that case the sync must be initiated from the iPad.

Syncing multiple devices & documents

To sync more than one iPad with iBank for Mac, configure each device using the same steps outlined above. To 
sync more than one iBank for Mac document with your iPad, create a new financial book for each document and 
configure it to sync using the steps outlined above. All configured sync connections will appear in the device list 
in iBank for Mac.

	 When syncing via WebDAV, each sync connection must be configured to use a unique directory. You can 
name this directory whatever you wish - for example, one financial book may be configured to sync to the 
URL, “http://www.myserver.com/ibank_data_1/,” while another may use the URL, “http://www.myserver.
com/ibank_data_2/.” When you are syncing multiple iPads, note that your data cannot sync directly be-
tween iPads but must be synced through iBank for Mac before it will sync to another iPad.

Resetting sync data

If you want to remove all the data in a financial book and replace it with the data in iBank for Mac, open the 
device list in iBank for Mac and click “Edit” next to the connection you want to reset. In the sheet that appears, 
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check “Reset all data on next sync” and click “Done.” The next time you sync your devices, all data in that financial 
book will be replaced with the data from your Mac.

Syncing with iBank Mobile

iBank Mobile works as a stand-alone application to let you track your accounts and transactions on the go, and 
can sync data with iBank for Mac via Bonjour Wi-Fi or a WebDAV server.

	 Using iBank Mobile, you may sync multiple iPhones and iPod touches to a single iBank document, but a 
single device cannot sync with more than one iBank document. 

Configuring a device for syncing

If you have not done so already, you first need to purchase a copy of iBank Mobile from the iTunes App Store 
and install it on your mobile device. Make sure your iPhone/iPod is connected to the same wireless network as 
your Mac. Launch iBank Mobile, tap the settings button in the bottom left corner of the main screen, tap the 
button under “Syncing,” then tap “Sync with iBank For Mac.” You should then see a four-digit code appear on the 
screen. Once you see this, you are ready to configure iBank for Mac.

Launch iBank for Mac, open the document you want to sync, choose File > Set Up Device for Sync-
ing or select “Sync Settings” in the “Manage” section of the source list, click the “Devices” tab, and then click “Set 
Up New Device.” The following sheet will appear:

http://itunes.com/apps/iggsoftwarellc/ibank


451Chapter 11: Syncing With Mobile Devices

This screen provides a basic overview of the sync options available to you. Click “Next” to proceed:
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Your mobile device should appear in the list automatically. If it does not, check to make sure your iPhone/iPod 
and Mac are on the same wireless network, and that you can still see the four-digit code on your mobile device 
screen. If you need to refresh the list, click “Back” and then “Continue” again.

Select your mobile device from the list and click “Continue” to proceed:

On this screen, enter the four-digit code that you see on your iPhone/iPod, then click the option you wish to use 
for syncing:

Bonjour Wi-Fi: •	 Click this button if you want to sync your data directly with your Mac whenever your mo-
bile device and Mac are connected to the same wireless network. iBank for Mac must be running whenever 
you sync using this option.

WebDAV:•	  Click this button if you want to sync your data via a custom WebDAV server.
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Once you have chosen your preferred sync option, click “Next” to proceed. iBank may ask you to complete some 
additional configuration settings depending on your choice. If you chose WebDAV, you will need to enter the 
URL where the server can be accessed, as well as a username and password. Bonjour Wi-Fi does not require any 
additional configuration. Once this step is complete, you will see your iPhone/iPod added to iBank’s device list. 
Choose File > Sync Devices or click “Sync Devices” on the toolbar to sync your data to the mobile device. 
If you want to add another device, click “Set Up New Device.”

	 When a sync connection is first established, the data in iBank Mobile is replaced with the data from iBank 
for Mac. If you have data in iBank Mobile that you do not want to lose, you will need to export it to a QIF file 
and import that file into iBank for Mac before syncing.

Adding a device manually

If you are syncing via WebDAV and cannot connect your mobile device to the same wireless network as your 
Mac, you can still configure the connection manually. When you get to the list of available devices, click “Manual 
Setup.” Enter a name for the sync connection and choose which mobile app you are syncing with. In the box 
below, enter the full URL for the WebDAV server, along with the username and password needed to access the 
server. When you click “Done,” iBank will attempt to connect to the server. If successful, it will add the connection 
to your device list and you may sync your data to the WebDAV server. You will then need to manually configure 
syncing in iBank Mobile as well.

Viewing, editing, and removing synced devices

To view the device list, choose File > Set Up Device for Syncing or select “Sync Settings” in the 
“Manage” section of the source list, then click the “Devices” tab. If you have already configured at least one 
iPhone or iPod touch, the device will appear in the list:



454 Chapter 11: Syncing With Mobile Devices

This list shows all the sync connections you have configured. Each item shows an icon for the app it is synced to 
(iBank Mobile or iBank for iPad), the name of the sync connection, the method chosen for syncing, the date and 
time of the last sync, and the URL for the WebDAV server (if applicable). To edit the connection settings, click the 
“Edit” button. To remove a sync connection from the list, select it and click “Delete Device” at the bottom of the 
list.

Syncing your data with iBank Mobile

If you chose the Bonjour Wi-Fi method of syncing for your device, simply connect the device to the same wire-
less network as your Mac, make sure iBank for Mac is running, and tap the sync button in iBank Mobile. You 
cannot initiate a Bonjour Wi-Fi sync from iBank for Mac. To sync your data via WebDAV, click the “Sync Devices” 
button on the toolbar in iBank for Mac, or choose File > Sync Devices. While iBank is uploading your 
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data to the WebDAV server, you will see a progress bar appear at the bottom of the source list. Once the sync is 
complete, tap the sync button in iBank Mobile to sync the device with the WebDAV server.

	 To sync your data via WebDAV automatically when you launch and quit iBank, choose iBank > Preferences, 
click the “General” button, and check “Sync devices on launch and quit.” This option cannot be used when 
syncing via Bonjour Wi-Fi, because in that case the sync must be initiated from the mobile device.

Resolving sync conflicts

If a transaction was modified in iBank for Mac and iBank Mobile, and the changes are not consistent when you 
attempt to sync your data, iBank for Mac will alert you about the conflict:
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The two versions of the transaction are shown side-by-side so that you can compare them. A yellow warning 
badge  appears next to the bits of information that are inconsistent between the two transactions. Choose 
the version you wish to keep by clicking on it, then click “Continue” to proceed with the sync. If you anticipate 
multiple conflicts and wish to resolve all conflicts automatically using the “local” (iBank for Mac) version or the 
“remote” (iBank Mobile) version, click the appropriate transaction and check “Resolve all conflicts with local/
remote data” before clicking “Continue.”

Syncing multiple devices

To sync more than one iPhone or iPod touch with iBank for Mac, configure each device using the same steps 
outlined above. All configured devices will appear in the device list.

	 When syncing via WebDAV, each device must be configured to use a unique directory. You can name this 
directory whatever you wish - for example, one device may be configured to sync to the URL, “http://www.
myserver.com/ibank_data_1/,” while another may use the URL, “http://www.myserver.com/ibank_data_2/.” 
Data does not sync directly between devices, but must be synced through iBank for Mac before it can be 
synced to other devices.

Resetting sync data

If you want to remove all the data on your iPhone or iPod touch and replace it with the data in iBank for Mac, 
open the device list and click “Edit” next to the device you want to reset. In the sheet that appears, check “Reset 
all data on next sync” and click “Done.” The next time you sync your devices, all iBank Mobile data on that iP-
hone/iPod will be replaced with the data from your Mac.



457Chapter 11: Syncing With Mobile Devices

Syncing with iBank Investor

To access your investment portfolio on your mobile device, you will need to download a copy of iBank Investor, 
available for free at the iTunes App Store (banner ads can be removed for a small fee). iBank Investor works as a 
stand-alone application to let you track your portfolio on the go, and can sync data with iBank for Mac via IGG 
Software’s cloud syncing service, which you can access with a free IGG customer account.

	 Using iBank Investor, you may sync multiple iPads, iPhones, and iPod touches to a single iBank document, 
but a single device cannot sync with more than one iBank document. 

Setting up your IGG customer account

Launch iBank for Mac, open the document you want to sync, choose File > Set Up Device for Syncing or select 
“Sync Settings” in the “Manage” section of the source list, and click the “iBank Investor” tab:

http://itunes.com/apps/iggsoftwarellc/ibankinvestor
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If you have not already signed up for a free IGG Customer Account, click “Create IGG Account.” Fill out the form 
that appears on your screen, and click “Create Account” to proceed. Once your account has been set up, iBank 
will log you in automatically. An email will be sent to you in order to verify your email address, but you may 
begin using your IGG customer account before verification is complete. Just be sure to complete the verification 
process within two weeks, or your account will be suspended.

If you already have an IGG customer account, simply enter your username and password, then click “Sign In.” 
iBank will connect to the IGG server and access your account. If you forgot your password, click the “Lost pass-
word” button and enter your email address to receive an email from IGG with a link that you can click to reset 
the password.

Once you have logged in successfully, you may click “Edit Info” to change your customer information or click 
“Change Password” to change your password. iBank saves your password in the Mac OS X Keychain so that you 
do not need to log in each time you launch the program. To sign out of your IGG customer account, click “Sign 
Out.”

Configuring a device for syncing

Launch iBank for Mac, go to the sync settings screen described above, sign into your IGG customer account, and 
check “Sync my investments and portfolio data.” iBank will automatically upload the data from your investment 
accounts to the IGG cloud servers. You can then configure your mobile devices to download the synced data.

If you have not done so already, download iBank Investor from the iTunes App Store onto your iPad, iPhone, or 
iPod touch. If you are launching the app for the first time, tap “Sync” on the welcome screen and log in to your 
IGG customer account. If it is not your first time using iBank Investor, tap the “Settings” button in the top left cor-
ner, then tap “Sign In” to access your account. Once you have logged in, your portfolio data will be downloaded 
from the IGG cloud servers automatically.

http://itunes.com/apps/iggsoftwarellc/ibankinvestor
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	 When you sign in to your IGG customer account and sync your mobile device, any data that was entered 
directly into iBank Investor is erased and replaced with the data synced from iBank for Mac. When syncing is 
enabled, all editing features are disabled. All changes to your investment data must be recorded in iBank for 
Mac, then synced to your devices.

Updating your synced portfolio

To keep your data in sync, launch iBank for Mac and choose File > Sync Devices or click “Sync Devices” 
on the toolbar to upload the latest investment data to the IGG cloud servers. Your mobile devices will automati-
cally update their portfolios when iBank Investor is launched. Please note that iBank Investor can only handle 
investments in one currency at a time. If you maintain investment accounts in iBank for Mac that use different 
currencies, you will need to use the currency selector at the top of the summary pane to choose which currency 
you want to sync.

	 To sync your portfolio data automatically when you launch and quit iBank, choose iBank > Prefer-
ences, click the “General” button, and check “Sync devices on launch and quit.” 

Deleting synced data

If you want to stop syncing your investment data and remove the synced data from the IGG cloud servers, first 
sign out of your IGG customer account in iBank Investor on each of your mobile devices. Launch iBank for Mac, 
select “Sync Settings” in the “Manage” section of the source list, and click the “iBank Investor” tab. Uncheck “Sync 
my investments and portfolio data;” iBank will stop syncing your portfolio and delete your synced data from the 
IGG cloud servers. You may log out of your IGG customer account, but this is not required.
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FAQ Index

iBank users often write to us with the following questions. Check here first to see if someone else has already 
asked your question!  The following sections make up this chapter:

Updating, Upgrading, Installing, & Registering… ……………………………………………………… 465
How do I update iBank?… ………………………………………………………………………………………… 465

When will I have to upgrade iBank?… …………………………………………………………………………… 467

Why won’t iBank accept my registration?… ……………………………………………………………………… 468

What if my free trial expires? Will I lose all of my data?… ………………………………………………………… 469

Can I install iBank on more than one computer?… ……………………………………………………………… 469

Managing Documents……………………………………………………………………………………… 471
Why won’t iBank open my document automatically?… ………………………………………………………… 471

Does iBank save my data automatically?… ……………………………………………………………………… 471

Can two or more people share the same iBank document?… …………………………………………………… 471

Accounts & Transactions…………………………………………………………………………………… 473
Can I change account types?… …………………………………………………………………………………… 473

Can I rename items in the source list?……………………………………………………………………………… 473

How do I see all transactions in a category for specific dates?… ………………………………………………… 473

What is that number at the bottom-right corner of the screen?… ……………………………………………… 474

Why are dates missing/incorrect when I import transactions?… ………………………………………………… 474

Miscellaneous… …………………………………………………………………………………………… 475
Can I download quotes for non-U.S. securities?…………………………………………………………………… 475

Why can’t I configure income categories for my budget?… ……………………………………………………… 475

Do you recommend a particular check stock?… ………………………………………………………………… 476
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Why does iBank attempt to contact “iggsoftware.com” at startup?… …………………………………………… 476

Does iBank integrate with NeatReceipts?… ……………………………………………………………………… 476

What keyboard shortcuts are available in iBank?… ……………………………………………………………… 476

If you still can’t find the answer to your question, check our online forums or email customer support for assis-
tance (see Chapter 13: Contact Us for more information).
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Updating, Upgrading, Installing, & Registering

How do I update iBank?

We are constantly working to improve our software. Periodically, we will release updates with bug fixes, security 
enhancements, and feature additions. As long as the main version number matches the one you purchased, it 
is free to install - your original registration code will be automatically recognized. That means if you purchased 
iBank 4, v4.01, v4.1, v4.52, etc. are all free to you! Check the iBank page on our website (www.iggsoftware.com/
ibank) frequently to stay up-to-date, or have iBank check automatically and notify you when a new version is 
available. To read our policy on paid upgrades, see When will I have to upgrade iBank?

	 If you purchased iBank through the Mac App Store, all updates must be installed through the App Store as 
well. Update notifications are not available in that version of iBank. 

To enable update notifications:

Choose iBank > Preferences and click the “General” button. Check “Notify me when an update is avail-
able.” The next time you launch iBank, it will connect to our website and check the number of the latest version 
available (don’t worry - no information is transmitted to us in the process). If the latest version is newer than the 
one you have installed, iBank will show you this window:

http://www.iggsoftware.com/ibank/
http://www.iggsoftware.com/ibank/
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The latest iBank version number is displayed - to download it using your default web browser, click “Download 
Now.” If you want to skip the update but be reminded again next time you launch iBank, click “Ask Again Later.” If 
you don’t want to be notified again, click “Change Preferences” and uncheck “Notify me when an update is avail-
able.” To view a list of the changes made in each version, visit this page on our website: http://www.iggsoftware.
com/ibank/version_changes_4.html.

To install the update once it has been downloaded:

Quit iBank if it is currently open. Assuming you clicked “Download Now” when the update notification appeared, 
you should have a file named “iBank4_Update.dmg” on your Desktop (or in your Downloads folder). Double-
click it to mount the “iBank 4” disk image. A window should automatically appear containing the iBank applica-
tion:

http://www.iggsoftware.com/ibank/version_changes_4.html
http://www.iggsoftware.com/ibank/version_changes_4.html
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Drag the iBank application onto the Applications folder, and allow the Finder to overwrite the existing iBank 
program. Drag both the “iBank 4” disk image and the “iBank4_Update.dmg” file from your Desktop to the Trash, 
and double-click the iBank application in your Applications folder to open it. Your update is now complete!

When will I have to upgrade iBank?

Periodically we will release minor updates to improve iBank’s functionality. As long as the main version number 
matches the one you purchased, it is free to install - your original registration code will be automatically recog-
nized. That means if you purchased iBank 4, v4.01, v4.1, v4.52, etc. are all free to you!
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Each major version of iBank we release, however, is considered to be a paid upgrade. That is, if you purchased 
iBank 4 and we release iBank 5, you will have to pay an additional fee to upgrade. Our promise to you is that 
we will not release major versions less than one year apart. Additionally, we frequently offer reduced upgrade 
pricing for registered users of previous versions. Visit our online store (secure.iggsoftware.com/store) for more 
details.

Why won’t iBank accept my registration?

If you purchased iBank from our online store, or ordered a license through the iBank application:

First, make sure you installed the correct version of the software. If you purchased a license for iBank 3 and 
installed version 4, it will not accept your code. Once you are sure you have the correct version of iBank installed, 
read on.

iBank is very picky about how you enter your registration information. You must type your name, email •	
address, and license code exactly as they appear in the receipt that was emailed to you after you submitted 
your order. iBank uses your name and email address to verify the license code, so be precise.

Pay attention to uppercase/lowercase letters, spaces, punctuation, and special characters.•	

If you only entered one name at the time of purchase, type that name into the “First name” field and then •	
type a single blank space into the “Last name” field.

If you have a middle name or initial in your registration, such as “John Q. Smith”, enter the first and middle •	
name(s) in the “First name” field (e.g. “John Q.”). The “Last name” field should only contain one name (e.g. 
“Smith”).

Be careful to distinguish between the capital letter ‘O’ and the number ‘0’.•	

https://secure.iggsoftware.com/store
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Some special characters cause problems with iBank’s registration algorithm. If you have accented charac-•	
ters, umlauts, etc. in your name then please contact us.

If you purchased the boxed version of iBank from a retail store:

Enter the license number that appears on the sticker affixed to your iBank CD sleeve. The line should begin with 
“IBNK” and contain several dashes. Ignore any numbers that are printed vertically along the side of the sticker, 
as they are not part of the license code. You may enter any name and email address with the license code - just 
make sure to type something in each field.

Additional information:

For more information about registering iBank, see How do I purchase and/or register iBank? in Chapter 1: Get-
ting Started.

What if my free trial expires? Will I lose all of my data?

No, even if your free trial period runs out, your data will be preserved. Whenever you purchase a license and 
register the software, it will be available to use again. If iBank does not open your document automatically after 
registering, double-click the document in the Finder to open it.

Can I install iBank on more than one computer?

Yes, technically the iBank license agreement allows you to install the software on two separate computers and 
register them both using the same license code. This is intended mainly for backup purposes and is considered 
acceptable on the condition that both copies of the software are not run at the same time.
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Installing one copy of iBank at the office and one copy at home so that you can work on your finances from 
both locations is perfectly fine. If two different people will be using the software for their own purposes, or both 
copies of iBank need to be used at the same time, then we ask that you purchase an additional license.
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Managing Documents

Why won’t iBank open my document automatically?

Each time you start iBank, it should automatically display the last document you opened. iBank relies on the 
Mac OS X feature “Recent Items” to remember the location of your document - if you have this feature disabled, 
iBank will not be able to open the file automatically. To make sure you have not disabled this feature, open 
System Preferences and click the “Appearance” button. Under “Number of Recent Items,” make sure you have a 
number selected next to “Documents” and not “None.”

	 Some third-party menu utilities may interfere with the “Recent Items” feature. If iBank is not opening your 
document automatically and you have one of these utilities installed, you may need to reconfigure or 
uninstall the utility.

Does iBank save my data automatically?

Yes, iBank saves every change you make, as soon as you make it. You should never need to save your data manu-
ally! For more information, see How do I manage iBank documents? in Chapter 1: Getting Started.

Can two or more people share the same iBank document?

iBank is intended for single-user operation. Generally speaking, two users cannot access the same document 
without making a copy of the file. The Core Data foundation on which iBank relies for data management does 
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not play well with network access - so if you place your iBank document in a shared folder (even if both users are 
on the same computer), iBank may not be able to write changes to the file. You can use a shared folder to keep a 
central copy of the file, which users can copy to their Desktop before making changes in iBank and then replac-
ing the file afterwards.

	 Some of our customers have reported that they are able to share iBank documents using third-party sync-
ing software such as Dropbox. We recommend against syncing your data in this manner, as corruption of 
your financial information is likely to result when sync conflicts arise.
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Accounts & Transactions

Can I change account types?

No, once you create an account you cannot change its type. If you accidentally set up an account with the 
wrong type, simply create a new account with the correct type, then cut and paste all the transactions from the 
old account into the new one. Be sure to use the “Cut” command instead of “Copy,” or else the transfers in the 
account may create duplicates in other accounts.

Can I rename items in the source list?

Accounts, budgets, and reports can be renamed by double-clicking them, changing the “Name” field, and click-
ing “Save.” Websites can be renamed by double-clicking the accounts to which they belong, changing the “Bank” 
field, and clicking “Save.” Items in the “Manage” section of the source list cannot be renamed.

How do I see all transactions in a category for specific dates?

Create an Income & Expense report, then edit the report settings and choose a “Custom” date range. Set the 
range to cover a large period of time so that all transactions are covered, as pictured here:
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Once you’ve saved the chart settings, click on a category to “drill down” - iBank will show you all of the transac-
tions that make up that category. Feel free to print the report or save it to a PDF file. Click on any transaction to 
view and edit it in the account where it was recorded.

What is that number at the bottom-right side of the screen?

The number displayed at bottom right corner of the main window is the balance of whatever 
account is currently selected in the source list.

Why are dates missing/incorrect when I import transactions?

The date is probably missing or incorrect because the wrong date format was supplied for parsing the imported 
file. Under normal circumstances, iBank interprets the dates in QIF files automatically. If it cannot recognize the 
date format used in the file, however, then it will prompt you to choose a format, and you must take care to 
choose the correct format.

Use the custom date format field to match your exact format if one is not available in the pop-up button. See 
the examples below:

Example 1: To match a date format of mm/dd/yyyy you would enter %m/%d/%Y•	

Example 2: To match a date format of d.m.yy you would enter %e.%m.%y•	

Example 3: To match a date format of m-d-yy you would enter %m-%e-%y•	

For more information, see How do I choose a date format for a QIF import? in Chapter 5: Importing Data.
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Miscellaneous

Can I download quotes for non-U.S. securities?

iBank uses the Yahoo! Finance quote service for downloading security prices. Any security that is listed on 
Yahoo, iBank should be able to download; just be sure to enter the symbol that Yahoo uses in iBank’s investment 
transactions and securities.

Quotes can be downloaded from non-US stock exchanges by adding the appropriate suffix to each of your se-
curity symbols. For example, the symbol for Google on the London Exchange is “GGEA.L”. For a list of supported 
exchange suffixes, visit http://finance.yahoo.com/exchanges.

For more information about investment accounts, see Chapter 6: Investments.

Why can’t I add income categories to my budget?

You must designate some categories as income-based before you will be able to add any categories to the in-
come section of your budget. Select “Categories” in the “Manage” section of the source list and select a category 
you want to use to track income. At the bottom of the screen, change the category’s type to “Income.” Repeat 
for each of your income categories. When you return to your budget setup, those categories will be available for 
use in the income section.

http://finance.yahoo.com/
http://finance.yahoo.com/exchanges


476 Chapter 12: Frequently Asked Questions

Do you recommend a particular check stock?

No, we designed the check printing template system to be flexible enough to work with just about any check 
stock you might find. So feel free to pick whichever one catches your fancy! IGG Software does not sell check 
stock specifically designed for use with iBank.

Why does iBank attempt to contact “iggsoftware.com” at startup?

That’s the name of the server where our website is hosted. If you have update notifications enabled, iBank will 
automatically connect to our website every time it is launched to find out if a new version of iBank is available 
for download.

Don’t worry - it is our policy that iBank never transmits any information about you or your computer back to IGG 
Software. To view a copy of our official privacy policy, see this page on our website: http://www.iggsoftware.
com/privacy.html

Does iBank integrate with NeatReceipts?

Yes, if you drag and drop a NeatReceipts PDF file onto an account icon in the iBank source list, iBank will auto-
matically create a new transaction for that item in the selected account. The appropriate date, payee, category, 
and amount will be assigned to the transaction, and a copy of the receipt will be attached to it.

What keyboard shortcuts are available in iBank?

iBank has the following shortcuts available for use:

http://www.iggsoftware.com/legal
http://www.iggsoftware.com/legal
http://www.neatco.com/products/neatreceipts
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Key Combination Command
Option - Shift - N Create a New iBank Document
Command - O Open an iBank Document
Option - Command - S Sync Mobile Devices
Option - Command - I Import Data
Option - Command - E Export Data to QIF/TXF
Command - W Close the Window
Command - S Save
Shift - Command - S Save As
Shift - Command - P Page Setup
Command - P Print
Option - Shift - Command - P Print Checks for Selected Transactions
Command - , (Comma) Open iBank Preferences
Command - H Hide iBank
Command - Option - H Hide Other Applications
Command - Q Quit iBank
Command - Z Undo
Shift - Command - Z Redo
Command - X Cut
Command - C Copy
Command - V Paste
Option - Shift - Command - V Paste and Match Style
Command - A Select All
Command - : (Colon) Show Spelling and Grammar
Command - ; (Semicolon) Check Spelling
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Key Combination Command
Command - I Show the Popup Inspector
Shift - Command - O Open the Selection in a New Window
Shift - Command - N Create a New Account
Shift - Command - G Create a New Account Group
Shift - Command - A Create a New Smart Account
Option - Command - T Go To the Selected Account’s Website
Command - D Direct Download Transactions for All Accounts
Shift - Command - D Direct Download Transactions for the Selected Account
Control - Command - D Update Security Quotes
Control - Command - R Update Currency Exchange Rates
Command - L Show Loan Settings for the Selected Account
Option - Command - R Reconcile the Selected Account with a Bank Statement
Command - N Create a New Transaction
Command - E Edit the Selected Transaction
Command - Delete Delete the Selected Transaction
Option - Command - Y Show/Hide Split Items for the Selected Transaction
Option - Command - N Add a Split Item
Option - Command - Delete Delete the Selected Split Item
Command - Right Arrow View the Transfer Linked to the Selected Transaction
Shift - Command - R Create a Report
Shift - Command - B Create a Budget
Control - Command - S View Upcoming Scheduled Transactions
Shift - Command - C Launch the Calculator App
Command - M Minimize the Window
Tab Cycle Through Fields
Return Save the Current Transaction
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Key Combination Command
Escape Cancel Changes to the Current Transaction
Down Arrow Show a Calendar (While Editing a Date) or Choose from a List (While 

Editing a Payee, Category, or Security Symbol)
[ (Left Bracket) Decrease the Date by 1 Day (While Editing a Date)
] (Right Bracket) Increase the Date by 1 Day (While Editing a Date)
Home (or Function - Left Arrow) Scroll to the Top of the Register
End (or Function - Right Arrow) Scroll to the Bottom of the Register
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Where can I find help or get additional support?

In addition to this manual, we offer free technical assistance via live chat, email, and a community-driven knowl-
edge base. Please feel free to contact us at any time; we will be sure to respond to your inquiry in a timely and 
effective manner.

To see if other iBank users have previously discussed a topic that concerns you, please browse our knowledge 
base at: qa.iggsoft.com/ibank

If you can’t find an answer to your question, please contact us at iggsoftware.com/support for assistance.

http://qa.iggsoft.com/ibank
http://www.iggsoftware.com/support/
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