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Overview

How to use these help files:

Welcome to iBank! This manual is provided to assist you in finding your way around the iBank 
application. Whether you are a first-time user just learning the ropes, or an iBank expert hunt-
ing for power user tips, we trust that this guide will help you take advantage of everything 
iBank has to offer. To get you started, here are a few notes about how to use the iBank User’s 
Guide.

Browsing: To get a quick overview of what is contained in this manual, please visit the Table of 
Contents page and browse the chapter headings. Page numbers are included for quick refer-
ence. If your PDF viewer has a Bookmarks tab, you can also use this to easily jump between 
chapters.

Searching: If you have a particular question in mind, you can use the search function in your 
PDF viewer to locate the section of the manual that addresses it. The contents of this manual 
have been organized in question format to better help you find what you are looking for. 

Hyperlinks: Throughout the guide, you will find words or phrases that are highlighted in yel-
low. The color indicates that the word or phrase is a hyperlink. If you are reading the manual 
in PDF format, you can click any hyperlink to jump to another section for more information on 
that topic. These cross-references should help to ensure that you always find the right answers 
to your questions, no matter where you start your search.
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Notes: Interspersed throughout the manual you will find boxes containing extra information 
about the topic at hand. They might offer caveats about certain features, explain in greater 
detail how certain functions work, or provide extra tips for power users who want to get a little 
bit more out of iBank.

	  
Look for boxes like this one for hints, tips, and extra info. 

Menu commands: In this manual, you are often instructed to choose commands from the 
various menus provided in iBank. To simplify the menu hierarchy, we chose to use the ‘>’ 
character to denote each sub-menu or menu item. To illustrate, when you see “View>Show 
Transactions>Recent,” this can be interpreted as “Go to the View menu, then go to the Show 
Transactions submenu, then choose Recent.”

About tracking finances with iBank:

Tracking your finances can be a lot like cleaning the house: you really want to do it, but some-
times it just doesn’t get done. Just like cleaning the house can be more enjoyable with good 
cleaning supplies and tools, tracking your money can be much easier if you have the appropri-
ate software application to assist you. iBank is the premier Mac OS X financial application to 
make tracking your finances as easy as possible.
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System requirements:

iBank 3 requires Mac OS X 10.5 or higher, at least 512 MB of RAM, 20 MB free hard drive space, 
and a screen resolution of at least 1024x640. For older systems, try iBank 2 (10.4) or iBank 1.5 
(10.3).

http://www.iggsoftware.com/ibank/downloads.php#older
http://www.iggsoftware.com/ibank/downloads.php#older
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What’s New in iBank 3.0?

Finally, the Mac OS X financial manager you’ve been waiting for! We’ve tried the competition, 
we’ve listened to our users and we’ve delivered the best financial manager available.

Take a look at these new features:

Direct Downloads. iBank 3 can connect to your bank “behind the scenes” and import 
your data for you.* No more going to websites, logging in, going to the correct page, 
setting date parameters, etc; now it just happens, automatically. This was our most 

requested feature and we’ve delivered.

*Your bank must support the OFX protocol specifications. If you bank doesn’t support it correctly or at all, you 
may still need to log in to a website to download transactions.

Interactive Graphs. Graphs in iBank 3 have received a complete overhaul. Now utiliz-
ing the power of Core Animation, you can click on pie graph slices to see sub-category 
totals or even “flip” the slices to see a list of the transactions making up that slice. 

While we certainly wanted to make the graphs look slick, they are way more functional and 
more enjoyable to use.

Category Images. iBank 3 comes loaded with high resolution images for the most 
popular categories. These images are then used when making charts or viewing graphs 
so you can quickly see which part of a graph belongs to which category. You can also 

change the images to match your own preferences or add images to your own custom catego-
ries.
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 Sync With Your iPhone. We delivered a solution for editing your transactions on the 
road, using your iPhone or iPod Touch. Using the latest Web 2.0 technologies you can 
view historical transactions and create and edit new ones while you’re on the go. To 

sync your data to MobileMe, it’s just one click from within iBank. MobileMe membership is 
required.

Cover Flow for Transactions. Ever wanted to see your transactions outside of a list? 
Enter Cover Flow on iBank: you can view, edit, and flip through your transactions while 
seeing how you spent (or earned) your money with gorgeous category images (see 

above). A graph along the bottom shows your account balance through time; click anywhere in 
the graph to jump to that transaction.

Loan Management. Easily manage loans and other debt with scheduled payment plans. 

Smart Portfolios. Use a smart portfolio to summarize your investments for any ac-
counts or securities. Want a portfolio to represent your Roth IRA, but not your personal 
investment account? No problem. Just want to see how your Apple stock is doing since 

a specified date or from a specified account? No problem.

Check Your Stocks on the Road. Upload your portfolios to your MobileMe account 
from iBank and view your securities’ performance from any web browser (including 
your iPhone and iPod Touch, of course).
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Stock Performance Graph. Ever wonder how your stock picks stack up against the S&P 
500 or NASDAQ, even after adjusted for dividend payouts? With the new performance 
graph in iBank you can select any securities to graph against each other to see how 

they compare, through time, adjusted for splits and dividends.

More Drag and Drop. Now to make a scheduled transaction you can just drag any 
transaction onto the “Scheduled Transactions” item in the source list. Want to add a 
category to a report? Just drag and drop it! Trying to reconcile a statement? Just drag 

and drop missing transactions into the statement until it is balanced.

Tax Support. Export your tax records to TurboTax and other tax software, plus assign 
tax numbers to your categories for easy tracking. 

Standard Reports. Easily compare assets and liabilities with a Balance Sheet or check 
the performance of your investments with Capital Gains and ROI Reports.

...and much more! Continue on to learn about getting started with iBank 3.
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How do I install iBank?

If you purchased iBank from our online store:

Download the iBank application from our website at: 1.	 http://www.iggsoftware.com/ibank/
downloads.php

Look for “iBank.dmg” on your Desktop or in your Downloads folder.  Double-click this file 2.	
to mount the “iBank” disk image on your Desktop.

The disk image should appear on your Desktop - it looks like an external drive icon with 3.	
the iBank logo on it.  Double-click the disk image to open it.

In the window that appears, you should see the iBank application, a Read Me, and some 4.	
other files. Drag and drop the iBank icon onto your Applications folder to copy the software 
to your computer. If you have a previous version of iBank installed, allow the computer to 
replace the existing application.

Close the disk image window, then drag both the “iBank” disk image and “iBank.dmg” from 5.	
your Desktop or Downloads folder to the Trash.

Open your Applications folder and drag “iBank” onto your Dock to keep it there for easy 6.	
access.

Click the iBank icon on your Dock to launch the software.7.	

If you purchased iBank from a retail store or Amazon.com:

Insert the iBank CD into your drive.1.	

http://www.iggsoftware.com/ibank/downloads.php
http://www.iggsoftware.com/ibank/downloads.php
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The CD should appear on your Desktop - double-click the CD icon to open it.2.	

In the window that appears, you should see the iBank application, a Read Me, and some 3.	
other files. Drag and drop the iBank icon onto your Applications folder to copy the software 
to your computer. If you have a previous version of iBank installed, allow the computer to 
replace the existing application.

Close the CD window, then drag both the CD icon from your Desktop to the Trash to eject 4.	
it.

Open your Applications folder and drag “iBank” onto your Dock to keep it there for easy 5.	
access.

Click the iBank icon on your Dock to launch the software.6.	

That should do it!  iBank should now be installed correctly on your computer.

Read on to learn about getting started with the iBank Setup Assistant.
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How do I use the iBank Setup Assistant?

Every time you launch iBank, the first thing you will see is a welcome screen provided by the 
Setup Assistant:
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On the left side you will see a list of new features in iBank 3; clicking a feature in this section 
will take you to our website, where you will find more information about what is new in version 
3.0. On the right side you will see options under three headings:

Getting Started

New Document: Click this option to have iBank guide you through the process of creating a 
new data file. Follow the prompts to choose a name and save location for your iBank data file. 
You will also be asked whether you want to add our default selection of categories for “Home” 
or “Business” to your data file; check one or both of these items to use them (categories can 
always be added, deleted, or modified later).

Upgrade: If you previously used iBank 1 or 2, click this option to convert your existing data for 
use with iBank 3. You will be presented with two options:

If you are upgrading from iBank 2, select your data file from the drop-down list provided, •	
and then click “Open Selected Document.” iBank will make a backup copy of your old data 
file (in the same location as the original) and convert the original for use with iBank 3. 
Once the file has been upgraded for use with iBank 3, it can no longer be opened by iBank 
2.
If you are upgrading from iBank 1, click the “Upgrade from Version 1” button. Follow the •	
prompts to choose a name and save location for your new iBank data file. You will also be 
asked whether you want to add our default selection of categories for “Home” or “Business” 
to your data file; check one or both of these items to use them (categories can always be 
added, deleted, or modified later). Once you have done this, iBank will prompt you import 
the iBank 1 data. Click “Begin Import” to start the process (What if I can’t?), then kick back 

http://www.iggsoftware.com
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or go out for a cup of coffee - depending on how much data you have, the import can take 
a while! Once the process has finished, click “Done” to begin using iBank.

Documentation

Quick Start Guide: Click this option to download a brief introductory tutorial from our website. 
The Quick Start Guide is a great starting point for first-time iBank users - it introduces iBank’s 
basic approach to financial management, defines some key terms, and walks you through the 
basic features of the program.

iBank Help: Click this option to open iBank Help, the program’s built-in documentation. Here 
you can search for answers to your questions, or browse through the various help categories 
for information on every aspect of the software. If you prefer a printable version of the docu-
mentation, feel free to download the iBank 3 Manual in PDF format from our website: http://
www.iggsoftware.com/ibank/downloads.php#manuals

Additional Support

User Forums: Click this option to visit our online discussion forums. Browse topics as a guest, 
or register an account to be able to contribute your opinion. The forums are a great first stop 
for unanswered questions about our software, listening to buzz about upcoming versions, and 
submitting requests for new features. Join our active online community of users!

IGG Website: Click this option to visit our company website, where you will find product 
updates, news and announcements, Dashboard widgets, and other extras, as well as general 
information about our team.

http://www.iggsoftware.com
http://www.iggsoftware.com/ibank/downloads.php#manuals
http://www.iggsoftware.com/ibank/downloads.php#manuals
http://www.iggsoftware.com/forums/
http://www.iggsoftware.com
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Disabling the Setup Assistant:

If you don’t want the Setup Assistant to appear every time you launch iBank, check “Do not 
show this at start up” and click “OK.” You can revisit the Setup Assistant at any time by choos-
ing Help>Open Setup Assistant.



15Chapter 1: Getting Started

How do I purchase and/or register iBank?

Each time you launch iBank in trial mode, you will be prompted to purchase the full version.
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If you are not ready to purchase yet, click “Use Demo” to continue using iBank in trial mode. 
The software will run unrestricted until one of your accounts reaches 50 transactions, after 
which the software will only run for 10 minutes at a time. The purchase box will appear each 
time you start iBank until you order a license code.

To purchase iBank:

If you have not already registered iBank, you will be prompted to purchase the program each 
time you start it. To purchase a license, click “Purchase Info” and then click “Continue Pur-
chase.” Our secure online purchase window will appear:
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The top-right corner of the window will show you the license you are about to order. If you 
previously had a registered copy of iBank 2 running on your computer, iBank 3 should recog-
nize this automatically and indicate that you are purchasing an upgrade license (at a discount!). 
If you are not a registered user of a previous iBank version, iBank 3 will indicate that you are 
purchasing a full license.

In the space provided, enter your name, email address, and credit card information. Once you 
have verified that everything has been entered correctly, click “Purchase” to connect to our 
online store and submit your order (you must be connected to the Internet to complete this 
step). Once the order has been accepted, iBank 3 will register itself automatically and cease 
to operate in trial mode. An alert will display your license code (it’s probably a good idea to 
write this down) and confirm that your order was processed successfully. You will also receive 
a confirmation email within 24 hours containing a receipt of your purchase and a copy of your 
license code. Be sure to print a copy of this email and file it away for safe keeping!

	 If you prefer not to purchase iBank directly through the software, if you have problems 
with the built-in order form, or if you wish to purchase iBank together with our other 
software as part of a package deal, please visit our online order page: http://www.
iggsoftware.com/purchase

To register iBank with an existing code:

If you are reinstalling iBank, or you obtained a registration code from our online order page, 
click “Enter License” in the purchase window (choose iBank>License if you don’t see the pur-
chase window).

http://www.iggsoftware.com/purchase
http://www.iggsoftware.com/purchase
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Enter your name, email address, and registration code exactly as they appear in your confirma-
tion email, paying attention to capitalization and other such details (What if iBank doesn’t ac-
cept my code?). Upon successful entry of your registration info, the program’s trial limitations 
will be disabled and you will no longer be pestered to buy at startup.
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To verify your registration:

To review your registration information at any time, choose iBank>Registration Info. A window 
will appear displaying your registered name, email address, and license code. If you do not see 
“Registration Info” in the iBank menu, but instead see “License,” then your copy of iBank has 
not yet been registered.
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How do I manage data files in iBank?

An iBank data file contains all of the financial information that you will use when working with 
iBank. This typically includes accounts and their transactions, categories, memorized transac-
tions, scheduled transactions, import settings, charts, budgets, and forecasts. Storing all of 
this information in a single file allows for greater portability as well as easier backups.

In the Finder, an iBank data file looks like this: 

To create a new data file:

Choose File>New iBank Document. A blank window will appear to which you can add accounts 
and other information. When you try to close the window or quit iBank, you will be asked to 
choose a name and save location for the data file. Alternatively, you can use the Setup Assis-
tant to help you create a new data file and add some default categories.

To open an existing data file:

Choose File>Open and select a valid iBank 3 document, or double-click the data file in the 
Finder. You can open iBank 2 documents as well, but iBank 3 must first convert your data for 
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use with the new version. A backup of your iBank 2 file will be created automatically in the 
same location as the original file.

iBank will remember the last several data files you opened under File>Open Recent. You can 
clear this menu by choosing File>Open Recent>Clear Menu. When you launch iBank, it will 
automatically show the last data file that was opened. To override this, hold down the Option 
key as iBank is starting up.

Using mutiple data files:

You can have multiple iBank documents open at one time, but most information cannot be 
transferred between them. Transactions can be moved from one data file to another using copy 
& paste. You may want to create a separate data file for accounts you don’t use anymore, or 
you may want to keep separate documents for you and your spouse. In most cases, however, 
only one iBank document is necessary for tracking your own finances.

To save changes to a data file:

After adding transactions or making other changes to a data file, save those changes by 
choosing File>Save. iBank automatically saves your data every three minutes, when you close 
the data file, and when you quit iBank. If iBank is unable to save your changes for any reason, it 
will alert you to the error and advise you on how to fix the problem.
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To delete a data file:

Quit iBank and locate the data file on your hard drive. Drag it to the Trash to delete it. The next 
time you open iBank, you will need to open a different data file or create a new one.
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How do I use the main window?

The main window displaying your iBank data file appears like this:

The numbers on the image above correspond to the following program areas:



Toolbar1.	 : Contains shortcuts to many program functions, including the search command. 

Source list2.	 : Your accounts are listed in the top half of the source list; other main program 
features are listed below. The window contents displayed to the right of the source list will 
change depending on your current selection. 

Mini-graph3.	 : Provides a quick snapshot of your recent expenses or a summary of your 
investment portfolio (depending on the current selection). 

Transaction view4.	 : Displays all transactions in the selected account. 

Transaction editor5.	 : A convenient way to edit the transactions displayed in the register 
above. Hide or show this pane by clicking the button at the bottom-right side of the win-
dow.

Many of these window panes can be resized by clicking and dragging the dividers between 
them. Below the transaction editor you will find several other buttons (including filtering op-
tions) that allow you to perform different actions depending on your current selection in the 
source list.
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How do I customize the toolbar?

To customize the toolbar (located across the top of the main iBank window) Control-click 
anywhere in the toolbar area and choose “Customize Toolbar” from the contextual menu (or 
choose View>Customize Toolbar). The sheet that appears will allow you to add or remove tool-
bar items via drag & drop, and choose how these items appear (e.g. whether to show text or 
what size icons to use). Click “Done” when you have finished customizing the toolbar.

You can show or hide the entire toolbar at any time by clicking the oval-shaped button  in 
the top right corner of the main iBank window or choosing View>Hide Toolbar (this is standard 
for most Mac OS X applications).
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How do I get started with iBank? (Quick basics)

To use iBank to track your finances, you will want to set up accounts for each “real-life” ac-
count you have. That is, you will want an account for each of your credit cards as well as 
checking, savings, and investment accounts. Then, for each account you will want to have 
a transaction for each “real-life” transaction that occurs in the account. For example, if you 
receive a bank statement that shows two trips to the ATM and one point-of-sale (aka debit) 
purchase, then you will want to enter three transactions in iBank to match those.

We have mentioned transactions a lot, and for good reason - they are the core “unit” in iBank 
for effectively tracking your money in each of your accounts. In iBank, each transaction that 
results in money being taken out of your account (e.g. a withdrawal) should have a nega-
tive value and each transaction that results in money going into your account (e.g. a deposit) 
should be positive. So far, if you do as suggested and record a transaction in iBank for each 
transaction that occurs in real-life, iBank will track, to the penny, exactly how much money you 
have in each of your accounts.

This should be reason enough to use iBank: to know exactly, at any minute, the balances of 
all of your accounts. However, the real power of iBank comes into play when you start tracking 
where you are spending your money. We’re not talking about entering a transaction for the 
amount of -$40.00 and making the where the payee “J.D. McCliments,” a local pub. Although 
this information is helpful, it would be better to categorize this transaction by associating it 
with a category like “Meals,” or “Dining.” iBank allows you to assign a category to each of your 
transactions. By assigning categories to transactions, you’ll be set up to run robust reports 
analyzing spending based on those categories. Categorizing your transactions will also allow 
you to set up budgets to help you plan ahead.
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In a lot of ways, you can think of categories as accounts, and you can think of a transac-
tion as always moving money from one account to another (fancy accountants will call this 
“double-entry bookkeeping”). So if you buy dinner on your checking account debit card, you 
are essentially moving money from the checking account and adding money to the “Dining” 
category-type account.

In summary:

•	  Accounts mirror your real-life bank accounts. 

•	  Transactions record deposits and withdrawals in your accounts. 

•	  Categories track where your money comes from and goes to. 

•	  Charts and reports allow you to quickly analyze your spending habits. 

Don’t forget - this is just an overview of iBank’s major features; much more awaits inside! 
Hopefully these principles and guidelines will help you get started tracking your money and 
spending with iBank. Read on for more detailed information about using iBank’s various fea-
tures.
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What are accounts all about?

 Accounts in iBank are designed to mirror your real-life bank accounts. They are the first 
thing you need to set up in iBank after creating a data file. All of your accounts are kept in the 
top half of the source list, which appears on the left side of the main window and looks like 
this:
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Accounts can be reordered by clicking and dragging them to different positions in the source 
list. Double-click an account to change its name. The balance of each account is displayed 
directly below the account name.

Overall totals:

The two amounts displayed at the bottom of the source list reflect the total value of cleared 
transactions and the total value of all transactions in those accounts that have been marked for 
inclusion in the totals.

	 Though each account displays a balance in its own currency, the overall totals automati-
cally convert amounts between currencies before summing them. The conversions are 
calculated using iBank’s current exchange rate information. Click the small double-
arrows next to the currency symbol by “Total value” to select which currency is used to 
display the overall totals.

View options:

You may choose whether to display large or small icons in the “Accounts” section of the source 

list. Choose iBank>Preferences, click the  Appearance button, and check “Use small size 
for source list items” if desired.
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How do I add and delete accounts?

The first thing to do with iBank after creating a data file is to set up your accounts. Start by 
creating an iBank account for each financial account you have in real life (e.g. checking, sav-
ings, credit card, investment). You may also want to add a cash account to keep track of the 
money in your pocket.

To create a new account:

Click the  Account button on the toolbar, or click the  button below the source list on 
the left. In the sheet that appears, choose the appropriate account type, then type in a name 
for the account and its starting and minimum balances:
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The starting balance should reflect the balance in the account at the time from which you wish 
to track your transactions with iBank. If you want to track records back to the opening of the 
account, enter “0.00” (or the amount of your initial deposit) as the account’s starting balance. If 
you only want to track records starting a week ago, enter the account balance as it was a week 
ago. For credit card accounts, the minimum balance should be negative to reflect that this type 
of account never (or rarely) carries a positive balance.

By default, iBank will input your currency information from System Preferences. If you want 
to use a different currency with the new account, choose one from the drop-down list. If the 
desired currency is not present, click the “Edit” button to configure the list of available curren-
cies. For more information about using iBank with multiple currencies, see the section about 
multiple currencies in this chapter.

When you are done, click “Create Account.” If you added a loan account, you will be presented 
with another sheet to configure loan options. Otherwise, the new account will be added to the 
source list. Select the account to view its contents in the right side of the main window. 

To delete an account:

Select the account in the source list and press the ‘Delete’ key on your keyboard, or choose 
Edit>Delete. A sheet will appear asking you to confirm that you want to permanently delete 
the account. All transactions contained within the account will also be deleted. Any transfers 
in the account will be deleted, but the transactions in other accounts to which those transfers 
are connected will not be deleted (they simply will no longer show the account in their category 
fields).
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How do I edit account information?

Select an account in the source list and choose View>Show Account Info. The account info 
pane will appear below the source list. Add information or make changes as appropriate:
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A few tips:

Be sure to set the correct minimum balance for the account, or else the account may ap-•	
pear with a warning badge  on its icon in the source list when it actually contains suf-
ficient funds.

If you fill in the URL field with your bank’s website, iBank can quickly open that website to •	
let you view your accounts online or download transaction updates. For more information, 
see the section on using the built-in web browser in Chapter 5: Importing Data. 

You can easily assign a URL to an account by dragging & dropping a “.webloc” file from the •	
Finder onto the account name in iBank. 

When you •	 import transactions, the “Last import” date is automatically updated to the date 
on which the import was performed. By adjusting this date manually, you can control 
which transactions are retrieved during a direct download operation (only transactions 
after the date specified will be downloaded).

Use the “Include in total” checkbox to mark whether or not an account’s balance should be •	
included in the total value amount below the source list. If an account is not marked to be 
included in the total, its balance in the source list is displayed in gray. 

“Is Loan Account”	is typically only used for loan accounts (as the name suggests), but can •	
sometimes be useful for tracking liabilities that include loan information (like a mortgage, 
for example).

Click the  button at the top right to close the account info pane.

To change an account’s starting balance, look for a transaction in the account’s register with 
“Starting Balance” listed as its payee and change its amount. If there is no such transaction, you 
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can add one manually - just enter “Starting Balance” as the payee, and make sure that its date 
precedes all other transaction dates in the account.

	 Account types cannot be changed. If you accidentally created an account with the wrong 
type, you will need to create a new account with the correct type. You can transfer your 
existing transactions from the old account to the new one using cut & paste.
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What are the different account types?

iBank offers a number of different types to choose from when creating an account. By selecting 
the appropriate types, your iBank accounts can be set up to mirror your real-life bank ac-
counts. Here is an overview of each type and what it is used for:

 Checking

Used to track deposits and withdrawals from a typical bank checking account.

 Savings

Used to track deposits and withdrawals from a typical bank savings account.

 Credit Card

Used to track charges made against a credit account. When using a credit card account, be 
sure to enter its starting balance as ‘0.00’ and set the minimum balance to reflect the card’s 
credit limit (as a negative number). Charges made to the account should be entered as negative 
transactions.
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 Investment

Used to track purchases and sales of stocks, bonds, and mutual funds, as well as other 
security-related transactions. Investment accounts should be set up to reflect your brokerage 
accounts. The balance of each investment account includes the cash value of the account in 
addition to the value of its securities. The Portfolio provides summary information about your 
holdings across all investment accounts, as well as gain/loss totals. For more information 
about tracking investments, see Chapter 6: Investments.

 Money Market

Used to track deposits and withdrawals from a typical bank money market account.

 Line of Credit

Used to track charges made against a line of credit. When using a line of credit account, be 
sure to enter its starting balance as ‘0.00’ and set the minimum balance to reflect the card’s 
credit limit (as a negative number). Charges made to the account should be entered as negative 
transactions.
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 Asset

Used to track the value of an object or money that is owed to you. For example, if you have 
paid off the mortgage on your house, an asset account can help you track any interest that you 
collect on your home value. When using an asset account, enter the base value of the asset into 
the starting balance, then enter any gains or earnings as positive transactions.

 Liability

Used to track debt or money owed for which you do not make regular payments. When using 
a liability account, be sure to enter the amount owed into the starting balance (as a negative 
number), then enter any payments made against the debt as positive transactions.

 Loan

Used to track loans for which you maintain a payment schedule. Typically, loan accounts 
should not be assigned a starting balance because the loan amount will be entered in the Loan 
Setup and Information sheet. Payments made towards the loan should be entered as positive 
transactions. For more information about configuring loan account options, see the section on 
managing loan payments later in this chapter.
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 Cash

Used to track the spending of cash you withdraw from a bank (or an account like cash advance 
from a Visa). Whenever you take cash out of an account (e.g. an ATM withdrawal), transfer the 
money to your newly created cash account. Then, whenever you spend your cash on some-
thing, create a transaction in the cash account for the appropriate amount and set the other 
attributes of the transaction as appropriate.
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How do I configure accounts for online access?

iBank 3 features the ability to connect directly to your financial institutions via the Internet 
and update your accounts automatically. Transactions are downloaded using Open Financial 
Exchange (OFX), which is not supported by all financial institutions (and some may charge a fee 
for this service). We do not guarantee online access for all accounts.

To configure an account for online access:

You must first select a financial instituion with which to connect your account. When you cre-
ate an account, iBank will initiate this process automatically. To enable access for an existing 
account, select the account in the source list, make sure you are connected to the Internet, and 
choose Account>Setup Online Account Access. iBank will update its list of supported financial 
institutions and then present a sheet displaying them.

Type the name of your financial institution in the search box at the top of the sheet to narrow 
down the list of available options. When you locate the correct institution, select it and click 
“Continue Setup.” You will then be asked for the username and password required to acces 
your account online. If you do not have or cannot remember the username and/or password, 
please contact your financial institution for assistance.
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If multiple accounts are available for download, you will be asked which one to use. Select the 
account that corresponds to the iBank account you are configuring. iBank will then attempt to 
connect to your financial institution. After establishing a successful connection, iBank will give 
you the option to “Download Transactions Now,” if you wish. Click this button to update your 
account, or else click “OK” to wait for another time.
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	 Transactions are downloaded using the Open Financial Exchange (OFX) protocol, which 
is not supported by all financial institutions (and some may charge a fee for this ser-
vice). We do not guarantee online access for all accounts.

To update your accounts automatically:

See the section on direct downloading in Chapter 5: Importing Data for more information.

To disable online access:

If you no longer want to use the online access feature with a particular account, select that 
account in the source list and choose Account>Disable Online Account Access. The account 
will no longer be configured for direct downloading. You may reestablish online access for that 
account at any time.
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How do I track scheduled loan payments?

In order to effectively manage loans and payments in iBank, first add a new account and 
choose the “Loan” type. After configuring the standard account options, enter all relevant in-
formation into the Loan Setup and Information sheet:
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To configure loan options:

Click the “Setup” tab in the Loan Setup and Information sheet, if it is not already selected. 
Configure the following options to match the details of your loan:

Name of lender:•	  The institution responsible for administering the loan and processing 
your payments.

Loan amount:•	  Total amount of money originally borrowed from the financial institution.

Interest rate:•	  If the loan has a fixed interest rate, enter it here as a percentage. If the rate 
is variable, check “Variable rate loan,” enter the appropriate number of payments in the 
“Rate changes after” field, and then click the “Details” button. A new sheet will appear 
displaying one line for each payment period - on the left is the total number of payments 
due in that period; on the right is the interest rate for that period. Double-click to edit 
either amount, and use the  and  buttons to add or remove payment periods. 
Make sure the total amount of payments is equal to the “Total # of payments” specified on 
the main Loan Setup and Information sheet.
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First payment date:•	  The date on which the first payment is due.

Payment frequency:•	  How often payment is required on the loan.

Total # of payments:•	  The total number of payments scheduled over the loan’s entire 
repayment plan.

Interest category:•	  Your loan payments will be tracked as split transactions, with one part 
of each going towards capital and the other going towards interest. Choose here the cate-
gory that you want to use to track the interest portion of each payment for charts, reports, 
and budgets.

Canadian loan:•	  By default, interest is compounded monthly. Check this option to have the 
interest compounded every 6 months (semi-annually) instead.

To view summary information about your loan payments:

Click the “Payment” tab in the Loan Setup and Information sheet:
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This sheet will show you an overview of your payment history, including the minimum payment 
amount, additional payments required with each payment (see below for more information), 
the total payment amount, and expected date for the entire loan to be paid off. Total interest 
and principal paid to date are displayed in the middle of the sheet, along with the number of 
payments made to date and total number remaining.
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	 Any transfer into a loan account will be considered a loan payment by iBank. If you are 
not using scheduled transactions to track your loan payments automatically, be sure to 
enter your loans as transfers from one or more other accounts into the loan account, or 
iBank will not count them in the payment summary shown above.

If your loan payments include additional fees, such as taxes or surcharges, click the  
button on this sheet to enter them. The following sheet will appear:

Click the  and  buttons to add and remove additional payments. Click the left side of 
each payment to choose a category to assign the payment to, and double-click the right side 
of each payment to enter the payment amount. click “OK” to return to the loan payment sum-
mary.
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To view your payment schedule:

Click the “Payoff Schedule” tab in the Loan Setup and Information sheet:

Here you will see a table displaying each payment with its scheduled due date, principal 
amount, interest rate, interest amount, and amount remaining to be paid on the original loan. 
As with any tabular view, click a column header to sort the list according to the values in that 
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column. Click a second time to reverse the direction of the sort. This table cannot be edited 
directly; to make adjustments to your payment schedule, edit the settings under the “Setup” 
tab.

	 Payments are shown here with their projected amounts based on minimum require-
ments. Once you have entered a payment, the actual amounts will be shown in the 
payoff schedule table instead of the projected amounts.

To save a copy of your payment schedule for reference, click the  button and choose 
a location to save the file. iBank will generate a text file in CSV format for easy viewing in Excel 
or any other spreadsheet software.

If you have configured your loan correctly, you should see that the remaining amount after the 
last payment is “0.00”. If there is still a remaining balance after the last payment, then check 
to make sure you have entered the correct total number of payments, and that the number 
of payments in the “Variable Interest Rate Setup” sheet adds up to match the total number of 
payments.

To automatically generate a scheduled payment for your loan:

Click the  button and choose from the drop-down list which 
account you will use to make the payments. iBank will take you to the Scheduled Transactions 
pane and automatically create a scheduled transaction for your loan payments based on the 
information you entered in the Loan Setup and Information sheet. The first posting date for 
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the scheduled transaction will be the due date you entered for the first payment. Subsequent 
transactions will be posted at the interval you specified.

	 iBank will only allow you to create one scheduled transaction for each loan account 
using the steps above. To generate a new scheduled payment from the Loan Setup and 
Information sheet, you must first delete the original payment from the scheduled trans-
action view.

When posted, the payment will appear as a split transaction: the capital amount will be trans-
ferred to the loan account, the interest will be allocated to your specified interest category, 
and each additional payment will be allocated to the categories you specified. The scheduled 
transaction can be edited at any time by clicking “Scheduled Transactions” in the source list.
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How do I use smart accounts?

 Smart accounts are special accounts that are used to dynamically group transactions 
based on criteria you specify. They do not necessarily reflect real-life bank accounts, rather 
they use customizable rules to compile and display transactions from multiple iBank accounts. 
Smart accounts work in very similar fashion to smart playlists in iTunes, or smart albums in 
iPhoto.

To create a smart account:

Choose Account>New Smart Account, or click the  button below the source list and 
choose “New Smart Account.” Using the sheet that appears, give the smart account a name, 
then click the  and  buttons, respectively, to add and remove the rules that will determine 
which transactions are displayed in the account:
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Smart account rules:

Any/All of the following are true:•	  If you choose “Any” as the option for this rule, all 
transactions that match at least one of your specified rules will be displayed in the smart 
account. If you choose “All,” only transactions that match all of the rules will be displayed. 
This rule cannot be removed.

Date:•	  Use one or more date rules to specify a timeframe for transactions to include. 

Transaction payee:•	  Use this rule to display transactions that include or exclude a specified 
payee.

Transaction memo:•	  Use this rule to display transactions that contain or do not contain a 
specified word or phrase in their memo fields.

Amount:•	  Use one or more amount rules to specify a range of values for transactions to 
include.

Category:•	  Use this rule to include or exclude transactions that are assigned to a specified 
category.

Account:•	  Use this rule to include or exclude transactions in a particular account.

Type:•	  use this rule to include or exclude transactions of a specified type.

Rules are executed in the order in which they appear. To illustrate, the example above will first 
look at transactions in the account “Checking,” then it will narrow those down to ones that are 
dated after June 9, 2007, then it will eliminate any dated after December 9, 2007, and finally it 
will only display those remaining that have the word “automatic” in their memo field.
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When you are done configuring the smart account rules, click “OK” to add the new smart ac-
count to the source list. The account will dynamically update to show you all transactions that 
match the rules you defined when the account was created.

Smart accounts and transactions:

Smart accounts allow you to view transactions only; they do not permit you to add, remove, or 
edit transactions. To make changes to transactions shown in a smart account, you must first 
locate the transactions in their original accounts and then modify them. Smart accounts cannot 
be used in charts and reports, budgets, or forecasts, nor do they affect the totals displayed at 
the bottom of the source list.

Editing smart accounts:

To edit the rules for an existing smart account, select it in the source list and choose 
Account>Edit Smart Account. Any changes made to the smart account criteria will immediately 
take effect when you click “OK.”

To delete a smart account:

Select the account in the source list and press the ‘Delete’ key on your keyboard, or choose 
Edit>Delete. A sheet will appear asking you to confirm that you want to permanently delete the 
account. The transactions displayed in the smart account will not be affected.
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How do I group accounts?

 Account groups can be created to organize your accounts hierarchically.

To create an account group:

Choose Account>New Account Group, or click the  button below the source list and 
choose “New Account Group.” Enter a name for the group in the sheet that appears and click 
“Create Account Group” to add it to the source list. Use drag & drop to move accounts in and 
out of the group. Click the small disclosure triangle next to the group’s icon to hide or display 
the accounts within.

The amount that displays below the group’s name represents the total balance of all the ac-
counts within. Selecting the account group itself will display transactions from all the enclosed 
accounts in the transaction view to the right. Transactions cannot be added or removed when a 
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group is selected, but any changes made in list view will be applied to the transactions in their 
original accounts.

	 When accounts using different currencies are added to a group, the total balance dis-
played for the group will use the currency selected at the bottom of the source list. In 
that case, the balances of the accounts inside the group will be automatically converted 
using the exchange rates in the Currencies sheet.

To delete an account group:

Select the group in the source list and press the ‘Delete’ key on your keyboard, or choose 
Edit>Delete. A sheet will appear asking you to confirm that you want to permanently delete the 
group. All accounts contained within the group will also be deleted. To remove accounts from 
the group before deleting it, drag and drop them to another location in the source list.
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How do I hide unused accounts?

If you have old or unused accounts in iBank that you no longer want cluttering up your source 
list, but you don’t want to delete them entirely, you can easily hide them from view. Choose 
Account>Show Account Manager and the following sheet will appear:

Check the box next to any accounts you want to hide, and they will no longer appear in the 
source list. The balances of hidden accounts will not be counted in the totals displayed below 
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the source list. Uncheck an account in the Account Manager to show it in the source list again. 
You can return to the Account Manager at any time to show and hide your accounts.
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How do I manage accounts in multiple currencies?

One of iBank’s more advanced features is the ability to manage accounts in different currencies 
and track exchange rates automatically. By default, iBank sets your main currency to match 
the one you have specified in System Preferences, under the “Formats” tab in the International 
pane:
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To add or edit the list of currencies available in iBank:

Choose Account>Show Currencies to view the Currencies sheet:

Click the  button to add a new currency to the list. Double-click the currency’s 
name, code, and symbol to edit each one:

Name:•	  Enter the full name of the currency for easy reference. This name is displayed in the 
drop-down menu shown when you are creating new accounts.

Code:•	  Enter the Alpha-3 code used to identify the currency on the market. It is important 
that you enter a valid code here, or iBank will not be able to retrieve exchange rates au-
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tomatically for that currency. To view a complete list of supported currency codes, visit 
Yahoo! Finance online at http://finance.yahoo.com.

Symbol:•	  Enter the symbol typically used with values displayed in this currency. Currency 
symbols appear in various places throughout iBank, including the drop-down menu next 
to the overall account totals shown below the source list.

To update the exchange rates for your currencies:

First, make sure you are connected to the Internet. Choose Account>Download Exchange 
Rates, or open the Currencies sheet and click the  button. iBank will con-
nect to Yahoo! Finance and download updated exchange rate information automatically.

To view the exchange rate for a particular currency, click the arrows in that currency’s “Com-
pare To” column (in the Currencies sheet) and select the currency you want to compare it to. 
The exchange rate will be shown in the “Rate” column, and should be interpreted from left 
to right. Using the example of the first line in the Currencies sheet shown above, the correct 
interpretation would be, “1 British Pound is currently valued at 1.36 Euros.” Be sure to update 
your currency exchange rates frequently!

To remove a currency from iBank:

Choose Account>Show Currencies to open the Currencies sheet, select the currency you want 
to remove, and click the  button. You cannot delete any currency that has been 
assigned to an account.

http://finance.yahoo.com
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To specify which currency to use with a particular account:

Each iBank account can be assigned a single currency. Assign a currency to a new account by 
selecting it from the “Currency” menu in the “Create New Account” sheet. Click the “Edit” but-
ton as a shortcut to show the Currencies sheet.

You can change the currency assigned to an existing account by selecting the account in the 
source list, choosing View>Show Account Info, and selecting a different currency from the 
“Currency” drop-down list.

Each account shows its balance in the source list in its own currency. The “Total value” figure 
automatically converts all account balances to a single currency (based on iBank’s current 
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exchange rates) before summing them. To select which currency to use for the total value 
display, click the arrows next to the currency symbol.

	 Smart accounts do not automatically convert between different currencies. Transactions 
in smart accounts will appear in their own currencies, but will be summed as if they 
were using the same currency. For that reason, it is best to limit your smart accounts to 
use only accounts with the same currency.

To apply an exchange rate to an individual transaction:

Each transaction has an exchange rate associated with it for when the transaction involves a 
change in currency. The exchange rate can be accessed in the transaction editor by clicking the 

 button to reveal additional options, then clicking  (if splits are currently 
showing):
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Click the  button to make changes to the transaction. The figure displayed to the 
right of the “Ex. rate” field is the “base amount,” which represents the transaction amount in 
whatever currency the transaction was originally conducted. The transaction’s resulting amount 
is equal to the base amount times the exchange rate you enter.

To enter or adjust the exchange rate applied to a transaction, first click the currency symbol 
next to the base rate and choose the currency in which the transaction was conducted. You can 
then enter any two of these three figures: base amount, exchange rate, and resulting amount. 
iBank will calculate the third figure based on the two you enter. An exchange rate of “1.000” 
indicates that no exchange has been made; the resulting amount of the transaction is equal to 
its base amount.
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Transferring money between accounts with different currencies:

To record a transfer that involves a currency conversion, simply add a transfer transaction 
to the account from which the money is being withdrawn (entering the transaction amount 
in that account’s currency), then edit the transaction in the receiving account and change its 
amount to reflect the currency of that account. iBank will automatically calculate the exchange 
rate based on the ratio of the two amounts, and display this figure in the “Ex. rate” field in the 
transaction editor. When transferring funds between accounts, you cannot edit the exchange 
rate directly.

To view the exchange rate, click the  button to reveal additional options, then click 
 (if splits are currently showing):

The figure displayed to the right of the “Ex. rate” field represents the “base amount” of the 
transaction: this is equal to the original amount entered for the transaction, and is displayed 
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in the currency of its original account regardless of which side of the transfer you are currently 
viewing. The exchange rate is displayed in the “Ex. rate” field. An exchange rate of “1.000” (on 
the receiving end of the transfer) indicates that no exchange has been made; the two sides of 
the transfer are using the same currency.

About multiple currencies and other features:

	 The category list, smart accounts, charts, budgets, and forecasts do not automatically 
convert between currencies. Be careful when viewing totals that include transactions 
from accounts that use different currencies, as they will not be accurate. Each transac-
tion is counted in its own currency, and transactions that are added together are treated 
as if they were the same currency.

To avoid miscalculations based on multiple currencies when creating charts, be sure to only 
include accounts that use the same currency. Certain charts allow you specify a currency to 
use; this will simply filter out transactions from accounts in different currencies so that they 
will not be counted in the chart. Smart accounts let you add rules to filter their transactions 
based on account type.
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How can I export my data for use in other 
software?

If you want to be able to export transaction data from your accounts for archival purposes, or 
for use in another software package, iBank makes it easy. With just a couple of clicks you can 
save your data to a QIF file, which can be read by most financial applications.

To export data from a single account:

Select the account in the source list and choose File>Export. Enter a name and choose a loca-
tion in which to save the file, then click “Export” to complete the process.

To export all of your account data:

Choose File>Export, then check “Export all accounts.” Enter a name and choose a location in 
which to save the file, then click “Export” to complete the process.

For additional export options:

Quick Summary and Custom charts also provide export capabilities, which you can read about 
in the section pertaining to those charts in Chapter 7: Charts & Reports.
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What are transactions all about?

 Transactions are what iBank uses to store the bulk of your financial data. Transactions 
are kept under each account you set up, and are intented to represent deposits, withdrawals, 
transfers, and any other exchange of money that takes place in real life and would normally 
appear on a bank statement. Examples of transactions that can be tracked in iBank include a 
visit to the ATM for $40 or using a debit card to purchase groceries.

When you select an account from the source list, your transactions will be displayed to the 
right. Depending on which button you currently have selected in the toolbar, one of three 
transaction views will appear:

List view:

Select the  button or choose View>As List to see the list view:

This view is designed to look similar to a check register that you might keep in your 
checkbook. In this view, transactions can be edited directly in the register by double-clicking, 
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or by using the transaction editor at the bottom of the list. Split transactions in list view display 
hierarchically; click the small disclosure triangle to the left of the Date to reveal a transaction’s 
split items.

To sort the transaction list, click a column header; the transactions will automatically sort 
according to the values in that column. For example, if you want to sort your transactions by 
date, click “Date.” Click the column header a second time to reverse the direction of the sort.

	 The balance column will always calculate its line items in chronological order, regardless 
of how your transactions are sorted. If you want the balance column to display in logical 
fashion, sort your transactions according to date.

To hide and show columns in the list view, click the  button to the right of the column head-
ers. A drop-down menu will appear showing all of the columns available; checked items are 
currently visible. Select an item from the menu to hide or show that column. To adjust the line 

height of list view transactions, choose iBank>Preferences and click the  Appearance 
button. Drag the slider to set the height of the rows in the account register (ranging from 16 to 
32 pixels).

Transactions in list view are displayed with a background color or highlight based on the cat-
egories you have assigned to them. If you don’t want iBank to display these background colors 

in list view, choose iBank>Preferences, click the  Appearance button, and check the “Hide 
category background colors” option. Here you can also change the colors of positive and nega-
tive amounts: click the colored box next to “Positive” or “Negative,” respectively, to choose a 
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new color for positive or negative transaction amounts. The selected colors will display under 
the Amount column in the transaction list only.

Cover flow view:

Select the  button or choose View>As Cover Flow to see the cover flow view:

This view works in similar fashion to Cover Flow in iTunes or the Finder. Transactions are rep-
resented by the images assigned to them, or by the images assigned to their categories, and 
arranged in chronological order from left to right. Click on an image to bring that transaction 
to the front and view more information about it, or use the left and right arrow keys on your 
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keyboard to browse back and forth. You can also click and drag the small blue dot appearing 
below the transactions to browse left and right.

Below the transactions is a line graph representing the overall account balance as it is affected 
by each transaction. The graph appears in green as long as the balance is above the minimum 
balance specified for that account; it appears in red when the balance goes below the mini-
mum. Transactions in cover flow view can only be edited using the transaction editor.

Thumbnail view:

Select the  button or choose View>As Thumbnail to see the thumbnail view:
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This view is similar to the list view, but leaves more space to display the image associated 
with each transaction (or its assigned category). Split transactions in this view do not appear 
as separate line items, but instead display all split items within the same line. Transactions in 
thumbnail view can only be edited using the transaction editor. The thumbnail view cannot be 
sorted directly, but it will follow the same sort order specified in the list view.
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How do I add, delete, and edit transactions?

To add a transaction:

Select an account from the source list, then click the  button at the bottom of the main 
window. A new transaction will appear in the selected account’s transaction view, and the 
“Payee” field will be highlighted in the transaction editor so that you can begin entering infor-
mation for that transaction.

To delete a transaction:

Click to select the transaction in the transaction view (or Command-click to select multiple 
transactions in list view), then click the  button at the bottom of the main window or 
press the ‘Delete’ key on your keyboard. iBank will ask you to confirm that you want to delete 
the transaction before removing it.

	 You can disable the confirmation alert if you don’t need the extra protection. To restore 
this and other warnings after disabling them, choose iBank>Preferences and click the 

 button.

To edit a transaction:

Use the transaction editor, which you will find below the transaction view:
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The transaction editor displays detailed information about whichever transaction is currently 
selected in the register. It provides a simple check-like interface for entering or modfying that 
information. You can show or hide the transaction editor at any time by clicking the  but-
ton at the bottom of the main window, or by choosing View>Toggle Transaction Editor.

To make changes to the currently selected transaction, click the  button and 
click “OK” to enable the transaction editor.

	 You can disable the confirmation alert if you don’t need the extra protection. To restore 
this and other warnings after disabling them, choose iBank>Preferences and click the 

 button.



80 Chapter 3: Transactions

You can now use the transaction editor to make changes to the various transaction properties 
(see the next section for information about specific properties). Once the transaction editor has 
been enabled, you are not permitted to do anything else in iBank until you save your changes 
by clicking “Save” or discard them by clicking “Cancel.” You can also press the ‘Enter’ key on 
your keyboard to save any changes made in the transaction editor.

Additional information about the transaction can be viewed by clicking the  button (and 
 if splits are currently showing):

Initially, the “Security and Other Info” section will be displayed. Here you can edit details for 
investment transactions, view exchange rates, and change the time associated with transac-
tions.

To view the split items associated with a transaction, click :
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Here you can add, remove, and modify items that are part of split transactions. For more infor-
mation about splits, see the section on split transactions later in this chapter.

Editing in list view:

Alternatively, if you have your transactions displayed in list view and prefer not to use the 
transaction editor, double-click one of the transaction’s fields in the list to type information 
directly into that field:

Click the double-arrows in the Type, Payee, or Category field to select items from a drop-down 
list. The payee list is based on your Memorized Transactions.
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	 Power User Tip: To enter transactions as effeciently as possible, use the list view with 
the transaction editor hidden. You can add new transactions by typing Cmd-N on 
your keyboard, then use the Tab key to quickly cycle through each field and enter the 
transaction details. Changes will be saved as you go along, without any confirmation 
required.
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What properties do transactions have?

Transactions in regular accounts have the following properties that can be edited using either 
the account register or transaction editor. For a list of transaction properties pertaining to 
investment accounts, see the section about investment transaction properties in Chapter 6: 
Investments.

√ (Cleared)

The checkbox to the left of each transaction in list view and thumbnail view indicates whether 
or not the transaction has been”cleared” - that is, processed successfully and recorded by 
the bank. Any transactions that are downloaded from the bank or imported from a file are 
automatically checked, as iBank assumes they are coming from a verified source. Transactions 
that have not been checked appear in bold in the account register. Checked transactions are 
counted as part of the “Cleared value” as long as their accounts are marked for inclusion in 
that total.

	 Check or uncheck multiple transactions at once (in list view or thumbnail view) by using 
Command-click to select them, then choosing Transaction>Toggle Cleared. 

The “cleared” checkbox is disabled for any transactions that are considered “reconciled” - that 
is, transactions that have been added to your iBank statements. When a transaction appears on 
a statement, its checkbox is automatically checked and becomes disabled so that it cannot be 
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changed, either on the statement or in the account register. In order to uncheck a transaction 
once it has been reconciled, you must first remove the transaction from the statement to which 
it has been assigned. For an illustration of the difference between “cleared” and “reconciled,” 
please see this page in the FAQ.

Account

The account to which the transaction belongs. This column cannot be edited directly. For in-
formation about moving transactions between accounts, see the section later in this chapter.

	 This column appears automatically when viewing a smart account in list view. In other 
accounts it is disabled by default, but can be shown in list view by clicking the  but-
ton and checking the “Account” item.

Date

The date at which the transaction occurred, or the date at which the transaction was cleared 
with your bank. It is up you which you prefer to track - just remember to be consistent!

In the transaction editor, you can type in a date directly, click the  buttons to increment or 
decrement a number, or click the  button to use the pop-up calendar. When viewing the 
calendar, click the  and  buttons to choose a month, then click the number of the desired 
date. The  button can be used to return to whatever date is currently assigned to the trans-
action.
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The date cannot be hidden from the list view like the other properties. 

Type

The activity associated with the transaction, typically some variation of withdrawal (debit) or 
deposit (credit). Some transaction types have a value (positive or negative) assigned to them 
and will add or remove the minus sign on the transaction’s amount when selected. For a de-
scription of transaction types, see the section later in this chapter.

# (Check number)

The check number of the transaction - this only applies to transactions that have their type set 
to “Check.” This number will automatically increment based on the last number entered in that 
account, but can be changed manually.

Payee/Split Info

The name of the person or institution with whom the transaction was carried out (e.g. the 
name of the store where you purchased your groceries). iBank memorizes transactions that you 
enter based on their payee entries.



86 Chapter 3: Transactions

This field is also used to enter extra information about split items when using split transac-
tions.

Memo

Any notes or specific details pertaining to the transaction (e.g. a tracking number for the book 
you just ordered from Amazon.com).

Category

The category associated with the transaction for use in charts and budgets. For more detailed 
information about how to use categories, Chapter 4: Categories.

For transactions with their types set to “Transfer”, the category setting is used to specify the 
sending or receiving account. Accounts can be found at the bottom of the category list and are 
preceded by the ‘•’ character.

If the transaction is a split transaction, this field will automatically show “detailed.”

Amount

The monetary amount of the transaction: negative if it is a withdrawal (debit), positive if it is 
a deposit (credit). Certain transaction types will only allow positive or negative amounts to be 
entered.
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Balance

A running total of the account’s overall value, showing each transaction’s effect on the total. 
This field is automatically calculated by iBank and cannot be edited.

	 Entries in the balance column are always calculated in chronological order, regardless 
of the current sort order. If the numbers in this column don’t seem to be making sense, 
click the “Date” column header to make sure your transactions are sorted by date.

Image

A space for associating an image with a transaction (e.g. you could associate 
a PDF electronic receipt or a picture of that newly purchased DVD player). 
For more information, see the section about adding images later in this 
chapter.

Security info

For information about the Symbol, Comm., Shares, and Price properties, see the section about 
investment transaction properties in Chapter 6: Investments.
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Exchange rate

For infomation about the Ex. rate property, see the section about multiple currencies in Chap-
ter 2: Accounts.

Time

The time at which the transaction occurred. This is stored together with the date in order to 
provide a means of sorting multiple transactions that occur on the same day. If you are not 
concerned with knowing the time at which your transactions occurred, just ignore this field - it 
will make sure that your transactions are kept in the order you entered them.



89Chapter 3: Transactions

How do I add images to my transactions?

Each transaction can be assigned its own image to be displayed in cover flow or thumbnail 
view. Take a picture of your brand new iMac for posterity, add photos of your friends to whom 
you owe money, or scan the receipt for that fancy jewelry you bought (just in case!). You can 
even add documents in PDF format.

To add an image to a transaction:

Select the transaction to which you wish to attach the image and click the 
 button in the transaction editor. On the left side of the edi-

tor, you will see the generic transaction image (unless you have chosen a 
category with an image, in which case you will see that category’s image 
displayed instead). Simply drag and drop an image file into this space to add 
it to the transaction. A copy of the image will be stored inside your iBank 
data file, so you can delete the original if desired.

If your Mac has a built-in iSight, or if you have another video camera attached to your com-
puter, click the  button to open the snapshot window. Here you can take a picture with your 
camera to associate with the transaction:
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Click the  button to take a picture, then 
use the slider to crop the snapshot to the ap-
propriate size. Click “Recent Pictures” to select 
a snapshot you have previously taken, or click 
the “Choose” button to select an existing 
image file. Once you have the image prepared 
the way you want it, click the “Set” button to 
assign it to the transaction.

	 Images added through the snap-
shot window will be automatically 
reversed (like in a mirror) so that if 
you take a picture of a receipt, for 
instance, it will be displayed cor-
rectly in the transaction view.
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To view the image associated with a transaction:

Once you have added an image to a transaction, it will automatically be displayed with that 
transaction in the cover flow and thumbnail views. You can also view your images in list view 
by clicking the  button and checking “Images.” Click the  button below the image in the 
transaction editor to open a window showing the image at full-size (you do not need to be 
editing the transaction to do this).

To copy an image from one transaction to another:

Select the transaction with the image you want to copy. Click the  button in the 
transaction editor, click the transaction’s image to select it, and choose Edit>Copy. Click “Can-
cel” to leave editing mode, then select the transaction that you want to give the new image. 
Open the transaction for editing, click to select its image, and choose Edit>Paste. The image 
you copied will be added to the current transaction.

To remove an image from a transaction:

Select the transaction with the image you want to remove, click the  button in 
the transaction editor, and click the  button below the image. The image will revert to the 
default transaction image, or to the image associated with the transaction’s category.
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What are the different transaction types?

Here you will find a list of the various types that can be assigned to transactions in iBank. The 
definitions provided are relatively loose; although some types force transaction amounts to be 
either positive or negative, the differences between types are for the most part nominal. Please 
feel free to use your own discretion in choosing the appropriate type for a particular transac-
tion.

Standard account transaction types:

ATM - money withdrawn at an ATM •	

Charge - money withdrawn by a credit or debit card •	

Check - money withdrawn by check •	

Deposit - money added by any method •	

Online - money withdrawn through online banking •	

POS - money withdrawn through point-of-sale transaction (usually debit card) •	

Transfer - money moved from one account to another (for more information about •	 account 
transfers, see the next section in this chapter)

Withdrawal - money taken out by any method •	

Investment account transaction types:

Buy - money withdrawn to purchase shares •	
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Buy to Close - money withdrawn to close out a position on a stock option opened with •	
“Sell to Open” 

Buy to Open - money withdrawn to purchase a stock option put or call (i.e. open a long •	
position)

Dividend - interest deposited back into the account, whether in cash or shares (for cash •	
dividends, enter the symbol and amount; for reinvested dividends, enter the symbol and 
number of shares) 

Move Shares - •	 securities transferred between brokerage accounts, or received as a gift 
or inheritance (the price entered for this transaction will not affect the cash value of your 
investment account, but will be counted in the security’s cost basis) 

Sell - money deposited as a result of selling shares •	

Sell to Close - money deposited to close out a position on a stock option opened with “Buy •	
to Open” 

Sell to Open - money deposited to write/sell a stock option put or call (i.e. open a short •	
position) 

Split - stock split (enter the number of •	 shares gained as a result of the split; in the case of 
a reverse split, enter the number of shares lost as a negative number)
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How do I transfer funds between accounts?

When you want to move money from one account to another, use a transfer transaction:

Create a transactio•	 n and set its type to “Transfer.” Enter the date, payee, memo, and 
amount of money to be transfered.

Click the arrow in the •	 category field, scroll to the bottom of the drop-down list, and look 
for the name of the account to which you want to transfer the money. The account will 
have a ‘•’ symbol before its name, indicating that it is available as a destination account 
for a transfer. 

A new transaction will automatically appear in the account to which you are transfering the •	
money, with the same transaction details as the original (except for the amount, which will 
be opposite to the original). 

The two transactions are now linked: •	 changing the details of one will update the other 
automatically and deleting one will delete the other. There are two exceptions to this rule, 
however: each side of the transaction can be cleared and reconciled separately, and the 
amounts can be changed independently to indicate a currency conversion.

	 Transfer transactions use the category field to indicate the destination account for the 
transfer. If the category for a particular transaction begins with the ‘•’ character, it is a 
transfer. These “categories” are considered a special case and are not displayed in the 
main category list, but can be used in charts, budgets and smart accounts like other 
categories.
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How do I move a transaction from one account to 
another?

To move transactions beteween accounts:

Select a transaction in the any account (or Command-click to select more than one, in list 
view), then choose Edit>Cut. Select the account to which you want to move the transaction(s) 
and choose Edit>Paste. The transaction(s) will be removed from the original account and added 
to the selected account.
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How do I search my accounts or filter the 
transaction view?

To search for a particular transaction:

Click in the search box on the toolbar, or choose View>Select Search Field:

Type in a word or phrase. Every transaction that matches the word or phrase you typed will 
be displayed in the transaction view. A toolbar with additional search options will also appear 
across the top of the transaction view:

By clicking the various buttons on this bar, you can choose whether to search all accounts or 
only the selected account; and whether to search for matches in the payee, memo, amount, 
and/or category fields.
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	 The figure displayed at the bottom-right corner of the main window  
is the total amount of all visible transactions. This figure is not 
equal to the account balance! It updates automatically to 
reflect the total of the transactions displayed as your search results.

To cancel the search and show all transactions in the account, click the  button inside the 
search box.

To filter your transactions:

Click one of these three buttons at the bottom of the main window: 

All:•	  show all transactions in the selected account(s). 

This Year:•	  show only transactions in the selected account(s) with a date in the current 
year. 

Recent:•	  show only transactions in the selected account(s) with a date in the time period 
specified in iBank>Preferences under the 

 
General pane.

You can also access these filter options by choosing View>Show Transactions.

	 The figure displayed at the bottom-right corner of the main window  
is the total amount of all visible transactions. This figure is not 
equal to the account balance! It updates automatically based 
on the account you have selected and the filter option you have chosen.
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Can iBank remember transactions I enter more 
than once?

 Memorized transactions are used to help you enter repeated transactions more quickly, so 
you can work more efficiently.

Each time you enter a transaction, iBank automatically memorizes its type, payee, category, 
and amount. The next time you start typing a payee name into a new transaction, iBank will 
suggest payees based on those it has remembered; pressing ‘Tab’ or ‘Return’ on your key-
board will accept the suggestion and automatically fill in the rest of the transaction details.

To force iBank to memorize a transaction, select it in the transaction view (Command-click to 
select multiple transactions in list view) and choose Transaction>Memorize Selected Transac-
tions.

To view memorized transactions:

iBank maintains a list of all the transactions it has memorized under “Memorized Transactions” 
in the source list. Select this item to view all of the transactions that iBank currently has stored 
in its memory:
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To add a memorized transaction:

Most of the time, you won’t need to add transactions to iBank’s memory yourself. If you want 
to enter one manually, click the  button at the bottom of the screen, then edit the details 
of the new transaction that appears.
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To edit a memorized transaction:

Double-click the field you want to edit in the memorized transaction list and type in the value 
you want to be memorized. You can also click the small double-arrows to select the transac-
tion type or category using a drop-down menu.

To delete a memorized transaction:

Select the transaction in the memorized transaction list, then click the  button at the 
bottom of the screen to remove it. iBank will no longer suggest the details from that item when 
you create a new transaction.
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How do I use split transactions?

iBank allows you to categorize transactions for charts and budgets, but what happens when a 
single transaction needs to be broken down and assigned to multiple categories? For example, 
let’s say that you go to the grocery store and spent $50, but you only spent $30 on groceries - 
the other $20 was spent on pet supplies. How do you enter this into iBank without creating two 
separate transactions?

Split transactions allow you to itemize your transactions so that categories can be assigned 
to smaller parts of those transactions. You can schedule split transactions, but iBank cannot 
memorize them like other transactions.

To create a split transaction:

Select one of your accounts and create a new transaction. In the transaction editor, enter a 
date, transaction type, payee, and memo as desired. Enter the total amount of the transaction 
in the amount field, then click the  button to reveal more options in the transaction editor. 
Click the  button if the split information is not already showing:
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	 You must always enter an amount into the main transaction before specifying amounts 
for split items. iBank cannot calculate the amount of the main transaction based on split 
amounts.

The split information table is currently empty, because you have not yet added any splits. Click 
the  button to split the transaction; its category will change to “detailed”, and two blank 
split items will appear in the splits table (unless you had a category assigned to the transaction 
before splitting it, in which case one of the splits will be given that category automatically):
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For each split item, double-click the various fields to enter a category, memo, and amount for 
that item (you can also click the double-arrows in the category field to select one from a drop-
down list). When you change the amount of one split item, iBank will automatically adjust the 
amount of the other split item to compensate; the total of the split items must always be equal 
to the amount of the main transaction. Note that iBank will not adjust amounts for splits that 
you have already assigned categories to - if necessary, iBank may create an additional split 
item to balance the total.

	 It is important that you assign a category to a split item before changing its amount. 
Having a category specified lets iBank know that it should not automatically adjust that 
split item to balance the transaction.
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Following our above example, let’s split this transaction into two parts: $30 for groceries and 
$20 for pet supplies. We already split the transaction, so next we assign the category “Grocer-
ies” to one split item. Its amount started at -50.00, so we change it to -30.00. Notice that the 
other split item automatically changes to -20.00 to balance the transaction:

Now the only thing that remains is to assign a category to the second split. Since no category 
for “Pet Supplies” currently exists, we’ll double-click the category field for that split item and 
type in “Pet Supplies” followed by the Return key:
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That’s it! Now we click the “Save” button to save our changes, and the split transaction is com-
plete. Each split item has been assigned its own category, so the spending can be tracked more 
accurately with charts and budgets.

	 When entering the amount for a split item, iBank will initially force the amount to be 
negative if the item was assigned an expense category or positive if the item was as-
signed an income category. If you want to change the sign, simply correct the amount 
and enter it a second time - iBank will accept it this time.

As an alternative method of entry, you can select a transaction in list view and click the  
button at the bottom of the main window to split the transaction. The split items will appear 
and can be edited directly in the transaction list.
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To add additional split items:

Click the  button for each item you want to add to the table.

To delete a split item:

Select the item you want to remove, then click the  button at the bottom of the table to 
remove it. iBank will automatically adjust one of your uncategorized split items to balance the 
transaction, or add a new split item if necessary.

To view your split transactions:

Split transactions appear differently depending on which transaction view you are using.

List view

In list view, a small disclosure triangle appears to the left of the transaction, which you can 
click to reveal the split items:

Note that any memos entered for the split items are displayed under the “Payee/Split Info” 
column in list view.
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Thumbnail view

In thumbnail view, the splits appear in gray underneath the main transaction information:

Cover flow view

In cover flow view, the splits are not shown. The category “detailed” is displayed to indicate 
that there are split items associated with the transaction:
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To record a paycheck:

Create a transaction in the account where your paycheck is being deposited, and set its 1.	
amount equal to your net pay.

Split the transaction and edit the first item to give it an amount equal to your gross pay. 2.	
Assign it to the “Salary” category, or whatever category you prefer to use for tracking your 
income.

Add a split item for each deduction that is taken out of your pay. Each one should be as-3.	
signed to the appropriate category and have its amount recorded as a negative number. 
Transfers to other accounts (e.g. 401k contributions) can be recorded by specifying the 
name of the destination account in the split item category field.

Once you have configured all of the split items, they should balance out to the amount of your 
net pay. You will then be able to use charts and reports to analyze the categories you assigned 
to your deductions and see how much has been taken out of your paychecks over time.
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How do I schedule recurring transactions?

 Scheduled transactions can be created to track financial activities that occur on a repeat-
ing basis, for example a monthly mortgage payment or biweekly paycheck.

To add a scheduled transaction:

Select “Scheduled Transactions” in the source list and click the  button at the bottom of 
the main window. A blank transaction will appear in the scheduled transaction list. Alternative-
ly, drag and drop a transaction from any transaction view onto the “Scheduled Transactions” 
item in the source list to create a scheduled transaction based on that transaction.

To delete a scheduled transaction:

Select it in the scheduled transaction list and click the  button at the bottom of the main 
window, or press the ‘Delete’ key on your keyboard.

To edit a scheduled transaction:

Select it in the scheduled transaction list. Using the transaction editor, choose the account to 
which the transaction should be added, then configure the other transaction properties just 
like you would for any normal transaction.
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Be sure to enter the date on which the transaction should be posted to the account. Under 
“Other info” (click the  button if necessary), choose a frequency to specify 
how often the transaction should repeat (use “Once” if the transaction should only be posted a 
single time). Below the frequency setting, enter the number of times you wish the transaction 
to be posted, or choose “Unlimited” to have it repeat indefinitely.
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	 You can also schedule split transactions (to track itemized deductions on a paycheck, 
for example). Use the  button in the transaction editor to view the 
splits table and edit split items just as you would in the transaction view.

To set a reminder:

If you would like iBank to notify you before the scheduled transaction is posted, click “Remind-
ers: Always” in the transaction editor. If a transaction is pending when iBank is launched, the 
following sheet will appear:

Click “  Post Transaction” to post the selected transaction to its specified account, or click 
“Skip Transaction” to leave the transaction pending. You will be notified again the next time 
you launch iBank. Click “Done” to dismiss the sheet and continue using iBank.
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If you prefer not to set a reminder on the scheduled transaction, click “Reminders: Never” in 
the transaction editor. iBank will automatically post the transaction to its specified account at 
the specified date and time without notifying you.

To create an iCal event:

Check the “Add next transaction to iCal” box in the transaction editor and choose a calendar 
from the drop-down list. An event named after the transaction’s payee and amount will be 
created in the selected iCal calendar on the time and date specified.

Scheduled transaction status:

Each scheduled transaction has a status icon displayed next to it, in the ‘!’ column:

 Scheduled: the transaction is ready to be posted at a future time/date.

 Pending: the transaction has passed its posting time/date and is waiting to be posted.

To post a scheduled transaction ahead of its posting date:

Select the scheduled transaction in the list and click the  button at the bottom 
of the main window. The transaction will immediately be posted to the specified account with 
its date set to the original posting date (in the future). The scheduled transaction will incre-
ment itself to prepare for the next posting date.
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How do I reconcile my account with a bank 
statement?

If you are in the habit of comparing your records to your bank’s on a regular basis, iBank 
makes it easy to track the monthly statements your bank sends in the mail. Create a virtual 
statement in iBank to mirror the printed copy your financial institution sends in the mail.

To create a new statement:

When you receive a statement from your financial institution, launch iBank, select the iBank 
account you want to reconcile, and choose Account>Reconcile with Bank Statement to create a 
new virtual statement. The following sheet will appear:
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Enter a name for the statement that can be used to help distinguish it from others, then type 
in the starting and ending balance as indicated on your printed statement. Type in the first and 
last dates that appear on the statement.

	 When reconciling credit card accounts, be sure to enter both the starting and ending 
balance amounts as negative numbers. 

Click “OK” when you are finished. You will notice that a new 
item,  Statements, has been added to the source list under 
your account (click the small disclosure triangle next to the 
account name if you don’t see it):
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On the right side of the main window you will see the statement view:

The left side of the statement view displays a list of all the statements you have saved under 
the current account. The top-right side shows all transactions associated with the selected 
statement; this section is automatically populated with any cleared transactions that fall inside 
the date range you specified when creating the statement. The bottom-right side of the state-
ment view shows all transactions that have not yet been added to any statement.
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	 By default, new statements automatically reconcile any cleared transactions that fall 
within their date ranges. To change this, choose iBank > Preferences and click the  

 Advanced button. In addition to the default setting, you can choose to have iBank 
automatically reconcile all transactions within the statements’ date ranges, or disable 
this feature so that new statements always start out blank.

To reconcile a statement:

Any transactions appearing in the top-right section of the statement view are considered “rec-
onciled.” To make adjustments to the current statement, add and remove transactions until the 
list matches the list of transactions on the printed statement from your financial institution.

Adding transactions

Sometimes transactions must be carried over from one statement period to the next, for ex-
ample when you write a check that is not cashed until the following month. When reconciling 
a statement in iBank, these “carry-overs” appear in the “Unreconciled Transactions” section at 
the bottom-right side of the statement view. To add a transaction appearing in this section to 
the current statement, simply drag and drop it into the section above with your other transac-
tions. It will automatically be marked as “cleared” and counted towards your reconciled balance 
for that statement.

You can add new transactions directly in the statement view by clicking the  button at the 
bottom of the transaction list, but you must return to the account register if you want to delete 
any transactions permanently.
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Editing transactions

If you need to make adjustments to a transaction, simply double-click the field you want to 
change. Keep in mind that any changes made in the statement view affect the original transac-
tions in your accounts, so be sure to double-check any adjustments you make.

Removing transactions

To remove a transaction that doesn’t belong on the current statement, select it and click the 

 button at the bottom of the transaction list - this will cause it to be sent back to the 
“Unreconciled Transactions” section, where it will be available for use on other statements. 
Transactions removed from statements will remain “cleared” but no longer be considered “rec-
onciled.”

	 Any given transaction can only be included on one statement at a time. If a transaction 
appears in the top-right side of one statement but you need it to appear on a differ-
ent statement, you must remove it from the statement it is currently on. You can then 
switch to the correct statement and drag & drop the transaction from the “Unreconciled 
Transactions” section to the top-right side where it belongs.

Comparing statement totals

To help you complete the statement reconciliation, iBank displays three figures that automati-
cally update as you add and remove transactions:
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Statement Total:•	  The target amount to be reached when reconciling is complete. This 
figure is equal to the difference between the “Starting Balance” and “Ending Balance” speci-
fied when the statement was first created.

Reconciled Balance:•	  The total value of all transactions included in the current statement.

Difference:•	  The statement total minus the reconciled balance. When reconciling is com-
plete and accurate, this number will equal ‘0.00.’

Check off transactions and make adjustments as necessary until the “Difference” reaches zero 
- then you have successfully reconciled the statement! iBank will place a green checkmark ( ) 
next to the statement’s name on the left, to show that it is balanced.

To adjust your account balance after reconciling:

Sometimes, after you have finished reconciling the transactions in iBank with those on your 
printed statement, a discrepancy may still exist between your reconciled balance and the end-
ing balance of your printed statement. If you check and double-check your records, and just 
can’t seem to find a transaction that was overlooked, you can enter a balance adjustment to 
sync up your records.

Click on your account in the source list to leave the statement view and return to the transac-
tion view. Choose Account>Adjust Balance, and the following sheet will appear:
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Enter the desired account balance and click “OK.” A transaction similar to this one will be 
added to the account:

If you return to the statement view and check off the “Balance adjust” transaction, your state-
ment should now be properly reconciled.

To edit statement settings:

If you make a mistake while setting up your statement in iBank, you can easily correct it. Select 
the statement in the statement view, then click the  button at the bottom of the list of 
statements (on the left side of the statement view). Make any changes necessary in the sheet 
that appears and click “OK”; the statement will refresh itself automatically and show you the 
updated list of transactions that belong to it.
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	 Changing the range of dates covered by a statement will never cause transactions to be 
removed from the statement. If you extend the date range, however, any unreconciled 
transactions within the new range will be added to the statement. 

To create additional statements:

Once you have created a statement under an account, you don’t have to choose 
Account>Reconcile with Bank Statement to create another one. Simply go to the statement 
view for that account and click the  button at the bottom of the list of statements to add 
a new one.

To delete a statement:

Under the account from which you want to delete the statement, select  Statements in the 
source list (click the small disclosure triangle next to the account to reveal this item if it is hid-
den) to bring up the statement view for that account. Select the statement you want to remove 
and click the  button at the bottom of the statement list to delete it.
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How do I use categories?

 Categories help you track where your money actually comes from and goes to, and enable 
you to use charts and budgets to manage your finances more effectively. Once you have cre-
ated accounts and added transactions, the real strength of iBank comes in assigning categories 
to those transactions. To do so, simply type or selecting it in the transaction’s category field.

iBank comes with default sets of “Home” and “Business” categories which you may have added 
when you set up your data file using the Setup Assistant, but you can customize iBank’s cat-
egories to your heart’s content.

To view the category list:

Click “Categories” in the source list. Two options are available for viewing your categories: list 
view and thumbnail view.

List view

Click the  button in the bottom-right corner of the main window to display your cat-
egories in list view:
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In this view, you can quickly see all of your categories organized by Name, Description, or 
other criteria - just click the header at the top of any column to sort the list according to the 
information in that column. Click a second time to reverse the direction of the sort. Categories 
that contain sub-categories will display small disclosure triangles next to their names in list 
view. Click one of these triangles to view that item’s sub-categories. For information about 
adding and deleting categories, see the next section in this chapter.
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Thumbnail view	

Click the  button in the bottom-right corner of the main window to display your cat-
egories in thumbnail view:

In this view, you can easily view and edit the images assigned to each category. Categories are 
displayed in alphabetical order from left to right, with each sub-category displayed in its own 
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box following the main category to which it belongs. For information about adding and delet-
ing categories, see the next section in this chapter.

	 You can quickly jump to a category associated with a transaction in any transaction view 
by selecting it and choosing Transaction>Go To Category. 
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How do I add and delete categories?

To add a category:

Click “Categories” in the source list. The right side of the main window will display a list of all 
categories that are currently available for use. Depending on which category view you currently 
have selected, your categories may appear in a list or as thumbnails. 
 
Click the  button at the bottom of the main window, or choose Transaction>Add New 
Category. A sheet will appear asking you to enter information about the new category.
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Type in a name for the category and a longer description of the category, if desired. Choose 
whether the category is intended for tracking expenses or income by selecting the appopriate 
item from the “Type” drop-down menu, and check the “Taxable” checkbox if you want to des-
ignate the category for tax purposes. Enter a tax code if desired, then click “Create Category” 
to add the new category to iBank. Read more about category properties in the next section of 
this chapter.

	 You can also create a new category simply by typing it into the category field of a trans-
action in the transaction editor. 

To add a sub-category, click the  button at the bottom of the main window. The same 
sheet will appear to allow you to create a new sub-category. Read more about sub-categories 
in the section about organizing category hierarchy later in this chapter.

To delete a category:

Categories can only be deleted from the list view. Click the  button in the bottom-right 
corner of the main window to switch to list view. Select the category you want to remove and 
click the  button at the bottom of the main window, or press the ‘Delete’ key on your 
keyboard. You will be asked to confirm that you want to remove the category. If the selected 
category has sub-categories, those will be deleted as well.

When you delete a category that has transactions assigned to it, iBank will present you with 
options for how to handle those transactions:
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If you want to assign the transactions to a different category, select the desired category from 
the drop-down list and click “Move Then Delete.” If you simply want to remove the category 
from any transactions to which it had been assigned, click “Just Delete.” The transactions 
themselves will not be deleted, but they will no longer have any category assigned to them.
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How do I edit category properties?

Click “Categories” in the source list to view your categories. You can edit their properties in list 
view or thumbnail view, but category images can only be edited in thumbnail view.

	 You can quickly jump to a category associated with a transaction by selecting the trans-
action and choosing Transaction>Go To Category. 

Each category has the following properties which may be edited:

Name

The name assigned to the category. Double-click the category name in list view to edit it; in 
thumbnail view, simply select the field and type your changes. If you change the name of a 
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category, your category assignments will not be lost - any transactions to which the category is 
assigned will simply update to reflect its new name.

Description

Enter a longer description about the category (if desired) to help you remember what it is used 
for. Double-click the category description in list view to edit it; in thumbnail view, simply select 
the field and type your changes. This is also a handy place to store tax reference information 
for taxable items.

Expense

Click the “Expense” checkbox to indicate that the category is used for expense items; leave it 
unchecked to indicate that it is used for income. This property determines which section of 
your budgets the category will be available in.

Taxable

Click the “Taxable” checkbox to designate the category as tax-related. Items that have this 
property checked will be added to charts when the “Add All Taxable Categories” command is 
chosen.

Tax code

If the category is associated with a particular tax code, enter the number of the code in this 
field to help you remember it. Double-click the tax code in list view to edit it; in thumbnail 
view, make sure “Taxable” is checked and select the “Code” field. iBank includes a list of U.S. 
tax codes for easy reference - click the  button (in the “Create New Category” sheet or 
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thumbnail view) to view and search them. Please note that we cannot guarantee the accuracy of 
the tax code list, but we do our best to keep it up-to-date. If you want to submit a correction, 
please don’t hesitate to contact us.

	 iBank can attempt to assign tax codes to your categories automatically, based on its 
internal U.S. tax code list. Click the  button at the bottom of the 
main window. iBank will search for tax codes for each category based on its name and 
description. It will not replace any existing tax codes. Please double-check the codes 
assigned, as we cannot guarantee that they will be 100% accurate.

Color

Click the  color box (in list view) or the  button (in thumbnail view) to open the 
Apple color picker and choose a color for that category. Any transactions to which the category 
has been assigned will appear in the account register with the selected color as its background. 
If you don’t want category colors displayed in the account register, choose iBank>Preferences, 
click the “Appearance” button, and check the “Hide category background colors” option. Cat-
egory colors are also used to determine how the categories appear in pie and line graphs. To 
remove the color from a category and reset it to black, Control-click on the category in list 
view and choose “Remove Color”.

Image

Category images are only displayed in thumbnail view. To add an image to a category, drag 
and drop the image file from the Finder onto the image box on the left side of the category you 
want it associated with. Alternatively, you can copy an image to the clipboard, click to select 
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a category’s image box, then choose Edit>Paste to add the image. To remove an image from 
a category, click the image to select it and click the  button or press ‘Delete’ on your key-
board.

The image assigned to a category will appear as the default image for any transaction assigned 
to that category, when you view your transactions in thumbnail or cover flow view. Images 
assigned to individual transactions will display in place of the category images, but will not 
change the images assigned to the categories themselves.

Total

Displays the total amount of all transactions to which the category has been assigned. In 
thumbnail view, the total appears in gray at the bottom-right corner of the category box. 
Expense totals are shown as positive numbers; income totals are shown as negative numbers. 
This field cannot be edited directly, but changing the amounts of the transactions assigned to 
a category will affect that category’s total.

	 If you are using multiple currencies, please be aware that the category totals do not 
automatically convert between currencies. The totals shown are straight sums combin-
ing amounts in different currencies.
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How do I combine categories?

If you discover that you have duplicate category entries, or if you simply wish to merge two or 
more different categories, what you need to do is combine those categories. Make sure you are 
in category list view, then Command-click to select the categories you want to combine. Once 
they have been selected, Control-click and choose “Combine” from the menu that appears:

A single category will be created with “Combined” appended to its name. All transactions that 
were previously assigned the original categories will now be assigned the new category. Feel 
free to rename the new category by double-clicking its name in the category list.



How do I organize my categories hierarchically?

Categories can be organized into levels of hierarchy so that some categories are listed under 
others.

Say, for example, that you have a category for auto expenses named “Auto”. You want to track 
all of your car-related expenses under this category, but what if you also want to be able 
to track how much you spend on repairs alone, or gas? iBank makes it easy to create sub-
categories, so that you can categorize both “Service” and “Fuel” under “Auto”. Using charts and 
reports, you can then see at a glance how much you spent on repairs alone, or how much your 
car is costing you in total:

Adding sub-categories

To add a sub-category, view your categories in list view, select the category under which you 
want to create the sub-item, and click the  button at the bottom of the main window. The 
“Create New Category” sheet will appear just as it does when you create any other category. 
Enter the appropriate information for the sub-category and click “Create Category.” A small 
disclosure triangle will appear next to the main category - click this to expand the category 
and view the sub-category you just added. Once they have been created, sub-categories can 
be edited just like any other category.
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In thumbnail view, each sub-category will appear in its own category box, sorted after the main 
category to which it belongs. The main category name appears in gray above the sub-category 
name:

When you assign a sub-category to a transaction in one of your accounts, the transaction will 
display both the main category and its sub-category, separated by a colon. To illustrate, say 
that you assign the above-mentioned “Fuel” sub-category to a transaction. In the transaction 
view, the transaction will then show “Auto:Fuel” in its Category field:

Organizing category hierarchy

You can easily reorganize your category hierarchy at any time by dragging and dropping cate-
gories and sub-categories in the category list view. If you drop one category on top of another, 
that category will become a sub-category of the one you dropped it on. If you drag a sub-
category to a place in the list outside of the main category to which it belongs, it will become 
a main category itself. Rearranging categories in this fashion will not disrupt any transactions 
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that are assigned to those categories; the transactions will automatically update to reflect the 
category changes. You can create as many levels and sub-levels of categories as you wish.

Sub-categories in charts and reports

For information about how categories and sub-categories are handled by charts and reports, 
please refer to the pages about each chart type in Chapter 7: Charts & Reports. 
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How do I import transactions from my bank or 
other financial software?

iBank can import transaction data from your financial institutions or other money-management 
software in a variety of formats. You can import transactions regularly to keep current with 
your bank’s records, or just do a one-time import of your transaction history the first time you 
start iBank.

You can easily migrate your account data from other financial products like Quicken or Micro-
soft Money, or if you use PDA software such as SplashMoney or Ultrasoft Money to manage 
your finances you can import that data into iBank as well. iBank 3 now supports direct down-
loading as well, so that you can update your accounts at the click of a button!

Supported formats:

iBank can import transaction data from the following file formats: QIF (Quicken Interchange 
Format), OFX (Open Financial Exchange, sometimes called QFX) and CSV (Comma-Separated 
Value). It cannot import from CSV files that use two separate columns for the transaction 
amounts, nor can investment transactions be imported in CSV format.

Import options:

iBank can import transactions using any of the following three methods:
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By connecting directly to your financial institution and downloading transaction updates 1.	
automatically (see the section in this chapter about direct downloads).

By using the built-in web browser to visit your bank’s website and let you download trans-2.	
actions manually (see the section in this chapter about the built-in web browser).

By importing transactions from an external data file (see below).3.	

To initiate an import from an external data file:

If you are just getting started with iBank and want to begin by using the transactions you have 
stored in a data file, create a new iBank document, then choose File>Import and check “Create 
accounts for this file” in the window that appears. If you have already set up your accounts in 
iBank and want to add some transactions from a data file, select the account into which you 
want to import the transactions and choose File>Import. In both cases, the next step is to 
locate the data file containing the transactions you want to import, and click “Import.”

	 Checking “Create accounts for this file” will cause iBank to automatically detect which 
bank accounts the transactions in the import file came from, and automatically add 
those accounts to your data file. Be sure to use this option only if the transactions you 
want to import do not belong in any of your existing accounts.

Another quick way to initiate an import is to drag and drop the data file from the Finder onto 
the iBank application icon in the Dock. If the QIF, OFX, QFX, and CSV file types are associated 
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with iBank, all you have to do is double-click the data file in the Finder to initiate the import 
process in iBank.

Configuring import settings:

If the data file uses the QIF or CSV format, you will be asked to configure some additional set-
tings before proceeding with the import. For more information, see the section in this chapter 
about confguring import settings. If you are using OFX or QFX format, no configuration is 
required - continue on to the section about processing imported transactions.
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How do I update my accounts automatically?

iBank 3 features the ability to connect directly to your financial institutions via the Internet 
and update your accounts automatically. Transactions are downloaded using Open Financial 
Exchange (OFX), which is not supported by all financial institutions (and some may charge a fee 
for this service). We do not guarantee online access for all accounts.

To configure your accounts for online access:

Before you can download updates directly from your financial institutions, you must configure 
your accounts for online access. For information on how to do this, see the section about on-
line account access in Chapter 2: Accounts.

To update your accounts automatically:

Click the  Download button on the toolbar or choose Account>Download Transactions 
for All Accounts. If you only want to update one account, select it in the source list and choose 
Account>Download Transactions for Select Account. iBank will then attempt to connect to your 
financial institution(s) and retrieve the latest transactions for the account(s) indicated. To can-
cel downloading for a particular account, click the button next to that account’s progress bar. 
To cancel all downloads, click “Cancel.”
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When downloading is complete, the import window will appear so that you can process the new 
transactions. For more information about working with imported transactions, see the section 
in this chapter about processing imported transactions.

	 When updating your accounts automatically, iBank only retrieves transactions dated 
after the last import date noted for each account. The last import date updates auto-
matically each time you download transactions for that account. You can set the last 
import date for an account to the current date by selecting the account in the source list 
and choosing Account>Set Last Import Date to Today, or you can specify a date in the 
account information pane.
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How do I use the built-in web browser to 
download transactions?

For those financial institutions that don’t support direct downloading, iBank offers a built-in 
web browser to simplify the process of updating your accounts manually. The first step in 
downloading transaction updates using the built-in browser is to associate a valid URL with 
your bank account.

To enter a URL for your bank’s website:

In the source list, select the account you want to use with the built-in web browser and choose 
View>Show Account Info. The account info pane will appear in the bottom half of the source 
list. Enter your bank’s web address in the URL field. Try to be as specific as possible (i.e. enter 
the address that will take you directly to your account login) so as to avoid unnecessary brows-
ing when it comes time to update your accounts. When you are done, click the  button to 
close the account info pane.

To visit your bank’s website using the built-in browser:

In the source list, select the account you want to update. Click the  Website button on the 
toolbar or choose Account>Go to Website to open the built-in browser in place of the transac-
tion view to the right. Assuming you have an active connection to the Internet, the web page 
you specified as the URL for the selected account will be opened automatically:



149Chapter 5: Importing Data

At the top of the browser window, you will see two tabs: Click “Transactions” to switch back to 
the transaction view at any time for reference; click the other tab to return to the web browser 
(its name will change to show the title of the page that is currently being shown). 

Use iBank’s built-in browser just like you would any other web browser (e.g. Safari, Firefox, 
Internet Explorer, Opera) - click a link to browse to that page, and use the buttons along the 
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bottom of the screen to navigate. Click  to go back,  to go forward,  to stop 
loading the current page (the  indicator will show as the page is loading), and  to re-
fresh the current page.

Downloading the transaction updates:

Each financial institution handles the download process a little bit differently (some do not 
allow you to download transactions from their websites at all). For specfic help with download-
ing transactions from your bank’s website, please contact a customer support representative at 
your bank. In general, however, there are four main steps you must follow:

Log into your personal account by typing in your user ID and password.1.	

Browse to the page within your account where you can download transactions.2.	

Select the account from which to download the transactions, and enter a start and end date 3.	
for the download.

Choose a file format and initiate the download.4.	

Here is a sample download form from 
one bank’s website:



When specifying a start and end date for the download, be sure to choose dates that are not 
likely to retrieve transactions that you have already imported into iBank. Although iBank will 
screen for duplicates during the import process, it is best to avoid duplicates at the source as 
much as possible. If possible, choose the OFX or QFX file format as these require no configura-
tion to import. If neither of those are available, choose QIF format, which requires minimal 
configuration, or CSV format if necessary. Please note that iBank cannot import investment 
transactions using CSV format.

	 Some banks provide several download options without specifying which file type each 
one uses. Generally speaking, “”Microsoft Money” usually indicates OFX, “Quicken Web 
Connect” usually indicates QFX, “Quicken” format usually indicates QIF, and “Excel” gen-
erally indicates CSV. You do not actually need to own the software indicated to down-
load a file in a particular format - just use the software name as a guide to determine 
the file type you need.

Once you have configured your download settings, begin the download! iBank will automati-
cally open the file for importing when the download is complete. Next you will be asked to 
configure import settings, if necessary, and then the import window will appear to let you 
process the new transactions.

To close the built-in web browser:

When you are done downloading transaction updates from your bank’s website, click the 
 button at the bottom-right side of the main window to close the broswer and re-

turn to the transaction view.
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To disable the built-in web browser:

If you would prefer not to use the built-in web browser, open iBank>Preferences and click the 

 General button. Check the “View websites in default browser” option, and iBank will use 
your default browser to load your banks’ websites instead.
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How do I configure the import settings properly?

When importing transaction data from a QIF or CSV file, iBank will first ask you to configure a 
few settings. (OFX and QFX files do not require any configuration before importing.)

QIF settings:

If you choose a QIF file for import, the following sheet will appear:

Next to “The date currently looks like” is a sample date taken from your import file. Look at 
this date carefully and choose the matching date format from the drop-down menu. Pay atten-
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tion to the order of the day and month, as well as the number of digits in the year. The format 
code shown at the bottom will update itself automatically depending on your menu selection.

Custom Format Codes

If the sample date doesn’t match 
any of the drop-down menu selec-
tions, choose “Custom” so that you 
can enter a customized date format 
code. The codes below can be used to 
match the format of the sample date. 
For example, to match a date format 
of “12/31/2005” you would enter 
“%m/%d/%Y”, or “31.12.05” would be 
“%d.%m.%y”.

These are the codes available for use:

%a - Abbreviated weekday name (e.g. “Mon”) •	

%A - Full weekday name (e.g. “Monday”) •	

%b - Abbreviated month name (e.g. “Jan”) •	

%B - Full month name (e.g. “January”) •	

%d - Day of the month as a two-digit number (01-31) •	
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%e - Day of the month as a number, without the leading zeros for 1-9 •	

%j - Day of the year as a three-digit number (001-366) •	

%m - Month as a number (01-12) •	

%w - Weekday as a number (0-6), where Sunday is 0 •	

%y -Year without century (00-99) •	

%Y - Year with century (such as 1990) •	

	 Two common mistakes are using an incorrect separator (e.g. entering slashes instead 
of dashes or dots between the month, day, and year codes) or using the wrong code for 
the year. If the sample date has a four-digit year (e.g. “2006”) then be sure your format 
code includes “%Y” instead of “%y” - the case of the letter ‘y’ is important.

CSV settings:

Most CSV files are formatted differently depending on the financial institutions or software that 
generated them. If you choose a CSV file for import, the following sheet will appear.

At the top of the window is a preview of the data inside the CSV file. The bar across the middle 
of the window lists each of the columns that can be imported. Use the mouse to drag and drop 
the various columns into the correct order to match the order of the items in the preview pane.
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	 Note that iBank only has one “Amount” column available for the CSV import. iBank can-
not import data from CSV files that use separate columns for debit and credit amounts. 

For example, the first transaction listed in the preview pane above reads, 
2/1/2005,2/1/2005,”ACH PMT - THANK YOU”,30.00,”Payments”.  To match this transaction, 
drag the columns so that they read in this order: Date, Payee, Amount, Memo.  You’ll notice, 
however, that there is an extra date in the preview transaction. 
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Use the +/- buttons to add and delete placeholder columns for extraneous information in your 
CSV file. Following our example, click the + button to add a placeholder column (it will appear 
as “Blank”), then drag and drop it in front of the “Date” column (we’re going to use the second 
date in the CSV file). This is how things should look after rearranging the columns and adding 
a placeholder:

At the bottom of the window, you will see a couple of sample transactions formatted according 
to the settings you entered. They will update automatically as you make changes so that you 
can use them to help you determine when the importer has been configured properly. 
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In addition to making sure the columns are arranged correctly, you will also need to choose a 
date format (see above for more information on this) and specify a separator. Given that CSV 
stands for “comma-separated values,” most CSV files will use a comma to separate items in the 
file, but there are exceptions. If your file uses a semicolon, tab, or other character to separate 
the payee, memo, and other information, type that character next to “Items are separated by.”

	 If you are importing from a tab-delimited file (i.e. the values are separated by tab spac-
es instead of commas), you must enter the tab character into the separator field. Since 
iBank will not allow you to type the tab character directly, you will need to select one of 
the tab spaces in the preview pane, choose Edit>Copy, then select the contents of the 
“Items are separated by” field and choose Edit>Paste.

Sometimes, when working with CSV files, it may be useful to do some preparatory work on the 
file before importing it into iBank. The following suggestions may help you to avoid potential 
problems with the import process:

Remove any unneccessary data from the CSV file, such as header rows or blank entries. The 1.	
first line of the CSV file should be the first transaction record you want to import.

Remove any extra commas that are not used to separate the values in each transaction - 2.	
for example, an amount of “1,000.00” should be changed to “1000.00” or else iBank will 
read it as two values (“1” and “000.00”).

If you really want to simplify the process, remove all data except for the four values iBank 3.	
can import: Date, Payee, Memo, and Amount.
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To save your import settings:

Once you have finished configuring the import settings, click “Continue Importing” to proceed 
with the import process. If you are planning to import transactions from the same source on a 
regular basis, click “Save Settings” and your configuration will be stored for later use. The next 
time you import data into that account, your saved settings will be used automatically; you will 
not be asked to configure them again.

	 Import settings are stored separately for each account. If you configure settings for one 
account and save them, then import data into another account, you will be asked to 
configure the import settings again for the new account.

To edit your saved import settings:

If you need to adjust settings after saving them, select the appropriate account from the source 
list, then choose Account>Edit Import Settings. In the sheet that appears, you can reconfigure 
the import settings for that account:
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Choose the QIF or CSV tab to edit settings for the respective file type. Make any changes nec-
essary, then click “OK.” The next time you import data, your new settings will automatically be 
applied. Check “Fill with memorized info” if you want the categories of imported transactions 
to be automatically filled in based on your memorized transactions.

To reset your saved import settings:

If you want iBank to forget your saved settings and ask you to configure them manually the 
next time you import data, open the Import Settings sheet, click “Defaults” and then “OK.”
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How do I process transactions that are being 
imported into iBank?

When importing transactions into iBank, after you configure the import settings (if required), 
the import window will appear (unless you chose the “Create accounts for this file” option, in 
which case the import proceeds automatically). This window is used to screen for duplicates, 
select the transactions you want to import, set up and apply smart import rules, and choose 
which account to add the new transactions to:
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The top half of the import window displays the transactions in the import file; the bottom 
half shows current transactions in the destination account, for reference. If you don’t see any 
transactions in the bottom half, select a destination account from the “Import into Account” 
drop-down menu button.

	 You can resize the top and bottom panes by clicking the small divot at the center of the 
window and dragging it up or down. 

Across the top of the import window is a tab bar - when you are importing from more than 
one data file (such as when you initiate a direct download), each data file will show its own tab 
here. Click a tab to view and process the transactions in that file.

To screen for duplicates:

The split-screen view of the import window allows you to easily compare new transactions 
against those already existing in your account. When the import window opens, iBank will 
automatically compare the transactions in the top half against the transactions in the bottom 
half; any matches it finds will be unchecked in the top half so that they will not import. The 
corresponding transactions in the bottom half will be marked “cleared” because they have now 
been verified by the bank records. It is always a good idea to double-check for duplicates in 
case iBank makes a mistake during the matching process.
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	 iBank checks for duplicates based on the date, amount, and check number only. If two 
transactions have the exact same amount and are within a few days of each other, or if 
they have the same amount and check number (regardless of date), iBank will consider 
them a match and uncheck the transaction for importing

You can filter the transactions shown in the bottom half of the import window by typing a word 
or phrase into the “Filter Transactions” box. Only transactions containing that word or phrase 
in their payee, memo, or category fields will be shown. Click  the button inside the filter box 
to show all transactions in the destination account. Click any column header to sort the list by 
the information contained in that column, and click a second time to reverse the direction of 
the sort.

If you find any duplicates, simply click the checkbox next to the transaction in the top half of 
the import window so that it is unchecked; this tells iBank not to import the transaction. If you 
find a transaction that iBank thought was a duplicate but is not, place a check in its box so that 
it will be imported.

To select which transactions to import:

As when screening for duplicates, simply place a check in the “Import” column in the top half 
of the window next to any transaction that you wish to import. Click “Toggle All For Import” 
to check or uncheck all of the new transactions at once. To change the account into which the 
transactions will be imported, click the drop-down menu button labeled “Import into Account” 
and choose a new destination account.
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To apply smart import rules:

You can also create smart import rules to automatically assign types, payees, memos, and/or 
categories to certain transactions based on criteria you specify. For more information, see the 
next section in this chapter.

To complete the import:

Once you have finished preparing your transactions to be imported, click the 

 button. The progress bar on the left side of the import window will 
update as iBank processes the new transactions. When the import is complete, the new trans-
actions will appear in the destination account.

	 In some cases, transfer transactions you import from an external file may not be linked 
once they arrive in iBank. In this case, a transaction will be listed in each of the ac-
counts associated with the transfer. Your account balances will be accurate - the only 
difference is that changes made to one side of the transfer will not affect the other side. 
You can re-link imported transfers manually by assigning the appropriate category (the 
destination account) to one of the transactions, and deleting the other transaction.

After completing an import, the destination account’s info pane will be updated to the cur-
rent date and time. To set an account’s “Last import” to the current date without completing 
an import (for example, you may want to do this if you enter transactions manually instead 
of performing an import), choose Account>Set Last Import Date to Today. You can edit the 
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last import date manually on the account info pane if necessary - just select the account and 
choose View>Show Account Info.

To cancel the import process:

If you are importing from multiple data files, click the  button on any file’s tab to cancel 
importing from that file. If only one tab is showing, simply close the import window to cancel 
the import. You can revisit the import window at any time by choosing Window>Show Import 
Window.
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How do I use smart import rules?

 Smart import rules can be used to help you import transactions more efficiently. Files 
imported from banks often contain extraneous information or are not worded the way you 
would like them to be - smart import rules allow you to import your data using words that 
make sense to you.

For example, let’s say that a purchase you made at your local market shows a payee of “123 
Main St. Market ID:992311” when downloaded from the bank. Using a smart import rule, you 
can choose to have any imported transaction that contains “123 Main St” in the payee field be 
automatically changed to “Mimi’s Market” with a category of “Groceries.”

To add a smart import rule:

First, start an import. After configuring import settings (if required), the import window will 
appear. Select a transaction in the top half of this window upon which you would like to base 
the new smart import rule:
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Click the  button. A sheet will appear with a new smart import rule based on the 
payee and memo of the transaction you had selected:

First, give the rule a name by changing the “Name” field at the top - choose anything that 
will help to distinguish it from other rules you create. In the space below, you will see several 
criteria upon which the rule is based. Each transaction, before it is imported, will be compared 
against these critieria in order to determine whether or not the rule should be applied to it.
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To configure smart import rule criteria:

When you first create a rule, iBank tries to guess which criteria you want to use, but you can 
edit the list however you see fit. Click the  and  buttons, respectively, to add and remove 
the criteria that will determine which transactions are to be modified by the smart import rule. 
The following criteria are available:

Any/All of the following are true:•	  If you choose “Any” as the option for this criterion, all 
transactions that match at least one of the specified criteria will be modified by the smart 
import rule. If you choose “All,” only transactions that match all of the criteria will be af-
fected. This criterion cannot be removed.

	 Be careful with the “any” option - if you choose this option and accidentally leave one of 
your criteria blank, you may end up with a rule that applies itself to all of your imported 
transactions!

Payee:•	  Use this criterion to look for transactions matching a particular payee name. Type in 
the word or phrase you want iBank to look for - if you want iBank to apply the rule to any 
transaction containing that word or phrase (e.g. “Cat” will match both “Cat” and “Catcher in 
the Rye”), choose “Contains.” If you want iBank to apply the rule only to transactions that 
match the word or phrase exactly (e.g. “Cat” will match “Cat” but not “Catcher in the Rye”), 
choose “Is Equal To.” 

Memo:•	  Use this criterion to look for transactions matching a particular memo note. Type in 
the word or phrase you want iBank to look for - if you want iBank to apply the rule to any 
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transaction containing that word or phrase, choose “Contains.” If you want iBank to apply 
the rule only to transactions that match the word or phrase exactly, choose “Is Equal To.” 

Transaction type:•	  Use this criterion to limit the smart import rule to a specific type of 
transaction, or to exclude a specific transaction type.

Account:•	  Use this criterion to limit the smart import rule for use with specific iBank ac-
counts only.

Following our example from above, here is how the rule looks after adding a name and a 
couple more “payee” criteria:
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To specify smart import rule actions:

The last step is to specify what the smart import rule actually does, that is how it will change 
those transactions to which it is applied. Use the four fields at the bottom of the window (Pay-
ee, Memo, Type, and Category) to specify how you want the transaction to look after the rule 
has been applied. If you change the payee to “Mr. Rogers,” for example, then any transaction 
that satisfies the rule’s criteria will be given a payee of “Mr. Rogers.” If you don’t want the rule 
to change a particular field, leave it blank or leave the menu set to “No Value.”

Here is a finished version of the example rule we created above. For any imported transaction 
whose payee contains “Pure Foods Market,” “Albertson,” or “Safeway,” this rule will assign to 
it the category “Groceries” and will not change any other fields. Note that we had to clear the 
payee field so that it wouldn’t change the payee field of the transactions to which it was ap-
plied:
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When you are done configuring your rule, click “OK” to return to the import window. The rule 
will be applied automatically and any transactions to which it applies will be modified immedi-
ately. In our example, note that both “Pure Foods Market” transactions now have the category 
“Groceries” assigned to them.

To add and remove additional smart import rules:

Click the  button to bring up the smart import rules window again. To 
add additional smart import rules, click the  button. A new rule will added to the list, 
ready for editing. To delete a rule, select it in the list and click the  button.

To edit your smart import rules:

Any smart import rules you create will be applied not only to the current import, but to all 
future imports as well. To edit the list of rules that are applied during an import, select “Smart 
Import Rules” from the source list in the main window. You will see all of your smart import 
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rules listed - click on a rule to view its criteria. You can modify the criteria for each rule on the 
right side of the screen, and use the buttons at the bottom of the window to add and delete 
smart import rules from the list.
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How do I import my data from Quicken?

If you are just getting started with iBank and want to transfer your data over from Quicken*, 
follow these steps:

Launch iBank and 1.	 create a new data file. 

Do not add any 2.	 accounts yet, but choose File>Save to save the empty data file. 

Switch to Quicken, choose File>Export, and select the “Full Export” option. Other versions 3.	
of Quicken may keep the export command elsewhere in the program - consult Quicken’s 
help files to locate it. The important thing is to export all of your Quicken data to a QIF file. 

Follow the prompts and save the export file to your Desktop, then quit Quicken. If you are 4.	
using Quicken for Windows, save the file to a flash drive or other portable media, then copy 
it to your Mac Desktop.

Switch back to iBank, and choose File>Import. 5.	

Check “Create accounts for this file” and choose the QIF file you just saved to your Desktop. 6.	

Choose the appropriate date format to use for the import (see the section about 7.	 configur-
ing import settings, earlier in this chapter, for more information on preparing a QIF import) 
and click “Continue Import”. 

That’s it! Kick back and wait for iBank to finish importing your data. iBank will automatically 8.	
recreate your Quicken accounts with all of their associated transactions. Once the accounts 
have been recreated, you can enable online access to update them automatically. 
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If you would prefer to set up the accounts in iBank manually, you can export the transactions 
from each Quicken account to a separate QIF file and import them one at a time. See the be-
ginning of this chapter for more information about standard transaction importing.

*Quicken is copyright Intuit, Inc. iBank can not guarantee complete importing of data from Quicken.
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About Investments

iBank can be used to track activity in your investment accounts (like IRAs, SEPs, etc.). There are 
two main components that work together to help you track investments in iBank:

 •	  Investment accounts are designed to reflect your real-life brokerage accounts and 
are the place where you enter information about the securities you own. 

 •	  The Portfolio provides a quick summary of your gains & losses and the value of your 
holdings, as well as a place to track watchlist items and stock indices. 

Read on for more information about both components.
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How do I use investment accounts?

 Investment accounts are designed to reflect your real-life brokerage accounts and are 
the place where you enter information about the securities you own. To get started with in-
vestment tracking in iBank, begin here - in order to enter your securities, you must first create 
an investment account. Even if you do not maintain a brokerage account in real life, you must 
create a “virtual” brokerage account in iBank to enter the securities.

To add an investment account:

Create an account like you would any other, but be sure to 
choose “Investment” from the pop-up menu in the “Create 
New Account” sheet. You probably will want to name the 
account after your brokerage firm, e.g. “Morgan Stanley” or 
“Scottrade”. After clicking “Create Account” you will see the 
account appear in the source list.

Just like with other iBank accounts, selecting the account 
in the source list will display the transaction view to the 
right, where you can enter transactions pertaining to that 
account. Each purchase, sale, cash transfer, dividend re-
ceived, etc. must be entered as a separate transaction in 
the investment account. See the next section in this chap-
ter for more information about tracking your investment 
activity.
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Understanding investment balances:

When dealing with investment accounts, there are three balances you need to be aware of:

Cash Value

This value reflects the amount of cash in your brokerage account only. In most cases, cash is 
not actually held in your brokerage account for long - when you purchase shares of a stock, 
you transfer the money to your broker and then it is immediately spent to purchase the securi-
ties. When you receive money from the sale of a stock, the money is immediately transferred 
into a savings or other account. In iBank, you must remember to track each of these transac-
tions, entering transfers where appropriate, so that the cash balance of your investment ac-
count remains accurate. The cash value of your investment account is displayed as the balance 
in the transaction view:

Cash Value

Market Value

This value reflects the approximate worth of your portfolio, based on quotes for all the securi-
ties you are currently holding. The market value of your investment account is displayed in the 
summary table of the Portfolio:
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Market Value

Total Value

This value represents the combined worth of the cash value of the brokerage account and the 
market value of your investment portfolio. It is a straight sum of these two figures. The total 
value of your investment account is displayed next to the account name in the source list:

To edit investment account details:

Select the account in the source list and choose View>Show Account Info. The account info 
pane will appear, where you can edit details for that account just like any other.
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	 The minimum balance for an investment account applies only to the cash value of the 
account. Even if the total value of the account remains above the minimum balance you 
specified, if the cash value drops below it you will see a warning badge displayed on the 
account’s icon in the source list.

To delete an investment account:

Select the account in the source list and press the ‘Delete’ key on your keyboard, or choose 
Edit>Delete. A sheet will appear asking you to confirm that you want to permanently delete 
the account. All transactions contained within the account will also be deleted. Any transfers 
in the account will be deleted, but the transactions in other accounts to which those transfers 
are connected will not be deleted (they simply will no longer show the account in their category 
fields).
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How do I track my investment activity?

To track your investment activity in iBank, you must first set up an investment account and 
then add transactions to the account as you buy and sell securities.

To add an investment transaction:

Select an investment account from the source list and click the  button at the bottom of 
the main window to add a new transaction. Choose the appropriate type for the transaction 
(see below for more information about investment transaction types) and enter the trade date 
into the date field. Enter a payee and memo if desired, but these are not required for invest-
ment transactions. Enter the number of shares involved in the transaction, price per share, and 
commission if applicable.

	 Before adding a “Buy” transaction, you will usually need to transfer money into your 
investment account from another account. Say, for example, that in real life you use 
$1,000.00 from your checking account to purchase Apple stock. In iBank, you must cre-
ate two transactions: first, a “Transfer” from your checking account to your investment 
account; second, a “Buy” transaction in your investment account to purchase the stock.

The transaction’s amount will calculate automatically based on the specified number of shares, 
price per share, and commission (except for cash dividends, for which you must enter the 
amount manually). The balance is then updated accordingly.
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Investment transaction properties:

You will notice that the transaction properties displayed in investment accounts are differ-
ent from regular transaction properties, including the list of available transaction types. The 
following security-related fields will become available in the transaction editor (if you do not 
see the “Security Info” box, click the  button to reveal additional information, then click 

 if necessary):

Symbol:•	  The ticker symbol, usually 1 to 5 letters, used to identify the security on an 
exchange. iBank uses this symbol to retrieve quotes for the security over the Internet. 
When entering a symbol for the first time, iBank will ask you to configure some additional 
options for that security. The symbol is required even if the security is a bond or CD – in 
this case, enter anything that will distinguish the security for reporting purposes, such 
as “_BOND1”, “_CD2”, etc. A suffix may be added to the symbol to specify which exchange 
should be used to retrieve quotes (for example, “GOOG.SW” will lookup quotes for Google 
on the Swiss Exchange).
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	 See http://finance.yahoo.com/exchanges for a list of supported exchanges and their 
suffixes. Be aware that each exchange provides quotes in its local currency and that 
iBank does not automatically convert these to the default currency for your investment 
account.

Shares:•	  The number of shares of the security bought, sold, moved, or received in the 
transaction. 

Comm.:•	  The amount of commission paid or earned on the transaction. 

Price:•	  The price per share paid or collected on the transaction. 

Need examples?

Even though iBank can help simplify the process, managing investments is often tricky busi-
ness. To read several examples of how to track various kinds of investment activities in iBank, 
see the last section of this chapter.

http://finance.yahoo.com/exchanges
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How do I manage information about my 
securities?

To track securities that you own, you must first create an investment account and then add 
several investment transactions to record the purchase of those securities. You can then moni-
tor the performance of your holdings using the Portfolio. There are two types of securities 
iBank can track:

Active securities:1.	  Each time you enter a new security symbol in an investment transaction 
for shares you actually own, you will automatically be asked to enter additional informa-
tion about the security for tracking purposes. The security will then appear in the Portfolio, 
where you can monitor its performance.

Watchlist items and indices:2.	  To track information about securities you don’t actually own, 
or to monitor stock indices like the Dow Jones or S&P 500, you can add these items directly 
to the Portfolio. They will not provide any share-specifc information until you enter trans-
actions pertaining to those securities in your investment accounts.

To add an active security:

Select an investment account from the source list and add a new transaction. Type in a symbol 
for the security involved, and if it has not been previously entered into iBank the following 
sheet will appear:
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Enter a name for the security, make sure the symbol is correct, and enter any notes about it 
that you want to remember. 

	 iBank uses the Yahoo! Finance quote service to download security quotes. To ensure 
that your securities are supported, look them up at http://finance.yahoo.com/lookup. 
This is also a handy way to identify the correct symbol to use for a particular security.

http://finance.yahoo.com/lookup
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Choose the appropriate type to match the nature of the security. iBank can retrieve quotes 
automatically for stocks and mutual funds, but it will not look up bonds or CDs when you click 

 Get Quotes on the toolbar.

If you have stocks or mutual funds that are not listed on Yahoo! Finance, or have bonds or CDs 
in your Portfolio, you will need to enter prices for those securities manually. Select  Port-
folio in the source list, locate the security you want to update in the securities table, double-
click in the “Quote” column, and type in the current price per share.

To add a watchlist item or index:

As mentioned above, watchlist items let you track securities of which you don’t actually own 
any shares. To add a watchlist item to the Portfolio, click the  button at the bottom of 
the main window. Enter the security information as described above, choosing the most ap-
propriate security type (but not “Index” in this case), then click “Create.” Your watchlist item 
will appear in the Portfolio and will remain in view when the “Watch” button is selected. If you 
add transactions to an investment account and associate them with this security, it will then be 
considered an active security instead of a watchlist item.

To track stock indices such as NASDAQ or the Dow Jones, add a watchlist item as above. Enter 
the name of the index, and be sure to enter a ‘^’ symbol in front of the index’s ticker symbol 
(for example, “^IXIC” or “^DJI”). Select the “Index” type before you click “Create.” Any indices 
you add to the Portfolio will be displayed in the Portfolio when the “All” button is selected, and 
in the box at the bottom-left of the Portfolio pane:
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The first number displayed across from the index name is the current estimated value of the 
index. The second number is the average change in value per share since the close of the 
previous day.

To edit information about a security:

Select  Portfolio in the source list, click a security to select it, then click the  
button and choose “Toggle Info Drawer.” The info drawer will appear to one side of the main 
window (you may need to resize the main window to see it onscreen).



191Chapter 6: Investments

Here you can edit the security’s name, sym-
bol, type, and notes, as well as change the 
color used to display its performance chart 
(when multiple securities are selected). Any 
changes you make to your securities in the 
info drawer will be reflected in the Portfolio 
and applied to any investment transactions 
pertaining to those securities.

To delete a security:

Select it in the Portfolio and click the  
button. iBank will present an alert to remind 
you that the security may have investment 
transactions associated with it. If you choose 
to delete the security, its associated transac-
tions will not be deleted, but they will lose 
their association to any security (i.e. the 
“Symbol” field for those transactions will be 
cleared). Once deleted, the security will no 
longer be listed in the Portfolio or any smart 
portfolios.
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How do I use the Portfolio?

 The Portfolio works together with your investment accounts to provide summary infor-
mation about the securities you own. You can use the Portfolio to download quotes, view gains 
and losses, chart the performance of your securities over time, and track watchlist items and 
stock indices. To view your Portfolio, select “Portfolio” from the source list:
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Any securities associated with your investment transactions will automatically appear in the 
securities table at the top of the Portfolio view. Most securities should not be entered directly 
into the Portfolio; instead, set up an investment account and use “Buy” transactions to add 
securities (see the previous section in this chapter for more information about entering and 
editing securities). The figure displayed under the Portfolio name in the source list is the total 
market value of all the securities you are currently holding, based on iBank’s current price data.

To view the performance of a security:

Select a security from the list at the top of the Portfolio view. There are three types of informa-
tion displayed about the security in the Portfolio:

Current performance

The securities table displayed at the top of the Portfolio view contains several columns that 
display information about each security:

To change which columns are visible, click the  button at the top-right of the Portfolio 
window and check the columns you want to view. As with any column view, columns can be 
arranged by dragging and dropping the column headers. Click a column header to sort the 
list according to the values in that column (click twice to reverse the direction of the sort). The 
following columns are available for use:
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•	 Name: The security name. Double-click to edit this field. 

Notes:•	  Any notes pertaining to the security. Double-click to edit this field. 

Symbol:•	  The security’s ticker symbol. May also include a suffix to specify which exchange 
to use. Double-click to edit this field.

•	 Cost: The cost basis of the security, calculated from the price and commission entered for 
all relevant transactions associated with the security. Reinvested dividends are included in 
this figure, which is used for tax-related calculations.

	 iBank allows you to specify how the cost basis is calculated. Choose iBank>Preferences, 
click the  Portfolio button, and choose whether to calculate the cost basis using the 
“First In, First Out” or “Average” method. 

At Risk:•	  The original purchase value of the security, calculated from the price and com-
mission entered for all relevant transactions associated with the security. Reinvested divi-
dends are not included in this figure, which is used to calculate the security’s performance.

Cost/Share:•	  The cost basis divided by the number of shares owned (cost per share). 

Shares:•	  The total number of shares owned. 

•	 Quote: Current value (or estimate) of the sale price per share. Update this figure automati-

cally by choosing Account>Download Quotes, or by clicking  Get Quotes on the 
toolbar. Alternatively, you can double-click to enter a value manually.

Change:•	  The difference between the current quote and the security’s opening price on the 
current date. 
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Value:•	  The current estimated value of your shares, equal to the quote times the number of 
shares. 

Gain/Loss:•	  The difference between the current value of the shares and their purchase (at 
risk) value. 

% Gain/Loss:•	  The percent change between the current value of the shares and their pur-
chase (at risk) value. 

Updated:•	  The date and time at which the last quote was downloaded for that security. 

For columns that display changes, positive changes are shown in green while negative changes 
are shown in red.

Performance over time

Below the securities table you will see a chart showing performance over time for the selected 
security:
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	 To adjust the relative sizes of the securities table and performance chart, click the small 
divot appearing between the two sections and drag it up and down. 

There are two options for the type of information displayed in this graph. Choose 
iBank>Preferences, click the  Portfolio button, and select one of the options next to 
“Portfolio graph shows:”

Stock price:•	  This option will graph the daily share price of the security at market close. 
The horizontal axis represents time; the vertical axis represents share price (in the secu-
rity’s native currency).

Percent gain/loss:•	  This option will graph the daily percentage gain or loss for the security, 
from market opening to market close for each day plotted on the chart. The horizontal 
axis represents time; the vertical axis represents percent change in value (in the security’s 
native currency).

Select multiple securities to see their performance charted together on the same graph. Histor-
ical data for each security is downloaded automatically when you select the security; you may 
need to wait a moment while iBank retrieves this information. Security performance can only be 
charted for those securities for which iBank is able to download quotes automatically.

Click a line on the chart to view the symbol of the security it represents. Press the up or down 
arrow key on your keyboard to select another security. Each security is assigned its own color 
on the chart - for information about how modify these colors, see the previous section in this 
chapter about managing securities.
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	 To force iBank to refresh the performance chart for one or more securities, select them 
in the securities table, then click the  button and choose “Refresh Per-
formance Graph.”

Portfolio summary

At the bottom right corner of the Portfolio view, iBank presents summary information for all 
securities currently displayed (depending on what filter option is selected):

Avg. % Gain/Loss:•	  The percent gain/loss of all shares divided by the total number of 
securities. 

% Gain/Loss:•	  The percent change between the current value of all shares and their pur-
chase (at risk) value. 

Gain/Loss:•	  The total difference between the current value of all shares and their purchase 
(at risk) value. 

Total At Risk:•	  The total purchase value of all securities, excluding reinvested dividends.

Market Value:•	  The current total estimated value of all securities. 
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To update your security information:

Make sure you are connected to the Internet, then click  Get Quotes on the toolbar or 
choose Account>Download Quotes. iBank will automatically retrieve quotes for the stocks and 
CDs in your Portfolio (bonds and mutual funds are excluded) and update the information dis-
played onscreen. A progress wheel will appear next to the Portfolio item in the source list while 
the update is taking place.

Be advised that quotes are delayed by at least 15 minutes, depending on the exchange from 
which they are downloaded. If you only want to download quotes for one or more specific 
securities, select them in the securities table, then click the  button and choose 
“Download Selected Quotes.”

	 iBank uses the Yahoo! Finance quote service to download security quotes. To ensure 
that your securities are supported, look them up at http://finance.yahoo.com/lookup. 
This is also a handy way to identify the correct symbol to use for a particular security.

To filter the Portfolio view:

Click one of the three buttons appearing at the bottom of the Portfolio view:

All:•	  all securities, including active securities, watchlist items, and indices, will be displayed 
in the securities table

http://finance.yahoo.com/lookup
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Active:•	  only active securities will be displayed in the securities table

Watch:•	  only watchlist items and indices will be displayed in the securities table

For more information about the different security types, see the previous section in this chap-
ter about managing securities.

To look up additional information about a security:

Select a security in the Portfolio, or Command-click  to select multiple securities. 
Click the button and choose “Research Selected” to lookup the selected securities on Yahoo! 
Finance or another online quote service. To choose your preferred quote service for this func-
tion, choose iBank>Preferences, click the  Portfolio button, and pick a service using the 
“Research stocks using” pop-up button.
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How do I use smart portfolios?

 Smart portfolios allow you to view performance information on specific subsets of your 
investment portfolio. Whereas the main Portfolio view includes all of your securities, a smart 
portfolio can be set up to include only securities from a particular investment account, or pur-
chased within a certain date range, for example.

To create a smart portfolio:

Choose Manage>Add New Smart Portfolio. Using the sheet that appears, give the smart port-
folio a name, then click the  and  buttons, respectively, to add and remove the rules that 
will determine which securities are displayed in the smart portfolio:
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Smart portfolio rules:

Any/All of the following are true:•	  If you choose “Any” as the option for this rule, all 
securities that match at least one of your specified rules will be displayed in the smart 
portfolio. If you choose “All,” only securities that match all of the rules will be displayed. 
This rule cannot be removed.

Security notes:•	  Use this rule to include securities that contain or do not contain a specified 
word or phrase in their security notes.

Date:•	  Use one or more date rules to specify a timeframe for investment transactions - only 
data from transactions within the range will be included in the calculations for the securi-
ties displayed.

Payee:•	  Use this rule to include investment transactions that contain or do not contain a 
specified payee - only data from transactions that meet this criteria will be included in the 
calculations for the securities displayed.

Transaction memo:•	  Use this rule to include investment transactions that contain or do not 
contain a specified word or phrase in their memo fields - only data from transactions that 
meet this criteria will be included in the calculations for the securities displayed.

Security:•	  Use this rule to include or exclude specific securities in or from the portfolio.

Account:•	  Use this rule to include investment transactions from a particular account - only 
data from transactions that meet this criteria will be included in the calculations for the 
securities displayed.

Rules are executed in the order in which they appear. To illustrate, the example above will first 
look at investment transactions in the account “Brokerage,” then it will narrow those down to 
ones that are dated after January 1, 2007, and then it will exclude the security with symbol 
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“GOOG.” Only those securities that have investment transactions in “Brokerage” will appear in 
the smart portfolio, and the data displayed for them will only take into account transactions 
conducted in or after 2007.

When you are done configuring the smart portfolio rules, click “OK” to add the new smart port-
folio to the source list. It will appear under the main Portfolio - click the small disclosure trian-
gele next to the Portfolio item to hide and show your smart portfolios. As you make changes to 
your investment accounts, each smart portfolio will dynamically update to show you informa-
tion about the securities that match the rules you defined when that portfolio was created. The 
mini-graph will also update itself according to which portfolio you currently have selected.

Editing smart portfolios:

To edit the rules for an existing smart portfolio, select it in the source list and choose 
Manage>Edit Smart Portfolio. Any changes made to the smart portfolio rules will immediately 
take effect when you click “OK.”



203Chapter 6: Investments

To delete a smart portfolio:

Select the smart portfolio in the source list and press the ‘Delete’ key on your keyboard, or 
choose Edit>Delete. A sheet will appear asking you to confirm that you want to permanently 
delete the portfolio. The securities displayed in the smart portfolio, and their associated in-
vestment transactions, will not be affected.
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How do I publish my portfolios to MobileMe?

If you are a MobileMe subscriber, iBank makes it easy to publish your Portfolio to a web page 
and check the performance of your securities on the go! Create a unique page for each of your 
smart portfolios and get up-to-date quotes via any web browser.

Configure your MobileMe account:

To take advantage of this feature, you must be signed in to MobileMe. Choose “System Prefer-
ences” from the Apple menu, then click the MobileMe button to enter your account details and 
sign in.

To publish a portfolio:

Select the portfolio you want to publish from the source list, and click one of the 
 buttons at the bottom of the portfolio view to determine which 

securites you want to publish (only visible securities will be published). Next, click the 
 button and choose “Publish Portfolio to MobileMe.” You will be asked to config-

ure a few options before publishing.

http://www.apple.com/mobileme/
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Choose what information you would like to have displayed in your online portfolio, then click 
“Publish to MobileMe” to continue. iBank will attempt to connect to your MobileMe account (you 
must have an active Internet connection for this to work) and upload the portfolio data. When 
the process is complete, iBank will display an alert with an address where you can visit the site 
online.
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You may publish your main Portfolio and/or any smart portfolios you wish to access online. 
Keep in mind that the online portfolios do not automatically synchronize with your iBank port-
folios - any time you make changes to your portfolios in iBank (e.g. buying or selling shares, or 
changing smart portfolio settings), you must publish them again to see the changes reflected 
online.

To view your portfolios online:

Click the “Visit Site” button in the alert displayed by iBank after a portfolio has been published, 
or open any web browser and navigate to the address provided in that alert. A page similar to 
this one will appear:
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When the page loads, it will automatically retrieve updated quotes for your securities and indi-
ces. You will see the following components on the page:

Portfolio name

The name of the current portfolio is displayed as the title of the page (you can rename any 
portfolio in iBank by double-clicking its name in the source list).
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Summary table

Under the page title is a table with the same summary information you see when looking at any 
portfolio in iBank, plus the “% Daily Avg. Change” for all securities displayed.

Update button

Below the summary table is the “Update” button - click this to retrieve the latest quote infor-
mation and update the security data displayed for the current portfolio. The “Last updated” 
date will change to show you the last time quotes were successfully retrieved.

Portfolio menu

Next to the update button is the portfolio selection menu. If you uploaded more than one 
portfolio from iBank, you can select which one to view here. The page will refresh automati-
cally when you select a different portfolio to view. It may take a moment for the page to detect 
which portfolios have been uploaded - while it is searching, a progress wheel will appear next 
to the menu.

Securities table

At the bottom of the screen is a table displaying all of your security information. Indices are 
listed in a separate section at the top of the table. Click any column header to sort the table 
according to that values in that column; click a second time to reverse the direction of the sort. 
Values in the “Change” and “% Change” columns will be colorized to show at a glance whether 
the security is up or down - green indicates a positive change, red indicates a negative 
change, and brown indicates no change. Watchlist items will appear with gray text.
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	 The online portfolio page uses cookies to remember certain settings between sessions. 
If you visit the page from the same computer more than once, it will remember which 
portfolio you viewed last, which column you used for sorting, and which direction the 
values were sorted in. IGG Software does not use cookies to collect any information 
from you whatsoever.

To “unpublish” a portfolio:

If you want to remove a portfolio so that it is no longer available for viewing online, select it in 
the source list in iBank. Click the  button and choose “Unpublish Portfolio.” iBank 
will remove the selected portfolio from the online site.
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Examples of investment activity

Setting up an IRA:

So you just celebrated your birthday again, and you’ve decided that you just can’t put it off any 
longer - it’s time to start planning for your retirement. So you take that $2000 you’ve been 
saving from your paychecks down to Smith Barney and open an IRA. You want to keep close 
tabs on your contributions, however, so you come home and want to set up iBank to help you 
track the account. Here’s what you need to do:

Click the 1.	  Account button on the toolbar to create a new account. 

Choose “Investment” as the account type and enter “Smith Barney IRA” as its name. 2.	
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Since you opened the account with $2000, enter that amount as the starting balance and 3.	
click “Create Account”. (For simplicity’s sake, let’s assume that Smith Barney doesn’t allow 
direct downloading and so we cancel the online access setup.) 

The new account will appear in the 4.	 source list. Select it to display its transaction view: 

You will see your starting balance listed in the register. Each time you make a contribution 5.	
to the account, add a “Deposit” transaction (or a “Transfer” - see below). When you direct 
your custodian to buy and sell shares, use “Buy” and “Sell” transactions to track the pur-
chases and sales. 

Sit back and relax, knowing that you’ll be safe and secure when retirement finally arrives 6.	
(provided you actually make those contributions!). 

Purchasing shares from a checking account:

Let’s assume that you already have an investment account set up in iBank. Your monthly sal-
ary comes in (direct deposited into your checking account), and you determine that you have 
$500.00 to invest. After exploring your options, you decide that the best way to spend that 
money would be to purchase 5.5556 shares of Apple stock at $90.00 each. Here’s how you 
would track this in iBank:

Select your checking account in the 1.	 source list. Add a transaction for your paycheck: 
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Transfe2.	 r the $500.00 to your investment account so that you can buy stock with it. Add a 
transaction to your checking account: 

Select your investment account in the source list. Add a transaction to 3.	 buy Apple stock: 

Switch to the 4.	 Portfolio to view updated information about your holdings (click “Get Quotes” 
on the toolbar to download current quotes): 

Think about diversifying your investments a bit! 5.	

Selling shares:

Following the example above, let’s say that you decide to diversify your portfolio a bit. The first 
step is to sell some of your Apple stock (prices are up anyways, so why not?). Perhaps later you 
can use that money to buy shares in Microsoft (hey, we’re diversifying, right?). So you decide to 
sell 150 shares of your Apple stock, and put the money you get into your savings account for 
now. Here’s how you would track this in iBank:

Select your 1.	 investment account in the source list. Add a transaction to sell Apple stock 
(make sure to enter the correct sale price - iBank will enter the current quote by default): 
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Select your savings account in the source list. Add a 2.	 transfer transaction to move the cash 
you just earned from your investment account into your savings account: 

Switch to the 3.	 Portfolio to view updated information about your holdings (click “Get Quotes” 
on the toolbar to download current quotes): 

Receiving a gift of stock:

You know that rich uncle who amassed a fortune as a day trader? Right, the one who just 
passed away. Well, it turns out that, even though he never met you, he must have thought well 
of you, because he left you 500 shares of Google stock. Imagine that! Here’s how you would 
track this in iBank:

Assuming that you don’t already have an 1.	 investment account set up, create a new one. It 
doesn’t matter that you don’t actually have a brokerage account and all you own are those 
500 Google shares - as far as iBank is concerned, you are your own brokerage account. Call 
the investment account “My Investments” and give it a starting balance of 0. 

Add a 2.	 “Move Shares” transaction to enter the Google shares. Since you got them for free, 
leave the price at 0 (if you wanted the shares to count towards your cost basis, however, 
you would enter the average cost per share in the price field - either way it will not affect 
the cash value of your account): 
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(Notice that your account balance remains at 0, because you haven’t spent or received any 
cash.)

Switch to the 3.	 Portfolio and click   Get Quotes on the toolbar to update the value of 
the new shares. Watch yourself get rich and ponder how sweet life really is: 

Receiving cash dividends:

Now, everybody knows that you’re a hard worker. You may have just been gifted a fortune in 
Google stock, but you’re not ready to retire just yet. No! Instead, you’re going to let the invest-
ment sit and watch it grow as you keep your nose to the grindstone. Lucky for you, Google just 
decided to start paying out cash dividends, so every month you can get a little bit richer. To 
track each dividend in iBank:

Select your 1.	 investment account in the source list. Add a transaction and set its type to 
“Dividend.” 
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Because this is a cash dividend, enter how much you received in the “Amount” field. Do not 2.	
enter anything in the “Security”, “Shares”, “Price”, or “Comm.” fields. Feel free to enter a 
payee or memo if desired. 

Now you will see a 3.	 cash balance in your investment account. Since you got a check in the 
mail from Google, however, this still doesn’t quite represent how you received the dividend. 
In reality, you took that check and deposited it directly into your checking account. To 
reflect this in iBank, add a transfer transaction to move the dividend into your checking 
account: 

To specify the destination account for the transfer, use the “Category” field in the transac-
tion editor.

Add another one of these each month, or set up a 4.	 scheduled transaction to do it for you. 
Try to find some time to spend all the extra money in between your work hours!
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Receiving stock dividends:

Instead of receiving cash dividends on your Google stock each month, let’s say you’ll be get-
ting stock dividends instead. Here’s how you track them in iBank:

Select your 1.	 investment account in the source list. Add a transaction and set its type to 
“Dividend.” 

Because this is a stock dividend, enter the security symbol and number of shares received, 2.	
but do not type in an amount. Feel free to enter a payee or memo if desired. 

(Notice that your account balance remains at 0, because you haven’t spent or received any 
cash.)

Switch to the 3.	 Portfolio to see the gains on your new shares.
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Tracking a stock split:

Now, it just so happens that Google continues to trend upward in the market. The price per 
share reaches a truly astronomical level, so Google execs decide to do a 3-for-1 split, just for 
the heck of it. This is what you need to do to enter the split into iBank:

Select your 1.	 investment account in the source list. Add a transaction and set its type to 
“Split.” 

Enter Google’s security symbol. iBank will automatically show you the current price per 2.	
share (based on the most recent quote it downloaded): 

Calculate the number of shares you gained in the split and enter this into the transaction. 3.	
In a 2:1 split, the number of shares gained is equal to the number you owned prior to the 
split. In a 3:1, you gain twice the number of shares previously owned, etc. The price in this 
case is irrelevant, so you can either leave this alone or change it to zero - either way, it will 
not affect the value of your securities:
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Click 4.	  Get Quotes on the toolbar to update the price of your stocks, then switch to 
the Portfolio to view your changes. Consider an early retirement as you wait for the price to 
continue rising! 

Tracking stock option puts and calls:

After all this time, it looks like your hard work has finally paid off. Google just decided to hire 
you, and they’ve granted you stock options! Here’s how you would track those in iBank:

Let’s say Google gives you the option to buy 200 shares of their stock. In financial terms, 1.	
you have opened a long position in the options market. Add a “Buy to Open” transaction to 
your investment account. Make a note of the stock symbol in the memo field for reference 
if you wish, but don’t enter any shares or price information (because you haven’t actually 
purchased the shares yet - you simply acquired the option to buy). Leave the amount at 0 
as well, because you didn’t purchase the option - it was given to you for free. Notice that 
neither the cash value of your account nor the market value of your Portfolio has changed.
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To monitor the performance of Google’s stock before you exercise your options (let’s as-2.	
sume you don’t already own any Google shares), add Google to your Portfolio as a watchlist 
item. Select the Portfolio in the source list and click the  button to add a new security. 
Enter “Google” as the name, “GOOG” as the symbol, “Stock” as the type, and any notes you 
want to keep track of, then click “OK” to add it to the Portfolio. Make sure you have the 
“Watch” filter button selected at the bottom of the window to view the stock in your security 
table, and you can easily check the current price and change information for that stock. 

Click  Get Quotes on the toolbar to update quotes for your securities.
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Now, let’s say the stock takes a little dip and you decide it is a good time to exercise your 3.	
options and buy the 200 shares. In iBank, you have to enter three transactions: one to 
transfer money into the investment account, one to purchase the shares, and one to close 
the position on your option. First, add a “Transfer” transaction to your investment account 
to obtain the necessary funds from your checking account. Set the category to the name 
of your checking account (you’ll find it at the bottom of the drop-down category list) and 
enter the amount to be transferred as a positive number. 

Second, add a “Buy” transaction and enter “GOOG” as the symbol, “200” as the number of 
shares, and whatever price you paid per share. 

Third, add a “Sell to Close” transaction, making a note of the stock symbol in the memo 
field for reference, and leaving all other fields blank. Since you exercised the option instead 
of selling it, you don’t enter an amount (after all, you didn’t earn money from any sale).
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This transaction is just used to indicate that the position is now closed and you no longer 
hold any stock options. 
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What are charts & reports all about?

 Charts and reports are where iBank really begins to demonstrate its value. After putting in 
the time and effort to set up your accounts, enter transactions, and categorize everything, you 
can use charts to make sense out of all that information quickly and easily. Charts are based 
on categories, so the key to generating effective charts is to assign appropriate categories to 
each of your transactions.

With very little setup, you can view breakdowns of your spending habits, track the changes in a 
particular expense from month to month, list all the transactions assigned to a particular cat-
egory, and more. iBank also allows you to export data from Quick Summary and Custom charts 
for further analysis with other software, or for archival purposes.

Each chart you create is saved and displayed under 
the “Charts” item in the “Manage” section of the 
source list. Click the small disclosure triangle next 
to “Charts” to reveal your saved charts. Select one 
to view that chart in the right side of the main 
window. If you don’t see the “Charts” item in your 
source list at all, you probably haven’t created any 
charts yet!
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To view a summary of your charts:

Click “Charts” in the source list. Summary information about all of your saved charts will be 
displayed to the right:
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About reports:

In iBank, it is important to understand the distinction between charts and reports. Charts are 
dynamic - each one has a number of options which you can configure and reconfigure on the 
fly to shape your analysis of the data in real-time. Reports are text documents based on stan-
dardized formats. Each type of chart in iBank has a particular standardized report associated 
with it; in order to generate a report, you must first create the appropriate chart.

Quick Summary and Custom charts can be used to produce standard Cash Flow Reports. As 
you might guess, Balance Sheet, Capital Gains, and ROI charts can produce standard reports 
according to their names. For more information about generating specific reports, refer to the 
section on the pertinent chart type.
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How do I add and delete charts?

By creating a chart, you can analyze your income and expenditures over time, compare assets 
and liabilities on a balance sheet, assess capital gains, and check the return on your invest-
ments. Each chart has a standardized report associated with it as well.

To add a new chart:

Click the  Chart button on the 
toolbar, or choose Manage>Add 
New Chart. The “Make New Chart” 
sheet will appear:
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Type in a name for the new chart at the top of the sheet, then select a chart type from the list:

Balance Sheet•	 : Compare assets and liabilities across all accounts at a particular point in 
time, and generate a standard Balance Sheet report (automatically populates with all ac-
counts).

Capital Gains•	 : Analyze profit and loss from the sale of securities from your investment 
accounts, and generate a standard Capital Gains report.

Custom•	 : Compare income and expenditures across selected accounts and categories, and 
generate a standard Cash Flow report.

Quick Summary•	 : Compare income and expenditures across all accounts and categories, 
and generate a standard Cash Flow report (automatically populates with all accounts and 
active categories).

ROI (Return on Investment)•	 : Analyze the return on investment for one of your portfolios, 
and generate a standard ROI report.

Finally, configure a few basic options:

Portfolio:•	  If you chose the Capital Gains or ROI chart, select whether you want to base the 
chart on the main Portfolio or one of your smart portfolios.

Report on:•	  Select the time frame you want to use for the chart, if applicable. The option 
you select will automatically change the “Start” and “End” dates accordingly.

Start:•	  The starting date for the chart timeframe.

End:•	  The ending date for the chart timeframe. For the Balance Sheet chart, the “End” date 
is used to indicate the date of the snapshot represented by the chart.
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	 You can also specify whether pie charts slices should be filled with category images or 
colors (where applicable). Choose iBank>Preferences, click the Graph button, and 
select the appropriate option next to “Fill graph slices with.”

When you are finished, click “OK” to add your new chart to the source list. For more informa-
tion about configuring and analyzing the chart, click on the appropriate account type above.

To delete a chart:

Select it in the source list, then press the ‘Delete’ key on your keyboard. iBank will ask for 
confirmation before deleting the chart.
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How do I use Quick Summary and Custom charts?

The Quick Summary and Custom chart types are used to compare income and expenditures 
across multiple accounts and categories. The Quick Summary chart is simply a Custom chart 
that automatically populates with all accounts and active categories. Both charts allow you to 
generate a standard Cash Flow report based on the information they contain.

To get started with a Quick Summary/Custom chart:

Create a new chart and choose the “Quick Summary” or “Custom” 
option. Immediately to the right of the source list you will see a 
number of properties which are used to configure the chart.

Any changes made to the chart settings will update the chart 
automatically. Because charts are generated on-the-fly, you don’t 
need to wait to see your changes take effect.

To add accounts:

Start by choosing which accounts you want to include in the chart. 
Click the  button to add a blank account item to the list. 
Click the item to show a pop-up menu from which you can choose 
the account you want to include. To remove an account from the 
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list, select it and click the  button. If you leave the “Limit to Accounts (Optional)” list 
empty, iBank will automatically include all visible accounts.

To add categories:

Next, choose which categories to include in the chart. Click the  button to add a blank 
category item to the list. Just as you did with accounts, click the blank item to show a pop-up 
menu from which you can select the category you want to include. Choose “no category” to 
include transactions on the chart that have no category assigned to them.

	 In addition to standard categories, you can also include account transfers so that you 
can track, for example, how much money you are putting into a savings account each 
month. Add a new category to the chart and select the appropriate account name from 
the bottom of the item’s pop-up menu.

To remove a category from the list, select it and click the  button. Click the  button 
to view additional options for adding categories:

Add All Active Categories:•	  Select this option to add any categories to your chart that have 
transactions associated with them in iBank (this is not restricted to the account(s) and date 
range specified for the chart). Both income and expense categories will be added.

Add All Taxable Categories:•	  Select this option to add all categories designated as “tax-
able” to your chart.
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Add Active Income Categories:•	  Select this option to add any categories to your chart that 
have transactions associated with them in iBank (this is not restricted to the account(s) and 
date range specified for the chart). Only income categories will be added.

Add Active Expense Categories:•	  Select this option to add any categories to your chart 
that have transactions associated with them in iBank (this is not restricted to the account(s) 
and date range specified for the chart). Only expense categories will be added.

	 Another way to add categories to a chart is to switch to the category view by clicking 
“Categories” in the source list, then dragging and dropping the desired categories onto 
the chart in the source list.

To configure other options:

Set the following options to determine which transactions are used and how the charts will be 
displayed.

Interval:•	  Choose a frequency to be used for the “Through Time” and “Category & Date” 
views (see below for more information on the different chart views). 

Show:•	  Choose whether to include all of the transactions in the specified accounts and 
categories, only those transactions with a date in the current year, or only transactions 
within a specified date range. 

Start/End:•	  If you have selected “Show: Range of Dates,” enter the desired range here. 
Unless you want to specify start and end times as well, leave these at 12:00 AM and 11:59 
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PM, respectively - this will ensure that all transactions on the start and end dates are in-
cluded in the chart. 

Currency:•	  If you have iBank set up to use multiple currencies, choose which one to use for 
the chart (and Cash Flow report). Only transactions in accounts that use the specified cur-
rency will be included. iBank cannot automatically convert transactions between currencies 
for use in this chart. 

To view the chart results:

Once you have your chart settings configured the way you want them, iBank provides four dif-
ferent ways of viewing the chart. Switching between views is as easy as clicking the tabs across 
the top of the chart pane: 
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By Category

Click this tab to view a pie chart showing a breakdown of the categories you selected for 
inclusion in the chart. If you selected expense categories, the chart will show “Expenses;” if 
you selected income categories, the chart will show “Income.” If you selected both types of 
categories, the chart will only display the expense categories (after all, it doesn’t make sense 
to compare income to expenses on a pie graph).
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Each pie slice represents the total amount of the transactions assigned to a particular category. 
The slices are drawn proportionally so that you can quickly get a sense of how your categories 
compare. The name of each category is displayed with each slice, along with the number of 
sub-categories contained within it (where applicable). If you assigned custom colors to your 
categories, they will be used to color the pie slices; otherwise, iBank will assign colors auto-
matically to differentiate them. To highlight a particular slice and view its category name, total 
amount, and percentage relative to the other categories included in the chart, click on the 
slice you want to see. Press one of the arrow keys on your keyboard to move the selection to 
another pie slice.

Double-click a pie slice to “dig down” and view more detailed information about it. If the slice 
represents a category with sub-categories inside it, double-clicking will break the slice into 
its component pieces (hold Command while double-clicking to show the sub-categories in 
their own chart). If the slice represents a category without sub-categories, a list of transactions 
assigned to that category (within the accounts and date range specified for the chart) will be 
shown. To “climb back up” towards the original pie graph, click the  button at the top-left of 
the chart view.
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Above the pie chart is a figure representing the total amount of all transactions included in the 
chart, regardless of category. If you have included both income and expense categories in the 
chart, this total will include the income amounts even though the income categories are not 
displayed in the pie graph.

	 Both main (“parent”) categories and sub-categories can be included in charts, but it is a 
good idea not to mix and match them (e.g. including both “Auto” and “Auto:Fuel” on the 
same chart). Parent categories will include transactions assigned to all sub-categories 
as well as those assigned directly to the parent category itself. Thus, if you put “Auto” 
and “Auto:Fuel” on the same chart, the proportions of those pie slices will appear incor-
rect because the “Auto:Fuel” transactions are included in both slices. Regardless of how 
the pie slices are drawn, the total value above the chart will still calculate correctly; the 
transactions will not be double-counted in the total.
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Through Time

Click this tab to view a bar graph showing the cash flow for each category over time. Time is 
plotted on the horizontal axis and amounts are plotted on the vertical axis. By default, each 
bar represents the amount of earnings or income for a single category during the interval you 
specified. Selecting a shorter interval will result in more bars appearing on the chart, making it 
easier to visualize trends in the data, but may cause the chart to appear cluttered if there too 
many categories displayed.
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If you assigned custom colors to your categories, they will be used to color the bars; otherwise, 
iBank will assign colors automatically to differentiate them. Click any bar to view the category 
and amount that it represents.

To simplify the chart by combining all income categories together and all expense categories 
together, check “Composite income and expenses” below the chart view. On the resulting 
chart, red bars indicate the sum of all included expense categories for each interval; green 
bars indicate the sum of all included income categories for each interval.
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Category & Date

Click this tab to view a table showing a breakdown of categories and their amounts over time. 
Next to each category name is the total amount of all transactions in that category for the 
period of time you specified for the chart. Click the small disclosure triangle next to each cat-
egory to view a breakdown by date according to the interval you specified in the chart settings.
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Any sub-categories that belong to categories included in the chart are also displayed in the 
Category & Date table. The main “parent” categories only count transactions that are assigned 
to them directly; sub-categories are not totaled under the parent categories.

As with any table in iBank, you can click any of the column headers to sort the list accord-
ing to the values in that column. Click twice to reverse the direction of the sort. To resize the 
columns, click and drag the dividers between column headers. Columns can be repositioned by 
clicking and dragging the column headers.
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Transactions

Click this tab to view a table showing detailed information about the transactions assigned to 
the categories included in the chart. Split transaction items are counted and displayed indi-
vidually in the transaction table, but they will show the payee and memo information from the 
main transactions to which they belong.
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At the bottom-right corner of the chart view is a “Total” figure representing the sum of 
amounts of all the transactions included in the chart, regardless of category. In addition, the 
“Selected total” shows the sum of all transactions currently highlighted in the table.

As with any table in iBank, you can click any of the column headers to sort the list accord-
ing to the values in that column. Click twice to reverse the direction of the sort. To resize the 
columns, click and drag the dividers between column headers. Columns can be repositioned by 
clicking and dragging the column headers.

To generate a standard Cash Flow report:

Cash Flow reports provide a tabular breakdown of your income and expenses over a 12-month 
period, beginning with the start date specified for the chart. The chart’s end date is irrelevant, 
as a standard Cash Flow report always covers a 12-month period. Only categories included in 
the chart setup will appear in the report, and only transactions from accounts included in the 
chart setup will be counted.

Make sure you have a Quick Summary or Custom chart selected in the source list, then click 
the  button at the bottom of the main window. iBank will generate a PDF 

document of the report and open it using the  Preview application (or your default PDF 
viewer). From there, you can print the report or save it for your records; iBank does not save 
your reports internally.
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	 If you check “Add Report to Quick Look” before generating the report, an image of the 
Cash Flow report will be stored inside your data file. If you highlight your iBank data file 
in the Finder and press the spacebar to invoke Quick Look, you will see all of your saved 
reports in a slideshow format.

Interpreting Cash Flow reports

Across the top of each page of the report, you will see the date the chart was generated, the 
title of the report (“Cash Flow Analysis”), the name of the iBank chart from which the report was 
generated, the page number, and the name of the application that created the report (“iBank”).

The left-most column lists each of the categories included in the chart in groups according to 
type - income categories are listed first, then expense categories.

The six columns in the middle of the report represent category totals for each month. Each 
category row displays its corresponding amount in the appropriate month column. Income and 
expense categories are subtotaled, and a grand total for each month is displayed at the bottom 
of the column.

	 Both main “parent” categories and sub-categories can be included in the same report 
(e.g. “Auto” and “Auto:Fuel”). Parent categories (and the resulting totals) will display 
two amounts, one in parentheses and one not. The amount in parentheses indicates the 
total amount of all transactions assigned directly to the parent category as well as those 
assigned to its sub-categories. The amount without parentheses indicates the total 
amount of transactions assigned directly to the parent category only (not counting those 
assigned to its sub-categories).
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The right-most column displays subtotals for each category for the six months shown on that 
half of the report. Subtotals for the income, expense, and grand total rows are cumulative in 
the second half of the report: for example, the “Income” subtotal for the second six months of 
the report includes the “Income” subtotals from the first six months as well. The final “Grand 
Total” figure at the bottom-right corner of the last page is the combined total of all income 
and expense categories for the entire twelve-month period.

To export the chart data:

Make sure you have a Quick Summary or Custom chart selected in the source list, then click the 
 button at the bottom-right corner of the main window. It doesn’t matter which 

chart view you have selected. Choose one of the following options from the pop-up menu:

Category & Date as CSV File:•	  This option will let you save a CSV (Comma-Separated 
Value) file containing the information from the “Category & Date” view (no header informa-
tion is included). CSV files can be easily imported into Excel and most other financial and 
statistical programs. 

Transactions as CSV File:•	  This option will let you save a CSV (Comma-Separated Value) 
file containing the information from the “Transactions” view (no header information is 
included). CSV files can be easily imported into Excel and most other financial and statisti-
cal programs.

TXF (Tax Format) File:•	  This option will let you save a TXF (Tax Exchange Format) file 
containing details of all transactions included in the chart that are assigned to tax-related 
categories. TXF files can be easily imported into TurboTax, TaxCut, and most other tax 
filing programs. 
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Regardless of which option you choose, iBank will prompt you to enter a name and choose a 
location in which to save the file. Click “Save” to complete the export process.



247Chapter 7: Charts & Reports

How do I use Balance Sheet charts?

The Balance Sheet chart type is used to compare assets and liabilities (including cash and 
securities held) across multiple accounts at a particular point in time. When you first create 
a Balance Sheet chart, it will automatically populate with all visible accounts. Once you have 
configured the chart, you can generate a standard Balance Sheet report based on the informa-
tion contained in the chart.

To get started with a Balance Sheet chart:

Create a new chart and choose the “Balance Sheet” option. Im-
mediately to the right of the source list you will see a number of 
properties which are used to configure the chart.

Any changes made to the chart settings will update the chart 
automatically. Because charts are generated on-the-fly, you don’t 
need to wait to see your changes take effect.

To add accounts:

Start by choosing which accounts you want to include in the chart. 
Click the  button to add a blank account item to the list. 
Click the item to show a pop-up menu from which you can choose 
the account you want to include. To remove an account from the 
list, select it and click the  button.
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To configure other options:

Set the following options to determine which transactions are used and how the chart will be 
displayed.

End:•	  Enter the date and time you want the “snapshot” to represent. By changing this set-
ting, you can easily compare the state of your financial accounts at various points in time. 

Currency:•	  If you have iBank set up to use multiple currencies, choose which one to use for 
the chart. iBank will automatically convert your account balances to the selected currency, 
using the current exchange rates under Account>Show Currencies. Please note that the 
resulting totals (when you are using accounts with different currencies) are only estimates 
based on these conversions.
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To view the chart results:

Once you have your chart settings configured the way you want them, you will see a pie graph 
to the right, with tabs to select whether to view your assets or liabilities. Click “Assets” to view 
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a breakdown of all accounts with a net positive balance. Click “Liabilities” to view a breakdown 
of all accounts with a net negative balance.

Each pie slice represents the total balance of one of your accounts. The slices are drawn pro-
portionally so that you can quickly get a sense of how your accounts compare. The name of 
an account is displayed with each slice; click any slice to view the associated account name, 
balance, and percentage relative to the other accounts shown on the graph. Press one of the 
arrow keys on your keyboard to move the selection to another pie slice.

Double-click a pie slice to “dig down” and break the slice into its component parts. Each asset 
or liability is considered to have two components: a cash value and the value of securities held 
in that account (though the latter only pertains to investment accounts). If you hold the Com-
mand key on your keyboard while double-clicking a pie slice, the breakdown of cash value and 
held securities for the slice you clicked will appear in their own pie graph.
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Double-clicking on the “Held Securities” portion will dig down further and reveal the market 
value of individual securities held in that account. To “climb back up” towards the original pie 
graph, click the  button at the top-left of the chart view.

Above the pie chart is a figure representing the total amount of your assets or liabilities, de-
pending on which tab you currently have selected.

To generate a standard Balance Sheet report:

Balance Sheet reports provide a tabular breakdown of your assets and liabilities, including all 
cash in your accounts and securities you currently hold, at a particular point in time. Only ac-
counts included in the chart setup will be counted.

Make sure you have a Balance Sheet chart selected in the source list, then click the 
 button at the bottom of the main window. iBank will generate a PDF 

document of the report and open it using the  Preview application (or your default PDF 
viewer). From there, you can print the report or save it for your records; iBank does not save 
your reports internally.
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	 If you check “Add Report to Quick Look” before generating the report, an image of the 
Balance Sheet report will be stored inside your data file. If you highlight your iBank data 
file in the Finder and press the spacebar to invoke Quick Look, you will see all of your 
saved reports in a slideshow format.
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Interpreting Balance Sheet reports

Across the top of each page of the report, you will see the date the chart was generated, the 
title of the report (“Balance Sheet”), the name of the iBank chart from which the report was 
generated, the page number, and the name of the application that created the report (“iBank”).

The column on the left lists the names of your accounts, separated into two sections: assets 
and liabilities. Any account with a net positive balance is considered to be an asset; any ac-
count with a net negative balance is considered to be a liability. The column on the right lists 
each account’s balance, with subtotals for the “Asset” and “Liability” sections.

At the bottom of the report is an overall total showing your combined assets and liabilities. 
This figure represents your Net Worth for the date indicated in the chart setup.

	 If you are using multiple currencies, the Balance Sheet report will subtotal the accounts 
based on the currencies assigned to them. Your net worth will also be broken down by 
currency. Unlike the dynamic charts, the standard Balance Sheet report does not apply 
currency conversions to your balances in order to provide estimates of the combined 
totals.
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How do I use Capital Gains charts?

The Capital Gains chart type is used to analyze profit and loss from the sale of securities in one 
of your portfolios across a specified range of dates. Once you have configured the chart, you 
can generate a standard Capital Gains report based on the information contained in it.

To get started with a Capital Gains chart:

Create a new chart and choose the “Capital Gains” option. Immediately to the right of the 
source list you will see a few properties which are used to configure the chart:

Any changes made to the chart settings will update the chart automatically. Because charts are 
generated on-the-fly, you don’t need to wait to see your changes take effect.
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To configure the chart options:

Set the following options to determine which transactions are used and how the chart will be 
displayed.

Start date:•	  Enter the starting date of the time period you want the chart to cover. 

End date:•	  Enter the ending date of the time period you want the chart to cover. 

Portfolio:•	  Select a portfolio (either your main Portfolio or one of your smart portfolios) 
to use for the chart. Only security sales that are included in the selected portfolio (within 
the date range specified) will be counted when the chart values are calculated. If you have 
iBank set up to use multiple currencies, make sure you configure your smart portfolios so 
that accounts with different currencies are not included in the same portfolio. iBank cannot 
automatically convert transactions between currencies for use in this chart. 

To view the chart results:

Once you have your chart settings configured the way you want them, you will see a pie graph 

to the right, with tabs to select whether to view your gains or losses (click 
 
Get Quotes 

on the toolbar to make sure these figures are up-to-date). Click “Gains” to view a breakdown 
of all securities from which you have turned a profit. Click “Losses” to view a breakdown of all 
securities from which you have suffered a loss.
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Each pie slice represents the total amount of money gained or loss from sales of a particular 
security. The slices are drawn proportionally so that you can quickly get a sense of how your 
securities compare. A security symbol is displayed with each slice; click any slice to view the 
total gain/loss for that security and its percentage relative to the other securities shown on the 
graph. Press one of the arrow keys on your keyboard to move the selection to another pie slice.
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Double-click a pie slice to “dig down” and break the slice into its component parts. Each gain 
or loss is considered to have two components: short-term (for sales made less than a year 
after purchase) and long-term (for sales made a year or more after purchase). If you hold the 
Command key on your keyboard while double-clicking a pie slice, the breakdown of short- and 
long-term components for the slice you clicked will appear in their own pie graph.

Double-clicking on one of these components will dig down further and reveal a table of gains 
and losses from individual sales of the selected security. To “climb back up” towards the origi-
nal pie graph, click the  button at the top-left of the chart view.

Above the pie chart is a figure representing the total amount of your gains or losses, depend-
ing on which tab you currently have selected.



258 Chapter 7: Charts & Reports

To generate a standard Capital Gains report:

Capital Gains reports provide a tabular breakdown of your gains and losses from the sale of 
securities over a specified range of dates. Only sales included in the portfolio you specified in 
the chart setup will be counted.

Make sure you have a Capital Gains chart selected in the source list, then click the 
 button at the bottom of the main window. iBank will generate a PDF 

document of the report and open it using the  Preview application (or your default PDF 
viewer). From there, you can print the report or save it for your records; iBank does not save 
your reports internally.
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	 If you check “Add Report to Quick Look” before generating the report, an image of the 
Capital Gains report will be stored inside your data file. If you highlight your iBank data 
file in the Finder and press the spacebar to invoke Quick Look, you will see all of your 
saved reports in a slideshow format.

Interpreting Captial Gains reports

Across the top of each page of the report, you will see the date the chart was generated, the 
title of the report (“Capital Gains Report”), the name of the iBank chart from which the report 
was generated, the page number, and the name of the application that created the report 
(“iBank”).

Each row in the table shows a single sale transaction. The column on the left lists the names 
of your securities, separated into two sections: short-term and long-term. The next column 
shows the total number of shares sold for each security; after that is a column showing the 
date of the sale. Next is the price of the sale, followed by the original cost of those shares. The 
column on the right shows the difference between the sale price and cost basis, resulting in the 
gain or loss for that sale.

Below each section of the report is a row subtotaling the sale prices, cost basis, and gain/loss 
for your short- and long-term sales. The last line of the report provides overall totals. The 
figure at the bottom-right of the report is your final Capital Gain (or Capital Loss, as the case 
may be).
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	 If you are using multiple currencies, the Capital Gains report will sum the transactions 
as if they were using the same currency, which may lead to inaccurate totals. iBank can-
not automatically convert transactions between currencies for use in this chart. To avoid 
this, use a smart portfolio to define a subset of your investment transactions that only 
uses one currency.
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How do I use ROI (Return on Investment) charts?

The ROI chart type is used to analyze the return on investment for one of your portfolios across 
a specified range of dates. Once you have configured the chart, you can generate a standard 
ROI report based on the information contained in it.

To get started with an ROI chart:

Create a new chart and choose the “ROI (Return on Investment)” option. Immediately to the 
right of the source list you will see a few properties which are used to configure the chart:

Any changes made to the chart settings will update the chart automatically. Because charts are 
generated on-the-fly, you don’t need to wait to see your changes take effect.
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To configure other options:

Set the following options to determine which transactions are used and how the chart will be 
displayed.

Start date:•	  Enter the starting date of the time period you want the chart to cover. 

End date:•	  Enter the ending date of the time period you want the chart to cover. 

Portfolio:•	  Select a portfolio (either your main Portfolio or one of your smart portfolios) to 
use for the chart. Only investment transactions that are included in the selected portfolio 
(within the date range specified) will be counted when the chart values are calculated. If 
you have iBank set up to use multiple currencies, make sure you configure your smart 
portfolios so that accounts with different currencies are not included in the same portfolio. 
iBank cannot automatically convert transactions between currencies for use in this chart. 

To view the chart results:

Once you have your chart settings configured the way you want them, you will see a pie graph 

to the right, with tabs to select whether to view your ROI gains or losses (click  Get 
Quotes on the toolbar to make sure these figures are up-to-date). Click “Gains” to view a 
breakdown of all securities that are currently worth more than their original purchase (at risk) 
value. Click “Losses” to view a breakdown of all securities that are currently worth less than 
their original purchase value.
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Each pie slice represents the difference between the total market value and original purchase 
(at risk) value for all shares held in a particular security. The slices are drawn proportionally so 
that you can quickly get a sense of how your securities compare. A security symbol is displayed 
with each slice; click any slice to view the total gain/loss for that security and its percentage 
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relative to the other securities shown on the graph. Press one of the arrow keys on your key-
board to move the selection to another pie slice.

Double-click a pie slice to reveal a table detailing the beginning market value, individual pur-
chases and sales, and final market value for the selected security. To go back to the original 
pie graph, click the  button at the top-left of the chart view.

Above the pie chart is a figure representing the total amount of your ROI gains or losses, de-
pending on which tab you currently have selected.
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To generate a standard ROI report:

ROI (Return on Investment) reports provide a tabular breakdown of the performance of one of 
your portfolios over a specified period of time. Only investment transactions included in the 
portfolio you specified in the chart setup will be counted.

Make sure you have an ROI chart selected in the source list, then click the  
button at the bottom of the main window. iBank will generate a PDF document of the report 

and open it using the  Preview application (or your default PDF viewer). From there, you 
can print the report or save it for your records; iBank does not save your reports internally.
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	 If you check “Add Report to Quick Look” before generating the report, an image of the 
ROI report will be stored inside your data file. If you highlight your iBank data file in the 
Finder and press the spacebar to invoke Quick Look, you will see all of your saved re-
ports in a slideshow format.

Interpreting ROI reports

Across the top of each page of the report, you will see the date the chart was generated, the 
title of the report (“Return on Investment Report”), the name of the iBank chart from which 
the report was generated, the page number, and the name of the application that created the 
report (“iBank”).

Each row in the table shows a single transaction or market value listing. The column on the left 
lists the dates of the transactions, grouped according to the security to which they pertain. The 
next column shows the type of the transaction (generally “Buy” or “Sell”); after that is a column 
showing a description of the transaction (either the security symbol or a market value indica-
tor). Next is the amount of the original investment (original market value plus the purchase 
value of the shares), followed by the returns earned (ending market value plus earnings from 
any sales). The column on the right shows the percentage of return on the investment, or the 
security’s performance.

The last line of the report provides combined totals of your investment and returns. The figure 
at the bottom-right of the report is your overall Return on Investment for the specified portfo-
lio.
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	 If you are using multiple currencies, the ROI report will sum the transactions as if they 
were using the same currency, which may lead to inaccurate totals. iBank cannot auto-
matically convert transactions between currencies for use in this chart. To avoid this, 
use a smart portfolio to define a subset of your investment transactions that only uses 
one currency.
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How do I use the mini-graph?

The mini-graph appears in the lower left corner of the main window, below the source list. It is 
designed to provide a summary of your overall spending habits at a glance:

Similar to the “By Category” view in the Quick Summary and Custom charts, the mini-graph 
shows a breakdown of expense categories in which activity has occurred within a specified 



269Chapter 7: Charts & Reports

time period (see mini-graph settings, below). Transactions from all visible accounts are includ-
ed in the mini-graph. Each pie slice represents the total amount of the transactions assigned 
to a particular category. The slices are drawn proportionally so that you can quickly get a sense 
of how your categories compare.

The name of each category is displayed with each slice, along with the number of sub-catego-
ries contained within it (where applicable). If you assigned custom colors to your categories, 
they will be used to color the pie slices; otherwise, iBank will assign colors automatically to 
differentiate them. To highlight a particular slice and view its category name, total amount, and 
percentage relative to the other categories included in the chart, click on the slice you want to 
see. Press one of the arrow keys on your keyboard to move the selection to another pie slice.

Double-click a pie slice to “dig down” and view more detailed 
information about it. If the slice represents a category with 
sub-categories inside it, double-clicking will break the slice 
into its component pieces (hold Command while double-
clicking to show the sub-categories in their own chart). If the 
slice represents a category without sub-categories, a list of 
transactions assigned to that category (within the accounts and 
date range specified for the chart) will be shown. To “climb 
back up” towards the original pie graph, click the  button at 
the top-left of the chart view.

Above the pie chart is a figure representing the total amount of 
all transactions included in the chart, regardless of category. If 
you have included both income and expense categories in the 
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chart, this total will include the income amounts even though the income categories are not 
displayed in the pie graph.

To view a summary of your portfolio:

If you select an investment account or port-
folio in the source list, The mini-graph will 
change to show you a summary of the securi-
ties you currently own. If you select a smart 
portfolio, only the securities listed in that 
portfolio will be included.

Each pie slice represents the current market 

value of a particular security (click  Get 
Quotes on the toolbar to make sure these 
figures are up-to-date). The slices are drawn 
proportionally so that you can quickly get 
a sense of how your securities compare. A 
security symbol is displayed with each slice; 
click any slice to view the market value of 
that security and its percentage relative to the 
other securities shown on the graph. Press 
one of the arrow keys on your keyboard to 
move the selection to another pie slice.
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Double-click a pie slice to “dig down” and reveal a table of investment transactions pertaining 
to that security. To “climb back up” towards the original pie graph, click the  button at the 
top-left of the chart view.

Above the pie chart is a figure representing the total market value of the selected portfolio.

To change the mini-graph settings:

Choose iBank>Preferences and click the  Graphs button. 
 
Under the “Mini-Graph” heading, drag the slider to set the maximum number of categories 
displayed on the mini-graph. All categories beyond the number specified will be merged and 
displayed as a single category named “Other.”
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You can also select the range of dates to be displayed, ranging from the past week to the last 
two months. Any transactions that fall within the specified range will be included in the mini-
graph.
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Planning Ahead

iBank provides two main features to help you plan your finances in advance:

 •	  Budgets allow you to lay out a plan to manage your income and expenses, then moni-
tor your progress against your goals. 

 •	  Forecasts allow you to project your account balances into the future, based on past 
trends or upcoming expenses. 

Read on for more information about budgeting and forecasting.
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How do I set up and track a budget?

 Budgets can be set up in iBank to help you keep a better eye on your spending habits. 
iBank allows for the creation of multiple budgets so that you can, for example, track both a 
household and a personal budget at the same time. Budgeting is based on categories, so the 
key to budgeting effectively is to assign appropriate categories to each of your transactions.

Each budget you create is saved and displayed under the “Budgets” item in the “Manage” sec-
tion of the source list:

Click the small disclosure triangle next to “Budgets” to reveal your saved budgets. If you don’t 
see the “Budgets” item in your source list at all, you probably haven’t created any budgets yet!
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To view an overview of your budgets:

Click “Budgets” in the source list. Summary information about all of your saved budgets will be 
displayed to the right:

For more information about how to interpret the information displayed here, read about the 
Budget Monitor below. You can launch the Budget Monitor by clicking the “Budget Monitor” 
button on this screen.
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To add a new budget:

Click the  Budget button on the toolbar, or choose Manage>Add New Budget. A blank 
budget item will appear in the source list; type in a name for the new budget.

To delete a budget:

Select it in the source list, then press the ‘Delete’ key on your keyboard or choose Edit>Delete. 
iBank will ask for confirmation before deleting the budget.

To configure a budget:

To change the budget’s name, double-click it in the source list. Click once to select a budget 
and view its configuration settings in the right side of the main window:
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Decide which categories you want to track using this budget, then add each one to the budget 
setup. Click the  button in the top half of the window to add income categories; click 
the one in the bottom half to add expense categories. Each time you click either button, a new 
category item will be added to the list above it.

	 If you are unable to add income categories, you may have forgotten to designate some 
of your categories for income. See the section about editing category properties in 
Chapter 4: Categories for more information about differentiating income from expense 
categories. 
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To change the category used, click the item’s category name and choose a new category from 
the drop-down list. Click the double-arrows in the “Frequency” column to choose a budget 
period for that item. Double-click in the “Amount” column and enter the amount you expect 
to spend or receive during the time period selected in the “Frequency” column. The “Average” 
column will display an estimate of how much is expected to be spent or received in the time 
frame selected next to “Display Average” at the bottom of the main window.

	 In addition to categories, you can also budget transfers into specified accounts, such 
as how much money you are putting into a savings account each month. To track ac-
count transfers, add a budget item and choose an account name from the bottom of 
the category list for that item. Accounts added to the “expense” section will track funds 
transferred into that account, while accounts added to the “income” section will track 
funds transferred out of that account.

To remove a budget item, select it and click the  button below the list.

Below the category lists are three figures that you can use to help balance your budget:

Total Expenses:•	  Displays the total amount budgeted for all included expense categories 
for the time period selected next to “Display Average” on the lower toolbar. 

Total Income:•	  Displays the total amount budgeted for all included income categories for 
the time period selected next to “Display Average” on the lower toolbar. 

Difference:•	  Displays the total budgeted income minus total budgeted expenses. A differ-
ence of 0 indicates a balanced budget, a positive difference indicates a budget surplus, 
and a negative difference indicates a budget deficit. 
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Example budget configuration

If your monthly paycheck is $4,000.00, you would add an income budget item to the top 
table, set its category to “Salary,” set its frequency to “Monthly,” and enter 4000 in the amount 
column. If you spend approximately $200 every two weeks on groceries, you would add an 
expense budget item for $200.00, set its category to “Groceries,” and set its frequency to 
“Two Weeks.” To view the estimated monthly amounts for both items, set “Display Average” to 
“Monthly” and look at the amounts in the “Average” column.

To monitor your budgets:

Once you have finished setting up a budget (or several), continue adding and categorizing 
transactions in your accounts so that iBank can track your financial activity. Then, use the 
Budget Monitor window to check your progress against your budgets.

To open the Budget Monitor window, click the  Budget Monitor button on the toolbar, or 
choose Manage>Show Budget Monitor.
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Choose which budget to display from the pop-up button in the top left corner of the window. 
In the top right corner of the window, choose a time period to view. The following columns are 
displayed for each budget:

Category:•	  The name of the budget category. 

Expense:•	  If the category is used to track expenses, this column displays a colored bar to 
represent the proportion of actual vs. budgeted expenditures in that category. For expense 
categories, green indicates that you are currently under the budgeted amount, yellow 
indicates that you are approaching the budgeted amount, and red indicates that you are 
over the budgeted amount. A blue checkmark  appears when you meet your budget 
exactly.
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Income:•	  If the category is used to track income, this column displays a colored bar to 
represent the proportion of actual vs. budgeted income in that category. For income cat-
egories, red indicates that you are currently under the budgeted amount, yellow indicates 
that you are approaching the budgeted amount, and green indicates that you are over the 
budgeted amount. A blue checkmark  appears when you meet your budget exactly.

Actual:•	  The total amount of all transactions assigned to the category (across all accounts) 
during the time period specified. 

Budgeted:•	  The amount budgeted for the category during the time period specified. 

	 As with any table in iBank, you can click any of the column headers to sort the list ac-
cording to the values in that column. Click twice to reverse the direction of the sort. To 
resize the columns, click and drag the dividers between column headers. Columns can 
be repositioned by clicking and dragging the column headers.

The “Summary” section displays two colored bars: one representing the proportion of actual 
spending for all expense categories to the total budgeted expenses, and another representing 
the proportion of actual earnings for all income categories to the total budgeted income. Ac-
tual amounts are displayed at the left side of each bar; budgeted amounts are displayed at the 
right side.
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How can I predict future account balances?

 Forecasts help you to estimate, based on current trends and upcoming financial activity, 
how much money you can expect to have in your accounts a little further down the road. iBank 
allows you to create and save forecasts for one or more accounts at a time.

Each forecast you create is saved and displayed under the “Forecasts” item in the “Manage” 
section of the source list:

Click the small disclosure triangle next to “Forecasts” to reveal your saved forecasts. If you 
don’t see the “Forecasts” item in your source list at all, you probably haven’t created any fore-
casts yet!
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To view an overview of your forecasts:

Click “Forecasts” in the source list. Summary information about all of your saved forecasts will 
be displayed to the right:
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To add a new forecast:

Click the  Forecast button on the toolbar, or choose Manage>Add New Forecast. A blank 
forecast item will appear in the source list; type in a name for the new forecast.

To delete a forecast:

Select it in the source list, then press the ‘Delete’ key on your keyboard or choose Edit>Delete. 
iBank will ask for confirmation before deleting the forecast.

To configure a forecast:

To change the forecast’s name, double-click it in the source 
list. Click once to select a forecast and view its configuration 
settings in the middle of the main window.

Any changes made to the forecast settings will update the 
forecast automatically. Because forecasts are generated 
on-the-fly, you don’t need to wait to see your changes take 
effect.

Accounts

Start by choosing which accounts you want to include in the 
forecast. Click the  button to add a blank account item 
to the list. Click in the “Account” column to show a pop-up 
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menu from which you can choose the account you want to include. To remove an account from 
the list, select it and click the  button.

Next to each account name is the average change and forecasted balance - each of which is 
calculated using the options below. At the bottom of the list is the total forecasted balance, 
which represents the sum of all the accounts’ forecasted balances.

	 As with any table in iBank, you can click any of the column headers to sort the list ac-
cording to the values in that column. Click twice to reverse the direction of the sort. To 
resize the columns, click and drag the dividers between column headers. Columns can 
be repositioned by clicking and dragging the column headers.

Options

Set the following options to determine how the forecast is calculated and displayed.

Calculate using:•	  Choose whether the forecast balance is calculated by sampling previous 
account balances, by looking for future scheduled transactions, or using both methods. 
If the method you choose uses previous balances, enter the number of intervals you want 
iBank to sample from your account(s) - the higher the number of samples, the more ac-
curate the forecast will be. The calculation method can be set differently for each account. 

Interval:•	  Choose a frequency to be used for the forecast graph. The interval selected here 
will also control what interval is used to calculate the average of previous balances (if you 
chose a method that uses previous balances). 
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Forecast to:•	  Enter the date and time for which iBank should predict the balance of your 
account(s). 

Understanding the forecast graph:

Once you have added an account to your forecast and configured the various options, you will 
see a line graph drawn in the right side of the main window:
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The lines show how your account balances are expected to change from the present to the date 
and time specified. Time is plotted on the horizontal axis; amounts are plotted on the vertical 
axis.

The account name for the selected line is displayed at the top of the forecast chart:

Each account you add to the forecast will be represented by its own line on the graph. Each 
point on a line represents the predicted account balance at the interval you specified. Selecting 
a shorter interval will result in more points appearing on the graph and possibly more accurate 
forecasts. Click any point on the graph to view figures for all data points on that line:
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How do I prevent other users from accessing my 
data?

If you share your computer with other users, you may be concerned about them accessing your 
financial records. You’ll be pleased to know that iBank provides simple password protection to 
lock your sensitive data away from prying eyes.

To enable password protection:

Open the iBank data file you want to lock (if it is not already open) and choose File>Password 
Protection. The following sheet will appear:
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Check “Password protect my account data”, enter your desired password (twice for verification), 
and click “OK”. Your data file is now password protected!

The next time you try to open the data file with iBank, the following window will appear:

Enter your password and click “Unlock” to open the file, or click “Cancel” to leave it closed. The 
password lock stays with your data file, so even if you open it on another computer you will be 
required to enter your password before opening it.

	 A password-protected data file copied from a PowerPC Mac to an Intel Mac (or vice-ver-
sa) will not unlock. Due to the two processors interpreting iBank’s password algorithm 
differently, even the correct password will not be accepted. To unlock the data file, 
copy it back to a computer with the same processor originally used to enable password 
protection.
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To disable password protection:

Open the data file and choose File>Password Protection. Uncheck “Password protect my ac-
count data” and click “OK”. iBank will no longer ask for a password before opening the file.
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How do I backup my data to MobileMe?

One of the best ways to protect your iBank data is to back it up regularly. iBank makes it very 
easy to backup your data to a MobileMe account. If you do not have a MobileMe account, we 
highly recommend getting one! You can learn more about it on Apple’s website.

To backup your iBank data to MobileMe:

First, make sure you are connected to the Internet. Open the iBank data file that you want to 
backup (if it is not already open) and choose File>Backup to MobileMe. iBank will automatically 
connect to your iDisk using the account information specified in the MobileMe pane of System 
Preferences. If iBank has a problem connecting to MobileMe during the backup process, check 
your configuration settings there.

During the backup, iBank saves a compressed copy of your data file to the following location: 
iDisk/Documents/iBank Backup/. The current date and the “.zip” extension will be appended to 
its file name (e.g. “iBank data 1-2-07.ibank.zip”).

To enable automatic backup:

Choose iBank>Preferences and click the  General button. Check “Backup to MobileMe 
when opening an iBank document.”

http://www.apple.com/mobileme/
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Every time you launch iBank or open a data file, iBank will automatically backup the file to your 
iDisk as described above.

To restore your data from MobileMe:

In the Finder, connect to your iDisk by choosing Go>iDisk>My iDisk, then navigate to this 
folder: iDisk/Documents/iBank Backups/. Choose the file you want to restore, then drag and 
drop it from your iDisk to your Desktop (or whatever location you prefer to keep the data file 
in). Double-click the file to decompress it, then double-click the resulting “.ibank” file to open 
it with iBank.

	 If iBank doesn’t recognize the file after decompression, rename the file so that it ends 
with the “.ibank” extension. 

The next time you launch iBank, it will automatically remember the location of your data file 
and open it at startup.
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How do I backup my iBank data manually?

One of the best ways to protect your iBank data is to back it up regularly. If you do not have a 
MobileMe account or don’t want to take advantage of the automatic backup feature, you can 
still backup your iBank data easily.

To backup your iBank data:

In the Finder, locate your data file. You chose a name and a save location for this file in the 
Setup Assistant the first time you launched iBank. If you don’t remember where you saved the 
file, check in your Documents folder, or search for files with the “.ibank” extension. The name 
of the file is displayed in the title bar of the main iBank window:

http://www.apple.com/mobileme/
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Once you have located the data file, simply drag and drop to copy the file to a backup location. 
For better security, choose a location outside of your local hard drive, such as a flash drive or 
a shared folder on a network. Feel free to rename the backup file to indicate that it is a copy of 
the original, if you like.

	 If you are handy with Automator, you can easily create a workflow to backup your iBank 
data. You can then attach the workflow to a repeating iCal event to have your Mac run 
the backup automatically at specified intervals.

To restore your data from a backup file:

In the Finder, browse to the folder containing the backup file you want to restore. Drag and 
drop the file to your Desktop (or whatever location you prefer to keep the data file in).

Double-click the file to open it in iBank. The next time you launch iBank, it will automatically 
remember the location of your data file and open it at startup.
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How do I print checks from iBank?

iBank offers completely customizable check printing so that you can either print checks on 
purchased check-stock paper or print checks entirely from scratch, on ordinary paper.

iBank check printing is done with user-configurable templates. Before you can print checks 
from an account, you must first configure a template to tell iBank how you want the checks 
to look. Each account stores its own template settings, so that you can use a different kind of 
check with each bank account.

To configure a check template:

First, select the account from which you will be printing checks. Choose Account>Show Check 
Printing Setup to view the check printing setup window:
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To set the page size and margins:

Choose File>Page Setup and select the appropriate option from “Paper Size” to match the 
check stock you are using, and change the orientation if necessary. To adjust margin settings, 
you will need to create a custom paper size - click the “Paper Size” drop-down menu button 
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and choose “Manage Custom Sizes.” You can then use the available options to configure the 
page size and margin settings exactly as you need them. Click “OK” when you are done with 
the Page Setup options.

To choose a template style:

Select the appropriate check style from the “Style” pop-up menu button at the bottom of the 
Check Printing Setup window. Choose the style that best matches the type of check you want 
to print:

Standard

Use this template to print three checks to a page with the date, payee, memo, and amount 
displayed on the check.

Wallet

Use this template to print three checks to a page with the date, payee, memo, and amount 
displayed on the check as well as on a detachable wallet tab on the left side of the check.

Voucher

Use this template to print one check at the top of the page, and two check-sized receipts be-
low. Date, payee, memo, and amount information are displayed on each.
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Custom

Use this template if you want to print checks using ordinary paper. The date, payee, memo, 
and amount are displayed in addition to your address, the payee’s address, the bank’s routing 
number, your account number, and the check number. Standard MICR numbers are displayed 
across the bottom of the check for automated processing.

iBank retrieves your address and the bank address automatically from Mac OS X’s built-in 
Address Book application. Your address is taken from the card you have designated as “Me” 
in Address Book. iBank will search for your bank’s address based on its name (as specified in 
the account info pane), so make sure you have a contact card in Address Book with the correct 
company name. The same applies to payees - iBank will search for your payee addresses based 
on their names. The routing number for your bank and your account number should be en-
tered in the account info pane under View>Show Account Info. When you print a custom check, 
the background gradient will be printed in addition to the text fields.

	 When printing checks using the custom template, you do not need to use check stock. 
Just add regular paper to your printer and print away! Check with your bank for any 
rules or regulations regarding printed checks; in some case, special MICR ink may be 
required. IGG Software does not guarantee that all banks will accept checks that you 
print yourself.
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To set the check size:

At the bottom of the Check Printing Setup window are two figures, ‘H’ and ‘W’, which represent 
the height and width of each check in pixels. Adjust these figures to match the size of your 
check stock - you may need to print a few test pages on blank paper until you are able to make 
sure things line up properly. Changing the paper size will cause the check size to automatically 
scale itself to fit three to a page.

Please note that the check height and width cannot exceed the paper size. If the check height 
and width are smaller than the paper size, you will see white space to the left and/or bottom of 
the checks in the Check Printing Setup window. If there is extra space, you can reposition the 
checks on the paper by adjusting the ‘X’ and ‘Y’ coordinates (horizontal and vertical position in 
pixels) at the bottom of the window.

To adjust field positions & font styles:

Click any text field (i.e payee name, transaction date, memo) in the top-most check are to 
select it. A box will appear around the field to indicate that it is selected:

To reposition the field, click and drag to move it to a new location. As you are dragging it, two 
numbers will appear at the top-left of the field representing the X and Y coordinates (horizon-
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tal and vertical location) of the field. You will notice that the two checks below automatically 
update to match the top check.

	 When using the “Voucher” check style, you can edit the middle check in addition to the 
top-most check. The top-most area controls how information will be printed on the 
check, while the middle area controls how the receipts will look.

To resize the field, click and drag the blue handle at either end of the selection box to make it 
bigger or smaller.

To change the font, size, shadow, etc. of the selected field, click the Fonts button at the bot-
tom of the window and make modifications as necessary. To change the color of the text, click 
the Color button and choose a new color.

To add the “Payee Address” field:

If you want to display the payees’ addresses on your checks, click the  Add button next to 
“Style” and choose “Payee’s Address” from the pop-up menu. A new field will be added to the 
template which you can reposition and style as necessary. To remove this field from the check 
template, select it and press ‘Delete’ on your keyboard.

	 Payee addresses are retrieved from the Address Book application. Make sure that you 
have an entry in Address Book that matches the payee for whom you are printing the 
check, otherwise iBank will not be able to display address information for that payee.
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To add an image or logo:

Drag and drop an image file from the Finder onto the top-most check:

Click and drag the image to reposition it; click and drag the handles around its border to resize 
it. Note that the image will appear in front of any text on the check and cannot be used as a 
background image. To remove an image from the template, click once to select it and press 
‘Delete’ on your keyboard.

To reset a template to the default setup:

Choose a different selection from the “Style” menu, then change back to the one you were us-
ing. Your changes will be erased and the default template will be shown again.
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To print checks:

Once you have finished configuring the check template, close the Check Printing Setup window. 
Select one or more transactions (Command-click to select multiple items in list view or thumb-
nail view) for which you want checks to be printed, then choose File>Print Checks for Selected 
Transactions.

Configure your printer settings as appropriate, then click “Print.” Each transaction will be 
printed to a separate check. Depending on how you have your template configured, checks will 
typically print three to a page. If you only select one or two checks for printing, only one or two 
checks will print on the page.
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How do I use iBank with my iPhone?

To use iBank on your iPhone or iPod Touch, you will need to purchase a copy of iBank Mobile, 
available on the iTunes App Store. iBank Mobile works as a stand-alone application to let 
you track your accounts and transactions on the go, and can sync data with iBank for Mac via 
Bonjour-WiFi, MobileMe, or any WebDAV server. If you have a MobileMe subscription and don’t 
want to purchase iBank Mobile, you can use our free iPhone web application instead - just be 
advised that it is currently being phased out and may not be supported in future versions of 
iBank.

	 Using iBank Mobile, you may sync multiple iPhones and/or iPod Touches to a single 
iBank data file, but a single device cannot sync with more than one iBank data file. 

Configuring a device for syncing

If you have not done so already, you first need to purchase a copy of iBank Mobile from the 
App Store and install it on your iPhone. Make sure your iPhone is connected to the same wire-
less network as your Mac. Launch iBank Mobile, tap the settings button in the bottom left 
corner of the main screen, tap the button under “Syncing,” then tap “Sync with iBank For Mac.” 
You should then see a four-digit code appear on the screen. Once you see this, you are ready 
to configure iBank for Mac.

http://itunes.apple.com/WebObjects/MZStore.woa/wa/viewSoftware?id=318802616&mt=8
http://www.apple.com/mobileme/
http://itunes.apple.com/WebObjects/MZStore.woa/wa/viewSoftware?id=318802616&mt=8
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Launch iBank for Mac, open the data file you want to sync, and choose File > Setup Device for 
Syncing. The following sheet will appear:

This screen provides a basic overview of the sync options available to you. Click “Continue 
Setup” to proceed:
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Your iPhone should appear in the list automatically. If it does not, check to make sure your 
iPhone and Mac are on the same wireless network, and that you can still see the four-digit 
code on your iPhone screen. If you need to refresh the list, click “Go Back” and then “Continue 
Setup” again.

Select your iPhone from the list and click “Setup Selected Device” to proceed:

On this screen, enter the four-digit code that you see on your iPhone, then click the option you 
wish to use for syncing:

WebDAV:•	  Click this button if you want to sync your data via a custom WebDAV server.

MobileMe:•	  Click this button if you have a MobileMe account and would like to use this ac-
count to sync your data over the air, regardless of whether or not your iPhone and Mac are 
connected to the same wireless network.
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Bonjour-WiFi:•	  Click this button if you want to sync your data directly with your Mac when-
ever your iPhone and Mac are connected to the same wireless network. iBank for Mac must 
be running whenever you sync using this option.

Once you have chosen your preferred sync option, iBank may ask you to complete some ad-
ditional configuration settings. If you chose MobileMe, you will need to enter your MobileMe 
username and password, as well as a path where iBank will store the data on your iDisk (un-
less you have a specific preference, just use the default path). If you chose WebDAV, you will 
need to enter the URL where the server can be accessed, as well as a username and password. 
Bonjour-WiFi does not require any additional configuration. Once this step is complete, you will 
see your iPhone added to iBank’s device list. Click “Sync Devices Now” to sync your data to the 
iPhone. If you want to add another device, click “Setup New Device.”

	 When a sync connection is first established, the data in iBank Mobile is replaced with the 
data in iBank for Mac. At the present time, there is no way to sync existing data from 
iBank Mobile to iBank for Mac unless a sync connection is already established and func-
tional.

Adding a device manually

If you are not able to connect your iPhone to the same wireless network as your Mac, you can 
still configure the device (manually) for syncing via MobileMe or WebDAV. When you see the list 
of available devices, click “Manual Setup.” Enter the name of the device, choose what kind of 
device it is, and choose whether you want to sync via MobileMe or WebDAV. In the box below, 
enter the settings specific to the method you chose. When you click “Continue,” iBank will at-
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tempt to connect to the server specified. If successful, it will add the device to your device list 
and you may sync your data to the server. Syncing will then need to be manually configured on 
iBank Mobile as well.

Viewing, editing, and removing synced devices

To view the device list, choose File > Setup Device for Syncing. If you have already configured 
at least one iPhone or iPod Touch, the device list will appear automatically:

This list shows each device you for which you have configured syncing. Each item shows the 
name of the device, the method chosen for syncing, and the corresponding MobileMe or Web-
DAV settings (if applicable). To edit your device settings, click the “Edit” button. To remove a 
device from the list, click the small  button to the right of the device.
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Syncing your data with iBank Mobile

To sync your data, click the  Sync Devices button on the toolbar, or choose File > Sync 
Devices. While iBank is uploading your data to the MobileMe or WebDAV server, you will see 
a progress bar appear at the bottom of the source list. If you chose the Bonjour-WiFi method 
of syncing for your device, you cannot initiate a sync from iBank for Mac; you must tell iBank 
Mobile to sync the data.

	 To sync data automatically when you launch and quit iBank, choose iBank > Preferences, 
click the  General button, and check “Sync devices on launch and quit.” 

Syncing multiple devices

To sync more than one iPhone or iPod Touch with iBank for Mac, configure each device using 
the same steps outlined above. Any mobile devices that are syncing via MobileMe must be 
configured to use the same MobileMe account (but different directories, as indicated below). 
All configured devices will appear in the device list and will sync when you click the  Sync 
Devices button on the toolbar.



323Chapter 11: iPhone Syncing

	 When syncing via MobileMe or WebDAV, each device must be configured to use a unique 
directory. You can name this directory whatever you wish - for example, a second  
iPhone syncing via MobileMe may use a directory like “/Documents/iBankMobileSync2.” 
Data does not sync directly between devices, but must be synced through iBank for Mac 
before it will appear on all devices.

Resetting sync data

If you want to remove all the data on your iPhone and replace it with the data in iBank for 
Mac, open the device list and click “Edit” next to the device you want to reset. In the sheet that 
appears, check “Reset all data on next sync” and click “Done.” The next time you sync your 
devices, all iBank Mobile data on that iPhone or iPod Touch will be replaced with the data from 
your Mac.
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How do I use the iBank for iPhone web 
application?

	 iBank for iPhone is currently being phased out; subsequent versions of iBank may not 
support syncing with this web app. For a more full-featured iPhone alternative, check 
out iBank Mobile, available at the iTunes App Store. Syncing with iBank Mobile is easier 
to set up and more comprehensive than using the free web application.

If you are a MobileMe subscriber, you can synchronize your iBank data to your MobileMe ac-
count and access it online via Safari on your Mac, iPhone, or iPod Touch! View transactions in 
any account and enter new ones while on-the-go, then sync your changes back to iBank when 
you get home. iBank for iPhone does not support entering investment transactions at this time.

To install iBank for iPhone:

iBank for iPhone requires a MobileMe subscription, which you can purchase from Apple online. 
To install iBank for iPhone, look for a folder labeled “iBank for iPhone” on your iBank CD, or 
contained within the iBank download file. Open this folder and copy the “iBank” file to your 
iDisk (make sure it is not inside any other folders - it should reside directly on your iDisk).

http://www.apple.com/mobileme/
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To synchronize your iBank data with MobileMe:

Once the “iBank” file has been placed on your iDisk, launch iBank from your Applications folder 
and open the data file you want to use with your iPhone. Because iBank for iPhone is being 
phased out (see above), the command to sync your data is not readily available. To access it, 

Control-click on the toolbar and choose “Customize Toolbar.” Drag the  Sync iPhone 
with Web App button onto the toolbar, then click “Done.”

Once you have added this button to your toolbar, click it to sync your data. The four most 
recent transactions in each account will be uploaded to MobileMe, and any transactions you 
entered from your iPhone will be downloaded to your computer.

	 Be sure to sync your data every time you make changes. If you add or edit transactions 
from your computer and on your iPhone before synchronizing, iBank will encounter a 
sync conflict when you attempt to sync and you will have to choose which set of data to 
keep. iBank cannot merge changes made from both sides.

When the sync operation is complete, iBank will notify you that iBank for iPhone is ready and 
present you with a URL where you can access your data online. Click “Visit Site” to open the 
page in your default web browser.
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To view your iBank data on your iPhone:

Open Safari on your iPhone and browse to the following address: https://idisk.me.com/ 
YourMobileMeUserName/iBank/index.html

Be sure to replace “YourMobileMeUserName” with your actual MobileMe user name - this is the 
name that appears in your MobileMe email address in front of “@me.com”. You will be asked to 
enter your MobileMe username and password in order to view the page, for security.

https://idisk.me.com/YourMobileMeUserName/iBank/index.html
https://idisk.me.com/YourMobileMeUserName/iBank/index.html
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Once you have authenticated successfully, the following screen will appear:

Each of your accounts are listed with their balances displayed to the right.
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Touch an account to view its transactions:

Here you can see the four most recent transactions in the selected account with all of their 
associated details. At the bottom of the list, the overall account balance is displayed (iBank 
for iPhone does not keep a running balance with each transaction amount). Touch the  
button to return to the account list.
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To add a new transaction from your iPhone:

Touch an account to view its transaction list, then touch the  button to add a new transac-
tion:

Here you can enter the details of the new transaction: touch each field to enter a date, payee, 
amount, category, memo, transaction type, and check number as appropriate. When you have 
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finished setting up the transaction the way you need it, touch the  button to add it to the 
current account, or else touch the  button to discard it.

After saving the new transaction, you will see it added to the transaction list:
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If you then launch iBank and synchronize your changes, you will see the new transaction added 
to your account:
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To edit or delete a transaction from your iPhone:

Any transactions you add from your iPhone appear in black in the transaction list and can be 
edited directly on the iPhone until you synchronize them with iBank. All of your other transac-
tions (the ones sent from iBank) appear in gray and cannot be edited on the iPhone.Touch a 
transaction to edit its details:
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Touch any field to edit its contents, then touch the  button to save the changes. To delete 
the transaction, touch the  button, then confirm that you 
actually want to delete the transaction.

After you are done entering changes from your iPhone, don’t forget to launch iBank and syn-
chronize the changes before continuing to work in iBank!

Author’s credit:

iBank for iPhone was developed by David Keith. Many thanks for his hard work.
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FAQ Index

iBank users often write to us with the following questions. Check here first to see if someone 
else has already asked your question!  The following sections make up this chapter:

Updating, Upgrading, Installing, & Registering…………………………………………………339
How do I update iBank?……………………………………………………………………………………… 339
When will I have to upgrade?… …………………………………………………………………………… 342
Why won’t iBank accept my registration?… …………………………………………………………… 342
What if my free trial expires? Will I lose all of my data?……………………………………………… 344
Why won’t iBank upgrade my data from version 1.x?………………………………………………… 344
Can I install iBank on more than one computer?… …………………………………………………… 345

Managing Data Files… …………………………………………………………………………………346
Why won’t iBank open my data file automatically?… ………………………………………………… 346
Does iBank save my data automatically?………………………………………………………………… 346
Can two or more people share the same iBank data?………………………………………………… 347

Accounts & Transactions……………………………………………………………………………348
Why are my account balances gray?……………………………………………………………………… 348
Why does my account show a warning badge?………………………………………………………… 348
Can I rename items in the source list?…………………………………………………………………… 348
Can I change account types?… …………………………………………………………………………… 349
Why are my transactions bold?… ………………………………………………………………………… 349
Why are my transaction dates orange?…………………………………………………………………… 349
How do I see all transactions in a category for specific dates?… ………………………………… 350
What is that number at the bottom-right side of the screen?……………………………………… 350
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What is the difference bewteen transactions that are “cleared” vs. “reconciled?”……………… 351
Managing Investments…………………………………………………………………………………353

Can I download quotes for non-U.S. securities?… …………………………………………………… 353
Can iBank help me track stock options?………………………………………………………………… 353

Importing & Exporting… ……………………………………………………………………………354
Why are dates missing/incorrect when I import transactions?……………………………………… 354
How do I associate QIF, QFX, OFX, or CSV files with iBank?………………………………………… 354
How do I export transactions to TurboTax?… ………………………………………………………… 355

Miscellaneous……………………………………………………………………………………………357
Why can’t I add any income categories to my budget?… …………………………………………… 357
Do you recommend a particular check stock?… ……………………………………………………… 357
Why does iBank attempt to contact “iggsoftware.iggsoftware.com” at startup?………………… 357
Does iBank integrate with NeatReceipts?………………………………………………………………… 358

If you still can’t find the answer to your question, check our online forums or email customer 
support for assistance (see Chapter 12: Contact Us for more information).
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Updating, Upgrading, Installing, & Registering

How do I update iBank?

We are constantly working to improve our software. Every so often, we will release updates 
with bug fixes, security enhancements, and feature additions. As long as the main version 
number matches the one you purchased, it is free to install - your original registration code 
will be automatically recognized. That means if you purchased iBank 3, v3.01, v3.1, v3.52, etc. 
are all free to you! Check the iBank page on our website (http://www.iggsoftware.com/ibank)
frequently to stay up-to-date, or have iBank check automatically and notify you when a new 
version is available. To read our policy on paid upgrades, visit http://www.iggsoftware.com/
support.php#upgrade_policy.

To enable automatic version checking:

Choose iBank>Preferences and click the  General button. Check “Notify me when an 
update is available”. The next time you launch iBank, it will connect to our website and check 
the number of the latest version available (don’t worry - no information is transmitted to us in 
the process). If the latest version is newer than the one you have installed, iBank will show you 
this window:

http://www.iggsoftware.com/ibank
http://www.iggsoftware.com/support.php#upgrade_policy
http://www.iggsoftware.com/support.php#upgrade_policy
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The latest iBank version number is displayed along with a list of changes made in that update 
(you can view this same version history information on our website at http://www.iggsoftware.
com/ibank/version_changes_3.html). For more information about iBank, click “Visit Site”. To 
download the update using your default web browser, click “Download Now”.

http://www.iggsoftware.com/ibank/version_changes_3.html
http://www.iggsoftware.com/ibank/version_changes_3.html
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To install the update once it has been downloaded:

Quit iBank if it is currently open. Regardless of whether you downloaded the update manually 
from our website or by clicking “Download Now” in the update window, you should have a file 
called “iBank.dmg” on your Desktop (or in your Downloads folder). Double-click it to mount the 
“iBank” disk image. A window should automatically appear containing the iBank application:

Drag the iBank application to your Applications folder, and allow the Finder to overwrite the 
existing iBank program. Drag both the “iBank” disk image and the “iBank.dmg” file from your 
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Desktop to the Trash, and double-click the iBank application in your Applications folder to 
open it. Your update is now complete!

When will I have to upgrade?

Each major version of iBank released is considered to be a paid upgrade; that is, if you pur-
chased iBank 3 and we release iBank 4, you will have to pay an additional fee to upgrade. Our 
promise to you is that we will not release major versions less than one year apart. Additionally, 
we frequently offer reduced pricing for upgrading users of previous versions. Visit our online 
order page (http://www.iggsoftware.com/purchase) for more details.

Why won’t iBank accept my registration?

If you purchased iBank from our online store, or directly through the iBank application:

First, make sure you installed the correct version of the software. If you purchased a license 
for iBank 2 and installed version 3, it will not accept your code. Once you are sure you have the 
correct version of iBank installed, read on.

iBank is very picky about how you enter your registration information. You must type your 
name, email address, and license code exactly as they appear in the confirmation email you 
received after submitting your order. iBank uses your name and email address to verify the 
license code, so be precise.

Pay attention to uppercase/lowercase letters, spaces, punctuation, and special characters. •	

http://www.iggsoftware.com/purchase
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If you only entered one name at the time of purchase, type that name into the “First name” •	
field and then type a single blank space into the “Last name” field. 

If you have a middle name or initial in your registration, such as “John Q. Smith”, enter the •	
first and middle name(s) in the “First name” field (e.g. “John Q.”). The “Last name” field 
should only contain one name (e.g. “Smith”). 

Be careful to distinguish between the capital letter ‘O’ and the number ‘0’. •	

Some special characters cause problems with iBank’s registration algorithm. If you have •	
accented characters, umlauts, etc. in your name or email address then please contact us. 

If you purchased the boxed version of iBank from a retail store:

Enter the license code as it appears on the first line of the sticker affixed to your iBank CD 
sleeve.  The line should begin with “IBNK” and contain several dashes.  Ignore any numbers ap-
pearing below this line, as they are not part of the license code. When typing the license code, 
keep these things in mind:

Be careful to distinguish between the capital letter ‘O’ and the number ‘0’. •	

Be careful not to mistake two ‘V’s for a ‘W’ - there are no ‘W’s in your license code.•	

You may enter any name and email address with the license code - just make sure to type •	
something in each field.

Additional information:

For more information about registering iBank, see the section about purchasing and registra-
tion in Chapter 1: Getting Started.
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What if my free trial expires? Will I lose all of my data?

No, even if your free trial period runs out, your data will be preserved. Whenever you purchase 
a license and register the software, it will be available to use again. If iBank does not open your 
data file automatically after registering, double-click the data file in the Finder to open it.

Why won’t iBank upgrade my data from version 1.x?

If you are trying to import data from iBank 1, but the Setup Assistant won’t recognize your old 
data, follow these steps:

Quit iBank 3. 1.	

Make sure your old iBank data is located here: /Users/2.	 yourUserName/Library/Application 
Support/IGG Software/iBank/ (be sure to replace yourUserName with your Mac OS X login 
name). If you had your iBank 1 data stored somewhere other than this default location, 
move it back. 

Launch iBank 3 and run the Setup Assistant again. Click “Upgrade” and follow the prompts 3.	
to import your iBank 1 data. 

If the “Upgrade” button in the Setup Assistant is still grayed out, try this next:

Quit iBank 3. 1.	

Download and (re-) install iBank 1.5 from 2.	 our website. 

Launch iBank 1.5. Make sure your data is accessible. 3.	

Quit iBank 1.5. 4.	

http://www.iggsoftware.com/ibank/downloads.php#older
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Launch iBank 3 and try again. 5.	

If that still doesn’t work, try one more thing:

Quit iBank 3. 1.	

Delete your preference files, located here:  2.	
/Library/Preferences/com.iggsoftware.iBank.plist 
/Users/yourUserName/Library/Preferences/com.iggsoftware.iBank.plist

Launch iBank 3 and try again. 3.	

One of these steps should fix the problem. If you try all these things and are still unable to 
upgrade your data from iBank 1.x, contact us and we can try to help.

For more information about upgrading data, see the section about using the Setup Assistant in 
Chapter 1: Getting Started.

Can I install iBank on more than one computer?

Yes, technically the iBank license agreement allows you to install the software on two separate 
computers and register them both using the same license code. This is intended mainly for 
backup purposes and is considered acceptable on the condition that both copies of the soft-
ware are not run at the same time.

Installing one copy of iBank at the office and one copy at home so that you can work on your 
finances from both locations is perfectly fine. If two different people will be using the software 
for their own purposes, or both copies of iBank need to be used at the same time, then we ask 
that you purchase an additional license.
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Managing Data Files

Why won’t iBank open my data file automatically?

Each time you start iBank, it should automatically display the last data file you opened. iBank 
relies on Mac OS X “Recent Items” to remember the location of your data file - if you have this 
feature disabled, iBank will not be able to open the file automatically. To make sure you have 
not disabled this feature, open System Preferences and click the “Appearance” button. Under 
“Number of Recent Items,” make sure you have a number selected next to “Documents” and 
not “None.”

	 Some third-party menu utilities may interfere with the “Recent Items” feature. If iBank 
is not opening your data file automatically and you have one of these utilities installed, 
you may need to reconfigure or uninstall the utility.

Does iBank save my data automatically?

Yes, iBank saves your data every three minutes, as well as when you close your data file or quit 
iBank. For more information about iBank data files, see the section about managing data files 
in Chapter 1: Getting Started.
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Can two or more people share the same iBank data?

iBank is intended for single-user operation.  Generally speaking, two users cannot access the 
same data file without making a copy of that file.  The Core Data foundation on which iBank 
relies for data management does not play well with network access - so if you place your iBank 
data file in a shared folder (even if both users are on the same computer), iBank will not be 
able to write changes to the file.  You can use a shared folder to keep a central copy of the file, 
which users can copy to their Desktop before making changes in iBank and then replacing the 
file afterwards.

One exception to this rule allows shared access to a data file via MobileMe.  To share your 
data using a MobileMe account, save the data file to your iDisk, then enable iDisk syncing on 
all computers you want to be able to access it (you will find this option in System Preferences 
under the MobileMe pane). You do not need to have the MobileMe backup feature enabled in 
iBank. Be sure to perform a synchronization just before opening the file on any given com-
puter, to ensure that the latest changes are available.
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Accounts & Transactions

Why are my account balances gray?

Account balances in the source list appear gray for accounts that are not included in the “total 
value” figure displayed at the bottom of the source list. To change whether or not a particular 
account balance is included in the total, select that account, choose View>Show Account Info, 
and check “Include in total.” For more information, see the section about editing account infor-
mation in Chapter 2: Accounts.

Why does my account show a warning badge?

This occurs if your account is overdrawn, that is to say the current balance is less than the 
minimum balance. You can set the minimum balance by selecting the account in the source 
list, choosing View>Show Account Info and entering the appropriate minimum balance for the 
selected account. For more information, see the section about editing account information in 
Chapter 2: Accounts.

Can I rename items in the source list?

Yes - any item in the source list can be renamed by double-clicking it. This includes your 
accounts as well as the Portfolio, Budgets, Memorized Transactions...anything you see listed 
there.
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Can I change account types?

No, once you create an account you cannot change its type. If you accidentally set up an ac-
count with the wrong type, simply create a new account with the correct type, then copy and 
paste all the transactions from the old account into the new one.

	 If you are handy with Applescript, you can use a script to change an account’s type. 
Download some sample scripts from our website (http://www.iggsoftware.com/ibank/
downloads.php) to get started, but please be aware that any modifications made your 
data file with Applescript are done at your own risk.

Why are my transactions bold?

Transactions appear in bold (in list view only) if they have not been marked as cleared. To 
mark a transaction, check it off in in the transaction list or thumbnail view.

Why are my transaction dates orange?

Transaction dates appear in orange when they indicate a time in the future. Sometimes 
imported transactions will be assigned dates with the year 2020 if the wrong date format was 
chosen for the import. For more information, see the section about configuring import settings 
in Chapter 5: Importing Data.

http://www.iggsoftware.com/ibank/downloads.php
http://www.iggsoftware.com/ibank/downloads.php
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How do I see all transactions in a category for specific dates?

Create a new chart.and choose the “Custom” type. Add the category or categories you want to 
report on, select “Show: Range of Dates,” and enter a start and end date. Click the “Transac-
tions” tab to view a list of transactions in the specified categories and dates. For more informa-
tion, see the section about Quick Summary and Custom charts in Chapter7: Charts & Reports.

What is that number at the bottom-right side of the screen?

The number displayed at bottom right corner of the main window is the total amount of all 
transactions currently displayed in the transaction view.

This will update automatically based on the account you have selected (or accounts, if you have 
an account group selected) and the filter option you have chosen. If you are currently perform-
ing a search, the number reflects the total of the transactions displayed as your search results.
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What is the difference between transactions that are “cleared” vs. “reconciled?”

Cleared:

“Cleared” is used to indicate that a transaction has successfully been processed and recorded 
by your financial institution. “Cleared” transactions show checkmarks in the √ (Cleared) column 
when viewing an account in list view or thumbnail view. Transactions can be marked “cleared” 
manually by clicking the checkbox. They may also be marked “cleared” automatically by iBank 
for any of these reasons:

They were •	 imported into iBank via direct download, the built-in browser, or an external 
file.

They were •	 matched against incoming transactions during an import (even if those transac-
tions were not imported).

They were added to a •	 statement and subsequently removed.

Reconciled:
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“Reconciled” is used to indicate that a transaction has been included in a statement. “Rec-
onciled” transactions show disabled checkmarks in the √ (Cleared) column when viewing an 
account in list view or thumbnail view. Transactions can be marked “reconciled” only by adding 
them to statements. To unreconcile them (or to be able to uncheck them so they are no longer 
“cleared”), you must first remove the transactions from the statements to which they belong.

All “reconciled” transactions are also considered “cleared” (and are marked as such automati-
cally when the transactions are added to statements), but “cleared” transactions are only con-
sidered “reconciled” if they have been assigned to statements. For more information about the 
“cleared” status designation, see the section about transaction properties in Chapter 3: Trans-
actions. For more information about reconciling transactions, see the section on statements & 
reconciling in the same chapter.
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Managing Investments

Can I download quotes for non-U.S. securities?

iBank uses the Yahoo! Finance quote service for downloading security prices. Any security that 
is listed on Yahoo! (http://finance.yahoo.com/lookup), iBank should be able to download; you 
just need to enter the same symbol in your investment transactions or Portfolio.

Quotes can be downloaded from non-US stock exchanges by adding the appropriate suffix to 
each of your security symbols. For a list of supported exchange suffixes, visit http://finance.
yahoo.com/exchanges. 

For more information about investment accounts, see Chapter 6: Investments.

Can iBank help me track stock options?

iBank 3 adds four new investment transaction types to help you track your stock options: Buy 
to Open, Sell to Open, Sell to Close, and Buy to Close (each of these types can be used with 
both puts and calls). These are intended primarily to help you keep track of cash moving in and 
out of your brokerage account due to options trading; at this time it is not possible to down-
load option prices or track expiration dates in iBank.

For more information on using these transaction types, see the section about examples in 
Chapter 6: Investments.

http://finance.yahoo.com/
http://finance.yahoo.com/lookup
http://finance.yahoo.com/exchanges
http://finance.yahoo.com/exchanges
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Importing & Exporting

Why are dates missing/incorrect when I import transactions?

The date is probably missing or incorrect because the wrong date format was supplied for 
parsing the imported file. You can change the date format on a per-account basis by selecting 
an account and then choosing Account>Edit Import Settings.

Use the custom date format field to match your exact format if one is not available in the pop-
up button. See the examples below:

Example 1: To match a date format of mm/dd/yyyy you would enter %m/%d/%Y•	

Example 2: To match a date format of d.m.yy you would enter %e.%m.%y•	

Example 3: To match a date format of m-d-yy you would enter %m-%e-%y•	

For more information, see the section about configuring import settings in Chapter 5: Import-
ing Data.

How do I associate QIF, QFX, OFX, or CSV files with iBank? 

The Finder has the ability to associate certain types of files with applications of your choosing. 
If you want iBank to automatically recognize the files you download from your bank’s website, 
you can tell the Finder to associate them with iBank:

In the Finder, select a QIF, QFX, OFX, or CSV file and choose File>Get Info. 1.	
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In the window that appears, click the small disclosure triangle next to “Open With” to view 2.	
the options in that section. 

Click the pop-up button and select iBank from the list to set it as the default application for 3.	
that file. 

Click “Change All” to associate all files of that type with iBank. 4.	

From that point forward, any time you double-click a file with the same type, it will automati-
cally open iBank and begin an import.

	 After associating the file type using the steps above, you can set your web browser to 
automatically open files of that type after they are downloaded. This will allow you to 
download and begin importing new transactions into iBank with one click from your 
bank’s website! Of course, this is not necessary if you use iBank’s built-in web browser.

How do I export transactions to TurboTax?

First, you must designate certain categories as tax-related. Click “Categories” in the source list 
and put a check in the “Taxable” column for any tax-related categories. You may also assign 
tax codes where appropriate.

Second, you must assign those categories to all relevant transactions. You may need to split 
some transactions and assign a tax category to one portion and another category to the re-
mainder.
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Next, you must create a “Custom” chart that includes all your tax categories. Use the  
button to “Add All Taxable Categories” to the chart quickly. Be sure to set an appropriate date 
range for the chart as well (after all, you don’t want to include 2006 transactions on your 2007 
tax forms!).

Finally, click the  button and choose “TXF (Tax Format) File.” Save the TXF file to 
your Desktop or any convenient location. When you run TurboTax or another tax program, it 
should ask you at some point to import data from another program - direct it to the TXF file 
you saved so that it can import your tax data.

	 Even if other categories are included in the chart, the TXF export will only include cat-
egories that are designated as “taxable.” Make sure you have your categories set up 
correctly before exporting.

For more information, see the end of the section on Quick Summary and Custom charts in 
Cahpter 7: Charts & Reports.
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Miscellaneous

Why can’t I add any income categories to my budget?

You must designate some categories as income-based before you will be able to add any cate-
gories to the income section of your budget. Select “Categories” in the source list and uncheck 
the “Expense” box next to any categories you wish to use track income. When you return to 
your budget setup, those categories will be available for use in the income section.

Do you recommend a particular check stock?

No, we designed the check printing template system to be flexible enough to work with just 
about any check stock you might find. So feel free to pick whichever one catches your fancy! 
IGG Software does not sell check stock specifically designed for use with iBank.

Why does iBank attempt to contact “iggsoftware.iggsoftware.com” at startup?

That’s the name of the server where our website is hosted. If you have automatic version 
checking enabled, iBank will automatically connect to our website every time it is launched to 
find out if any new updates are available.

Don’t worry - it is our policy that iBank never transmits any information about you or your 
computer back to IGG Software. To view a copy of our official privacy policy, see this page on 
our website: http://www.iggsoftware.com/privacy.html

http://www.iggsoftware.com/privacy.html
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Does iBank integrate with NeatReceipts?

Yes, if you drag and drop a NeatReceipts PDF file onto an account icon in the iBank source list, 
iBank will automatically create a new transaction for that item in the selected account.

http://www.neatco.com/products/neatreceipts
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Where can I find help or get additional support?

In addition to this manual, we offer free technical assistance via email and an interactive Web 
user forum. Please feel free to contact us at any time; we will be sure to respond to your in-
quiry in a timely and effective manner.

Please direct your email inquiries to the appropriate address:

General inquiries: •	 info@iggsoftware.com

Technical support: •	 support@iggsoftware.com

Bug reports: •	 bugs@iggsoftware.com

Feature requests: •	 feature_requests@iggsoftware.com

Or visit our online discussion forums: http://www.iggsoftware.com/forums/

mailto:info@iggsoftware.com
mailto:support@iggsoftware.com
mailto:bugs@iggsoftware.com
mailto:feature_requests@iggsoftware.com
http://www.iggsoftware.com/forums/
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